[PATCH 0/2] update python-hy

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 7 Mar 2023 20:55
(address . guix-patches@gnu.org)
820c5bf3-4d3d-0a2e-298b-5b446cf08e94@jackhill.us
Hi Guix,

These patches update Hy to the latest non-alpha release and let Hy know
it's version so that it can report it when invoked.

Of note, several tests are skipped. I checked and, unfortunately, this
release does not fix any of those failing tests.

Best,
Jack

Jack Hill (2):
gnu: python-hy: Update to 0.26.0.
gnu: python-hy: Report version.

gnu/packages/python-xyz.scm | 42 ++++++++++++++++++++++++-------------
1 file changed, 27 insertions(+), 15 deletions(-)

--
2.39.1
J
J
Jack Hill wrote on 7 Mar 2023 20:57
[PATCH 1/2] gnu: python-hy: Update to 0.26.0.
(address . 62038@debbugs.gnu.org)
20230307195736.29985-1-jackhill@jackhill.us
* gnu/packages/python-xyx.scm (python-hy): Update to 0.26.0.
[propagated-inputs]: Remove python-colorama.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db9067e699..7a1866314e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15008,7 +15008,7 @@ (define-public python-rply
(define-public python-hy
(package
(name "python-hy")
- (version "0.25.0")
+ (version "0.26.0")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -15017,7 +15017,7 @@ (define-public python-hy
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1am6z9m0s9svysj0wrfz069rpvbqqimphqll3912q4bvdlz6vrjp"))))
+ (base32 "1czhh7s81sg0nrnf4zv0ydqi4f7s6sywf4ks4fd59vpx441ca39v"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -15034,7 +15034,7 @@ (define-public python-hy
(native-inputs
(list python-pytest-7.1 python-wheel))
(propagated-inputs
- (list python-colorama python-funcparserlib))
+ (list python-funcparserlib))
(home-page "https://docs.hylang.org/en/stable/")
(synopsis "Lisp frontend to Python")
(description
--
2.39.1
J
J
Jack Hill wrote on 7 Mar 2023 20:57
[PATCH 2/2] gnu: python-hy: Report version.
(address . 62038@debbugs.gnu.org)
20230307195736.29985-2-jackhill@jackhill.us
* gnu/packages/python-xyz.scm (python-hy)[arguments]{phases}: Add
set-version and remove-installed-build-scripts.
---
gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++------------
1 file changed, 24 insertions(+), 12 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7a1866314e..88138db1f4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -58,7 +58,7 @@
;;; Copyright © 2015, 2018 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
-;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2019, 2023 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
@@ -15020,17 +15020,29 @@ (define-public python-hy
(base32 "1czhh7s81sg0nrnf4zv0ydqi4f7s6sywf4ks4fd59vpx441ca39v"))))
(build-system python-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-k"
- (string-append ; skip some failed tests
- "not test_sys_executable"
- " and not test_circular_macro_require"
- " and not test_macro_require"
- " and not test_requires_pollutes_core"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Hy includes a script that writes a version.py file the Hy uses to
+ ;; report its version. That script uses information from the git
+ ;; repository or the HY_VERSION environment variable. Therefore,
+ ;; these phases et HY_VERSION and then remove the support scripts
+ ;; which get installed in the root of the output.
+ (add-after 'unpack 'set-version
+ (lambda _
+ (setenv "HY_VERSION" #$version)))
+ (add-after 'install 'remove-installed-build-scripts
+ (lambda _
+ (delete-file-recursively (string-append #$output "/get_version"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-k"
+ (string-append ; skip some failed tests
+ "not test_sys_executable"
+ " and not test_circular_macro_require"
+ " and not test_macro_require"
+ " and not test_requires_pollutes_core"))))))))
(native-inputs
(list python-pytest-7.1 python-wheel))
(propagated-inputs
--
2.39.1
J
J
Jack Hill wrote on 16 Mar 2023 23:15
[PATCH v2 0/2] python-hy update v2 (typo fix)
(address . 62038@debbugs.gnu.org)
alpine.DEB.2.21.2303161814150.15296@marsh.hcoop.net
Sending a v2 of this patch series becasue I noticed I typo I made in the
code comment. The changes have otherwise not be modified.

Jack Hill (2):
gnu: python-hy: Update to 0.26.0.
gnu: python-hy: Report version.

gnu/packages/python-xyz.scm | 42 ++++++++++++++++++++++++-------------
1 file changed, 27 insertions(+), 15 deletions(-)

--
2.39.2
J
J
Jack Hill wrote on 16 Mar 2023 23:17
[PATCH v2 1/2] gnu: python-hy: Update to 0.26.0.
(address . 62038@debbugs.gnu.org)
20230316221734.23689-1-jackhill@jackhill.us
* gnu/packages/python-xyx.scm (python-hy): Update to 0.26.0.
[propagated-inputs]: Remove python-colorama.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83f3ec02ea..509bfa77d6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15027,7 +15027,7 @@ (define-public python-rply
(define-public python-hy
(package
(name "python-hy")
- (version "0.25.0")
+ (version "0.26.0")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -15036,7 +15036,7 @@ (define-public python-hy
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1am6z9m0s9svysj0wrfz069rpvbqqimphqll3912q4bvdlz6vrjp"))))
+ (base32 "1czhh7s81sg0nrnf4zv0ydqi4f7s6sywf4ks4fd59vpx441ca39v"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -15053,7 +15053,7 @@ (define-public python-hy
(native-inputs
(list python-pytest-7.1 python-wheel))
(propagated-inputs
- (list python-colorama python-funcparserlib))
+ (list python-funcparserlib))
(home-page "https://docs.hylang.org/en/stable/")
(synopsis "Lisp frontend to Python")
(description
--
2.39.2
J
J
Jack Hill wrote on 16 Mar 2023 23:17
[PATCH v2 2/2] gnu: python-hy: Report version.
(address . 62038@debbugs.gnu.org)
20230316221734.23689-2-jackhill@jackhill.us
* gnu/packages/python-xyz.scm (python-hy)[arguments]{phases}: Add
set-version and remove-installed-build-scripts.
---
gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++------------
1 file changed, 24 insertions(+), 12 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 509bfa77d6..3dc1a0834c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -58,7 +58,7 @@
;;; Copyright © 2015, 2018 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
-;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2019, 2023 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
@@ -15039,17 +15039,29 @@ (define-public python-hy
(base32 "1czhh7s81sg0nrnf4zv0ydqi4f7s6sywf4ks4fd59vpx441ca39v"))))
(build-system python-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-k"
- (string-append ; skip some failed tests
- "not test_sys_executable"
- " and not test_circular_macro_require"
- " and not test_macro_require"
- " and not test_requires_pollutes_core"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Hy includes a script that writes a version.py file that Hy uses to
+ ;; report its version. That script uses information from the git
+ ;; repository or the HY_VERSION environment variable. Therefore,
+ ;; these phases et HY_VERSION and then remove the support scripts
+ ;; which get installed in the root of the output.
+ (add-after 'unpack 'set-version
+ (lambda _
+ (setenv "HY_VERSION" #$version)))
+ (add-after 'install 'remove-installed-build-scripts
+ (lambda _
+ (delete-file-recursively (string-append #$output "/get_version"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-k"
+ (string-append ; skip some failed tests
+ "not test_sys_executable"
+ " and not test_circular_macro_require"
+ " and not test_macro_require"
+ " and not test_requires_pollutes_core"))))))))
(native-inputs
(list python-pytest-7.1 python-wheel))
(propagated-inputs
--
2.39.2
J
J
Jack Hill wrote on 16 Mar 2023 23:23
[PATCH v3 0/2] python-hy update v3 (another typo fix)
(address . 62038@debbugs.gnu.org)
alpine.DEB.2.21.2303161822230.15296@marsh.hcoop.net
Oops, I found yet another typo fix in the code comment. Here's a v3

Jack Hill (2):
gnu: python-hy: Update to 0.26.0.
gnu: python-hy: Report version.

gnu/packages/python-xyz.scm | 42 ++++++++++++++++++++++++-------------
1 file changed, 27 insertions(+), 15 deletions(-)

--
2.39.2
J
J
Jack Hill wrote on 16 Mar 2023 23:24
[PATCH v3 2/2] gnu: python-hy: Report version.
(address . 62038@debbugs.gnu.org)
20230316222423.23757-2-jackhill@jackhill.us
* gnu/packages/python-xyz.scm (python-hy)[arguments]{phases}: Add
set-version and remove-installed-build-scripts.
---
gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++------------
1 file changed, 24 insertions(+), 12 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 509bfa77d6..a5a2048fb5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -58,7 +58,7 @@
;;; Copyright © 2015, 2018 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
-;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2019, 2023 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
@@ -15039,17 +15039,29 @@ (define-public python-hy
(base32 "1czhh7s81sg0nrnf4zv0ydqi4f7s6sywf4ks4fd59vpx441ca39v"))))
(build-system python-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-k"
- (string-append ; skip some failed tests
- "not test_sys_executable"
- " and not test_circular_macro_require"
- " and not test_macro_require"
- " and not test_requires_pollutes_core"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Hy includes a script that writes a version.py file that Hy uses to
+ ;; report its version. That script uses information from the git
+ ;; repository or the HY_VERSION environment variable. Therefore,
+ ;; these phases set HY_VERSION and then remove the support scripts
+ ;; which get installed in the root of the output.
+ (add-after 'unpack 'set-version
+ (lambda _
+ (setenv "HY_VERSION" #$version)))
+ (add-after 'install 'remove-installed-build-scripts
+ (lambda _
+ (delete-file-recursively (string-append #$output "/get_version"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-k"
+ (string-append ; skip some failed tests
+ "not test_sys_executable"
+ " and not test_circular_macro_require"
+ " and not test_macro_require"
+ " and not test_requires_pollutes_core"))))))))
(native-inputs
(list python-pytest-7.1 python-wheel))
(propagated-inputs
--
2.39.2
J
J
Jack Hill wrote on 16 Mar 2023 23:24
[PATCH v3 1/2] gnu: python-hy: Update to 0.26.0.
(address . 62038@debbugs.gnu.org)
20230316222423.23757-1-jackhill@jackhill.us
* gnu/packages/python-xyx.scm (python-hy): Update to 0.26.0.
[propagated-inputs]: Remove python-colorama.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83f3ec02ea..509bfa77d6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15027,7 +15027,7 @@ (define-public python-rply
(define-public python-hy
(package
(name "python-hy")
- (version "0.25.0")
+ (version "0.26.0")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -15036,7 +15036,7 @@ (define-public python-hy
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1am6z9m0s9svysj0wrfz069rpvbqqimphqll3912q4bvdlz6vrjp"))))
+ (base32 "1czhh7s81sg0nrnf4zv0ydqi4f7s6sywf4ks4fd59vpx441ca39v"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -15053,7 +15053,7 @@ (define-public python-hy
(native-inputs
(list python-pytest-7.1 python-wheel))
(propagated-inputs
- (list python-colorama python-funcparserlib))
+ (list python-funcparserlib))
(home-page "https://docs.hylang.org/en/stable/")
(synopsis "Lisp frontend to Python")
(description
--
2.39.2
N
N
Nicolas Goaziou wrote on 3 Apr 2023 18:40
Re: [bug#62038] [PATCH v3 0/2] python-hy update v3 (another typo fix)
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 62038-done@debbugs.gnu.org)
87r0t0or6b.fsf@nicolasgoaziou.fr
Hello,

Jack Hill <jackhill@jackhill.us> writes:

Toggle quote (2 lines)
> Oops, I found yet another typo fix in the code comment. Here's a v3

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
J
J
Jack Hill wrote on 3 Apr 2023 19:59
Re: bug#62038: [PATCH v3 0/2] python-hy update v3 (another typo fix)
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
alpine.DEB.2.21.2304031359420.15296@marsh.hcoop.net
On Mon, 3 Apr 2023, Nicolas Goaziou wrote:

Toggle quote (8 lines)
> Hello,
>
> Jack Hill <jackhill@jackhill.us> writes:
>
>> Oops, I found yet another typo fix in the code comment. Here's a v3
>
> Applied. Thank you.

Great, thank you!
Closed
?