[PATCH] %base-packages-networking: Add 'nss-certs'

  • Done
  • quality assurance status badge
Details
2 participants
  • Jacob Hrbek
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Jacob Hrbek
Severity
normal
J
J
Jacob Hrbek wrote on 7 Mar 2023 07:57
(address . guix-patches@gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20230307065736.28724-1-kreyren@rixotstudio.cz
.. as guix will fail do to updating without it

Signed-off-by: Jacob Hrbek <kreyren@rixotstudio.cz>
---
gnu/system.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/system.scm b/gnu/system.scm
index bb26d7c9a5..95143112bd 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -49,6 +49,7 @@ (define-module (gnu system)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module ((gnu packages certs) #:select nss-certs)
#:use-module (gnu packages compression)
#:use-module (gnu packages cross-base)
#:use-module (gnu packages firmware)
@@ -923,6 +924,7 @@ (define %base-packages-networking
(list inetutils isc-dhcp
iproute
wget
+ nss-certs
;; wireless-tools is deprecated in favor of iw, but it's still what
;; many people are familiar with, so keep it around.
iw wireless-tools))
--
2.37.3
M
M
Maxim Cournoyer wrote on 24 Apr 20:52 +0200
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 62026-done@debbugs.gnu.org)
8734rah9uw.fsf@gmail.com
Hi,

Jacob Hrbek <kreyren@rixotstudio.cz> writes:

Toggle quote (28 lines)
> .. as guix will fail do to updating without it
>
> Signed-off-by: Jacob Hrbek <kreyren@rixotstudio.cz>
> ---
> gnu/system.scm | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/gnu/system.scm b/gnu/system.scm
> index bb26d7c9a5..95143112bd 100644
> --- a/gnu/system.scm
> +++ b/gnu/system.scm
> @@ -49,6 +49,7 @@ (define-module (gnu system)
> #:use-module (gnu packages admin)
> #:use-module (gnu packages base)
> #:use-module (gnu packages bash)
> + #:use-module ((gnu packages certs) #:select nss-certs)
> #:use-module (gnu packages compression)
> #:use-module (gnu packages cross-base)
> #:use-module (gnu packages firmware)
> @@ -923,6 +924,7 @@ (define %base-packages-networking
> (list inetutils isc-dhcp
> iproute
> wget
> + nss-certs
> ;; wireless-tools is deprecated in favor of iw, but it's still what
> ;; many people are familiar with, so keep it around.
> iw wireless-tools))

Merged to master, with some follow-up commits.

--
Thanks,
Maxim
Closed
?