[PATCH] gnu: grep: Update to 3.9

  • Done
  • quality assurance status badge
Details
4 participants
  • Andreas Enge
  • Andy Tai
  • Andy Tai
  • Simon Tournier
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
Merged with

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230305223642.20508-1-atai@atai.org
* gnu/packages/base.scm (grep): Update to 3.9
---
gnu/packages/base.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fa5f1ef32b..0b0776edb3 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -106,14 +106,14 @@ (define-public hello
(define-public grep
(package
(name "grep")
- (version "3.6")
+ (version "3.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/grep/grep-"
version ".tar.xz"))
(sha256
(base32
- "0gipv6bzkm1aihj0ncqpyh164xrzgcxcv9r1kwzyk2g1mzl1azk6"))
+ "16dmf2hsr27lnlxk3vgy9h0ngj5s7gjj5d7y6nplqgg2kr013kdb"))
(patches (search-patches "grep-timing-sensitive-test.patch"))))
(build-system gnu-build-system)
(native-inputs (list perl)) ;some of the tests require it

base-commit: 833febb522bd37a38156b558b108372b89a34949
--
2.39.1
Andreas Enge wrote 2 years ago
grep in core-updates
(address . 61990@debbugs.gnu.org)
ZA5jsIEFN+4GQgya@jurong
Hello Andy,

in core-updates, grep is currently at version 3.8, and it has an enormous
number of dependent packages. So I would suggest to hold this patch back
until the core-updates merge has happened.

Andreas
Andy Tai wrote 2 years ago
[PATCH v2] gnu: grep: Update to 3.10
(address . 61990@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230325221033.10797-1-atai@atai.org
* gnu/packages/base.scm (grep): Update to 3.10
---
gnu/packages/base.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fa5f1ef32b..5363370e53 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -106,14 +106,14 @@ (define-public hello
(define-public grep
(package
(name "grep")
- (version "3.6")
+ (version "3.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/grep/grep-"
version ".tar.xz"))
(sha256
(base32
- "0gipv6bzkm1aihj0ncqpyh164xrzgcxcv9r1kwzyk2g1mzl1azk6"))
+ "0nw5ys5bhcr6c162rl43q5qpmf0bia3bhlcvhw072npvjnssbvr4"))
(patches (search-patches "grep-timing-sensitive-test.patch"))))
(build-system gnu-build-system)
(native-inputs (list perl)) ;some of the tests require it

base-commit: 04724e59971b03f86a410285653d24005c62b924
--
2.39.2
Simon Tournier wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)
867curvqtg.fsf@gmail.com
Hi,

On Sat, 25 Mar 2023 at 15:10, Andy Tai <atai@atai.org> wrote:
Toggle quote (2 lines)
> * gnu/packages/base.scm (grep): Update to 3.10

As Andreas pointed, this patch cannot go to master because it is an
intensive rebuild,

Toggle snippet (4 lines)
$ guix refresh -l grep | cut -f1 -d':'
Building the following 2879 packages would ensure 7748 dependent packages are rebuilt

Therefore, this change must go to the core-updates branch as documented
by point #9 in [1].


Cheers,
simon
Andy Tai wrote 2 years ago
(address . 61990@debbugs.gnu.org)
CAJsg1E-iqn2eMjKto2qYv7CUihE2z2YsLL6dUJuq6juWNK7wPA@mail.gmail.com
will determine next steps once the current core-update is merged to master
Andy Tai wrote 2 years ago
(address . 61990@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230427062018.16903-1-atai@atai.org
* gnu/packages/base.scm (grep): Update to 3.10
---
gnu/packages/base.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 6911ea78be..4d036d97e8 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -107,14 +107,14 @@ (define-public hello
(define-public grep
(package
(name "grep")
- (version "3.8")
+ (version "3.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/grep/grep-"
version ".tar.xz"))
(sha256
(base32
- "10n3mc9n1xmg85hpxyr4wiqzfp27ffxzwhvkv021j27vnk0pr3a9"))
+ "0nw5ys5bhcr6c162rl43q5qpmf0bia3bhlcvhw072npvjnssbvr4"))
(patches (search-patches "grep-timing-sensitive-test.patch"))))
(build-system gnu-build-system)
(native-inputs (list perl)) ;some of the tests require it

base-commit: db19e30673a72ff8ee34276ede5dd081e6023cd3
--
2.39.2
Simon Tournier wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)
86cz3hz5vb.fsf@gmail.com
Hi,

On Wed, 26 Apr 2023 at 23:20, Andy Tai <atai@atai.org> wrote:

Toggle quote (2 lines)
> * gnu/packages/base.scm (grep): Update to 3.10

This should go to a dedicated branch. It leads to the rebuild of ~1/3
of all the packages.

For instance, the recent update of grep in core-updates had broken many
packages because some default behaviour changed.

Cheers,
simon
Andy Tai wrote 2 years ago
[PATCH core-updates v4] gnu: grep: Update to 3.10
(address . 61990@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
77bba9e54c03e2044e0bd33252f34021cd29c00b.1683790980.git.atai@atai.org
* gnu/packages/base.scm (grep): Update to 3.10
---
gnu/packages/base.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d2f276c447..aa439e76db 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -107,14 +107,14 @@ (define-public hello
(define-public grep
(package
(name "grep")
- (version "3.8")
+ (version "3.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/grep/grep-"
version ".tar.xz"))
(sha256
(base32
- "10n3mc9n1xmg85hpxyr4wiqzfp27ffxzwhvkv021j27vnk0pr3a9"))
+ "0nw5ys5bhcr6c162rl43q5qpmf0bia3bhlcvhw072npvjnssbvr4"))
(patches (search-patches "grep-timing-sensitive-test.patch"))))
(build-system gnu-build-system)
(native-inputs (list perl)) ;some of the tests require it

base-commit: b4e5844700b2304bfde451322feb5797bf0c6179
--
2.39.2
Andy Tai wrote 1 years ago
[PATCH core-updates v5] gnu: grep: Update to 3.11
(address . 61990@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
b8ea85d06b7aa538a64145f91f4130517c3a323b.1696952900.git.atai@atai.org
* gnu/packages/base.scm (grep): Update to 3.11
---
gnu/packages/base.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c0813f7de0..4d8b6a7037 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -109,14 +109,14 @@ (define-public hello
(define-public grep
(package
(name "grep")
- (version "3.8")
+ (version "3.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/grep/grep-"
version ".tar.xz"))
(sha256
(base32
- "10n3mc9n1xmg85hpxyr4wiqzfp27ffxzwhvkv021j27vnk0pr3a9"))
+ "0nw5ys5bhcr6c162rl43q5qpmf0bia3bhlcvhw072npvjnssbvr4"))
(patches (search-patches "grep-timing-sensitive-test.patch"))))
(build-system gnu-build-system)
(native-inputs (list perl)) ;some of the tests require it

base-commit: f4e8baf3806e79d7111d2943859865ae4ee0b59d
--
2.41.0
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E8hGURpF7xF5TC8_dDw755PoRuU2GnaOv30t6=zFz0rYQ@mail.gmail.com
merge 61990 66459
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E_zKEgafY=mZ9ud7WKM52kpeJqcchKrxCYEiVGwy5WjRg@mail.gmail.com
unmerge 63095
unmerge 61990
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E8Mj5zRyd6UtpRp24DmQgMhFNqokO8+Xb9YnVKziZL7bw@mail.gmail.com
merge 66459 61990
merge 66460 63095 66331
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 61990@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61990
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help