No console messages with offload inferior

  • Open
  • quality assurance status badge
Details
One participant
  • Greg Hogan
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 3 Mar 2023 16:47
(address . bug-guix@gnu.org)
CA+3U0Zmi9ST4udYEM5pCUb-CGYGj4vq=ymeJbpQSW=9oEgt+xQ@mail.gmail.com
I see no console messages when running an offload build from a
manifest containing an inferior. It's only when the inferior is
included that the logging disappears. A sample manifest exhibiting the
issue:

$ guix build --system=aarch64-linux --manifest=test.scm

Toggle snippet (17 lines)
(use-modules
(guix channels)
(guix inferior))

(define channels
(list (channel
(name 'guix)
(url "https://git.savannah.gnu.org/git/guix.git")
(commit
"312f1f41d3f3f3e5d2c36ff46920c6dce1c21a17"))))

(define (pinned-version name)
(car (lookup-inferior-packages (inferior-for-channels channels) name)))

(packages->manifest
`(,(pinned-version "ungoogled-chromium")))
G
G
Greg Hogan wrote on 18 Apr 2023 19:17
(address . bug-guix@gnu.org)
CA+3U0ZkqdffPHEiXtvSAEEoLmwbePP_HVq_Gm-aoMO+r2qqG_w@mail.gmail.com
On Fri, Mar 3, 2023 at 10:47?AM Greg Hogan <code@greghogan.com> wrote:
Toggle quote (6 lines)
>
> I see no console messages when running an offload build from a
> manifest containing an inferior. It's only when the inferior is
> included that the logging disappears. A sample manifest exhibiting the
> issue:

I am also seeing this issue when building a local profile. There is no
obvious pattern to what triggers the lack of messages, but it is
consistent. For example, I recently changed my manifest to pin the
version of "libreoffice" and no longer see display logging after the
package listing ("The following packages will be installed: ...") even
though I can see packages being built (ls /tmp).
?