[PATCH 0/9] *** A requested with 8 dependencies ***

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303125046.88428-1-navid.afkhami@mdc-berlin.de
*** A requested package, which is r-seurat-utils, that has 8 dependencies ***

Navid Afkhami (9):
gnu: Add r-stringendo.
gnu: Add r-readwriter.
gnu: Add r-codeandroll2.
gnu: Add r-markdownhelpers.
gnu: Add r-markdownreports.
gnu: Add r-ggexpress.
gnu: Add r-tictoc.
gnu: Add r-hgnchelper.
gnu: Add r-seurat-utils.

gnu/packages/bioinformatics.scm | 281 ++++++++++++++++++++++++++++++++
1 file changed, 281 insertions(+)


base-commit: 4f681cdbc27e6a922f24d4297efe3c0b823195f0
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 1/9] gnu: Add r-stringendo.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-stringendo): New variable.
---
gnu/packages/bioinformatics.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 858fd1e975..caa50ce3bd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -793,6 +793,30 @@ (define-public r-rhtslib12
developers of other R packages who wish to make use of HTSlib.")
(license license:lgpl2.0+))))
+(define-public r-stringendo
+ (let ((commit "83b8f2d82a09b33b9e895438bb523a021138be01")
+ (revision "1"))
+ (package
+ (name "r-stringendo")
+ (version (git-version "0.3.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/Stringendo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ap0nhbyd6xx0yl2vgmwk38p22yrkv4k9hw13r35z4wf343rry6v"))))
+ (properties `((upstream-name . "Stringendo")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-devtools r-usethis))
+ (home-page "https://github.com/vertesy/Stringendo")
+ (synopsis "Stringendo is a string parsing library")
+ (description
+ "String parsing functionalites for generating plotnames, filenames and path.")
+ (license license:gpl3))))
+
(define-public r-streamgraph
(let ((commit "76f7173ec89d456ace5943a512e20b1f6810bbcb")
(revision "1"))

base-commit: 4f681cdbc27e6a922f24d4297efe3c0b823195f0
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 2/9] gnu: Add r-readwriter.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-2-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-readwriter): New variable.
---
gnu/packages/bioinformatics.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index caa50ce3bd..42e082765e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -817,6 +817,31 @@ (define-public r-stringendo
"String parsing functionalites for generating plotnames, filenames and path.")
(license license:gpl3))))
+(define-public r-readwriter
+ (let ((commit "71454f4aa706f5d2fbe606acd95abc14224e7058")
+ (revision "1"))
+ (package
+ (name "r-readwriter")
+ (version (git-version "0.2.9" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/ReadWriter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sp27smhdva2hi2x0svia2l56k8xrh7p5akn78g5b0lcvz4x3hd7"))))
+ (properties `((upstream-name . "ReadWriter")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-gdata r-gtools r-openxlsx r-readr
+ r-stringendo))
+ (home-page "https://github.com/vertesy/ReadWriter")
+ (synopsis "Functions to read and write files conveniently")
+ (description
+ "ReadWriter is a set of R functions to read and write files conveniently.")
+ (license license:gpl3))))
+
(define-public r-streamgraph
(let ((commit "76f7173ec89d456ace5943a512e20b1f6810bbcb")
(revision "1"))
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 4/9] gnu: Add r-markdownhelpers.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-4-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-markdownhelpers): New variable.
---
gnu/packages/bioinformatics.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fdfbf6459b..c6c0da74ff 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8813,6 +8813,30 @@ (define-public r-sccustomize
visualization and analysis of single-cell data using R.")
(license license:gpl3+))))
+(define-public r-markdownhelpers
+ (let ((commit "793372d28ebed607cc1d35f909a1caedb2b41ffe")
+ (revision "1"))
+ (package
+ (name "r-markdownhelpers")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/MarkdownHelpers")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d18s2ydhfjm3hjkxz42dirhwrrv792m6mvkmypallaa2qnwrmkg"))))
+ (properties `((upstream-name . "MarkdownHelpers")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-devtools r-stringendo r-usethis))
+ (home-page "https://github.com/vertesy/MarkdownHelpers")
+ (synopsis "Helper functions for MarkdownReports and ggExpress")
+ (description
+ "Set of R functions to parse markdown and other generic helpers.")
+ (license license:gpl3))))
+
(define-public r-snapatac
(package
(name "r-snapatac")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 5/9] gnu: Add r-markdownreports.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-5-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-markdownreports): New variable.
---
gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c6c0da74ff..b311ec6c33 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8837,6 +8837,43 @@ (define-public r-markdownhelpers
"Set of R functions to parse markdown and other generic helpers.")
(license license:gpl3))))
+(define-public r-markdownreports
+ (let ((commit "3ba1103e3ddc6df3a0c090eb884f5e65c461eb31")
+ (revision "1"))
+ (package
+ (name "r-markdownreports")
+ (version (git-version "4.5.9" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/MarkdownReports")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xmasdb630b6nvxi5m1i8pyxiy49nxpzyxf9h8spdppx92rhdkc8"))))
+ (properties `((upstream-name . "MarkdownReports")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-clipr
+ r-codeandroll2
+ r-colorramps
+ r-devtools
+ r-gplots
+ r-markdownhelpers
+ r-rcolorbrewer
+ r-readwriter
+ r-sessioninfo
+ r-sm
+ r-stringendo
+ r-venndiagram
+ r-vioplot))
+ (home-page "https://github.com/vertesy/MarkdownReports")
+ (synopsis "Tool for generating cientific figures and reports")
+ (description
+ "This is a set of R functions that allows you to generate precise figures.
+This tool will create clean markdown reports about what you just discovered.")
+ (license license:gpl3))))
+
(define-public r-snapatac
(package
(name "r-snapatac")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 3/9] gnu: Add r-codeandroll2.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-3-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-codeandroll2): New variable.
---
gnu/packages/bioinformatics.scm | 34 +++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 42e082765e..fdfbf6459b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -719,6 +719,40 @@ (define-public r-btools
for all types of microbial diversity analyses.")
(license license:expat))))
+(define-public r-codeandroll2
+ (let ((commit "d58e258851a5c0b430e8620d34dbeefb597c548f")
+ (revision "1"))
+ (package
+ (name "r-codeandroll2")
+ (version (git-version "2.3.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/CodeAndRoll2")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sy88mfgw6qqhpnlc5020qzr1jllkcrxfhl2lw42bkl5nb56is71"))))
+ (properties `((upstream-name . "CodeAndRoll2")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-colorramps
+ r-dplyr
+ r-gplots
+ r-gtools
+ r-plyr
+ r-rcolorbrewer
+ r-sessioninfo
+ r-sm
+ r-stringendo
+ r-stringr))
+ (home-page "https://github.com/vertesy/CodeAndRoll2")
+ (synopsis "CodeAndRoll2 for vector, matrix and list manipulations")
+ (description
+ "CodeAndRoll2 is a set of more than 130 productivity functions.
+These functions are used by MarkdownReports, ggExpress, SeuratUtils.")
+ (license license:gpl3))))
+
(define-public r-conospanel
(let ((commit "39e76b201a783b4e92fd615010a735a61746fbb9")
(revision "1"))
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 6/9] gnu: Add r-ggexpress.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-6-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-ggexpress): New variable.
---
gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b311ec6c33..14efaa9570 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8302,6 +8302,43 @@ (define-public infernal
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:bsd-3)))
+(define-public r-ggexpress
+ (let ((commit "82f169385f87af328ff971195c2f64ff3c573a8a")
+ (revision "1"))
+ (package
+ (name "r-ggexpress")
+ (version (git-version "0.6.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/ggExpress")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "122hnw8xv33ngcd4fd7hmf817a06ih1knrxxi0cgklj1fwinm0z4"))))
+ (properties `((upstream-name . "ggExpress")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-cowplot
+ r-ggplot2
+ r-ggpubr
+ r-markdownhelpers
+ r-markdownreports
+ r-rcolorbrewer
+ r-sessioninfo
+ r-seurat
+ r-sm
+ r-stringendo
+ r-tidyverse))
+ (home-page "https://github.com/vertesy/ggExpress")
+ (synopsis
+ "This is a fast tool to create, annotate and export plots in R")
+ (description
+ "This package is a set of R functions for generating precise figures.
+This tool helps you to create clean markdown reports about what you just
+discovered with your analysis script.")
+ (license license:gpl3))))
+
(define-public r-gg3d
(let ((commit "ffdd837d30c1671cd0895db94bdd7b1594dbfcb0")
(revision "1"))
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 7/9] gnu: Add r-tictoc.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-7-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-tictoc): New variable.
---
gnu/packages/bioinformatics.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 14efaa9570..42d0923ab1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8960,6 +8960,28 @@ (define-public r-snapatac
single cell ATAC-seq sequencing data.")
(license license:gpl3)))
+(define-public r-tictoc
+ (package
+ (name "r-tictoc")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "tictoc" version))
+ (sha256
+ (base32
+ "0ka7zd857xfqb5afn0psn0yzfv2qjb0ddxfyiq6aggbnla5qc3qj"))))
+ (properties `((upstream-name . "tictoc")))
+ (build-system r-build-system)
+ (home-page "https://github.com/jabiru/tictoc")
+ (synopsis
+ "Functions for timing R scripts and implementations of stack and list structures")
+ (description
+ "The tictoc package provides the timing functions tic and toc that can be nested.
+It provides an alternative to @code{system.time()} with a different syntax similar to
+that in another well-known software package. tic and toc are easy to use, and are
+especially useful when timing several sections in more than a few lines of code.")
+ (license license:asl2.0)))
+
(define-public r-tsis
(let ((commit "24460298fbe1d26e4da390f6e4f3d4d9d62334dc")
(revision "1"))
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 8/9] gnu: Add r-hgnchelper.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-8-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-hgnchelper): New variable.
---
gnu/packages/bioinformatics.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 42d0923ab1..b179fcb61a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9139,6 +9139,29 @@ (define-public r-archr
"This package is designed to streamline scATAC analyses in R.")
(license license:gpl2+))))
+(define-public r-hgnchelper
+ (package
+ (name "r-hgnchelper")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "HGNChelper" version))
+ (sha256
+ (base32
+ "0qwkk5658j4j6w2wgvxkp38cyvscjp93d3zc7gb97vcihqx0ngxa"))))
+ (properties `((upstream-name . "HGNChelper")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/waldronlab/HGNChelper")
+ (synopsis
+ "Identification and correction of invalid gene symbols for human and mouse")
+ (description
+ "Set of R functions for identifying and correcting HGNC human gene symbols.
+In addition, you can identify MGI mouse gene symbols, which have been converted
+to date format by Excel, withdrawn, or aliased. Also contains functions for
+reversibly converting between HGNC symbols and valid R names.")
+ (license license:gpl2+)))
+
(define-public r-icellnet
;; v1.0 tagged in 2020, last commit contains many fixes.
;; DESCRIPTION says Version: 0.0.0.9000.
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH vREVISION 9/9] gnu: Add r-seurat-utils.
(address . 61933@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230303130723.88484-9-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-seurat-utils): New variable.
---
gnu/packages/bioinformatics.scm | 55 +++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b179fcb61a..31dd2d856f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15955,6 +15955,61 @@ (define-public r-scopeloomr
files.")
(license license:expat))))
+(define-public r-seurat-utils
+ (let ((commit "0b6f5b548a49148cfbeaa654e8a618c0a020afa5")
+ (revision "1"))
+ (package
+ (name "r-seurat-utils")
+ (version (git-version "1.6.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/Seurat.utils")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mn64h375mkj6x4ix5493z32gqg96yc507j5jr0lx9g5wk1bf762"))))
+ (properties `((upstream-name . "Seurat.utils")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-codeandroll2
+ r-cowplot
+ r-dplyr
+ r-ggcorrplot
+ r-ggexpress
+ r-ggplot2
+ r-ggpubr
+ r-ggrepel
+ r-hgnchelper
+ r-htmlwidgets
+ r-markdownhelpers
+ r-markdownreports
+ r-matrix
+ r-matrixstats
+ r-princurve
+ r-r-utils
+ r-readr
+ r-readwriter
+ r-reshape2
+ r-scales
+ r-seurat
+ r-soupx
+ r-sparsematrixstats
+ r-stringendo
+ r-stringr
+ r-tibble
+ r-tictoc
+ r-vroom))
+ (home-page "https://github.com/vertesy/Seurat.utils")
+ (synopsis "Seurat.utils is a collection of utility functions for Seurat")
+ (description
+ "This is a collection of utility functions for Seurat v3.
+These Functions allow the automation and multiplexing of plotting,
+3D plotting, visualisation of statistics & QC, interaction with the
+Seurat object. Some functionalities require functions from
+CodeAndRoll and MarkdownReports libraries.")
+ (license license:gpl3))))
+
(define-public r-seuratwrappers
;; There are no releases or tags.
(let ((commit "d28512f804d5fe05e6d68900ca9221020d52cf1d")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
[PATCH 0/9] *** A requested with 8 dependencies ***
(address . 61933-done@debbugs.gnu.org)
87h6v1exdn.fsf@elephly.net
Thank you for the patches. I applied them all with minor changes to the
descriptions.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61933@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61933
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help