[PATCH] gnu: Add r-oscope.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230303105625.36854-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-oscope): New variable.
---
gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 22be8d3772..78eb24625f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7425,6 +7425,32 @@ (define-public r-organismdbi
the fact that each of these packages implements a select methods.")
(license license:artistic2.0)))
+(define-public r-oscope
+ (package
+ (name "r-oscope")
+ (version "1.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Oscope" version))
+ (sha256
+ (base32
+ "0454f9yc0jmg3mcq9264wb5v2n8n0kaf801hlvsiy1xa3baj3h29"))))
+ (properties `((upstream-name . "Oscope")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocparallel r-cluster r-ebseq r-testthat))
+ (home-page "https://bioconductor.org/packages/Oscope")
+ (synopsis
+ "Scillatory genes identifier in unsynchronized single cell RNA-seq")
+ (description
+ "Oscope is a oscillatory genes identifier in unsynchronized single cell RNA-seq.
+This statistical pipeline has been developed to identify and recover the
+base cycle profiles of oscillating genes in an unsynchronized single cell
+RNA-seq experiment. The Oscope pipeline includes three modules: a sine model
+module to search for candidate oscillator pairs; a K-medoids clustering module
+to cluster candidate oscillators into groups; and an extended nearest insertion
+module to recover the base cycle order for each oscillator group.")
+ (license license:asl2.0)))
+
(define-public r-pcaexplorer
(package
(name "r-pcaexplorer")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 61931-done@debbugs.gnu.org)
87pm9qdrh8.fsf@elephly.net
Thanks for the patch. I have applied it with commit
4f681cdbc27e6a922f24d4297efe3c0b823195f0.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61931@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61931
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help