Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
* guix/scripts/install.scm: Expose 'allow-collisions' option of 'package'
for 'upgrade' alias
---
guix/scripts/upgrade.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (30 lines)
diff --git a/guix/scripts/upgrade.scm b/guix/scripts/upgrade.scm
index beb59cbe6f..423760a93b 100644
--- a/guix/scripts/upgrade.scm
+++ b/guix/scripts/upgrade.scm
@@ -36,6 +36,8 @@ (define (show-help)
This is an alias for 'guix package -u'.\n"))
(display (G_ "
-p, --profile=PROFILE use PROFILE instead of the user's default profile"))
+ (display (G_ "
+ --allow-collisions do not treat collisions in the profile as an error"))
(display (G_ "
-v, --verbosity=LEVEL use the given verbosity LEVEL"))
(display (G_ "
@@ -65,7 +67,8 @@ (define %options
;; Preserve some of the 'guix package' options.
(append (filter (lambda (option)
(any (cut member <> (option-names option))
- '("profile" "dry-run" "verbosity" "do-not-upgrade")))
+ '("profile" "dry-run" "verbosity" "do-not-upgrade"
+ "allow-collisions")))
%package-options)
%transformation-options
base-commit: ef7df2ca7bb212455f1d6bbef5bbf7b1ac5a189d
prerequisite-patch-id: 5c2c505e1fefe02b0b8fe068d673dcc8fcc8b246
prerequisite-patch-id: b3de9e1babefba1a1903b848f185b9f8bcb224f4
prerequisite-patch-id: d827e9c76e13bae69214ec1b674b0f6bfc4bfb34
--
2.39.1