[PATCH] scripts: Expose 'allow-collisions' for 'guix upgrade'

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Josselin Poiret
  • Simon Tournier
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230302064930.7947-1-atai@atai.org
* guix/scripts/install.scm: Expose 'allow-collisions' option of 'package'
for 'upgrade' alias
---
guix/scripts/upgrade.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/guix/scripts/upgrade.scm b/guix/scripts/upgrade.scm
index beb59cbe6f..423760a93b 100644
--- a/guix/scripts/upgrade.scm
+++ b/guix/scripts/upgrade.scm
@@ -36,6 +36,8 @@ (define (show-help)
This is an alias for 'guix package -u'.\n"))
(display (G_ "
-p, --profile=PROFILE use PROFILE instead of the user's default profile"))
+ (display (G_ "
+ --allow-collisions do not treat collisions in the profile as an error"))
(display (G_ "
-v, --verbosity=LEVEL use the given verbosity LEVEL"))
(display (G_ "
@@ -65,7 +67,8 @@ (define %options
;; Preserve some of the 'guix package' options.
(append (filter (lambda (option)
(any (cut member <> (option-names option))
- '("profile" "dry-run" "verbosity" "do-not-upgrade")))
+ '("profile" "dry-run" "verbosity" "do-not-upgrade"
+ "allow-collisions")))
%package-options)
%transformation-options

base-commit: ef7df2ca7bb212455f1d6bbef5bbf7b1ac5a189d
prerequisite-patch-id: 5c2c505e1fefe02b0b8fe068d673dcc8fcc8b246
prerequisite-patch-id: b3de9e1babefba1a1903b848f185b9f8bcb224f4
prerequisite-patch-id: d827e9c76e13bae69214ec1b674b0f6bfc4bfb34
--
2.39.1
Simon Tournier wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)
86cz4jvr6b.fsf@gmail.com
Hi,

On Wed, 01 Mar 2023 at 22:49, Andy Tai <atai@atai.org> wrote:
Toggle quote (3 lines)
> * guix/scripts/install.scm: Expose 'allow-collisions' option of 'package'
> for 'upgrade' alias

I would apply the same explanation as Leo in [1] for #61864,

[PATCH] scripts: expose 'allow-collisions' for 'guix install'



Cheers,
simon
Josselin Poiret wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)
87lehm1wuh.fsf@jpoiret.xyz
Hi Andy and Simon,

Simon Tournier <zimon.toutoune@gmail.com> writes:

Toggle quote (12 lines)
> Hi,
>
> On Wed, 01 Mar 2023 at 22:49, Andy Tai <atai@atai.org> wrote:
>> * guix/scripts/install.scm: Expose 'allow-collisions' option of 'package'
>> for 'upgrade' alias
>
> I would apply the same explanation as Leo in [1] for #61864,
>
> [PATCH] scripts: expose 'allow-collisions' for 'guix install'
>
> 1: http://issues.guix.gnu.org/msgid/ZChh1GFQnKRBITmL@jasmine.lan

I agree. Closing, but feel free to continue the discussion.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmRlRHYQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcailpTC/9Tz9YP0WFh2NMB7QuuMMlQGz/GrRoDzTek
JR0VjnEL3DLNhk/1V4qZ1URxD5TXjrS+iUbk1yTpc+/DMvKCyNySo0p0pF5G8ePi
yC+ThJT4J3XqowYxrRlNCRMLr+P0wTKID9Xrr4yNLUb4v5X9pLLdNaFbh5oB3xga
Rk/fdrBpskTD4U86lhGH/FZshFMGmEKvV7EOV2GPOiOE0ihAJUlBN+DsEzNZeOji
27LNGYSHShU5RGxT0HnWdc+eB2fjPRcBJd9LdtWftjuJB7NtbKd/wyqCmnpJ7Ihr
rjP0mojULMKtZyjWjw/87QoiX21xetkSSzBUi+FYxgJs/wVwXuQ/5RXcwjhTaMu1
4h50YsydPuXLmtZzDWOgVXAR82kz20+BA4epV+/ftSwAtoh3PGBsQvSKRsP0RD0o
LJzYG46D344WtAcjsp3sdqyjylPBt+d/JXGm2eOcmi7Yfv51qi4fYthHKey9w2dC
piZo2yfco1bt0Z9diUmHfoqreKSzPWc=
=feYB
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61907@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61907
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help