[PATCH] gnu: Add r-biglm, r-cplm, r-som, r-chemometrics, r-metagenomeseq, r-maaslin2, r-mmuphin.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
b8977680-f41e-93b0-ebc4-9515542e885b@mdc-berlin.de
* gnu/packages/cran.scm (r-biglm, r-cplm, r-som, r-chemometrics): New
variables.

* gnu/packages/bioconductor.scm (r-metagenomeseq, r-maaslin2,
r-mmuphin): New variables.
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/7] gnu: Add r-cplm.
(address . 61891@debbugs.gnu.org)
20230301072343.708693-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-cplm): New variable.
---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fc8fe1a449..ddff93aa0d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -325,6 +325,41 @@ (define-public r-collections
queues, stacks, deques, dicts and ordered dicts.")
(license license:expat)))
+(define-public r-cplm
+ (package
+ (name "r-cplm")
+ (version "0.7-10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cplm" version))
+ (sha256
+ (base32 "0mqjk10265hq9bc5ihmgbx1l8fzay1gpdlvx3pirqmvr3w1kwlxk"))))
+ (properties `((upstream-name . "cplm")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biglm
+ r-coda
+ r-ggplot2
+ r-matrix
+ r-minqa
+ r-nlme
+ r-reshape2
+ r-statmod
+ r-tweedie))
+ (home-page "https://github.com/actuaryzhang/cplm")
+ (synopsis "Compound Poisson linear models")
+ (description "The Tweedie compound Poisson distribution is a mixture of a
+degenerate distribution at the origin and a continuous distribution on the positive
+real line. It has been applied in a wide range of fields in which continuous data
+with exact zeros regularly arise. The cplm package provides likelihood based and
+Bayesian procedures for fitting common Tweedie compound Poisson linear models.
+In particular, models with hierarchical structures or extra zero inflation can be
+handled. Further, the package implements the Gini index based on an ordered version
+of the Lorenz curve as a robust model comparison tool involving zero-inflated and
+highly skewed distributions.")
+ (license license:gpl2+)))
+
(define-public r-curry
(package
(name "r-curry")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/7] gnu: Add r-biglm.
(address . 61891@debbugs.gnu.org)
20230301072343.708693-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-biglm): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c7a81b96eb..fc8fe1a449 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1145,6 +1145,25 @@ (define-public r-bezier
degree elevation and curve fitting.")
(license license:gpl2+)))
+(define-public r-biglm
+ (package
+ (name "r-biglm")
+ (version "0.9-2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "biglm" version))
+ (sha256
+ (base32 "0iy9xr2bq42wlizgwlz7w5kh9206yqkw9h2cr6mcsmizgjg3rkvd"))))
+ (properties `((upstream-name . "biglm")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dbi))
+ (native-inputs (list gfortran))
+ (home-page "https://cran.r-project.org/package=biglm")
+ (synopsis "Bounded memory linear and generalized linear models")
+ (description "Regression for data too large to fit in memory.")
+ (license (list license:gpl2+ license:gpl3+)))) ;;expanded from GPL
+
(define-public r-bwstest
(package
(name "r-bwstest")

base-commit: efa091f9f4e77068353dff24f0ccd2d0613c3f48
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
(address . 61891@debbugs.gnu.org)
20230301072343.708693-3-madalinionel.patrascu@mdc-berlin.de
Date: Thu, 23 Feb 2023 00:56:33 +0100
Subject: [PATCH 3/7] gnu: Add r-som.

* gnu/packages/cran.scm (r-som): New variable.
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ddff93aa0d..b3aff2ee2c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16017,6 +16017,34 @@ (define-public r-softimpute
components).")
(license license:gpl2)))
+(define-public r-som
+ (package
+ (name "r-som")
+ (version "0.3-5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "som" version))
+ (sha256
+ (base32 "1fbza1jxvwrkf5x3inkj36vshhkn7mz0ajqlxalbfmk6ngjw1x56"))))
+ (properties `((upstream-name . "som")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=som")
+ (synopsis "Self-organizing map")
+ (description
+ "This package implements a self-organizing map which has application in gene
+clustering. It provides functions like:
+@itemize
+@item filtering data by certain floor, ceiling, max/min ratio, and max - min
+difference;
+@item normalization of the data;
+@item get the average distortion measure;
+@item train a self-organizing map;
+@item summarize a som object;
+@item yeast cell cycle.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public r-fftwtools
(package
(name "r-fftwtools")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
(address . 61891@debbugs.gnu.org)
20230301072343.708693-5-madalinionel.patrascu@mdc-berlin.de
Date: Thu, 23 Feb 2023 01:35:43 +0100
Subject: [PATCH 5/7] gnu: Add r-metagenomeseq.

* gnu/packages/bioconductor.scm (r-metagenomeseq): New variable.
---
gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4b5ec7db28..7de5750e09 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6644,6 +6644,39 @@ (define-public r-maser
and visualizaton of alternative splicing events generated by rMATS.")
(license license:expat)))
+(define-public r-metagenomeseq
+ (package
+ (name "r-metagenomeseq")
+ (version "1.40.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "metagenomeSeq" version))
+ (sha256
+ (base32 "01wjw4kcm8ysa5sn3cqg4a9i5pyksnwmbdqp5fr6n2l9hllkc9jy"))))
+ (properties `((upstream-name . "metagenomeSeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-foreach
+ r-glmnet
+ r-gplots
+ r-limma
+ r-matrix
+ r-matrixstats
+ r-rcolorbrewer
+ r-wrench))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/HCBravoLab/metagenomeSeq")
+ (synopsis "Statistical analysis for sparse high-throughput sequencing")
+ (description
+ "MetagenomeSeq is designed to determine features (be it @acronym{OTU, Operational
+Taxanomic Unit}, species, etc.) that are differentially abundant between two or
+more groups of multiple samples. This package is designed to address the effects
+of both normalization and under-sampling of microbial communities on disease
+association detection and the testing of feature correlations.")
+ (license license:artistic2.0)))
+
(define-public r-metaneighbor
(package
(name "r-metaneighbor")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
(address . 61891@debbugs.gnu.org)
20230301072343.708693-4-madalinionel.patrascu@mdc-berlin.de
Date: Thu, 23 Feb 2023 01:20:10 +0100
Subject: [PATCH 4/7] gnu: Add r-chemometrics.

* gnu/packages/cran.scm (r-chemometrics): New variable.
---
gnu/packages/cran.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b3aff2ee2c..fc24f3eafc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17025,6 +17025,44 @@ (define-public r-chemometricswithr
Life Sciences\" by Ron Wehrens, Springer (2011).")
(license license:gpl2+)))
+(define-public r-chemometrics
+ (package
+ (name "r-chemometrics")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "chemometrics" version))
+ (sha256
+ (base32 "0shqns0n964pfwnd0q5sadglrlpgs4g5fbv45fsj9p37l4pq61dp"))))
+ (properties `((upstream-name . "chemometrics")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-class
+ r-e1071
+ r-lars
+ r-mass
+ r-mclust
+ r-nnet
+ r-pcapp
+ r-pls
+ r-robustbase
+ r-rpart
+ r-som))
+ (home-page "http://www.statistik.tuwien.ac.at/public/filz/")
+ (synopsis "Multivariate statistical analysis in Chemometrics")
+ (description
+ "Multivariate data analysis is the simultaneous observation of more than one
+characteristic. In contrast to the analysis of univariate data, in this approach
+not only a single variable or the relation between two variables can be investigated,
+but the relations between many attributes can be considered. For the statistical
+analysis of chemical data one has to take into account the special structure of
+this type of data. This package contains about 30 functions, mostly for regression,
+classification and model evaluation and includes some data sets used in the R help
+examples. It was designed as a R companion to the book \"Introduction to Multivariate
+Statistical Analysis in Chemometrics\" written by K. Varmuza and P. Filzmoser (2009).")
+ (license license:gpl3+)))
+
(define-public r-als
(package
(name "r-als")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
(address . 61891@debbugs.gnu.org)
20230301072343.708693-7-madalinionel.patrascu@mdc-berlin.de
Date: Wed, 1 Mar 2023 08:16:27 +0100
Subject: [PATCH 7/7] gnu: Add r-mmuphin.

* gnu/packages/bioconductor.scm (r-mmuphin): New variable.
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c7f623343e..afe969e5de 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6811,6 +6811,46 @@ (define-public r-methylkit
TAB-Seq.")
(license license:artistic2.0)))
+(define-public r-mmuphin
+ (package
+ (name "r-mmuphin")
+ (version "1.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "MMUPHin" version))
+ (sha256
+ (base32 "0vpap3avmrjy187s3dva6f008al6d935kpdf816xzl5gxl7zvf62"))))
+ (properties `((upstream-name . "MMUPHin")))
+ (build-system r-build-system)
+ (arguments
+ (list #:tests? #f)) ;; non deterministic, also it requieres http access
+ (inputs (list glpk))
+ (propagated-inputs
+ (list r-cowplot
+ r-biocstyle
+ r-dplyr
+ r-fpc
+ r-ggplot2
+ r-igraph
+ r-maaslin2
+ r-metafor
+ r-stringr
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/MMUPHin")
+ (synopsis "Meta-analysis with uniform pipeline for heterogeneity in microbiome")
+ (description
+ "MMUPHin is an R package for meta-analysis tasks of microbiome cohorts. It
+has function interfaces for:
+@itemize
+@item covariate-controlled batch- and cohort effect adjustment;
+@item meta-analysis differential abundance testing;
+@item meta-analysis unsupervised discrete structure (clustering) discovery;
+@item meta-analysis unsupervised continuous structure discovery.
+@end itemize")
+ (license license:expat)))
+
(define-public r-motifrg
(package
(name "r-motifrg")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
(address . 61891@debbugs.gnu.org)
20230301072343.708693-6-madalinionel.patrascu@mdc-berlin.de
Date: Wed, 1 Mar 2023 04:17:48 +0100
Subject: [PATCH 6/7] gnu: Add r-maaslin2.

* gnu/packages/bioconductor.scm (r-maaslin2): New variable.
---
gnu/packages/bioconductor.scm | 51 +++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7de5750e09..c7f623343e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6533,6 +6533,57 @@ (define-public r-limma
different technologies, including microarrays, RNA-seq, and quantitative PCR.")
(license license:gpl2+)))
+(define-public r-maaslin2
+ (package
+ (name "r-maaslin2")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Maaslin2" version))
+ (sha256
+ (base32 "0ncvsywn9f8766gjb8nxzg82p3w30g8pjs85sy8s0bz9ilanpy89"))))
+ (properties `((upstream-name . "Maaslin2")))
+ (build-system r-build-system)
+ (arguments (list #:tests? #f)) ;test suite is non-deterministic :(
+ (propagated-inputs
+ (list r-biglm
+ r-car
+ r-chemometrics
+ r-cplm
+ r-data-table
+ r-dplyr
+ r-edger
+ r-ggplot2
+ r-glmmtmb
+ r-hash
+ r-lme4
+ r-lmertest
+ r-logging
+ r-lpsymphony
+ r-mass
+ r-mumin
+ r-metagenomeseq
+ r-optparse
+ r-pbapply
+ r-pcapp
+ r-pheatmap
+ r-pscl
+ r-rmarkdown
+ r-robustbase
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "http://huttenhower.sph.harvard.edu/maaslin2")
+ (synopsis
+ "Multivariable association discovery in population-scale meta-omics studies")
+ (description
+ "MaAsLin2 is comprehensive R package for efficiently determining multivariable
+association between clinical metadata and microbial meta'omic features. This
+package relies on general linear models to accommodate most modern epidemiological
+study designs, including cross-sectional and longitudinal, and offers a variety
+of data exploration, normalization, and transformation methods.")
+ (license license:expat)))
+
(define-public r-made4
(package
(name "r-made4")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
(address . 61891@debbugs.gnu.org)
20230301105339.709043-1-madalinionel.patrascu@mdc-berlin.de
Date: Wed, 1 Mar 2023 11:50:40 +0100
Subject: [PATCH] gnu: Test builds for r-maaslin and r-mmuphin.scm

This is my try to make the build of these two package reproducible.

I send this only in the case if the reviewer wants to dig more and maybe he can
solve the non deterministic build.
---
gnu/packages/bioconductor.scm | 138 ++++++++++++++++++++++++++++++++++
1 file changed, 138 insertions(+)

Toggle diff (172 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7de5750e09..15fad711af 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -33,6 +33,7 @@ (define-module (gnu packages bioconductor)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system r)
#:use-module (gnu packages)
@@ -6533,6 +6534,80 @@ (define-public r-limma
different technologies, including microarrays, RNA-seq, and quantitative PCR.")
(license license:gpl2+)))
+(define-public r-maaslin2
+ (package
+ (name "r-maaslin2")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Maaslin2" version))
+ (sha256
+ (base32 "0ncvsywn9f8766gjb8nxzg82p3w30g8pjs85sy8s0bz9ilanpy89"))))
+ (properties `((upstream-name . "Maaslin2")))
+ (build-system r-build-system)
+ (arguments (list ;;#:tests? #f)) ;test suite is non-deterministic :(
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; During the check there is needed for writable cache directory
+ ;; Fontconfig error: No writable cache directories
+ (add-before 'check 'set-cache
+ (lambda _
+ (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")))
+ ;; The check phase generates some log and pdf files. This cause that
+ ;; the build to be not reproducible
+ (add-after 'check 'make-reproducible
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append (assoc-ref outputs "out") "/site-library/Maaslin2/")))
+ (for-each delete-file-recursively
+ (list ;;(string-append out "Maaslin2-Ex.Rout")
+ ;;(string-append #$output "/Maaslin2-Ex.pdf")
+ ;;(string-append #$output "/Maaslin2-tests/testthat/output")
+ ;;(string-append #$output "/Maaslin2-tests/testthat/output2")
+ ;;(string-append #$output "Maaslin2-tests/testthat.Rout")
+ (string-append out "doc/demo_output/maaslin2.log")
+ (string-append out "doc/demo_output/figures")
+ ;;"doc/demo_output"
+ )))))
+ )))
+ (propagated-inputs
+ (list r-biglm
+ r-car
+ r-chemometrics
+ r-cplm
+ r-data-table
+ r-dplyr
+ r-edger
+ r-ggplot2
+ r-glmmtmb
+ r-hash
+ r-lme4
+ r-lmertest
+ r-logging
+ r-lpsymphony
+ r-mass
+ r-mumin
+ r-metagenomeseq
+ r-optparse
+ r-pbapply
+ r-pcapp
+ r-pheatmap
+ r-pscl
+ r-rmarkdown
+ r-robustbase
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "http://huttenhower.sph.harvard.edu/maaslin2")
+ (synopsis
+ "Multivariable association discovery in population-scale meta-omics studies")
+ (description
+ "MaAsLin2 is comprehensive R package for efficiently determining multivariable
+association between clinical metadata and microbial meta'omic features. This
+package relies on general linear models to accommodate most modern epidemiological
+study designs, including cross-sectional and longitudinal, and offers a variety
+of data exploration, normalization, and transformation methods.")
+ (license license:expat)))
+
(define-public r-made4
(package
(name "r-made4")
@@ -6760,6 +6835,69 @@ (define-public r-methylkit
TAB-Seq.")
(license license:artistic2.0)))
+(define-public r-mmuphin
+ (package
+ (name "r-mmuphin")
+ (version "1.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "MMUPHin" version))
+ (sha256
+ (base32 "0vpap3avmrjy187s3dva6f008al6d935kpdf816xzl5gxl7zvf62"))))
+ (properties `((upstream-name . "MMUPHin")))
+ (build-system r-build-system)
+ (arguments
+ (list ;;#:tests? #f)) ;; non deterministic, also it requieres http access
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'adjusts-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "inst/doc/MMUPHin.Rmd"
+ (("../man/figures")
+ (string-append #$output "/site-library/MMUPHin/help/figures")))
+ ;;(substitute* "inst/doc/MMUPHin.R"
+ ;; (("library(ggplot2)") "library(ggplot2)\ngetwd()"))
+ ))
+ (add-after 'install 'add-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (install-file "man/figures/structure_types.PNG"
+ (string-append #$output "/site-library/MMUPHin/help/figures"))
+ (install-file "vignettes/references.bib"
+ (string-append #$output "/site-library/MMUPHin/doc"))))
+ (add-before 'check 'set-cache
+ (lambda _
+ (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")))
+ )))
+ (inputs (list glpk
+ ; ;;pandoc
+ ; ;;r-rmarkdown
+ ))
+ (propagated-inputs
+ (list r-cowplot
+ r-biocstyle
+ r-dplyr
+ r-fpc
+ r-ggplot2
+ r-igraph
+ r-maaslin2
+ r-metafor
+ r-stringr
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/MMUPHin")
+ (synopsis "Meta-analysis with uniform pipeline for heterogeneity in microbiome")
+ (description
+ "MMUPHin is an R package for meta-analysis tasks of microbiome cohorts. It
+has function interfaces for:
+@itemize
+@item covariate-controlled batch- and cohort effect adjustment;
+@item meta-analysis differential abundance testing;
+@item meta-analysis unsupervised discrete structure (clustering) discovery;
+@item meta-analysis unsupervised continuous structure discovery.
+@end itemize")
+ (license license:expat)))
+
(define-public r-motifrg
(package
(name "r-motifrg")

base-commit: efa091f9f4e77068353dff24f0ccd2d0613c3f48
prerequisite-patch-id: 9e08f9ff2621a13d751e3d82c0837144b09494e4
prerequisite-patch-id: 4cfeb51eeb402b18b0d23c6782255a3bc1f1ff43
prerequisite-patch-id: cf4c417ccd15ef1f795ada39f3faee9f59bb3c36
prerequisite-patch-id: d79a8e82e46ec03cf54f25ec101a5b54592fdb1b
prerequisite-patch-id: 81871608ddab1ba624de7432ad473e52221efc08
--
2.39.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61891-done@debbugs.gnu.org)
87356mg8nw.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (8 lines)
> Date: Wed, 1 Mar 2023 11:50:40 +0100
> Subject: [PATCH] gnu: Test builds for r-maaslin and r-mmuphin.scm
>
> This is my try to make the build of these two package reproducible.
>
> I send this only in the case if the reviewer wants to dig more and maybe he can
> solve the non deterministic build.

I managed to get r-mmuphin to build reproducibly, but for r-maaslin the
problem is that the scatterplots are non-deterministic. I’ve opened a
new bug report for that and pushed the rest of the patches.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61891@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61891
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help