(address . bug-guix@gnu.org)
Hi,
As of commit ec8c7370dfd66136f7cb517d31fa6fda31e2cb74, the following `guix import` invocation fails:
$ guix import go --recursive github.com/tdewolff/minify/v2
Backtrace:
In ice-9/boot-9.scm:
222:29 19 (map1 _)
222:29 18 (map1 _)
222:29 17 (map1 _)
222:29 16 (map1 _)
222:29 15 (map1 _)
222:29 14 (map1 _)
222:29 13 (map1 _)
222:29 12 (map1 _)
222:29 11 (map1 _)
222:17 10 (map1 (((gnu packages check)) ((gnu packages #)) ((…)) …))
3327:17 9 (resolve-interface (gnu packages check) #:select _ # _ # …)
In ice-9/threads.scm:
390:8 8 (_ _)
In ice-9/boot-9.scm:
3253:13 7 (_)
In ice-9/threads.scm:
390:8 6 (_ _)
In ice-9/boot-9.scm:
3544:20 5 (_)
2836:4 4 (save-module-excursion _)
3564:26 3 (_)
In unknown file:
2 (primitive-load-path "gnu/packages/check" #<procedure a…>)
In gnu/packages/check.scm:
1037:13 1 (_)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
error: go-github-com-robfig-cron: unbound variable
Strangely enough, it does work inside pre-inst-env with that same commit:
$ ./pre-inst-env guix import go --recursive github.com/tdewolff/minify/v2
(define-public go-github-com-djherbis-atime
<...>
I'm very unsure as to why this is happening, as `(gnu packages golang)` is imported in `(gnu packages check)`. Plus, even more weirdly, `guix build` can't find the problematic package, but can build the one that depends on it:
$ guix build go-github-com-robfig-cron-1.2
guix build: error: go-github-com-robfig-cron-1.2: unknown package
$ guix build actionlint
/gnu/store/0nzn1lbq02mfp6ka7z34lp9ly5nhlrv4-actionlint-1.6.23
I'd appreciate any help tracking down what could possibly be wrong here, as it's very puzzling.
Thanks,
Winter