gnu: services: Add more dnsmasq options.

  • Open
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Wicki Gabriel (wicg)
Owner
unassigned
Submitted by
Wicki Gabriel (wicg)
Severity
normal
W
W
Wicki Gabriel (wicg) wrote on 28 Feb 2023 14:36
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
ZR0P278MB0268263F676D7ECB79683E7EC1AC9@ZR0P278MB0268.CHEP278.PROD.OUTLOOK.COM
Hi y'all

I've created a patch which adds more options to the dnsmasq service. Thanks in advance for merging,

g
Attachment: file
W
W
Wicki Gabriel (wicg) wrote on 8 Mar 2023 15:56
Updated patch
(name . 61869@debbugs.gnu.org)(address . 61869@debbugs.gnu.org)
ZR0P278MB0268E3B56637629A67B19AC5C1B49@ZR0P278MB0268.CHEP278.PROD.OUTLOOK.COM
Hi

There were two small changes i wanted to address before merging:
- the standard /24 block for documenting is 192.0.2.0/24
- i had the default option for --no-poll (poll?) wrong in the documentation.
Attachment: file
T
T
Tobias Geerinckx-Rice wrote on 15 Aug 2023 17:20
Re: gnu: services: Add more dnsmasq options.
(address . 61869@debbugs.gnu.org)
3506a89b1948f9d1cd30aa72a8c56a26@tobias.gr
Hi Gabriel,

I've rebased this patch onto current master (attached). I've also made
some changes in a third patch that I'd like *you* to review, and ideally
test.

Some remarks:
- For the commit message, I prefer ‘services: foo:’ to ‘gnu: services:’.
- Use the previous Texinfo @node{} title in the commit message.
- I added bind-interfaces? only because it occurs in my documentation
for another new option.
- I don't use the dnsmasq service so I'm not 100% confident about some
of my changes. Please let me know if, for example, something doesn't
make sense as a list.

Thanks!

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
From 279f143f6283f1a10875f039b613a22cace4c707 Mon Sep 17 00:00:00 2001
Message-ID: <279f143f6283f1a10875f039b613a22cace4c707.1691884801.git.me@tobias.gr>
In-Reply-To: <a55db64e79c95d483cdcf97c38ec6ab4a49170ba.1691884800.git.me@tobias.gr>
References: <a55db64e79c95d483cdcf97c38ec6ab4a49170ba.1691884800.git.me@tobias.gr>
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 13 Aug 2023 02:00:00 +0200
Subject: [PATCH 2/3] services: dnsmasq: Fix some indentation.

Let's make the next conflict resolution less painful.

* gnu/packages/dns.scm (dnsmasq-shepherd-service):
C-M-q MAKE-FORKEXEC-CONSTRUCTOR.
---
gnu/services/dns.scm | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/services/dns.scm b/gnu/services/dns.scm
index ff93731ba3..fc70834deb 100644
--- a/gnu/services/dns.scm
+++ b/gnu/services/dns.scm
@@ -842,23 +842,23 @@ (define (dnsmasq-shepherd-service config)
"--pid-file=/run/dnsmasq.pid"
#$@(if no-hosts?
'("--no-hosts")
- '())
+ '())
#$(format #f "--port=~a" port)
#$@(if local-service?
'("--local-service")
- '())
+ '())
#$@(map (cut format #f "--listen-address=~a" <>)
listen-addresses)
#$(format #f "--resolv-file=~a" resolv-file)
#$@(if no-resolv?
'("--no-resolv")
- '())
+ '())
#$@(if forward-private-reverse-lookup?
'()
- '("--bogus-priv"))
+ '("--bogus-priv"))
#$@(if query-servers-in-order?
'("--strict-order")
- '())
+ '())
#$@(if servers-file
(list #~(string-append "--servers-file=" #$servers-file))
'())
@@ -869,7 +869,7 @@ (define (dnsmasq-shepherd-service config)
#$(format #f "--cache-size=~a" cache-size)
#$@(if negative-cache?
'()
- '("--no-negcache"))
+ '("--no-negcache"))
#$@(if cpe-id
(list (format #f "--add-cpe-id=~a" cpe-id))
'())
@@ -907,16 +907,16 @@ (define (dnsmasq-shepherd-service config)
dhcp-options)
#$@(if tftp-enable?
'("--enable-tftp")
- '())
+ '())
#$@(if tftp-no-fail?
'("--tftp-no-fail")
- '())
+ '())
#$@(if tftp-single-port?
'("--tftp-single-port")
- '())
+ '())
#$@(if tftp-secure?
'("--tftp-secure")
- '())
+ '())
#$@(if tftp-max
(list (format #f "--tftp-max=~a" tftp-max))
'())
@@ -925,10 +925,10 @@ (define (dnsmasq-shepherd-service config)
'())
#$@(if tftp-no-blocksize?
'("--tftp-no-blocksize")
- '())
+ '())
#$@(if tftp-lowercase?
'("--tftp-lowercase")
- '())
+ '())
#$@(if tftp-port-range
(list (format #f "--tftp-port-range=~a"
tftp-port-range))
--
2.41.0
Attachment: 0003-f-dnsmasq.patch (.01 MiB)
W
W
Wicki Gabriel (wicg) wrote on 21 Aug 2023 17:12
Review of the third patch
(name . 61869@debbugs.gnu.org)(address . 61869@debbugs.gnu.org)(name . me@tobias.gr)(address . me@tobias.gr)
ZR0P278MB0268C0C0C203F9D0109A7BE9C11EA@ZR0P278MB0268.CHEP278.PROD.OUTLOOK.COM
Thank you very much for your review and the third patch!
I have 3 small additions to your work (see your adapted patch in the attachments):
* I added a commit message (although I guess you'll edit that again anyways)
* I extended your explanations on the `interface' option (when bind-dynamic??` or? bind-interfaces?? is set...)
* I filled in your TODO
Please let me know (don't forget to cc me in your reply) if I can do anything else to merge this patch-set.
Thanks again, for your time, patience and expertise
gabriel
Attachment: file
?