Hi Gabriel,
I've rebased this patch onto current master (attached). I've also made
some changes in a third patch that I'd like *you* to review, and ideally
test.
Some remarks:
- For the commit message, I prefer ‘services: foo:’ to ‘gnu: services:’.
- Use the previous Texinfo @node{} title in the commit message.
- I added bind-interfaces? only because it occurs in my documentation
for another new option.
- I don't use the dnsmasq service so I'm not 100% confident about some
of my changes. Please let me know if, for example, something doesn't
make sense as a list.
Thanks!
T G-R
Sent from a Web browser. Excuse or enjoy my brevity.
From 279f143f6283f1a10875f039b613a22cace4c707 Mon Sep 17 00:00:00 2001
Message-ID: <279f143f6283f1a10875f039b613a22cace4c707.1691884801.git.me@tobias.gr>
In-Reply-To: <a55db64e79c95d483cdcf97c38ec6ab4a49170ba.1691884800.git.me@tobias.gr>
References: <a55db64e79c95d483cdcf97c38ec6ab4a49170ba.1691884800.git.me@tobias.gr>
Let's make the next conflict resolution less painful.
* gnu/packages/dns.scm (dnsmasq-shepherd-service):
C-M-q MAKE-FORKEXEC-CONSTRUCTOR.
---
gnu/services/dns.scm | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
Toggle diff (78 lines)
diff --git a/gnu/services/dns.scm b/gnu/services/dns.scm
index ff93731ba3..fc70834deb 100644
--- a/gnu/services/dns.scm
+++ b/gnu/services/dns.scm
@@ -842,23 +842,23 @@ (define (dnsmasq-shepherd-service config)
"--pid-file=/run/dnsmasq.pid"
#$@(if no-hosts?
'("--no-hosts")
- '())
+ '())
#$(format #f "--port=~a" port)
#$@(if local-service?
'("--local-service")
- '())
+ '())
#$@(map (cut format #f "--listen-address=~a" <>)
listen-addresses)
#$(format #f "--resolv-file=~a" resolv-file)
#$@(if no-resolv?
'("--no-resolv")
- '())
+ '())
#$@(if forward-private-reverse-lookup?
'()
- '("--bogus-priv"))
+ '("--bogus-priv"))
#$@(if query-servers-in-order?
'("--strict-order")
- '())
+ '())
#$@(if servers-file
(list #~(string-append "--servers-file=" #$servers-file))
'())
@@ -869,7 +869,7 @@ (define (dnsmasq-shepherd-service config)
#$(format #f "--cache-size=~a" cache-size)
#$@(if negative-cache?
'()
- '("--no-negcache"))
+ '("--no-negcache"))
#$@(if cpe-id
(list (format #f "--add-cpe-id=~a" cpe-id))
'())
@@ -907,16 +907,16 @@ (define (dnsmasq-shepherd-service config)
dhcp-options)
#$@(if tftp-enable?
'("--enable-tftp")
- '())
+ '())
#$@(if tftp-no-fail?
'("--tftp-no-fail")
- '())
+ '())
#$@(if tftp-single-port?
'("--tftp-single-port")
- '())
+ '())
#$@(if tftp-secure?
'("--tftp-secure")
- '())
+ '())
#$@(if tftp-max
(list (format #f "--tftp-max=~a" tftp-max))
'())
@@ -925,10 +925,10 @@ (define (dnsmasq-shepherd-service config)
'())
#$@(if tftp-no-blocksize?
'("--tftp-no-blocksize")
- '())
+ '())
#$@(if tftp-lowercase?
'("--tftp-lowercase")
- '())
+ '())
#$@(if tftp-port-range
(list (format #f "--tftp-port-range=~a"
tftp-port-range))
--
2.41.0