[PATCH] gnu: Add r-sitar.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20230228004019.8686-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-sitar): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c80e98134a..abe89201b0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9652,6 +9652,40 @@ (define-public r-signal
It also includes interpolation functions.")
(license license:gpl2)))
+(define-public r-sitar
+ (package
+ (name "r-sitar")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sitar" version))
+ (sha256
+ (base32 "0lhwbbpq6anqrk3818xw3nrl63bj3vwgsmxad0dpl8y50rkcc4cs"))))
+ (properties `((upstream-name . "sitar")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dplyr
+ r-forcats
+ r-ggplot2
+ r-glue
+ r-magrittr
+ r-nlme
+ r-purrr
+ r-rlang
+ r-rsample
+ r-tibble
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/statist7/sitar")
+ (synopsis "Super imposition by translation and rotation growth curve analysis")
+ (description
+ "This package provides functions for fitting and plotting @acronym{SITAR, Super
+Imposition by Translation And Rotation} growth curve models. SITAR is a shape-
+invariant model with a regression B-spline mean curve and subject-specific random
+effects on both the measurement and age scales.")
+ (license license:gpl2+)))
+
(define-public r-gsubfn
(package
(name "r-gsubfn")

base-commit: 4db367f8ae4e704784ced52b552437ca00b94b89
--
2.39.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61855-done@debbugs.gnu.org)
87wn40g8tl.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-sitar): New variable.

Thanks for the patch. Pushed to the master branch with commit
ef7df2ca7bb212455f1d6bbef5bbf7b1ac5a189d.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61855@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61855
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help