• Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20230228001030.2658-1-madalinionel.patrascu@mdc-berlin.de
Date: Tue, 28 Feb 2023 01:07:34 +0100
Subject: [PATCH] gnu: Add r-chromomap.

* gnu/packages/cran.scm (r-chromomap): New variable.
---
gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c80e98134a..5af741674c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -306,6 +306,42 @@ (define-public r-changepoint
;; Any version of the GPL.
(license license:gpl3+)))
+;; The package sources include multiple non-mified js and v5.1.0 variant of d3.js
+;; The d3.js file is also non-minified and the file mention the version and the
+;; home-page.
+(define-public r-chromomap
+ (package
+ (name "r-chromomap")
+ (version "4.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "chromoMap" version))
+ (sha256
+ (base32 "1067h5d6jdbm811n7ayikhqfbcqmxbz5jgp05vf1sbln7qgn9l43"))))
+ (properties `((upstream-name . "chromoMap")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-htmltools r-htmlwidgets))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=chromoMap")
+ (synopsis "Interactive genomic visualization of biological data")
+ (description
+ "This package provides interactive, configurable and graphics visualization
+of the chromosome regions of any living organism allowing users to map chromosome
+elements (like genes, SNPs etc.) on the chromosome plot. It introduces a special
+plot viz. the \"chromosome heatmap\" that, in addition to mapping elements, can
+visualize the data associated with chromosome elements (like gene expression) in
+the form of heat colors. Users can investigate the detailed information about the
+mappings (like gene names or total genes mapped on a location) or can view the
+magnified single or double stranded view of the chromosome at a location showing
+each mapped element in sequential order. The package provide multiple features
+like visualizing multiple sets, chromosome heat-maps, group annotations, adding
+hyperlinks, and labelling. The plots can be saved as HTML documents that can be
+customized and shared easily. In addition, you can include them in R Markdown or
+in R Shiny applications.")
+ (license (list license:gpl3
+ license:isc )))) ;; for d3 bundled js
+
(define-public r-collections
(package
(name "r-collections")

base-commit: 9ae4846c502b75867b83180bb65d422ff838e4e6
--
2.39.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61854-done@debbugs.gnu.org)
87bklbfich.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (5 lines)
> Date: Tue, 28 Feb 2023 01:07:34 +0100
> Subject: [PATCH] gnu: Add r-chromomap.
>
> * gnu/packages/cran.scm (r-chromomap): New variable.

Applied with commit a7763e067d86908210758aab80d33e4f8b815b1c.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61854@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61854
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help