[PATCH 0/3] Update rng-tools to 6.16.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 27 Feb 2023 17:12
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1677514269.git.mirai@makinata.eu
Bruno Victal (3):
gnu: rng-tools: Rewrite using gexps.
gnu: rng-tools: Do not build randstat binary.
gnu: rng-tools: Update to 6.16.

gnu/local.mk | 1 +
gnu/packages/linux.scm | 40 ++++++++-------
.../rng-tools-revert-build-randstat.patch | 49 +++++++++++++++++++
3 files changed, 73 insertions(+), 17 deletions(-)
create mode 100644 gnu/packages/patches/rng-tools-revert-build-randstat.patch


base-commit: 55054c1235ff2048079d4b83840cf22a61d04e5a
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 17:14
[PATCH 1/3] gnu: rng-tools: Rewrite using gexps.
(address . 61845@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
7ed5e4122f849b5df8170fd785527fb83e3f9297.1677514269.git.mirai@makinata.eu
* gnu/packages/linux.scm (rng-tools)[arguments]: Rewrite using gexps.
---
gnu/packages/linux.scm | 29 +++++++++++++++--------------
1 file changed, 15 insertions(+), 14 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f9d75f8c6b..bd180f6325 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6595,20 +6595,21 @@ (define-public rng-tools
"0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))))
(build-system gnu-build-system)
(arguments
- `(;; Disable support for various hardware entropy sources as they need
- ;; dependencies that are not yet in Guix, and would significantly
- ;; increase closure size.
- #:configure-flags '("--without-nistbeacon"
- "--without-pkcs11"
- "--without-rtlsdr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-failing-test
- (lambda _
- (substitute* "tests/Makefile"
- ;; This test requires a hwrng, rdrand, or tpm device.
- ;; Worse, it appears to fail if that isn't sufficiently random.
- (("\\brngtestjitter\\.sh\\b") " ")))))))
+ (list
+ ;; Disable support for various hardware entropy sources as they need
+ ;; dependencies that are not yet in Guix, and would significantly
+ ;; increase closure size.
+ #:configure-flags #~(list "--without-nistbeacon"
+ "--without-pkcs11"
+ "--without-rtlsdr")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ (lambda _
+ (substitute* "tests/Makefile"
+ ;; This test requires a hwrng, rdrand, or tpm device.
+ ;; Worse, it appears to fail if that isn't sufficiently random.
+ (("\\brngtestjitter\\.sh\\b") " ")))))))
(native-inputs
(list autoconf automake pkg-config))
(inputs
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 17:14
[PATCH 3/3] gnu: rng-tools: Update to 6.16.
(address . 61845@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
78c1e5ed3ba6fd9da3fb7f9f697594198d05adce.1677514269.git.mirai@makinata.eu
* gnu/packages/linux.scm (rng-tools): Update to 6.16.
[arguments]: Disable qrypt.
[inputs]: Add libcap.
---
gnu/packages/linux.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9ba4b2b119..57664a39ed 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6585,7 +6585,7 @@ (define-public rng-tools
(package
(name "rng-tools")
(home-page "https://github.com/nhorman/rng-tools")
- (version "6.15")
+ (version "6.16")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page)
@@ -6593,7 +6593,7 @@ (define-public rng-tools
(file-name (git-file-name name version))
(sha256
(base32
- "0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))
+ "1rsk8nxs0j32b9hr88qk8hv029fb1q0hcrw0mfdywvm7dn2d15gn"))
(patches
(search-patches "rng-tools-revert-build-randstat.patch"))
(patch-flags '("-p0"))))
@@ -6605,7 +6605,8 @@ (define-public rng-tools
;; increase closure size.
#:configure-flags #~(list "--without-nistbeacon"
"--without-pkcs11"
- "--without-rtlsdr")
+ "--without-rtlsdr"
+ "--without-qrypt")
#:phases
#~(modify-phases %standard-phases
(add-before 'check 'disable-failing-test
@@ -6617,7 +6618,7 @@ (define-public rng-tools
(native-inputs
(list autoconf automake pkg-config))
(inputs
- (list sysfsutils openssl))
+ (list libcap sysfsutils openssl))
(synopsis "Random number generator daemon")
(description
"Monitor a hardware random number generator, and supply entropy
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 17:14
[PATCH 2/3] gnu: rng-tools: Do not build randstat binary.
(address . 61845@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
e256018a1dc50c59a0cede30e49a3c965e04631a.1677514269.git.mirai@makinata.eu
This trivial binary is rarely useful.

* gnu/local.mk (dist_patch_DATA): Register patch.
* gnu/packages/patches/rng-tools-revert-build-randstat.patch: New file.
* gnu/packages/linux.scm (rng-tools)[origin]: Add patch.
---
gnu/local.mk | 1 +
gnu/packages/linux.scm | 6 ++-
.../rng-tools-revert-build-randstat.patch | 49 +++++++++++++++++++
3 files changed, 55 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/rng-tools-revert-build-randstat.patch

Toggle diff (93 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 4ccf015316..4e84cf1b06 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1805,6 +1805,7 @@ dist_patch_DATA = \
%D%/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch \
%D%/packages/patches/retroarch-LIBRETRO_DIRECTORY.patch \
%D%/packages/patches/r-mixedpower-r2power.patch \
+ %D%/packages/patches/rng-tools-revert-build-randstat.patch \
%D%/packages/patches/rnp-add-version.cmake.patch \
%D%/packages/patches/rnp-disable-ruby-rnp-tests.patch \
%D%/packages/patches/rnp-unbundle-googletest.patch \
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bd180f6325..9ba4b2b119 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Stefan <stefan-guix@vodafonemail.de>
;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6592,7 +6593,10 @@ (define-public rng-tools
(file-name (git-file-name name version))
(sha256
(base32
- "0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))))
+ "0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))
+ (patches
+ (search-patches "rng-tools-revert-build-randstat.patch"))
+ (patch-flags '("-p0"))))
(build-system gnu-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/rng-tools-revert-build-randstat.patch b/gnu/packages/patches/rng-tools-revert-build-randstat.patch
new file mode 100644
index 0000000000..6402884af0
--- /dev/null
+++ b/gnu/packages/patches/rng-tools-revert-build-randstat.patch
@@ -0,0 +1,49 @@
+Source: https://src.fedoraproject.org/rpms/rng-tools/blob/aaca5d6d9c9a50e0d0eed74c67b09863ac37149a/f/2-rt-revert-build-randstat.patch
+
+From de2ee0d8b7e8ad2915165ef941a6ec37442a2fdc Mon Sep 17 00:00:00 2001
+From: Vladis Dronov <vdronov@redhat.com>
+Date: Tue, 6 Jul 2021 14:36:46 +0200
+Subject: [PATCH] Revert "Build randstat binary"
+
+We do not want new and mostly useless randstat binary.
+This reverts commit 2ce93190cb0111fcab2f622a539689d70960643a.
+
+Signed-off-by: Vladis Dronov <vdronov@redhat.com>
+---
+ .gitignore | 3 +--
+ contrib/Makefile.am | 5 +++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git .gitignore .gitignore
+index 943fa2b..5dc334d 100644
+--- .gitignore
++++ .gitignore
+@@ -1,6 +1,6 @@
+ *.a
+ *.o
+-.deps/
++/.deps/
+ /aclocal.m4
+ /ar-lib
+ /autom4te.cache/
+@@ -10,7 +10,6 @@
+ /config.status
+ /config.sub
+ /configure
+-/contrib/randstat
+ /depcomp
+ /install-sh
+ /missing
+diff --git contrib/Makefile.am contrib/Makefile.am
+index a81fb0e..18c4fbc 100644
+--- contrib/Makefile.am
++++ contrib/Makefile.am
+@@ -1,2 +1,3 @@
+-bin_PROGRAMS = randstat
+-randstat_SOURCES = randstat.c
++
++EXTRA_DIST = randstat.c
++
+--
+2.26.3
+
--
2.39.1
C
C
Christopher Baines wrote on 14 Mar 2023 11:41
Re: [bug#61845] [PATCH 0/3] Update rng-tools to 6.16.
(name . Bruno Victal)(address . mirai@makinata.eu)
87lejzzkbe.fsf@cbaines.net
Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (11 lines)
> Bruno Victal (3):
> gnu: rng-tools: Rewrite using gexps.
> gnu: rng-tools: Do not build randstat binary.
> gnu: rng-tools: Update to 6.16.
>
> gnu/local.mk | 1 +
> gnu/packages/linux.scm | 40 ++++++++-------
> .../rng-tools-revert-build-randstat.patch | 49 +++++++++++++++++++
> 3 files changed, 73 insertions(+), 17 deletions(-)
> create mode 100644 gnu/packages/patches/rng-tools-revert-build-randstat.patch

Thanks, pushed to master as cf59f6bb3b95911369aa71cb45b617ac5f8cf681.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQQT2VfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeCABAAqzdPdAMbvmZdYhKXNbfsK4YwIlwu8Dh0
QEsmmSs8Wi1EZSFiadBv8ETf6Y8nMKEP58+dQs8Z2PDG37TmtLN1iXrWudPtIaL7
j9VM3e/ca7A0bNba6BMzoWk7yv7vW55GGgzDuYHYmnxWjlczLjhEWDZ22zxpwxGN
/KP7keSUtdhE8954gr3pKhECrdLfeAxtwIlgYwYrsr0XRO8B5OIEeZbewswFht6U
pDLcn8AgvKrz1anLog+3TMB46pFoXWGYvLYgyAFnWzJvixumF9B1jM+B73cUtGDx
tCx0dnEZkouL38NaeulHPLVoEbtbYe62YYIDs5LNtOGWW6RbjGiTnYuz9lEWzfTT
vyyA8uhwAAE8Ierbiqbi6H1VEhZvjGnseeqC5B/xeeswMRYdzr54QzR7GeqVPO3d
2YMyG4sZyljV0F/rQEMoY0e5WUvGuPs95MUUnJ7j6sidTmKngcsfi9fqfbFh7TTU
gyYNryTuX1XA/ao/Yf4VddIAA4202LQ+Z4ufXFGbnW3ZF1YFBoqhVRxhkdoX6yb6
hOvH9CDXjzAWeAnxjcyFdGuk18cYK9b/K8oa/JLcp4CG9X76s/Sl1vU81WdFgiFs
HRlYhNsFYtusLE723tQYYPN76FtXfV7t8ymC3NdsLINmWshtEeoR/yXukm21CgDt
YK7pHolbuMo=
=GgOF
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 61845@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61845
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch