[PAtCH] gnu: Add r-simplermarkdown, r-rcppspdlog, r-n2r, r-sccore, r-leidenalg, r-drat, r-dendsort, r-pagoda2, r-conospanel, r-p2data, r-pma, r-rmumps and r-conos.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
669c9a4b05f74824b87f3bb57fd23c98@mdc-berlin.de
* * gnu/packages/cran.scm (r-simplermarkdown, r-rcppspdlog, r-n2r, r-sccore, r-leidenalg, r-drat, r-dendsort, r-pagoda2, r-conospanel, r-p2data, r-pma, r-rmumps): New variables.
* * gnu/packages/bioconductor.scm (r-conos): New variable.
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 01/13] gnu: Add r-simplermarkdown.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-simplermarkdown): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c80e98134a..f63112c3be 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9652,6 +9652,28 @@ (define-public r-signal
It also includes interpolation functions.")
(license license:gpl2)))
+(define-public r-simplermarkdown
+ (package
+ (name "r-simplermarkdown")
+ (version "0.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "simplermarkdown" version))
+ (sha256
+ (base32 "069pgx5m22rdqa21lyn5zqm9ym3g7w6z1d2wjwms8b1f2cp6266g"))))
+ (properties `((upstream-name . "simplermarkdown")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rjson))
+ (home-page "https://github.com/djvanderlaan/simplermarkdown")
+ (synopsis "Simple engine for generating reports using R")
+ (description
+ "This package runs R-code present in a pandoc markdown file and includes the
+resulting output in the resulting markdown file. This file can then be converted
+into any of the output formats supported by pandoc. The package can also be used
+as an engine for writing package vignettes.")
+ (license license:gpl3+)))
+
(define-public r-gsubfn
(package
(name "r-gsubfn")

base-commit: 5d10644371abd54d0edcd638691113f0a92de743
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 02/13] gnu: Add r-rcppspdlog.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rcppspdlog): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f63112c3be..46b8dbc9ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4992,6 +4992,30 @@ (define-public r-rcppml
factorization and divisive clustering for large sparse and dense matrices.")
(license license:gpl2+)))
+(define-public r-rcppspdlog
+ (package
+ (name "r-rcppspdlog")
+ (version "0.0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RcppSpdlog" version))
+ (sha256
+ (base32 "1nan0hm49xdl2l1lskm1jf01clfh7aw2v6h57j35qysvg8219fcx"))))
+ (properties `((upstream-name . "RcppSpdlog")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (native-inputs (list r-simplermarkdown))
+ (home-page "https://github.com/eddelbuettel/rcppspdlog")
+ (synopsis "R and C++ interfaces to 'spdlog' C++ header library for logging")
+ (description
+ "The spdlog library is a widely-used and very capable header-only C++ library
+for logging. This package includes its headers as an R package to permit other R
+packages to deploy it via a simple @code{LinkingTo: RcppSpdlog}. As of version
+0.0.9, it also provides both simple R logging functions and compiled functions
+callable by other packages.")
+ (license license:gpl2+)))
+
(define-public r-rcppthread
(package
(name "r-rcppthread")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 03/13] gnu: Add r-n2r.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-n2r): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 46b8dbc9ec..184cbd6d7f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8334,6 +8334,32 @@ (define-public r-tinytest
")
(license license:gpl3)))
+(define-public r-n2r
+ (package
+ (name "r-n2r")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "N2R" version))
+ (sha256
+ (base32 "12bv7xx6j6222qgpv6g61i68017fz0x6fjg9a9k5yhgw3zk05hpk"))))
+ (properties `((upstream-name . "N2R")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-matrix
+ r-rcpp
+ r-rcppeigen
+ r-rcppspdlog))
+ (home-page "https://github.com/kharchenkolab/N2R")
+ (synopsis "Fast and scalable approximate k-Nearest Neighbor search methods")
+ (description
+ "This package implements methods to perform fast approximate K-nearest neighbor
+search on input matrix. Algorithm based on the N2 implementation of an approximate
+nearest neighbor search using hierarchical @acronym{NSW, Navigable Small World}
+graphs.")
+ (license license:asl2.0)))
+
(define-public r-network
(package
(name "r-network")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 05/13] gnu: Add r-leidenalg.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-5-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-leidenalg): New variable.
---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index da2b2521a7..3784faa752 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23308,6 +23308,41 @@ (define-public r-leiden
guaranteeing well-connected communities.\" <arXiv:1810.08473>.")
(license license:gpl3)))
+(define-public r-leidenalg
+ (package
+ (name "r-leidenalg")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "leidenAlg" version))
+ (sha256
+ (base32 "1z96zrsms93gspylmficaggb0xj94kq9rg3p2svdbb451jbga9an"))))
+ (properties `((upstream-name . "leidenAlg")))
+ (build-system r-build-system)
+ (inputs
+ (list glpk
+ libxml2))
+ (propagated-inputs
+ (list gmp
+ r-igraph
+ r-matrix
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-sccore))
+ (native-inputs (list gfortran))
+ (home-page "https://github.com/kharchenkolab/leidenAlg")
+ (synopsis "Leiden algorithm via an R interface")
+ (description
+ "This package implements an R interface to the Leiden algorithm, an iterative
+community detection algorithm on networks. The algorithm is designed to converge
+to a partition in which all subsets of all communities are locally optimally assigned,
+yielding communities guaranteed to be connected. The implementation proves to be
+fast, scales well, and can be run on graphs of millions of nodes (as long as they can
+fit in memory).")
+ (license license:gpl3)))
+
(define-public r-patchwork
(package
(name "r-patchwork")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 06/13] gnu: Add r-drat.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-6-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-drat): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3784faa752..dbf98cdd81 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6380,6 +6380,29 @@ (define-public r-lava
variable models.")
(license license:gpl3)))
+(define-public r-drat
+ (package
+ (name "r-drat")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "drat" version))
+ (sha256
+ (base32 "191yxlj9jccakmz27g7n9izfcy19kj3fgnw4w6zl9iq66787qpm6"))))
+ (properties `((upstream-name . "drat")))
+ (build-system r-build-system)
+ (native-inputs (list r-simplermarkdown))
+ (home-page "https://github.com/eddelbuettel/drat")
+ (synopsis "'Drat' R archive template")
+ (description
+ "This package helps you with creation and use of R repositories via helper
+functions to insert packages into a repository, and to add repository information
+to the current R session. Two primary types of repositories are support: gh-pages
+at GitHub, as well as local repositories on either the same machine or a local
+network. Drat is a recursive acronym: Drat R Archive Template.")
+ (license license:gpl2+)))
+
(define-public r-drr
(package
(name "r-drr")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 07/13] gnu: Add r-dendsort.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-7-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-dendsort): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dbf98cdd81..d69d214d64 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5333,6 +5333,33 @@ (define-public r-dendextend
;; Any of these versions
(license (list license:gpl2 license:gpl3))))
+(define-public r-dendsort
+ (package
+ (name "r-dendsort")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dendsort" version))
+ (sha256
+ (base32 "0rs7y471wrhkgibxdmfh5xhp3pa004rrlm2w08b6qli5gq4im5d2"))))
+ (properties `((upstream-name . "dendsort")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/evanbiederstedt/dendsort")
+ (synopsis "Modular leaf ordering methods for dendrogram nodes")
+ (description
+ "The pacake represents an implementation of functions to optimize ordering
+of nodes in a dendrogram, without affecting the meaning of the dendrogram. A
+dendrogram can be sorted based on the average distance of subtrees, or based on
+the smallest distance value. These sorting methods improve readability and
+interpretability of tree structure, especially for tasks such as comparison of
+different distance measures or linkage types and identification of tight clusters
+and outliers. As a result, it also introduces more meaningful reordering for a
+coupled heatmap visualization.")
+ ;; Any of these versions
+ (license (list license:gpl2 license:gpl3))))
+
(define-public r-getoptlong
(package
(name "r-getoptlong")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 08/13] gnu: Add r-pagoda2.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-8-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-pagoda2): New variable.
---
gnu/packages/cran.scm | 52 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d69d214d64..e810924766 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2031,6 +2031,58 @@ (define-public r-pacman
functions which can speed up workflow.")
(license license:gpl2)))
+(define-public r-pagoda2
+ (package
+ (name "r-pagoda2")
+ (version "1.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pagoda2" version))
+ (sha256
+ (base32 "18ip8j5l5c3hqw1xsf5wnyas55i2mhk09phy68kjkjdgcymmpg7c"))))
+ (properties `((upstream-name . "pagoda2")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dendsort
+ r-drat
+ r-fastcluster
+ r-igraph
+ r-irlba
+ r-magrittr
+ r-mass
+ r-matrix
+ r-mgcv
+ r-n2r
+ r-plyr
+ r-r-utils
+ r-r6
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-rcppprogress
+ r-rjson
+ r-rlang
+ r-rmtstat
+ r-rook
+ r-rtsne
+ r-sccore
+ r-urltools))
+ (home-page "https://github.com/kharchenkolab/pagoda2")
+ (synopsis "Single cell analysis and differential expression")
+ (description
+ "The package offers functions for analyzing and interactively exploring large-scale
+single-cell RNA-seq datasets. Pagoda2 primarily performs normalization and differential
+gene expression analysis, with an interactive application for exploring single-cell
+RNA-seq datasets. It performs basic tasks such as cell size normalization, gene
+variance normalization, and can be used to identify subpopulations and run differential
+expression within individual samples. pagoda2 was written to rapidly process modern
+large-scale scRNAseq datasets of approximately 1e6 cells. The companion web application
+allows users to explore which gene expression patterns form the different subpopulations
+within your data. The package also serves as the primary method for preprocessing
+data for conos.")
+ (license license:gpl3)))
+
(define-public r-pals
(package
(name "r-pals")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 09/13] gnu: Add r-conos.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-9-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-conos): New variable.
---
gnu/packages/bioconductor.scm | 50 +++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index bc3bd8c930..333df756c9 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5581,6 +5581,56 @@ (define-public r-complexheatmap
self-defined annotation graphics.")
(license license:gpl2+)))
+;;This package depends on r-complexheatmap
+(define-public r-conos
+ (package
+ (name "r-conos")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "conos" version))
+ (sha256
+ (base32 "1wdhb3jxh4id6xaghawzip8s264g9jxp4i5xy7jfhi67yfxszx6w"))))
+ (properties `((upstream-name . "conos")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-abind
+ r-complexheatmap
+ r-cowplot
+ r-dendextend
+ r-dplyr
+ r-ggplot2
+ r-ggrepel
+ r-gridextra
+ r-igraph
+ r-irlba
+ r-leidenalg
+ r-magrittr
+ r-matrix
+ r-n2r
+ r-r6
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-rcppprogress
+ r-reshape2
+ r-rlang
+ r-rtsne
+ r-sccore
+))
+ (home-page "https://github.com/kharchenkolab/conos")
+ (synopsis "Clustering on network of samples")
+ (description
+ "This package wires together large collections of single-cell RNA-seq datasets,
+which allows for both the identification of recurrent cell clusters and the propagation
+of information between datasets in multi-sample or atlas-scale collections. Conos
+focuses on the uniform mapping of homologous cell types across heterogeneous sample
+collections. For instance, users could investigate a collection of dozens of
+peripheral blood samples from cancer patients combined with dozens of controls,
+which perhaps includes samples of a related tissue such as lymph nodes.")
+ (license license:gpl3)))
+
(define-public r-copywriter
(package
(name "r-copywriter")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 10/13] gnu: Add r-conospanel.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-10-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-conospanel): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e810924766..fdbaf6ef56 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23591,6 +23591,28 @@ (define-public r-harmony
function and interfaces to external frameworks.")
(license license:gpl3)))
+(define-public r-conospanel
+ (let ((commit "39e76b201a783b4e92fd615010a735a61746fbb9")
+ (revision "1"))
+ (package
+ (name "r-conospanel")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kharchenkolab/conosPanel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zf0aj5d4iaxc3ghvjnaja5qby1avlmljzh94bpyvxbd359z9snn"))))
+ (properties `((upstream-name . "conosPanel")))
+ (build-system r-build-system)
+ (home-page "https://github.com/kharchenkolab/conosPanel")
+ (synopsis "Package for conos data")
+ (description "Data used by conos")
+ (license license:gpl3))))
+
(define-public r-covr
(package
(name "r-covr")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 04/13] gnu: Add r-sccore.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-sccore): New variable.
---
gnu/packages/cran.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 184cbd6d7f..da2b2521a7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22401,6 +22401,48 @@ (define-public r-lintr
code edited with @code{RStudio IDE}, @code{Emacs} and @code{Vim}.")
(license license:expat)))
+(define-public r-sccore
+ (package
+ (name "r-sccore")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sccore" version))
+ (sha256
+ (base32 "12gm7pb6xbvf9kdsgl7ldw1c54ga9fgk99ps2kx2cq91q9m0ld4r"))))
+ (properties `((upstream-name . "sccore")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dplyr
+ r-ggplot2
+ r-ggrepel
+ r-igraph
+ r-irlba
+ r-magrittr
+ r-matrix
+ r-pbmcapply
+ r-proc
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-rcppprogress
+ r-rlang
+ r-scales
+ r-tibble
+ r-uwot
+ r-withr))
+ (home-page "https://github.com/kharchenkolab/sccore")
+ (synopsis "Core utilities for single-cell RNA-Seq")
+ (description
+ "This package implements core utilities for single-cell RNA-seq data analysis.
+Contained within are utility functions for working with @acronym{DE, differential
+expression} matrices and count matrices, a collection of functions for manipulating
+and plotting data via ggplot2, and functions to work with cell graphs and cell
+embeddings. Graph-based methods include embedding kNN cell graphs into a UMAP,
+collapsing vertices of each cluster in the graph, and propagating graph labels.")
+ (license license:gpl3)))
+
(define-public r-scs
(package
(name "r-scs")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 11/13] gnu: Add r-p2data.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-11-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-p2data): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fdbaf6ef56..517db893cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33149,6 +33149,28 @@ (define-public r-seuratdata
distributed as independent packages.")
(license license:gpl3))))
+(define-public r-p2data
+ (let ((commit "7d4c0e17d7899f9d9b08ab2bf455abe150912f4c")
+ (revision "1"))
+ (package
+ (name "r-p2data")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kharchenkolab/p2data")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hadrldldxvhqs43aqs3c88bqfgql3wcfkbll3jz7fh6z7p3x324"))))
+ (properties `((upstream-name . "p2data")))
+ (build-system r-build-system)
+ (home-page "https://github.com/kharchenkolab/p2data")
+ (synopsis "Data for pagoda2")
+ (description "This package contains data used by pagoda2.")
+ (license license:gpl3))))
+
(define-public r-phangorn
(package
(name "r-phangorn")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 12/13] gnu: Add r-pma.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-12-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-pma): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 517db893cd..61dcff7f12 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -905,6 +905,26 @@ (define-public r-googlesheets4
can read and write both the metadata and the cell data in a Sheet.")
(license license:expat)))
+(define-public r-pma
+ (package
+ (name "r-pma")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "PMA" version))
+ (sha256
+ (base32 "1rhiylm3jfarnqdkv7nwg536sgsa30ic80dk9byks9w0wf4mn59s"))))
+ (properties `((upstream-name . "PMA")))
+ (build-system r-build-system)
+ (home-page "https://github.com/bnaras/PMA")
+ (synopsis "Penalized multivariate analysis")
+ (description
+ "This package performs penalized multivariate analysis: a penalized matrix
+decomposition, sparse principal components analysis, and sparse canonical
+correlation analysis.")
+ (license license:gpl2+)))
+
(define-public r-proj4
(package
(name "r-proj4")
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 13/13] gnu: Add r-rmumps.
(address . 61838@debbugs.gnu.org)
20230227102850.18782-13-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rmumps): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 61dcff7f12..11939ee20f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5866,6 +5866,32 @@ (define-public r-rmpi
provides an interactive R manager and worker environment.")
(license license:gpl2+)))
+(define-public r-rmumps
+ (package
+ (name "r-rmumps")
+ (version "5.2.1-22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rmumps" version))
+ (sha256
+ (base32 "18wqy82hwnbiwqcyldg8ci0jmxfiaj65ila0fjzzv40d3kl8hx76"))))
+ (properties `((upstream-name . "rmumps")))
+ (build-system r-build-system)
+ (inputs (list zlib))
+ (propagated-inputs (list r-rcpp))
+ (native-inputs (list gfortran))
+ (home-page "http://www.mumps-solver.org/")
+ (synopsis "Wrapper for MUMPS library")
+ (description
+ "Some basic features of @acronym{MUMPS, Multifrontal Massively Parallel sparse
+direct Solver} are wrapped in a class whose methods can be used for sequentially
+solving a sparse linear system (symmetric or not) with one or many right hand
+sides (dense or sparse). There is a possibility to do separately symbolic
+analysis, LU (or LDL^t) factorization and system solving. Third part ordering
+libraries are included and can be used: PORD', METIS', SCOTCH'.")
+ (license license:gpl2+)))
+
(define-public r-lmoments
(package
(name "r-lmoments")
--
2.39.1
Ricardo Wurmus wrote 2 years ago
Re: [bug#61838] [PATCH 01/13] gnu: Add r-simplermarkdown.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61838@debbugs.gnu.org)
87zg8yhqjp.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-simplermarkdown): New variable.

Thanks for the patch. This package’s DESCRIPTION file says that Pandoc
must be installed and available in the search path, yet this package
does not have pandoc as an input.

Would it be possible to patch the reference to the pandoc executable?

--
Ricardo
Ricardo Wurmus wrote 2 years ago
Re: [bug#61838] [PATCH 02/13] gnu: Add r-rcppspdlog.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61838@debbugs.gnu.org)
87v8jmhqgl.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (1 lines)
> * gnu/packages/cran.scm (r-rcppspdlog): New variable.
[…]
Toggle quote (2 lines)
> + (synopsis "R and C++ interfaces to 'spdlog' C++ header library for logging")

Please remove the single quotes.

--
Ricardo
Ricardo Wurmus wrote 2 years ago
Re: [bug#61838] [PATCH 03/13] gnu: Add r-n2r.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61838@debbugs.gnu.org)
87r0uahqf1.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (1 lines)
> * gnu/packages/cran.scm (r-n2r): New variable.
[…]
Toggle quote (6 lines)
> + (description
> + "This package implements methods to perform fast approximate K-nearest neighbor
> +search on input matrix. Algorithm based on the N2 implementation of an approximate
> +nearest neighbor search using hierarchical @acronym{NSW, Navigable Small World}
> +graphs.")

Please use complete sentences. The second sentence is a fragment.

--
Ricardo
Ricardo Wurmus wrote 2 years ago
Re: [bug#61838] [PATCH 04/13] gnu: Add r-sccore.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61838@debbugs.gnu.org)
87mt4yhqdf.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-sccore): New variable.

LGTM

--
Ricardo
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH v2 01/13] gnu: Add r-simplermarkdown.
(address . 61838@debbugs.gnu.org)
20230227204249.1906-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-simplermarkdown): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c80e98134a..965b10c3a5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9652,6 +9652,30 @@ (define-public r-signal
It also includes interpolation functions.")
(license license:gpl2)))
+(define-public r-simplermarkdown
+ (package
+ (name "r-simplermarkdown")
+ (version "0.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "simplermarkdown" version))
+ (sha256
+ (base32 "069pgx5m22rdqa21lyn5zqm9ym3g7w6z1d2wjwms8b1f2cp6266g"))))
+ (properties `((upstream-name . "simplermarkdown")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list pandoc
+ r-rjson))
+ (home-page "https://github.com/djvanderlaan/simplermarkdown")
+ (synopsis "Simple engine for generating reports using R")
+ (description
+ "This package runs R-code present in a pandoc markdown file and includes the
+resulting output in the resulting markdown file. This file can then be converted
+into any of the output formats supported by pandoc. The package can also be used
+as an engine for writing package vignettes.")
+ (license license:gpl3+)))
+
(define-public r-gsubfn
(package
(name "r-gsubfn")

base-commit: 4db367f8ae4e704784ced52b552437ca00b94b89
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH v2 02/13] gnu: Add r-rcppspdlog.
(address . 61838@debbugs.gnu.org)
20230227211744.1978-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rcppspdlog): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Changes since v1:
- [synopsis]: removed single quotes.

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 965b10c3a5..f5dc9c3980 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4992,6 +4992,30 @@ (define-public r-rcppml
factorization and divisive clustering for large sparse and dense matrices.")
(license license:gpl2+)))
+(define-public r-rcppspdlog
+ (package
+ (name "r-rcppspdlog")
+ (version "0.0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RcppSpdlog" version))
+ (sha256
+ (base32 "1nan0hm49xdl2l1lskm1jf01clfh7aw2v6h57j35qysvg8219fcx"))))
+ (properties `((upstream-name . "RcppSpdlog")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (native-inputs (list r-simplermarkdown))
+ (home-page "https://github.com/eddelbuettel/rcppspdlog")
+ (synopsis "R and C++ interfaces to spdlog C++ header library for logging")
+ (description
+ "The spdlog library is a widely-used and very capable header-only C++ library
+for logging. This package includes its headers as an R package to permit other R
+packages to deploy it via a simple @code{LinkingTo: RcppSpdlog}. As of version
+0.0.9, it also provides both simple R logging functions and compiled functions
+callable by other packages.")
+ (license license:gpl2+)))
+
(define-public r-rcppthread
(package
(name "r-rcppthread")

base-commit: 4db367f8ae4e704784ced52b552437ca00b94b89
prerequisite-patch-id: edae0018d5bb597484681580e87ff4e84d3e4f97
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH v2 03/13] gnu: Add r-n2r.
(address . 61838@debbugs.gnu.org)
20230227233716.2455-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-n2r): New variable.

Changes from v1:
- [description]: Changed the description after the Ricardo's observation.
I hope that this is solve the issue.

---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f5dc9c3980..29f11bf3de 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8334,6 +8334,32 @@ (define-public r-tinytest
")
(license license:gpl3)))
+(define-public r-n2r
+ (package
+ (name "r-n2r")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "N2R" version))
+ (sha256
+ (base32 "12bv7xx6j6222qgpv6g61i68017fz0x6fjg9a9k5yhgw3zk05hpk"))))
+ (properties `((upstream-name . "N2R")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-matrix
+ r-rcpp
+ r-rcppeigen
+ r-rcppspdlog))
+ (home-page "https://github.com/kharchenkolab/N2R")
+ (synopsis "Fast and scalable approximate k-Nearest Neighbor search methods")
+ (description
+ "This package implements methods to perform fast approximate K-nearest neighbor
+search on the input matrix. The algorithm is based on the N2 implementation of an
+approximate nearest neighbor search using hierarchical @acronym{NSW, Navigable Small
+World} graphs.")
+ (license license:asl2.0)))
+
(define-public r-network
(package
(name "r-network")

base-commit: 4db367f8ae4e704784ced52b552437ca00b94b89
prerequisite-patch-id: edae0018d5bb597484681580e87ff4e84d3e4f97
prerequisite-patch-id: fe2fd38a8a277bb9352431960ff6322e66f56895
--
2.39.1
Ricardo Wurmus wrote 2 years ago
Re: [bug#61838] [PATCH v2 01/13] gnu: Add r-simplermarkdown.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . debbugs-submit@debbugs.gnu.org)(address . 61838@debbugs.gnu.org)
87sfeog1x2.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-simplermarkdown): New variable.

Thanks for the update.

Turns out we cannot easily patch references to the pandoc executable. I
tried this:

Toggle snippet (17 lines)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-pandoc-invocations
(lambda* (#:key inputs #:allow-other-keys)
(let ((pandoc (search-input-file inputs "/bin/pandoc")))
(substitute* '("R/mdtangle.R"
"R/mdweave.R"
"R/mdweave_to.R")
(("'pandoc ")
(string-append "'" pandoc " ")))
(substitute* "R/has_pandoc.R"
(("Sys.which\\(\"pandoc\"\\)")
(string-append "\"" pandoc "\"")))))))))

This works, but the resulting output no longer has any references to
/gnu/store/…-pandoc…/bin/pandoc. That’s because none of these files
make it to the output. Instead they all seemingly get squished into a
pair of simplermarkdown.rdx and .rdb files, which are compressed.

So it is safer to propagate pandoc.
This may point to a general problem with the r-build-system that we may
need to investigate later.

--
Ricardo
Ricardo Wurmus wrote 2 years ago
Re: [bug#61838] [PATCH 01/13] gnu: Add r-simplermarkdown.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 61838-done@debbugs.gnu.org)
87o7pcfvya.fsf@elephly.net
I’ve applied this series with a number of changes, not limited to the
following:

- moved non-CRAN packages to bioinformatics.scm (r-conospanel, r-p2data)
- reformatted descriptions
- fixed typos
- corrected license of leidenalg
- removed extraneous single quotes

All pushed with the last commit
f01b5299db6031174f05124b843c936388cd872a.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61838@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61838
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help