[PATCH 00/11] Purge pre-1.3.0 deprecated procedures & variables.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Bruno Victal
  • Simon Tournier
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 27 Feb 2023 01:10
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1677456515.git.mirai@makinata.eu
Bruno Victal (11):
gnu: Purge pre-1.3.0 deprecated packages.
gnu: curl-minimal: Remove variable.
services: ntp-service-type: Remove deprecated server as strings
support.
services: sddm: Remove 'sddm-service' procedure.
services: base: Remove 'console-keymap-service-type' variable.
services: base: Remove 'console-font-service' procedure.
services: guix-publish: Remove 'compression-level' field.
services: desktop: Remove 'gnome-desktop-service' procedure.
services: desktop: Remove 'mate-desktop-service' procedure.
services: desktop: Remove 'xfce-desktop-service' procedure.
guix: packages: Remove 'origin-sha256' procedure.

gnu/packages/astronomy.scm | 4 +--
gnu/packages/bioinformatics.scm | 2 --
gnu/packages/curl.scm | 3 --
gnu/packages/efi.scm | 4 ---
gnu/packages/games.scm | 2 +-
gnu/packages/guile.scm | 8 -----
gnu/packages/image.scm | 3 --
gnu/packages/kde.scm | 3 --
gnu/packages/linphone.scm | 3 --
gnu/packages/maths.scm | 4 ---
gnu/packages/mpi.scm | 2 --
gnu/packages/music.scm | 7 ----
gnu/packages/perl.scm | 6 ----
gnu/packages/sync.scm | 2 +-
gnu/packages/tryton.scm | 3 --
gnu/packages/video.scm | 3 --
gnu/services/base.scm | 52 ++++--------------------------
gnu/services/desktop.scm | 32 +++---------------
gnu/services/networking.scm | 57 ++++++++++++---------------------
gnu/services/sddm.scm | 6 ----
guix/packages.scm | 9 ------
tests/graph.scm | 2 +-
tests/import-utils.scm | 2 +-
tests/networking.scm | 11 -------
24 files changed, 38 insertions(+), 192 deletions(-)


base-commit: 6bae14f61479f04a40fee44b1d1d89a33d9e93c0
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 04/11] services: sddm: Remove 'sddm-service' procedure.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
554a9c36519877c185b6cab50bfa3be532f00657.1677456515.git.mirai@makinata.eu
* gnu/services/sddm.scm (sddm-service): Remove procedure.
---
gnu/services/sddm.scm | 6 ------
1 file changed, 6 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/services/sddm.scm b/gnu/services/sddm.scm
index 694ad736dc..9e02f1cc81 100644
--- a/gnu/services/sddm.scm
+++ b/gnu/services/sddm.scm
@@ -324,9 +324,3 @@ (define sddm-service-type
(description
"Run SDDM, a display and log-in manager for X11 and
Wayland."))))
-
-(define-deprecated (sddm-service #:optional (config (sddm-configuration)))
- sddm-service-type
- "Run the @uref{https://github.com/sddm/sddm,SDDM display manager}
-with the given @var{config}, a @code{<sddm-configuration>} object."
- (service sddm-service-type config))
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 01/11] gnu: Purge pre-1.3.0 deprecated packages.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
f2603891642df5aad30b76a2faeb631c82f2edd1.1677456515.git.mirai@makinata.eu
* gnu/packages/bioinformatics.scm (deeptools): Remove variable.
* gnu/packages/efi.scm (efi_analyzer): Ditto.
* gnu/packages/guile.scm (guile-2.2/bug-fix, guile-json): Ditto.
* gnu/packages/image.scm (libjpeg): Ditto.
* gnu/packages/kde.scm (kdevplatform): Ditto
* gnu/packages/linphone.scm (linphoneqt): Ditto.
* gnu/packages/maths.scm (blis-sandybridge, blis-haswell, blis-knl): Ditto.
* gnu/packages/mpi.scm (hwloc-2.0): Ditto.
* gnu/packages/music.scm (python-abjad, zlfo): Ditto.
* gnu/packages/perl.scm (perl-base, perl-parent): Ditto.
* gnu/packages/tryton.scm (python-trytond): Ditto.
* gnu/packages/video.scm (gnome-mpv): Ditto.
* tests/graph.scm: Use guile-json-1.
---
gnu/packages/bioinformatics.scm | 2 --
gnu/packages/efi.scm | 4 ----
gnu/packages/guile.scm | 8 --------
gnu/packages/image.scm | 3 ---
gnu/packages/kde.scm | 3 ---
gnu/packages/linphone.scm | 3 ---
gnu/packages/maths.scm | 4 ----
gnu/packages/mpi.scm | 2 --
gnu/packages/music.scm | 7 -------
gnu/packages/perl.scm | 6 ------
gnu/packages/tryton.scm | 3 ---
gnu/packages/video.scm | 3 ---
tests/graph.scm | 2 +-
13 files changed, 1 insertion(+), 49 deletions(-)

Toggle diff (216 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9e8f7e92f8..377661404c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3349,8 +3349,6 @@ (define-public python-deeptools
;; remainder of the code is licensed under the MIT license.
(license (list license:bsd-3 license:expat))))
-(define-deprecated deeptools python-deeptools)
-
(define-public cutadapt
(package
(name "cutadapt")
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 4625538d26..75eb24bf86 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -96,10 +96,6 @@ (define-public efi-analyzer
information.")
(license license:bsd-2))))
-(define-public efi_analyzer
- ;; For a short while the package name contained an underscore.
- (deprecated-package "efi_analyzer" efi-analyzer))
-
(define-public sbsigntools
(package
(name "sbsigntools")
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 2fd9b711ce..e11627a67e 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -291,8 +291,6 @@ (define-public guile-2.2
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
-(define-deprecated guile-2.2/bug-fix guile-2.2)
-
(define-public guile-2.2.4
(package
(inherit guile-2.2)
@@ -650,12 +648,6 @@ (define-public guile-json-1
;; Version 1.2.0 switched to GPLv3+ (from LGPLv3+).
(license license:gpl3+)))
-;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
-;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
-;; 'guile-json-3'.
-(define-deprecated guile-json guile-json-1)
-(export guile-json)
-
(define-public guile2.0-json
(package-for-guile-2.0 guile-json-1))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5071dd588f..a7784949a5 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1712,9 +1712,6 @@ (define-public libjpeg-turbo
license:ijg ;the libjpeg library and associated tools
license:zlib)))) ;the libjpeg-turbo SIMD extensions
-(define-deprecated libjpeg libjpeg-turbo)
-(export libjpeg)
-
(define-public niftilib
(package
(name "niftilib")
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 728051b9e4..5b6d638e4a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -412,9 +412,6 @@ (define-public kdevelop-pg-qt
for some KDevelop language plugins (Ruby, PHP, CSS...).")
(license license:lgpl2.0+)))
-;; kdevplatform was merged into kdevelop as of 5.2.x
-(define-deprecated kdevplatform kdevelop)
-
(define-public kdiagram
(package
(name "kdiagram")
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 84bc16805c..d41d368e67 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -876,9 +876,6 @@ (define-public linphone-desktop
(home-page "https://linphone.org/technical-corner/linphone")
(license license:gpl3+)))
-(define-public linphoneqt
- (deprecated-package "linphoneqt" linphone-desktop))
-
(define-public msopenh264
(let ((commit "88697cc95140017760d6da408cb0efdc5e86e40a")
(revision "0"))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 280465e284..58bcd8bc09 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4902,10 +4902,6 @@ (define-public blis
access to BLIS implementations via traditional BLAS routine calls.")
(license license:bsd-3)))
-(define-public blis-sandybridge (deprecated-package "blis-sandybridge" blis))
-(define-public blis-haswell (deprecated-package "blis-haswell" blis))
-(define-public blis-knl (deprecated-package "blis-knl" blis))
-
(define ignorance blis)
(define-public openlibm
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index e8c20919d7..f97bba24d7 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -180,8 +180,6 @@ (define-public hwloc-2
(("hwloc_topology_init" all)
(string-append "exit (77);\n" all)))))))))))
-(define-deprecated hwloc-2.0 hwloc-2)
-
(define-public hwloc
;; The latest stable series of hwloc.
hwloc-2)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f4a570189b..30092965c8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1543,9 +1543,6 @@ (define-public abjad
typographic detail of symbols on the page.")
(license license:expat)))
-(define-public python-abjad
- (deprecated-package "python-abjad" abjad))
-
(define-public abjad-ext-rmakers
(package
(name "abjad-ext-rmakers")
@@ -6491,10 +6488,6 @@ (define-public zplugins
(home-page "https://www.zrythm.org/en/plugins.html")
(license license:agpl3+)))
-(define-public zlfo
- ;; The "zlfo" package is now included in zplugins
- (deprecated-package "zlfo" zplugins))
-
(define-public remid-lv2
(package
(name "remid-lv2")
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 41b68baea8..a6b5a7b013 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -817,9 +817,6 @@ (define-public perl-bareword-filehandles
(description "This module disables bareword filehandles.")
(license (package-license perl))))
-(define-public perl-base
- (deprecated-package "perl-base" perl))
-
(define-public perl-browser-open
(package
(name "perl-browser-open")
@@ -8598,9 +8595,6 @@ (define-public perl-par-dist
distributions.")
(license (package-license perl))))
-(define-public perl-parent
- (deprecated-package "perl-parent" perl))
-
(define-public perl-path-class
(package
(name "perl-path-class")
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8e561cad45..0b367675ae 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -100,9 +100,6 @@ (define-public trytond
and security.")
(license license:gpl3+)))
-(define-public python-trytond
- (deprecated-package "python-trytond" trytond))
-
(define-public tryton
(package
(name "tryton")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f63d5494de..aaf0fdd670 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2347,9 +2347,6 @@ (define-public gallery-dl
images and image hosting sites.")
(license license:gpl2)))
-(define-public gnome-mpv
- (deprecated-package "gnome-mpv" celluloid))
-
(define-public mpv-mpris
(package
(name "mpv-mpris")
diff --git a/tests/graph.scm b/tests/graph.scm
index 6674b5cc8f..a6186ff7e8 100644
--- a/tests/graph.scm
+++ b/tests/graph.scm
@@ -477,7 +477,7 @@ (define (edge->tuple source target)
'("libffi" "guile" "guile-json")
(run-with-store %store
(mlet %store-monad ((path (shortest-path (specification->package "libffi")
- guile-json
+ guile-json-1
%reverse-package-node-type)))
(return (map package-name path)))))
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 05/11] services: base: Remove 'console-keymap-service-type' variable.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
92183462f795f9b38709f2f6a4cbe39ddf39bd78.1677456515.git.mirai@makinata.eu
* gnu/services/base.scm (console-keymap-service-type): Remove variable.
---
gnu/services/base.scm | 15 ---------------
1 file changed, 15 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 7ad1e765bd..b83e778856 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -808,21 +808,6 @@ (define virtual-terminal-service-type
#t ;default to UTF-8
(description "Ensure the Linux virtual terminals run in UTF-8 mode.")))
-(define console-keymap-service-type
- (shepherd-service-type
- 'console-keymap
- (lambda (files)
- (shepherd-service
- (documentation (string-append "Load console keymap (loadkeys)."))
- (provision '(console-keymap))
- (start #~(lambda _
- (zero? (system* #$(file-append kbd "/bin/loadkeys")
- #$@files))))
- (respawn? #f)))
- (description "@emph{This service is deprecated in favor of the
-@code{keyboard-layout} field of @code{operating-system}.} Load the given list
-of console keymaps with @command{loadkeys}.")))
-
(define %default-console-font
;; Note: the 'font-gnu-unifont' package cannot be cross-compiled (yet), but
;; its "psf" output is the same whether it's built natively or not, hence
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 03/11] services: ntp-service-type: Remove deprecated server as strings support.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
2046be031f35d2eb4e9ed278c06a2e832d565671.1677456515.git.mirai@makinata.eu
* gnu/services/networking.scm (<ntp-configuration>)[servers]: Rename accessor to ntp-configuration-servers.
(ntp-configuration-servers): Remove helper procedure.
(ntp-shepherd-service): Remove helper procedure usage.
* tests/networking.scm: Remove obsolete test.
---
gnu/services/networking.scm | 57 +++++++++++++------------------------
tests/networking.scm | 11 -------
2 files changed, 20 insertions(+), 48 deletions(-)

Toggle diff (107 lines)
diff --git a/gnu/services/networking.scm b/gnu/services/networking.scm
index dacf64c2d1..ef66393937 100644
--- a/gnu/services/networking.scm
+++ b/gnu/services/networking.scm
@@ -481,36 +481,19 @@ (define-record-type* <ntp-configuration>
ntp-configuration?
(ntp ntp-configuration-ntp
(default ntp))
- (servers %ntp-configuration-servers ;list of <ntp-server> objects
+ (servers ntp-configuration-servers ;list of <ntp-server> objects
(default %ntp-servers))
(allow-large-adjustment? ntp-allow-large-adjustment?
(default #t))) ;as recommended in the ntpd manual
-(define (ntp-configuration-servers ntp-configuration)
- ;; A wrapper to support the deprecated form of this field.
- (let ((ntp-servers (%ntp-configuration-servers ntp-configuration)))
- (match ntp-servers
- (((? string?) (? string?) ...)
- (format (current-error-port) "warning: Defining NTP servers as strings is \
-deprecated. Please use <ntp-server> records instead.\n")
- (map (lambda (addr)
- (ntp-server
- (type 'server)
- (address addr)
- (options '()))) ntp-servers))
- ((($ <ntp-server>) ($ <ntp-server>) ...)
- ntp-servers))))
-
(define (ntp-shepherd-service config)
(match-record config <ntp-configuration>
(ntp servers allow-large-adjustment?)
- (let ((servers (ntp-configuration-servers config)))
- ;; TODO: Add authentication support.
- (define config
- (string-append "driftfile /var/run/ntpd/ntp.drift\n"
- (string-join (map ntp-server->string servers)
- "\n")
- "
+ ;; TODO: Add authentication support.
+ (define config
+ (string-append "driftfile /var/run/ntpd/ntp.drift\n"
+ (string-join (map ntp-server->string servers) "\n")
+ "
# Disable status queries as a workaround for CVE-2013-5211:
# <http://support.ntp.org/bin/view/Main/SecurityNotice#DRDoS_Amplification_Attack_using>.
restrict default kod nomodify notrap nopeer noquery limited
@@ -524,21 +507,21 @@ (define (ntp-shepherd-service config)
# option by default, as documented in the 'ntp.conf' manual.
restrict source notrap nomodify noquery\n"))
- (define ntpd.conf
- (plain-file "ntpd.conf" config))
+ (define ntpd.conf
+ (plain-file "ntpd.conf" config))
- (list (shepherd-service
- (provision '(ntpd))
- (documentation "Run the Network Time Protocol (NTP) daemon.")
- (requirement '(user-processes networking))
- (start #~(make-forkexec-constructor
- (list (string-append #$ntp "/bin/ntpd") "-n"
- "-c" #$ntpd.conf "-u" "ntpd"
- #$@(if allow-large-adjustment?
- '("-g")
- '()))
- #:log-file "/var/log/ntpd.log"))
- (stop #~(make-kill-destructor)))))))
+ (list (shepherd-service
+ (provision '(ntpd))
+ (documentation "Run the Network Time Protocol (NTP) daemon.")
+ (requirement '(user-processes networking))
+ (start #~(make-forkexec-constructor
+ (list (string-append #$ntp "/bin/ntpd") "-n"
+ "-c" #$ntpd.conf "-u" "ntpd"
+ #$@(if allow-large-adjustment?
+ '("-g")
+ '()))
+ #:log-file "/var/log/ntpd.log"))
+ (stop #~(make-kill-destructor))))))
(define %ntp-accounts
(list (user-account
diff --git a/tests/networking.scm b/tests/networking.scm
index f2421370d2..fbf8db7a02 100644
--- a/tests/networking.scm
+++ b/tests/networking.scm
@@ -43,17 +43,6 @@ (define %ntp-server-sample
"server some.ntp.server.org iburst version 3 maxpoll 16 prefer"
(ntp-server->string %ntp-server-sample))
-(test-equal "ntp configuration servers deprecated form"
- (ntp-configuration-servers
- (ntp-configuration
- (servers (list "example.pool.ntp.org"))))
- (ntp-configuration-servers
- (ntp-configuration
- (servers (list (ntp-server
- (type 'server)
- (address "example.pool.ntp.org")
- (options '())))))))
-
;;;
;;; OpenNTPD
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 08/11] services: desktop: Remove 'gnome-desktop-service' procedure.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
93c0eaacb83c2c600612cfb708731542b5014f2d.1677456515.git.mirai@makinata.eu
* gnu/services/desktop.scm (gnome-desktop-service): Remove procedure.
---
gnu/services/desktop.scm | 13 ++++---------
1 file changed, 4 insertions(+), 9 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index 2034b3d099..de2b4296ae 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -1402,15 +1402,10 @@ (define gnome-desktop-service-type
(default-value (gnome-desktop-configuration))
(description "Run the GNOME desktop environment.")))
-(define-deprecated (gnome-desktop-service #:key (config
- (gnome-desktop-configuration)))
- gnome-desktop-service-type
- "Return a service that adds the @code{gnome} package to the system profile,
-and extends polkit with the actions from @code{gnome-settings-daemon}."
- (service gnome-desktop-service-type config))
-
-;; MATE Desktop service.
-;; TODO: Add mate-screensaver.
+
+;;;
+;;; MATE Desktop service.
+;;; TODO: Add mate-screensaver.
(define-record-type* <mate-desktop-configuration> mate-desktop-configuration
make-mate-desktop-configuration
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 06/11] services: base: Remove 'console-font-service' procedure.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
124066a347786c68528576cb6993b2cb6c3a03a6.1677456515.git.mirai@makinata.eu
* gnu/services/base.scm (console-font-service): Remove procedure.
---
gnu/services/base.scm | 8 --------
1 file changed, 8 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index b83e778856..483a4ccd05 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -880,14 +880,6 @@ (define console-font-service-type
\"/share/consolefonts/ter-132n\"))) ; for HDPI
@end example\n")))
-(define* (console-font-service tty #:optional (font "LatGrkCyr-8x16"))
- "This procedure is deprecated in favor of @code{console-font-service-type}.
-
-Return a service that sets up Unicode support in @var{tty} and loads
-@var{font} for that tty (fonts are per virtual console in Linux.)"
- (simple-service (symbol-append 'console-font- (string->symbol tty))
- console-font-service-type `((,tty . ,font))))
-
(define %default-motd
(plain-file "motd" "This is the GNU operating system, welcome!\n\n"))
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 09/11] services: desktop: Remove 'mate-desktop-service' procedure.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
90335a8328b727043296c366dfd069658003caf6.1677456515.git.mirai@makinata.eu
* gnu/services/desktop.scm (mate-desktop-service): Remove procedure.
---
gnu/services/desktop.scm | 8 --------
1 file changed, 8 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index de2b4296ae..08f05fbdf9 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -1435,14 +1435,6 @@ (define mate-desktop-service-type
(default-value (mate-desktop-configuration))
(description "Run the MATE desktop environment.")))
-(define-deprecated (mate-desktop-service #:key
- (config
- (mate-desktop-configuration)))
- mate-desktop-service-type
- "Return a service that adds the @code{mate} package to the system profile,
-and extends polkit with the actions from @code{mate-settings-daemon}."
- (service mate-desktop-service-type config))
-
;;;
;;; XFCE desktop service.
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 02/11] gnu: curl-minimal: Remove variable.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
551c2fabd7202726360d0aaf4f4feacd8caf605c.1677456515.git.mirai@makinata.eu
* gnu/packages/curl.scm (curl-minimal): Remove variable.
* gnu/packages/astronomy.scm (python-fitsio, gnuastro): Use curl.
* gnu/packages/games.scm (odamex): Ditto.
* gnu/packages/sync.scm (onedrive): Ditto.
---
gnu/packages/astronomy.scm | 4 ++--
gnu/packages/curl.scm | 3 ---
gnu/packages/games.scm | 2 +-
gnu/packages/sync.scm | 2 +-
4 files changed, 4 insertions(+), 7 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b6ed1e2f49..fe4ec637c6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -438,7 +438,7 @@ (define-public python-fitsio
(("self.use_system_fitsio") "True")
(("self.system_fitsio_includedir") includedir)
(("self.system_fitsio_libdir") libdir))))))))
- (inputs (list curl-minimal))
+ (inputs (list curl))
(propagated-inputs
(list python-numpy cfitsio))
(home-page "https://github.com/esheldon/fitsio")
@@ -605,7 +605,7 @@ (define-public gnuastro
'(#:configure-flags '("--disable-static")))
(inputs
(list cfitsio
- curl-minimal
+ curl
gsl
libgit2
libjpeg-turbo
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 45bd2e6d36..bd00a6d274 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -170,9 +170,6 @@ (define curl-7.84.0
"NUM_THREADS 100\n"))))))
(else phases)))))))
-(define-public curl-minimal
- (deprecated-package "curl-minimal" curl))
-
(define-public curl-ssh
(package/inherit curl
(arguments
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5783c1d1b..0ee51e3d7f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7616,7 +7616,7 @@ (define-public odamex
("sdl-mixer" ,sdl2-mixer)
("zlib" ,zlib)
("libpng" ,libpng)
- ("curl" ,curl-minimal)
+ ("curl" ,curl)
("alsa-lib" ,alsa-lib)))
(home-page "https://odamex.net/")
(synopsis "Multiplayer Doom port")
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index b0d8b4274e..75cd67fd2d 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -408,7 +408,7 @@ (define-public onedrive
(list pkg-config))
(inputs
(list bash-minimal
- curl-minimal
+ curl
ldc
libnotify
sqlite))
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 10/11] services: desktop: Remove 'xfce-desktop-service' procedure.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
98fb7c7335eb9aff42e83cb3df571f9be98c6397.1677456515.git.mirai@makinata.eu
* gnu/services/desktop.scm (xfce-desktop-service): Remove procedure.
---
gnu/services/desktop.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index 08f05fbdf9..1bbc7c5d12 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -1465,16 +1465,7 @@ (define xfce-desktop-service-type
(default-value (xfce-desktop-configuration))
(description "Run the Xfce desktop environment.")))
-(define-deprecated (xfce-desktop-service #:key (config
- (xfce-desktop-configuration)))
- xfce-desktop-service-type
- "Return a service that adds the @code{xfce} package to the system profile,
-and extends polkit with the ability for @code{thunar} to manipulate the file
-system as root from within a user session, after the user has authenticated
-with the administrator's password."
- (service xfce-desktop-service-type config))
-
-+
+
;;;
;;; Lxqt desktop service.
;;;
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 11/11] guix: packages: Remove 'origin-sha256' procedure.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
b385682f37115c576fe85de408fe6f450f261d14.1677456515.git.mirai@makinata.eu
* guix/packages.scm (origin-sha256): Remove procedure.
* tests/import-utils.scm (test-import-utils)
[alist->package with explicit source]: Use content-hash-value.
---
guix/packages.scm | 9 ---------
tests/import-utils.scm | 2 +-
2 files changed, 1 insertion(+), 10 deletions(-)

Toggle diff (42 lines)
diff --git a/guix/packages.scm b/guix/packages.scm
index 041a872f9d..bded89b1e0 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -73,7 +73,6 @@ (define-module (guix packages)
origin-uri
origin-method
origin-hash
- origin-sha256 ;deprecated
origin-file-name
origin-actual-file-name
origin-patches
@@ -345,14 +344,6 @@ (define-syntax-rule (origin fields ...)
specifications to 'hash'."
(origin-compatibility-helper (fields ...) ()))
-(define-deprecated (origin-sha256 origin)
- origin-hash
- (let ((hash (origin-hash origin)))
- (unless (eq? (content-hash-algorithm hash) 'sha256)
- (raise (condition (&message
- (message (G_ "no SHA256 hash for origin"))))))
- (content-hash-value hash)))
-
(define (print-origin origin port)
"Write a concise representation of ORIGIN to PORT."
(match origin
diff --git a/tests/import-utils.scm b/tests/import-utils.scm
index 44dff14597..1565dd610a 100644
--- a/tests/import-utils.scm
+++ b/tests/import-utils.scm
@@ -141,7 +141,7 @@ (define-module (test-import-utils)
(license:license? (package-license pkg))
(build-system? (package-build-system pkg))
(origin? (package-source pkg))
- (equal? (origin-sha256 (package-source pkg))
+ (equal? (content-hash-value (origin-hash (package-source pkg)))
(base32 "0ssi1wpaf7plaswqqjwigppsg5fyh99vdlb9kzl7c9lng89ndq1i")))))
(test-equal "alist->package with false license" ;<https://bugs.gnu.org/30470>
--
2.39.1
B
B
Bruno Victal wrote on 27 Feb 2023 01:11
[PATCH 07/11] services: guix-publish: Remove 'compression-level' field.
(address . 61829@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
014d8b0f1dc3cc1e9b05987bc71b4835e72e4a57.1677456515.git.mirai@makinata.eu
* gnu/services/base.scm (<guix-publish-configuration>)[compression-level]: Remove field.
(guix-publish-configuration-compression-level): Remove procedure.
(default-compression): Remove compression-level helper code.
---
gnu/services/base.scm | 29 +++++++----------------------
1 file changed, 7 insertions(+), 22 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 483a4ccd05..8d72ff900b 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -222,7 +222,6 @@ (define-module (gnu services base)
guix-publish-configuration-port
guix-publish-configuration-host
guix-publish-configuration-compression
- guix-publish-configuration-compression-level ;deprecated
guix-publish-configuration-nar-path
guix-publish-configuration-cache
guix-publish-configuration-ttl
@@ -1953,10 +1952,7 @@ (define-record-type* <guix-publish-configuration>
(default #f))
(compression guix-publish-configuration-compression
(thunked)
- (default (default-compression this-record
- (current-source-location))))
- (compression-level %guix-publish-configuration-compression-level ;deprecated
- (default #f))
+ (default (default-compression this-record)))
(nar-path guix-publish-configuration-nar-path ;string
(default "nar"))
(cache guix-publish-configuration-cache ;#f | string
@@ -1970,25 +1966,14 @@ (define-record-type* <guix-publish-configuration>
(negative-ttl guix-publish-configuration-negative-ttl ;#f | integer
(default #f)))
-(define-deprecated (guix-publish-configuration-compression-level config)
- "Return a compression level, the old way."
- (match (guix-publish-configuration-compression config)
- (((_ level) _ ...) level)))
-
-(define (default-compression config properties)
+(define (default-compression config)
"Return the default 'guix publish' compression according to CONFIG, and
raise a deprecation warning if the 'compression-level' field was used."
- (match (%guix-publish-configuration-compression-level config)
- (#f
- ;; Default to low compression levels when there's no cache so that users
- ;; get good bandwidth by default.
- (if (guix-publish-configuration-cache config)
- '(("gzip" 5) ("zstd" 19))
- '(("gzip" 3) ("zstd" 3)))) ;zstd compresses faster
- (level
- (warn-about-deprecation 'compression-level properties
- #:replacement 'compression)
- `(("gzip" ,level)))))
+ ;; Default to low compression levels when there's no cache so that users
+ ;; get good bandwidth by default.
+ (if (guix-publish-configuration-cache config)
+ '(("gzip" 5) ("zstd" 19))
+ '(("gzip" 3) ("zstd" 3)))) ;zstd compresses faster
(define (guix-publish-shepherd-service config)
(define (config->compression-options config)
--
2.39.1
S
S
Simon Tournier wrote on 28 Feb 2023 13:54
Re: [bug#61829] [PATCH 02/11] gnu: curl-minimal: Remove variable.
(name . Bruno Victal)(address . mirai@makinata.eu)
878rgij6fw.fsf@gmail.com
Hi,

On lun., 27 févr. 2023 at 00:11, Bruno Victal <mirai@makinata.eu> wrote:

Toggle quote (3 lines)
> -(define-public curl-minimal
> - (deprecated-package "curl-minimal" curl))

Similar comment as the other patch removing variables.

All the rest LGTM.

Cheers,
simon
S
S
Simon Tournier wrote on 28 Feb 2023 13:52
Re: [bug#61829] [PATCH 01/11] gnu: Purge pre-1.3.0 deprecated packages.
(name . Bruno Victal)(address . mirai@makinata.eu)
87edqaj6jd.fsf@gmail.com
Hi,

On lun., 27 févr. 2023 at 00:11, Bruno Victal <mirai@makinata.eu> wrote:

Toggle quote (14 lines)
> * gnu/packages/bioinformatics.scm (deeptools): Remove variable.
> * gnu/packages/efi.scm (efi_analyzer): Ditto.
> * gnu/packages/guile.scm (guile-2.2/bug-fix, guile-json): Ditto.
> * gnu/packages/image.scm (libjpeg): Ditto.
> * gnu/packages/kde.scm (kdevplatform): Ditto
> * gnu/packages/linphone.scm (linphoneqt): Ditto.
> * gnu/packages/maths.scm (blis-sandybridge, blis-haswell, blis-knl): Ditto.
> * gnu/packages/mpi.scm (hwloc-2.0): Ditto.
> * gnu/packages/music.scm (python-abjad, zlfo): Ditto.
> * gnu/packages/perl.scm (perl-base, perl-parent): Ditto.
> * gnu/packages/tryton.scm (python-trytond): Ditto.
> * gnu/packages/video.scm (gnome-mpv): Ditto.
> * tests/graph.scm: Use guile-json-1.

[...]

Toggle quote (3 lines)
> -(define-deprecated deeptools python-deeptools)
> -

Well, I do not use any of these packages, so I would not mind much.
But, I know some users who use this one for instance and I would like to
avoid them some breakage.

What is the rationale for removing this variable? Or the others, BTW.

Well, I understand the “being deprecated” and I agree it would be nice
to clean up. Thanks for this janitoring work. :-)

However, I would first announce such clean up, via guix-devel and/or
news, maybe info-guix, let some time, say one or two months, and after
proceed.

For what my opinion is worth.

Cheers,
simon
S
S
Simon Tournier wrote on 28 Feb 2023 13:57
Re: [bug#61829] [PATCH 11/11] guix: packages: Remove 'origin-sha256' procedure.
(name . Bruno Victal)(address . mirai@makinata.eu)
871qmaj6b6.fsf@gmail.com
Hi,

On lun., 27 févr. 2023 at 00:11, Bruno Victal <mirai@makinata.eu> wrote:

Toggle quote (2 lines)
> - origin-sha256 ;deprecated

[...]

Toggle quote (8 lines)
> -(define-deprecated (origin-sha256 origin)
> - origin-hash
> - (let ((hash (origin-hash origin)))
> - (unless (eq? (content-hash-algorithm hash) 'sha256)
> - (raise (condition (&message
> - (message (G_ "no SHA256 hash for origin"))))))
> - (content-hash-value hash)))

Similarly as previously, I would not remove this without more
advertisement.


Toggle quote (11 lines)
> diff --git a/tests/import-utils.scm b/tests/import-utils.scm
> index 44dff14597..1565dd610a 100644
> --- a/tests/import-utils.scm
> +++ b/tests/import-utils.scm
> @@ -141,7 +141,7 @@ (define-module (test-import-utils)
> (license:license? (package-license pkg))
> (build-system? (package-build-system pkg))
> (origin? (package-source pkg))
> - (equal? (origin-sha256 (package-source pkg))
> + (equal? (content-hash-value (origin-hash (package-source pkg)))

This LGTM although this test was for testing origin-sha256 specifically,
I guess. :-)

Cheers,
simon
B
B
Bruno Victal wrote on 2 Mar 2023 03:29
Re: [bug#61829] [PATCH 01/11] gnu: Purge pre-1.3.0 deprecated packages.
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
928e1b99-9c25-14f4-31eb-52ccd2c74b4d@makinata.eu
Hi Simon,

On 2023-02-28 12:52, Simon Tournier wrote:
Toggle quote (13 lines)
> Hi,
>
> On lun., 27 févr. 2023 at 00:11, Bruno Victal <mirai@makinata.eu> wrote:
>
>> -(define-deprecated deeptools python-deeptools)
>> -
>
> Well, I do not use any of these packages, so I would not mind much.
> But, I know some users who use this one for instance and I would like to
> avoid them some breakage.
>
> What is the rationale for removing this variable? Or the others, BTW.

[...]
Toggle quote (7 lines)
> Well, I understand the “being deprecated” and I agree it would be nice
> to clean up. Thanks for this janitoring work. :-)
>
> However, I would first announce such clean up, via guix-devel and/or
> news, maybe info-guix, let some time, say one or two months, and after
> proceed.

This was informally discussed in #guix with Ludovic as a follow-up to
the services cleanup. (tracked at #61789)

The idea is to shed pre-1.3.0 deprecated code from Guix to reduce the
overall maintenance burden. Given the age of the release and the warnings, I assume
most users/maintainers would have taken notice and applied updates.
(no actual package definitions have been removed, only their old aliases)

These variables were found by grep + git blame'ing the files and combing the output
to ensure that only pre-1.3.0 variables were considered.

Cheers,
Bruno
L
L
Ludovic Courtès wrote on 3 Mar 2023 17:29
Re: bug#61829: [PATCH 00/11] Purge pre-1.3.0 deprecated procedures & variables.
(name . Bruno Victal)(address . mirai@makinata.eu)
87v8jhvlwc.fsf_-_@gnu.org
Hi,

Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (5 lines)
> The idea is to shed pre-1.3.0 deprecated code from Guix to reduce the
> overall maintenance burden. Given the age of the release and the warnings, I assume
> most users/maintainers would have taken notice and applied updates.
> (no actual package definitions have been removed, only their old aliases)

I agree: the whole point of deprecation warnings is to communicate to
users the eventual removal of a symbol or functionality. I think it’s
more efficient than emails to info-guix in that regard.

The project has yet to define a clear deprecation policy, and I hope
maintainers can spearhead such an effort. In the meantime, removing
things that have been deprecated for 22+ months in this case sounds
reasonable to me.

Ludo’.
S
S
Simon Tournier wrote on 3 Mar 2023 19:57
Re: [bug#61829] [PATCH 01/11] gnu: Purge pre-1.3.0 deprecated packages.
(name . Bruno Victal)(address . mirai@makinata.eu)
86h6v1zmqg.fsf@gmail.com
Hi Bruno,

On Thu, 02 Mar 2023 at 02:29, Bruno Victal <mirai@makinata.eu> wrote:

Toggle quote (3 lines)
> This was informally discussed in #guix with Ludovic as a follow-up to
> the services cleanup. (tracked at #61789)

Ah cool!

Toggle quote (8 lines)
> The idea is to shed pre-1.3.0 deprecated code from Guix to reduce the
> overall maintenance burden. Given the age of the release and the warnings, I assume
> most users/maintainers would have taken notice and applied updates.
> (no actual package definitions have been removed, only their old aliases)
>
> These variables were found by grep + git blame'ing the files and combing the output
> to ensure that only pre-1.3.0 variables were considered.

Well, I have nothing for the removal, only with the process. Somehow,
we are missing a policy for such, IMHO. And that’s not related to this
series. :-)

Since the variables are deprecated since a very long time, yeah it
sounds reasonable to remove them.

Cheers,
simon
L
L
Ludovic Courtès wrote on 7 Apr 2023 18:02
Re: bug#61829: [PATCH 00/11] Purge pre-1.3.0 deprecated procedures & variables.
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 61829-done@debbugs.gnu.org)
87wn2nbrz5.fsf@gnu.org
Hi,

Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (13 lines)
> gnu: Purge pre-1.3.0 deprecated packages.
> gnu: curl-minimal: Remove variable.
> services: ntp-service-type: Remove deprecated server as strings
> support.
> services: sddm: Remove 'sddm-service' procedure.
> services: base: Remove 'console-keymap-service-type' variable.
> services: base: Remove 'console-font-service' procedure.
> services: guix-publish: Remove 'compression-level' field.
> services: desktop: Remove 'gnome-desktop-service' procedure.
> services: desktop: Remove 'mate-desktop-service' procedure.
> services: desktop: Remove 'xfce-desktop-service' procedure.
> guix: packages: Remove 'origin-sha256' procedure.

Finally pushed the whole series as
5481aaacb5f60ba43d8db7e51cb7cc967d5eb55e.

Thanks for the spring cleanup!

Ludo’.
Closed
?