* gnu/packages/bioinformatics.scm (deeptools): Remove variable.
* gnu/packages/efi.scm (efi_analyzer): Ditto.
* gnu/packages/guile.scm (guile-2.2/bug-fix, guile-json): Ditto.
* gnu/packages/image.scm (libjpeg): Ditto.
* gnu/packages/kde.scm (kdevplatform): Ditto
* gnu/packages/linphone.scm (linphoneqt): Ditto.
* gnu/packages/maths.scm (blis-sandybridge, blis-haswell, blis-knl): Ditto.
* gnu/packages/mpi.scm (hwloc-2.0): Ditto.
* gnu/packages/music.scm (python-abjad, zlfo): Ditto.
* gnu/packages/perl.scm (perl-base, perl-parent): Ditto.
* gnu/packages/tryton.scm (python-trytond): Ditto.
* gnu/packages/video.scm (gnome-mpv): Ditto.
* tests/graph.scm: Use guile-json-1.
---
gnu/packages/bioinformatics.scm | 2 --
gnu/packages/efi.scm | 4 ----
gnu/packages/guile.scm | 8 --------
gnu/packages/image.scm | 3 ---
gnu/packages/kde.scm | 3 ---
gnu/packages/linphone.scm | 3 ---
gnu/packages/maths.scm | 4 ----
gnu/packages/mpi.scm | 2 --
gnu/packages/music.scm | 7 -------
gnu/packages/perl.scm | 6 ------
gnu/packages/tryton.scm | 3 ---
gnu/packages/video.scm | 3 ---
tests/graph.scm | 2 +-
13 files changed, 1 insertion(+), 49 deletions(-)
Toggle diff (216 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9e8f7e92f8..377661404c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3349,8 +3349,6 @@ (define-public python-deeptools
;; remainder of the code is licensed under the MIT license.
(license (list license:bsd-3 license:expat))))
-(define-deprecated deeptools python-deeptools)
-
(define-public cutadapt
(package
(name "cutadapt")
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 4625538d26..75eb24bf86 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -96,10 +96,6 @@ (define-public efi-analyzer
information.")
(license license:bsd-2))))
-(define-public efi_analyzer
- ;; For a short while the package name contained an underscore.
- (deprecated-package "efi_analyzer" efi-analyzer))
-
(define-public sbsigntools
(package
(name "sbsigntools")
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 2fd9b711ce..e11627a67e 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -291,8 +291,6 @@ (define-public guile-2.2
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
-(define-deprecated guile-2.2/bug-fix guile-2.2)
-
(define-public guile-2.2.4
(package
(inherit guile-2.2)
@@ -650,12 +648,6 @@ (define-public guile-json-1
;; Version 1.2.0 switched to GPLv3+ (from LGPLv3+).
(license license:gpl3+)))
-;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
-;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
-;; 'guile-json-3'.
-(define-deprecated guile-json guile-json-1)
-(export guile-json)
-
(define-public guile2.0-json
(package-for-guile-2.0 guile-json-1))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5071dd588f..a7784949a5 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1712,9 +1712,6 @@ (define-public libjpeg-turbo
license:ijg ;the libjpeg library and associated tools
license:zlib)))) ;the libjpeg-turbo SIMD extensions
-(define-deprecated libjpeg libjpeg-turbo)
-(export libjpeg)
-
(define-public niftilib
(package
(name "niftilib")
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 728051b9e4..5b6d638e4a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -412,9 +412,6 @@ (define-public kdevelop-pg-qt
for some KDevelop language plugins (Ruby, PHP, CSS...).")
(license license:lgpl2.0+)))
-;; kdevplatform was merged into kdevelop as of 5.2.x
-(define-deprecated kdevplatform kdevelop)
-
(define-public kdiagram
(package
(name "kdiagram")
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 84bc16805c..d41d368e67 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -876,9 +876,6 @@ (define-public linphone-desktop
(home-page "https://linphone.org/technical-corner/linphone")
(license license:gpl3+)))
-(define-public linphoneqt
- (deprecated-package "linphoneqt" linphone-desktop))
-
(define-public msopenh264
(let ((commit "88697cc95140017760d6da408cb0efdc5e86e40a")
(revision "0"))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 280465e284..58bcd8bc09 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4902,10 +4902,6 @@ (define-public blis
access to BLIS implementations via traditional BLAS routine calls.")
(license license:bsd-3)))
-(define-public blis-sandybridge (deprecated-package "blis-sandybridge" blis))
-(define-public blis-haswell (deprecated-package "blis-haswell" blis))
-(define-public blis-knl (deprecated-package "blis-knl" blis))
-
(define ignorance blis)
(define-public openlibm
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index e8c20919d7..f97bba24d7 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -180,8 +180,6 @@ (define-public hwloc-2
(("hwloc_topology_init" all)
(string-append "exit (77);\n" all)))))))))))
-(define-deprecated hwloc-2.0 hwloc-2)
-
(define-public hwloc
;; The latest stable series of hwloc.
hwloc-2)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f4a570189b..30092965c8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1543,9 +1543,6 @@ (define-public abjad
typographic detail of symbols on the page.")
(license license:expat)))
-(define-public python-abjad
- (deprecated-package "python-abjad" abjad))
-
(define-public abjad-ext-rmakers
(package
(name "abjad-ext-rmakers")
@@ -6491,10 +6488,6 @@ (define-public zplugins
(home-page "https://www.zrythm.org/en/plugins.html")
(license license:agpl3+)))
-(define-public zlfo
- ;; The "zlfo" package is now included in zplugins
- (deprecated-package "zlfo" zplugins))
-
(define-public remid-lv2
(package
(name "remid-lv2")
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 41b68baea8..a6b5a7b013 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -817,9 +817,6 @@ (define-public perl-bareword-filehandles
(description "This module disables bareword filehandles.")
(license (package-license perl))))
-(define-public perl-base
- (deprecated-package "perl-base" perl))
-
(define-public perl-browser-open
(package
(name "perl-browser-open")
@@ -8598,9 +8595,6 @@ (define-public perl-par-dist
distributions.")
(license (package-license perl))))
-(define-public perl-parent
- (deprecated-package "perl-parent" perl))
-
(define-public perl-path-class
(package
(name "perl-path-class")
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8e561cad45..0b367675ae 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -100,9 +100,6 @@ (define-public trytond
and security.")
(license license:gpl3+)))
-(define-public python-trytond
- (deprecated-package "python-trytond" trytond))
-
(define-public tryton
(package
(name "tryton")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f63d5494de..aaf0fdd670 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2347,9 +2347,6 @@ (define-public gallery-dl
images and image hosting sites.")
(license license:gpl2)))
-(define-public gnome-mpv
- (deprecated-package "gnome-mpv" celluloid))
-
(define-public mpv-mpris
(package
(name "mpv-mpris")
diff --git a/tests/graph.scm b/tests/graph.scm
index 6674b5cc8f..a6186ff7e8 100644
--- a/tests/graph.scm
+++ b/tests/graph.scm
@@ -477,7 +477,7 @@ (define (edge->tuple source target)
'("libffi" "guile" "guile-json")
(run-with-store %store
(mlet %store-monad ((path (shortest-path (specification->package "libffi")
- guile-json
+ guile-json-1
%reverse-package-node-type)))
(return (map package-name path)))))
--
2.39.1