[PATCH] gnu: Add tenacity.

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal

Debbugs page

Liliana Marie Prikler wrote 2 years ago
(address . guix-patches@gnu.org)
361f3d02e27b26f09d1017fa9e174a363d4d70a6.camel@gmail.com
* gnu/packages/audio.scm (tenacity): New variable.
---
gnu/packages/audio.scm | 111 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 111 insertions(+)

Toggle diff (124 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ffb972175e..6f3fa2a580 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -990,6 +990,117 @@ (define-public audacity
tools.")
(license license:gpl2+)))
+(define-public tenacity
+ (package
+ (name "tenacity")
+ (version "1.3-beta2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/tenacityteam/tenacity")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pd2vxzqzq7ikz7l2a1h9qwq08276xicvphrpn47gvmwaslah1gn"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:imported-modules `((guix build glib-or-gtk-build-system)
+ ,@%cmake-build-system-modules)
+ #:modules
+ '((guix build utils)
+ (guix build cmake-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-upstream-headers
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("libraries/lib-files/FileNames.cpp")
+ (("\"/usr/include/linux/magic.h\"") "<linux/magic.h>"))))
+ (add-after 'unpack
+ 'i-spy-with-my-little-eye-something-in-the-wrong-folder
+ (lambda _
+ (symlink (string-append (getcwd) "/images")
+ "src/images")))
+ (add-after 'unpack 'fix-cmake-rpath
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$ORIGIN/\\.\\./\\$\\{_PKGLIB\\}")
+ (string-append (assoc-ref outputs "out") "/lib/tenacity"))
+ (("CMAKE_BUILD_WITH_INSTALL_RPATH [A-Z]*")
+ "CMAKE_BUILD_WITH_INSTALL_RPATH TRUE")
+ (("CMAKE_INSTALL_RPATH_USE_LINK_PATH [A-Z]*")
+ "CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE"))
+ (substitute* "src/CMakeLists.txt"
+ ;; Despite the name, this script breaks rpath. Don't run it.
+ (("install.*linux/fix_rpath\\.cmake.*")
+ "")
+ (("-Wl,--disable-new-dtags") "-Wl,--enable-new-dtags"))))
+ (replace 'configure
+ (lambda args
+ (define %configure (assoc-ref %standard-phases 'configure))
+ (with-exception-handler
+ (lambda (error)
+ (unless (invoke-error? error)
+ (raise error))
+ ;; Have you tried turning it off and on again?
+ (apply invoke (invoke-error-program error)
+ (invoke-error-arguments error)))
+ (lambda ()
+ (apply %configure args))
+ #:unwind? #t)))
+ (add-after 'wrap-program 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))
+ ;; Test suite? Which test suite?
+ #:tests? #f))
+ (inputs
+ (list wxwidgets
+ gtk+
+ alsa-lib
+ jack-1
+ expat
+ lame
+ flac
+ ffmpeg
+ libid3tag
+ libjpeg-turbo
+ ;;("libsbsms" ,libsbsms) ;bundled version is modified
+ libsndfile
+ mpg123
+ soundtouch
+ soxr ;replaces libsamplerate
+ sqlite
+ twolame
+ vamp
+ libvorbis
+ lv2
+ lilv ;for lv2
+ suil ;for lv2
+ portaudio
+ portmidi
+ wavpack))
+ (native-inputs
+ (list gettext-minimal ;for msgfmt
+ libtool
+ pkg-config
+ python
+ which))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TENACITY_MODULES_PATH")
+ (files '("lib/tenacity/modules")))
+ (search-path-specification
+ (variable "TENACITY_PATH")
+ (files '("share/tenacity")))))
+ (home-page "https://tenacityaudio.org/")
+ (synopsis "Software for recording and editing sounds")
+ (description
+ "Tenacity is a multi-track audio editor designed for recording, playing
+and editing digital audio. It features digital effects and spectrum analysis
+tools.")
+ (license license:gpl2+)))
+
(define-public audiofile
(package
(name "audiofile")
--
2.39.1
Liliana Marie Prikler wrote 2 years ago
(address . 61826-done@debbugs.gnu.org)
67b03bac7d29d14017c19f870f485f0e569e5e93.camel@gmail.com
Am Sonntag, dem 26.02.2023 um 21:50 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (1 lines)
> * gnu/packages/audio.scm (tenacity): New variable.
Pushed.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61826@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61826
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help