Various Ogg Vorbis crates

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Steve George
Owner
unassigned
Submitted by
Steve George
Severity
normal
S
S
Steve George wrote on 26 Feb 2023 17:58
(address . guix-patches@gnu.org)
1730281e-53f6-6484-ad21-28052dc4771c@futurile.net
Hi,

First set of crates to complete the dependency tree for
rust-librespot-audio-core

- rust-vorbisfile-sys
- rust-vorbis-sys
- rust-ogg-sys
- rust-vorbis

- rust-librespot-tremor
- rust-owning-ref
- rust-parking-lot-core (0.2)
- rust-parking-lot (0.4)

- rust-rental-impl
- rust-rental
- rust-alto

- rust-ogg
- rust-lewton
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 02/14] gnu: Add rust-vorbis-sys.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-2-steve@futurile.net
* gnu/packages/crates-io.scm (rust-vorbis-sys): New variable.
---

gnu/packages/crates-io.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a0fe36312f..93302c13fb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65865,6 +65865,34 @@ (define-public rust-volatile-register-0.2
hardware registers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-vorbis-sys-0.1
+ (package
+ (name "rust-vorbis-sys")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "vorbis-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1zgv7lwa4b2z091g25h83zil8bawk4frc1f0ril5xa31agpxd7mx"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-ogg-sys" ,rust-ogg-sys-0.0.9)
+ ("rust-cc" ,rust-cc-1)
+ ("rust-gcc" ,rust-gcc-0.3) ;errors if gcc crate isn't specified
+ ("rust-pkg-config" ,rust-pkg-config-0.3))))
+ (home-page "https://github.com/tomaka/vorbis-sys")
+ (synopsis "Rust FFI for the libvorbis library")
+ (description
+ "This package provides a Foreign Function Interface (FFI) for libvorbis.
+Ogg Vorbis is a fully open, non-proprietary, patent and royalty free,
+compressed audio format. It's used for audio and music at fixed and variable
+bitrates.")
+ (license license:expat)))
+
(define-public rust-vswhom-0.1
(package
(name "rust-vswhom")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 03/14] gnu: Add rust-vorbisfile-sys.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-3-steve@futurile.net
* gnu/packages/crates-io.scm (rust-vorbisfile-sys): New variable.
---

gnu/packages/crates-io.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 93302c13fb..1f85876193 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65865,6 +65865,34 @@ (define-public rust-volatile-register-0.2
hardware registers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-vorbisfile-sys-0.0.8
+ (package
+ (name "rust-vorbisfile-sys")
+ (version "0.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "vorbisfile-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1la2j2zbzdjd93byz21ij58c540bfn1r9pi0bssrjimcw7bhchsg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-ogg-sys" ,rust-ogg-sys-0.0.9)
+ ("rust-vorbis-sys" ,rust-vorbis-sys-0.1)
+ ("rust-gcc" ,rust-gcc-0.3)
+ ("rust-pkg-config" ,rust-pkg-config-0.3))))
+ (home-page "https://gitlab.com/taricorp/vorbisfile-rs")
+ (synopsis "Bindings for Ogg Vorbis' Libvorbisfile library")
+ (description "The Vorbisfile library provides a convenient high-level
+API for decoding and basic manipulation of all Vorbis 1 audio streams.
+Libvorbisfile is implemented as a layer on top of Xiph.Org's reference Libogg
+and Libvorbis libraries.")
+ (license license:isc)))
+
(define-public rust-vorbis-sys-0.1
(package
(name "rust-vorbis-sys")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 01/14] gnu: Add rust-ogg-sys.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-1-steve@futurile.net
* gnu/packages/crates-io.scm (rust-ogg-sys): New variable.
---

gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 310cec113f..a0fe36312f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37620,6 +37620,33 @@ (define-public rust-odds-0.2
("rust-memchr" ,rust-memchr-2)
("rust-quickcheck" ,rust-quickcheck-0.4))))))
+(define-public rust-ogg-sys-0.0.9
+ (package
+ (name "rust-ogg-sys")
+ (version "0.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ogg-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1cpx6n5ndh2d59g43l6rj3myzi5jsc0n6rldpx0impqp5qbqqnx9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2))
+ #:cargo-development-inputs
+ (("rust-gcc" ,rust-gcc-0.3)
+ ("rust-pkg-config" ,rust-pkg-config-0.3))))
+ (home-page "https://github.com/tomaka/ogg-sys")
+ (synopsis "Rust FFI for libogg, the media container.")
+ (description
+ "A Rust Foreign Function Interface (FFI) for libogg. Ogg is a fully
+open, non-proprietary, patent and royalty free container format used for
+efficient streaming and manipulation of high-quality digital multimedia")
+ (license license:expat)))
+
(define-public rust-oid-registry-0.2
(package
(name "rust-oid-registry")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 08/14] gnu: Add rust-parking-lot-0.4.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-8-steve@futurile.net
* gnu/packages/crates-io.scm (rust-parking-lot-0.4): New variable.
---

gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 53eaa14a7f..e4aed24782 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39176,6 +39176,27 @@ (define-public rust-parking-lot-0.7
("rust-rand" ,rust-rand-0.4)
("rust-rustc-version" ,rust-rustc-version-0.2))))))
+(define-public rust-parking-lot-0.4
+ (package
+ (inherit rust-parking-lot-0.9)
+ (name "rust-parking-lot")
+ (version "0.4.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "parking-lot" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0ph0kv3dfcxpjbi83wkzammqb7lm95j8in7w7hz17hgkjxdqz78l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-parking-lot-core" ,rust-parking-lot-core-0.2)
+ ("rust-owning-ref" ,rust-owning-ref-0.3))
+ #:cargo-development-inputs
+ (("rust-rand" ,rust-rand-0.3))))))
+
(define-public rust-parking-lot-core-0.9
(package
(name "rust-parking-lot-core")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 10/14] gnu: Add rust-rental.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-10-steve@futurile.net
* gnu/packages/crates-io.scm (rust-rental): New variable.
---

gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c1bdbf22a6..8770d87f58 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46699,6 +46699,31 @@ (define-public rust-remove-dir-all-0.5.2
#:cargo-development-inputs
(("rust-doc-comment" ,rust-doc-comment-0.3))))))
+(define-public rust-rental-0.5
+ (package
+ (name "rust-rental")
+ (version "0.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rental" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0bhzz2pfbg0yaw8p1l31bggq4jn077wslf6ifhj22vf3r8mgx2fc"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f
+ #:skip-build? #f
+ #:cargo-inputs
+ (("rust-rental-impl" ,rust-rental-impl-0.5)
+ ("rust-stable-deref-trait" ,rust-stable-deref-trait-1))))
+ (home-page "https://github.com/jpernst/rental")
+ (synopsis "Macro to generate safe self-referential structs")
+ (description "A macro to generate safe self-referential structs, plus
+premade types for common use-cases. This crate is frozen and should be
+avoided if possible.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rental-impl-0.5
(package
(name "rust-rental-impl")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 07/14] gnu: Add rust-parking-lot-core-0.2.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-7-steve@futurile.net
* gnu/packages/crates-io.scm (rust-parking-lot-core-0.2): New variable.
---

gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0edafd5c01..53eaa14a7f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39350,6 +39350,30 @@ (define-public rust-parking-lot-core-0.4
("rust-winapi" ,rust-winapi-0.3)
("rust-rustc-version" ,rust-rustc-version-0.2))))))
+(define-public rust-parking-lot-core-0.2
+ (package
+ (inherit rust-parking-lot-core-0.6)
+ (name "rust-parking-lot-core")
+ (version "0.2.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "parking-lot-core" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1yip8m6npxb87ilnn0q774psp1zd0vgv66fcjkkvr9rlyz6aicad"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-rand" ,rust-rand-0.4)
+ ("rust-smallvec" ,rust-smallvec-0.6)
+ ("rust-winapi" ,rust-winapi-0.3)
+ ("rust-backtrace" ,rust-backtrace-0.3)
+ ("rust-petgraph" ,rust-petgraph-0.4)
+ ("rust-thread-id" ,rust-thread-id-3))))))
+
(define-public rust-parquet-5
(package
(name "rust-parquet")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 05/14] gnu: Add rust-librespot-tremor.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-5-steve@futurile.net
* gnu/packages/crates-io.scm (rust-librespot-tremor): New variable.

---
Had to set the package to skip build. It errors saying rust-ogg-sys
can't be built, but it does. Unsure how to debug or fix.

gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 257f35e147..626dfafa8e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30681,6 +30681,32 @@ (define-public rust-libradicl-0.4
single-cell and single-nucleus sequencing data.")
(license license:bsd-3)))
+(define-public rust-librespot-tremor-0.2
+ (package
+ (name "rust-librespot-tremor")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "librespot-tremor" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1zmld16zawvn7ayrf318lwdr2d7awn4bk9s0d6kpim0mz6zjbxcp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ; errors building ogg-sys - though ogg-sys builds
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-ogg-sys" ,rust-ogg-sys-0.0.9))
+ #:cargo-development-inputs
+ (("rust-cc" ,rust-cc-1)
+ ("rust-pkg-config" ,rust-pkg-config-0.3))))
+ (home-page "https://github.com/librespot-org/librespot-tremor")
+ (synopsis "Rust bindings for Tremor, a fixed point Vorbis decoder")
+ (description "Rust bindings for Tremor, a fixed point decoder for the
+Vorbis audio format. Used by platforms that can't do floating point maths.")
+ (license license:expat)))
+
(define-public rust-libsqlite3-sys-0.23
(package
(name "rust-libsqlite3-sys")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 11/14] gnu: Add rust-al-sys.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-11-steve@futurile.net
* gnu/packages/crates-io.scm (rust-al-sys): New variable.
---

gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8770d87f58..0d55a799f6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2543,6 +2543,30 @@ (define-public rust-aliasable-0.1
types.")
(license license:expat)))
+(define-public rust-al-sys-0.6
+ (package
+ (name "rust-al-sys")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "al-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08whlcfrhn4gqi4nbglkdqv5ysdpnvnlsqg51q34q9hh9l7rp3gz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-libloading" ,rust-libloading-0.5)
+ ("rust-rental" ,rust-rental-0.5))
+ #:cargo-development-inputs
+ (("rust-cmake" ,rust-cmake-0.1))))
+ (home-page "https://github.com/jpernst/alto")
+ (synopsis "Raw bindings for OpenAL 1.1")
+ (description "Rust bindings for OpenAL, this crate contains FFI elements.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-alloc-no-stdlib-2
(package
(name "rust-alloc-no-stdlib")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 04/14] gnu: Add rust-vorbis.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-4-steve@futurile.net
* gnu/packages/crates-io.scm (rust-vorbis): New variable.
---

gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1f85876193..257f35e147 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65865,6 +65865,30 @@ (define-public rust-volatile-register-0.2
hardware registers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-vorbis-0.0
+ (package
+ (name "rust-vorbis")
+ (version "0.0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "vorbis" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0xn7diq8qz2zmsmwzg3rcsxmpmm2gj7wgnl2gdan0lq7ax21k2jy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-ogg-sys" ,rust-ogg-sys-0.0.9)
+ ("rust-vorbisfile-sys" ,rust-vorbisfile-sys-0.0.8)
+ ("rust-vorbis-sys" ,rust-vorbis-sys-0.1))))
+ (home-page "https://github.com/tomaka/vorbis-rs")
+ (synopsis "High-level bindings for the official Libvorbis library")
+ (description "A simple vorbis decoder in Rust using Libvorbis.")
+ (license license:asl2.0)))
+
(define-public rust-vorbisfile-sys-0.0.8
(package
(name "rust-vorbisfile-sys")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 06/14] gnu: Add rust-owning-ref-0.3.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-6-steve@futurile.net
* gnu/packages/crates-io.scm (rust-owning-ref-0.3): New variable.
---

gnu/packages/crates-io.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 626dfafa8e..0edafd5c01 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -38588,6 +38588,24 @@ (define-public rust-owning-ref-0.4
normally prevent moving a type that has been borrowed from.")
(license license:expat)))
+(define-public rust-owning-ref-0.3
+ (package
+ (inherit rust-owning-ref-0.4)
+ (name "rust-owning-ref")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "owning-ref" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0dqgf5hwbmvkf2ffbik5xmhvaqvqi6iklhwk9x47n0wycd0lzy6d"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-stable-deref-trait" ,rust-stable-deref-trait-1))))))
+
(define-public rust-packed-simd-0.3
(package
(name "rust-packed-simd")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 12/14] gnu: Add rust-alto.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-12-steve@futurile.net
* gnu/packages/crates-io.scm (rust-alto): New variable.
---

gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0d55a799f6..a632c6d4f3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2611,6 +2611,30 @@ (define-public rust-alloc-stdlib-0.2
be used with the stdlib.")
(license license:bsd-3)))
+(define-public rust-alto-3
+ (package
+ (name "rust-alto")
+ (version "3.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "alto" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1rgsdmh346s3rwhzqacjc6nz7jap4dd72c1gfmkaq9sgzh9fhnyp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; tests assume Windows
+ #:skip-build? #f
+ #:cargo-inputs
+ (("rust-al-sys" ,rust-al-sys-0.6)
+ ("rust-lazy-static" ,rust-lazy-static-0.2)
+ ("rust-parking-lot" ,rust-parking-lot-0.4))))
+ (home-page "https://github.com/jpernst/alto")
+ (synopsis "Idiomatic Rust bindings for OpenAL 1.1 and extensions (including EFX)")
+ (description "Rust bindings for OpenAL 1.1 and extensions (including EFX).")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-always-assert-0.1
(package
(name "rust-always-assert")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 09/14] gnu: Add rust-rental-impl.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-9-steve@futurile.net
* gnu/packages/crates-io.scm (rust-rental-impl): New variable.
---

gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e4aed24782..c1bdbf22a6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46699,6 +46699,30 @@ (define-public rust-remove-dir-all-0.5.2
#:cargo-development-inputs
(("rust-doc-comment" ,rust-doc-comment-0.3))))))
+(define-public rust-rental-impl-0.5
+ (package
+ (name "rust-rental-impl")
+ (version "0.5.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rental-impl" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pj0qgmvwwsfwyjqyjxzikkwbwc3vj7hm3hdykr47dy5inbnhpj7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://github.com/jpernst/rental")
+ (synopsis "Implementation details of the rust-rental crate")
+ (description "Implementation details for the rust-rental crate.
+Should not be used directly.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-reopen-0.3
(package
(name "rust-reopen")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 13/14] gnu: Add rust-ogg.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-13-steve@futurile.net
* gnu/packages/crates-io.scm (rust-ogg): New variable.
---

gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a632c6d4f3..92dffb8497 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37694,6 +37694,33 @@ (define-public rust-odds-0.2
("rust-memchr" ,rust-memchr-2)
("rust-quickcheck" ,rust-quickcheck-0.4))))))
+(define-public rust-ogg-0.8
+ (package
+ (name "rust-ogg")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ogg" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0vjxmqcv9252aj8byy70iy2krqfjknfcxg11lcyikj11pzlb8lb9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-0.4)
+ ("rust-futures" ,rust-futures-0.1)
+ ("rust-tokio-io" ,rust-tokio-io-0.1))
+ #:cargo-development-inputs
+ (("rust-rand" ,rust-rand-0.3))))
+ (home-page "https://github.com/RustAudio/ogg")
+ (synopsis "Ogg container decoder and encoder written in pure Rust")
+ (description "An Ogg decoder and encoder. Implements the xiph.org Ogg
+spec in pure Rust.")
+ (license license:expat)))
+
(define-public rust-ogg-sys-0.0.9
(package
(name "rust-ogg-sys")
--
2.39.1
S
S
Steve George wrote on 26 Feb 2023 18:09
[PATCH 14/14] gnu: Add rust-lewton.
(address . 61818@debbugs.gnu.org)
20230226170928.9407-14-steve@futurile.net
* gnu/packages/crates-io.scm (rust-lewton): New variable.

---

gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 92dffb8497..23cb4825a2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29720,6 +29720,35 @@ (define-public rust-lettre-0.9
sending emails from Rust applications.")
(license license:expat)))
+(define-public rust-lewton-0.10
+ (package
+ (name "rust-lewton")
+ (version "0.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lewton" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0c60fn004awg5c3cvx82d6na2pirf0qdz9w3b93mbcdakbglhyvp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #f
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-tinyvec" ,rust-tinyvec-1)
+ ("rust-futures" ,rust-futures-0.1)
+ ("rust-ogg" ,rust-ogg-0.8)
+ ("rust-tokio-io" ,rust-tokio-io-0.1))
+ #:cargo-development-inputs
+ (("rust-alto" ,rust-alto-3)
+ ("rust-ogg" ,rust-ogg-0.8))))
+ (home-page "https://github.com/RustAudio/lewton")
+ (synopsis "Pure Rust Vorbis decoder")
+ (description "A pure Rust Vorbis decoder. Vorbis is a free and open
+source audio format.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-lexical-core-0.8
(package
(name "rust-lexical-core")
--
2.39.1
S
S
Steve George wrote on 3 Jun 2023 11:32
Gentle nudge on #61818
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 61818@debbugs.gnu.org)
e9af4d57-3782-ebc0-8e1e-6b46e201b7e3@futurile.net
Hi,

I don't think you reviewed the crates in #61818 when the rust-branch was
merged. I checked master and rust-team.

Thanks,

Futurile
E
E
Efraim Flashner wrote on 4 Jun 2023 09:33
Re: [bug#61818] Various Ogg Vorbis crates
(name . Steve George)(address . steve@futurile.net)(address . 61818@debbugs.gnu.org)
ZHw-Y41Nb8Dcb4xO@3900XT
On Sun, Feb 26, 2023 at 04:58:22PM +0000, Steve George wrote:
Toggle quote (22 lines)
> Hi,
>
> First set of crates to complete the dependency tree for
> rust-librespot-audio-core
>
> - rust-vorbisfile-sys
> - rust-vorbis-sys
> - rust-ogg-sys
> - rust-vorbis
>
> - rust-librespot-tremor
> - rust-owning-ref
> - rust-parking-lot-core (0.2)
> - rust-parking-lot (0.4)
>
> - rust-rental-impl
> - rust-rental
> - rust-alto
>
> - rust-ogg
> - rust-lewton

I'm not sure which of these crates are actually necessary. I didn't see
any users of rust-librespot-tremor¹ and I wasn't even really sure where
some of the other crates came into use. Are you trying to package
rust-librespot?


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR8PmAACgkQQarn3Mo9
g1GF0A//ciWGLAbODExGpdp+sor1rk+gxaljvsmRwkoGOu4CTZrT4CfbeiD8dQI+
qnhQfSpV1ot+7i8pgAJMXZ3a1g/1Qi45xR+v2oS0GpC1QKxqma2vJc+0GkFhTaCW
XSQtpYlmNqljGGpo+0UjskJykFOtR5ujv1E8/rR469dbHkg9uZH212A6ztW8V4yv
MHa44mLKCVdb6179ClVLkUUS9Qw1AryE4eGy7F4fXr/pGRSwZLmJWivnlB2whjnx
XIV5iP5uTUQW+/tajCwqDNXw/1zR2jib4Cvh2o89084Crat6TrPFPvQ5ddLt9Xs1
2dMYUDZFawD0yQ+K4pbusVb55pLuXesZYgrX5KDWFZaOiFdXfAhCq+INy0ONwk7w
2CWcqpu3i46HAn9m5R44f1Ltm/tv2+UhIIMmKrnJ9mLuxwqEGMows4w9uH8zfmK8
TN0z+yIzk8Vb9+MEA+NxE33rwvJy1fZPQsHoQmpJOI3tm4PX3Q+o+0C/xELoBHwp
4epktLQk0PzgKpBbi2NOIT9RRtrJq6o7Wvg9wVZDAedUZZFgEbYCqZyHvGi5fHmB
O0dGa0Z2+59RzD+idQ1EyiUuZnPzJq7J03B3v/Q0x9fwJppXRaiLOaN7CWsWuUb4
ecF5grYh07YW39ptPpZv32xa26sfwEolg+EHBQbBsYrTNsKHIMY=
=Fmzb
-----END PGP SIGNATURE-----


S
S
Steve George wrote on 4 Jun 2023 10:53
6de302af-291c-415a-fc3c-8abe556990cc@futurile.net
Hi,

My overall goal is to package spotifyd. In February, it turned into a
massive amount of work with over 100 crates. I was starting to find it
unmanageable so I decided to start contributing the dependencies in
sections.

This section is in order to package rust-librespot-audio - which along
with some other 'librespot' packages is a top-level dependency for spotifyd.

This is the tree:

;rust-librespot-audio-0.2
;rust-librespot-core-0.2
;rust-librespot-protocol-0.2
;rust-protobuf-codegen-pure-2.14 ; done
;rust-protobuf-codegen-2.14 ; done
;rust-protobuf-2.14 ;done
;rust-pbkdf2-0.8
;rust-password-hash-0.2
;rust-priority-queue-1
;rust-shannon-0.2
rust-hyper-proxy-0.9
;rust-tokio-1.23
;rust-mio-aio-0.6
;rust-mockall-0.11
;rust-downcast-0.11
;rust-fragile-2
;rust-slab-0.4.5
;rust-mockall-derive-0.11
;rust-mockall-double-0.3
;rust-pretty-assertions-0.5
;rust-parking-lot-0.12.1 ; 0.12.1
;rust-lock-api-0.4.6
; rust-tokio-stream-0.1.1 ;; start here
; rust-aes-ctr-0.6 ;; patch done
; rust-lewton-0.10 ;; patch done
; rust-ogg-0.8 ;; patch done
; rust-alto-3 ;; patch done
; rust-al-sys-0.6 ;; patch done
; rust-rental-0.5
; rust-rental-impl-0.5
; rust-parking-lot-0.4 ;; patch done
; rust-parking-lot-core-0.2 ;; patch done
; rust-owning-ref-0.3 ;patch done
; rust-librespot-tremor-0.2 ;; patch done
; rust-ogg-sys-0.0.9 ;; patch done
; rust-vorbis-0.0 ;; patch done
;rust-vorbisfile-sys-0.0.8 ;; patch done
;rust-vorbis-sys-0.1 ;; patch done
; ;rust-ogg-sys ;; patch done

I didn't want to send '40' patches, because "as a newbie" it's quite a
lot to keep on track - the patches, the format of everything, branches
etc. Sorry if that's not helpful!

Steve


On 04/06/2023 08:33, Efraim Flashner wrote:
Toggle quote (30 lines)
> On Sun, Feb 26, 2023 at 04:58:22PM +0000, Steve George wrote:
>> Hi,
>>
>> First set of crates to complete the dependency tree for
>> rust-librespot-audio-core
>>
>> - rust-vorbisfile-sys
>> - rust-vorbis-sys
>> - rust-ogg-sys
>> - rust-vorbis
>>
>> - rust-librespot-tremor
>> - rust-owning-ref
>> - rust-parking-lot-core (0.2)
>> - rust-parking-lot (0.4)
>>
>> - rust-rental-impl
>> - rust-rental
>> - rust-alto
>>
>> - rust-ogg
>> - rust-lewton
>
> I'm not sure which of these crates are actually necessary. I didn't see
> any users of rust-librespot-tremor¹ and I wasn't even really sure where
> some of the other crates came into use. Are you trying to package
> rust-librespot?
>
> ¹ https://crates.io/crates/librespot-tremor/reverse_dependencies
>
E
E
Efraim Flashner wrote on 4 Jun 2023 11:06
(name . Steve George)(address . steve@futurile.net)(address . 61818@debbugs.gnu.org)
ZHxUBMKtUko7moV1@3900XT
On Sun, Jun 04, 2023 at 09:53:54AM +0100, Steve George wrote:
Toggle quote (7 lines)
> Hi,
>
> My overall goal is to package spotifyd. In February, it turned into a
> massive amount of work with over 100 crates. I was starting to find it
> unmanageable so I decided to start contributing the dependencies in
> sections.

As unfortunate as it is to sometimes drop patches, I'd suggest moving to
spotifyd@0.3.5 since it updates the librespot crates to 0.4 and should
result in newer (and hopefully already packaged!) crates being needed.

Toggle quote (85 lines)
> This section is in order to package rust-librespot-audio - which along with
> some other 'librespot' packages is a top-level dependency for spotifyd.
>
> This is the tree:
>
> ;rust-librespot-audio-0.2
> ;rust-librespot-core-0.2
> ;rust-librespot-protocol-0.2
> ;rust-protobuf-codegen-pure-2.14 ; done
> ;rust-protobuf-codegen-2.14 ; done
> ;rust-protobuf-2.14 ;done
> ;rust-pbkdf2-0.8
> ;rust-password-hash-0.2
> ;rust-priority-queue-1
> ;rust-shannon-0.2
> rust-hyper-proxy-0.9
> ;rust-tokio-1.23
> ;rust-mio-aio-0.6
> ;rust-mockall-0.11
> ;rust-downcast-0.11
> ;rust-fragile-2
> ;rust-slab-0.4.5
> ;rust-mockall-derive-0.11
> ;rust-mockall-double-0.3
> ;rust-pretty-assertions-0.5
> ;rust-parking-lot-0.12.1 ; 0.12.1
> ;rust-lock-api-0.4.6
> ; rust-tokio-stream-0.1.1 ;; start here
> ; rust-aes-ctr-0.6 ;; patch done
> ; rust-lewton-0.10 ;; patch done
> ; rust-ogg-0.8 ;; patch done
> ; rust-alto-3 ;; patch done
> ; rust-al-sys-0.6 ;; patch done
> ; rust-rental-0.5
> ; rust-rental-impl-0.5
> ; rust-parking-lot-0.4 ;; patch done
> ; rust-parking-lot-core-0.2 ;; patch done
> ; rust-owning-ref-0.3 ;patch done
> ; rust-librespot-tremor-0.2 ;; patch done
> ; rust-ogg-sys-0.0.9 ;; patch done
> ; rust-vorbis-0.0 ;; patch done
> ;rust-vorbisfile-sys-0.0.8 ;; patch done
> ;rust-vorbis-sys-0.1 ;; patch done
> ; ;rust-ogg-sys ;; patch done
>
> I didn't want to send '40' patches, because "as a newbie" it's quite a lot
> to keep on track - the patches, the format of everything, branches etc.
> Sorry if that's not helpful!
>
> Steve
>
>
> On 04/06/2023 08:33, Efraim Flashner wrote:
> > On Sun, Feb 26, 2023 at 04:58:22PM +0000, Steve George wrote:
> > > Hi,
> > >
> > > First set of crates to complete the dependency tree for
> > > rust-librespot-audio-core
> > >
> > > - rust-vorbisfile-sys
> > > - rust-vorbis-sys
> > > - rust-ogg-sys
> > > - rust-vorbis
> > >
> > > - rust-librespot-tremor
> > > - rust-owning-ref
> > > - rust-parking-lot-core (0.2)
> > > - rust-parking-lot (0.4)
> > >
> > > - rust-rental-impl
> > > - rust-rental
> > > - rust-alto
> > >
> > > - rust-ogg
> > > - rust-lewton
> >
> > I'm not sure which of these crates are actually necessary. I didn't see
> > any users of rust-librespot-tremor¹ and I wasn't even really sure where
> > some of the other crates came into use. Are you trying to package
> > rust-librespot?
> >
> > ¹ https://crates.io/crates/librespot-tremor/reverse_dependencies
> >
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR8U/4ACgkQQarn3Mo9
g1F/gg//cx5NVU10ZqqPfojgcxOzdgyx9D+R6r8sxvrh7m+c3YVzV/XwauY9NVo8
NPy79l6brT9mpx8++veBTFm3qm+YtoHB8gDxRoOGBiJhXad5JU6v2m/sAKT80H/w
vkQ45C4bQ9RMYU9xkbAuVPWcifQZHUjxiahsU2NZBKjtZRU1OE6F8EVS1xgk7BMG
UgAMNyr6TnkbGdmzZzRxMsE1yiWNxj7uKKKDiAr7LQ6NGeiEcDDIyjkFegyvIdSi
NxGhwQzQyodeva+L1aA4BsT1UKUT3w6Vh/If3mOfMCoYIXJzaj28J37yo2BQlAZw
nNGzBg24CGSRTlzz+UBZ4qToWTlsoKr6c6Iqsk4IYPYvq27y0BST0H3LHrNKtmNN
+m6Vj9nbf7OLLvD4xYV9AqcQooifBn8Wt3HvF+qCPcaMhckpWAJBoqzqJEfl+zj3
zXg/3RfZe8e6gqDMM26GMN3Eyd6sYO84fZVrVpiwub/fagre/AhBzcEVasQNvO8n
pf+jVmQ0GoLIhjmxfyTbJL311F5I1PhMHTGZacdm4N179vTrHesRHtfiJByrh/wY
xVYq7Jmj1DGTgtu9FTJFHuoj/VSecbCSphBwxZ32XDw4iygWo4J+/2jJHRwjIljv
tvkI8bQCiJtcTc0nE4cO3k7GuZ2OFRYzOknGlFhzbDBJkvtwjCc=
=CyWR
-----END PGP SIGNATURE-----


S
S
Steve George wrote on 21 Feb 16:48 +0100
Checking if this goes to the submitter
(address . 61818-submitter@debbugs.gnu.org)
ZdYbQsCSrIVYt8lZ@t25sg
Hi,

This email should come to me, as the original submitter if submitter@debbugs.gnu.org works.
S
S
Steve George wrote on 21 Feb 17:36 +0100
Close bug#61818
(address . 61818-done@debbugs.gnu.org)
ZdYmmjzIrqza4siv@t25sg
These were done in a different series.
Closed
S
S
Steve George wrote on 21 Feb 17:45 +0100
archive bug#61816
(address . control@debbugs.gnu.org)
ZdYok3N3I45GNeeF@t25sg
archive 61818
quit
?