[PATCH 1/2] gnu: Add python-panflute.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 26 Feb 2023 16:23
(address . guix-patches@gnu.org)
20230226152351.22119-1-wz@freeshell.de
* gnu/packages/textutils.scm (python-panflute): New variable.
---
gnu/packages/textutils.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index aeff4593a8..fad790c065 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -57,6 +57,7 @@ (define-module (gnu packages textutils)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages golang)
@@ -69,6 +70,7 @@ (define-module (gnu packages textutils)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
@@ -1522,3 +1524,30 @@ (define-public ack
easily specify file types, match highlighting, Perl-Compatible Regular
Expressions, and being faster to type than grep.")
(license license:artistic2.0)))
+
+(define-public python-panflute
+ (package
+ (name "python-panflute")
+ (version "2.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "panflute" version))
+ (sha256
+ (base32
+ "1jk5b2sp1h4drkjrg2ks77d0ca6j043n2myvacm77nfc93y9vzff"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-click python-pyyaml))
+ (native-inputs (list python-configparser
+ python-coverage
+ python-flake8
+ python-pandocfilters
+ python-pytest
+ python-pytest-cov
+ python-requests))
+ (home-page "http://scorreia.com/software/panflute/")
+ (synopsis "Pythonic Pandoc filters")
+ (description
+ "Panflute is a Python package that makes Pandoc filters fun to
+write. It is a pythonic alternative to John MacFarlane's pandocfilters, from
+which it is heavily inspired.")
+ (license license:bsd-3)))

base-commit: 53a739ae5d05c3278f09e05f0cba13d698031d92
--
2.39.1
W
W
Wiktor ?elazny wrote on 26 Feb 2023 16:31
[PATCH 2/2] gnu: Add pandoc-include.
(address . 61815@debbugs.gnu.org)
20230226153138.22696-1-wz@freeshell.de
* gnu/packages/textutils.scm (pandoc-include): New variable.
---
gnu/packages/textutils.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index fad790c065..e03ea3d448 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1551,3 +1551,31 @@ (define-public python-panflute
write. It is a pythonic alternative to John MacFarlane's pandocfilters, from
which it is heavily inspired.")
(license license:bsd-3)))
+
+(define-public pandoc-include
+ (package
+ (name "pandoc-include")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandoc-include" version))
+ (sha256
+ (base32
+ "01nrbzs85mrd7jcflicsz0bmfnzi6wsy0ii262xl01zsabqd7n91"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-natsort python-panflute))
+ (home-page "https://github.com/DCsunset/pandoc-include")
+ (synopsis "Pandoc filter to allow file and header includes")
+ (description "@code{pandoc-include} extends Pandoc to support:
+
+@enumerate
+@item include as raw blocks
+@item indent and dedent included contents
+@item partial include
+@item code include
+@item Unix style pathname
+@item recursive include
+@item Yaml header merging
+@item header include
+@end enumerate")
+ (license license:expat)))
--
2.39.1
L
L
Ludovic Courtès wrote on 8 Jun 2023 23:36
Re: bug#61815: [PATCH 1/2] gnu: Add python-panflute.
(name . Wiktor ?elazny)(address . wz@freeshell.de)(address . 61815-done@debbugs.gnu.org)
875y7xzleh.fsf@gnu.org
Hi,

Wiktor ?elazny <wz@freeshell.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/textutils.scm (python-panflute): New variable.

[...]

Toggle quote (2 lines)
> * gnu/packages/textutils.scm (pandoc-include): New variable.

Finally applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61815@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61815
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch