[PATCH] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.02.06

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Leo Famulari
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230226082806.11291-1-atai@atai.org
* gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
(opencl-headers): Update to 2023.02.06
(opencl-icd-loader): Update to 2023.02.06
---
gnu/packages/opencl.scm | 19 +++++++++++--------
1 file changed, 11 insertions(+), 8 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 8cf90698ea..2e4297217a 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,7 +55,7 @@ (define-module (gnu packages opencl)
(define-public opencl-headers
(package
(name "opencl-headers")
- (version "2021.06.30")
+ (version "2023.02.06")
(source
(origin
(method git-fetch)
@@ -63,7 +64,7 @@ (define-public opencl-headers
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nrvx0x9r1nz1qpmzbgffnn9h9pn2fwcxsksf101bkpmqziq5lii"))))
+ (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
@@ -95,7 +96,7 @@ (define-public opencl-headers-1.0
(define-public opencl-clhpp
(package
(name "opencl-clhpp")
- (version "2.0.15")
+ (version "2023.02.06")
(source
(origin
(method git-fetch)
@@ -103,14 +104,16 @@ (define-public opencl-clhpp
(url "https://github.com/KhronosGroup/OpenCL-CLHPP")
(commit (string-append "v" version))))
(sha256
- (base32 "1wycdbvwbdn7lqdd3sby8471qg2zdisr70218ava6cfvxdsqcp83"))
+ (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
(file-name (git-file-name name version))))
(native-inputs
- `(("python" ,python-wrapper)))
+ `(("python" ,python-wrapper)
+ ("ruby" ,ruby)))
(propagated-inputs
(list opencl-headers))
(arguments
- `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF")
+ `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF"
+ "-DBUILD_TESTING=OFF") ;; CTest needs this to be turned off
;; The regression tests require a lot more dependencies.
#:tests? #f))
(build-system cmake-build-system)
@@ -123,7 +126,7 @@ (define-public opencl-clhpp
(define-public opencl-icd-loader
(package
(name "opencl-icd-loader")
- (version "2021.06.30")
+ (version "2023.02.06")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -132,7 +135,7 @@ (define-public opencl-icd-loader
(file-name (git-file-name name version))
(sha256
(base32
- "007ws357n1ijrxal1bf9lwy68p0dz1sm9cfcfnnz5f88iwc9xd6m"))))
+ "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Tests need stub loader setup.
(native-search-paths

base-commit: cb0d8100b288b5b0d130820207db17764b7d2140
--
2.39.1
Leo Famulari wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 61801@debbugs.gnu.org)
Y/uZ/aWXjvoxF1VT@jasmine.lan
On Sun, Feb 26, 2023 at 12:28:06AM -0800, Andy Tai wrote:
Toggle quote (4 lines)
> * gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
> (opencl-headers): Update to 2023.02.06
> (opencl-icd-loader): Update to 2023.02.06

Thanks!

Is it correct to assume that these packages should be updated in the
same commit. That is, if they are updated one at a time, will the suite
of software be broken on each commit, until they are all updated?
Andy Tai wrote 2 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 61801@debbugs.gnu.org)
CAJsg1E_n8h10QwFADjb-FAimh3ZuDFKGK4Gs9ZkdXqbbRW43Dw@mail.gmail.com
There is a comment in the current source requiring the three to be
updated in lock step

On Sun, Feb 26, 2023 at 9:42 AM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (11 lines)
>
> On Sun, Feb 26, 2023 at 12:28:06AM -0800, Andy Tai wrote:
> > * gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
> > (opencl-headers): Update to 2023.02.06
> > (opencl-icd-loader): Update to 2023.02.06
>
> Thanks!
>
> Is it correct to assume that these packages should be updated in the
> same commit. That is, if they are updated one at a time, will the suite
> of software be broken on each commit, until they are all updated?
Leo Famulari wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 61801@debbugs.gnu.org)
Y/vD1D2cb6moD4TX@jasmine.lan
On Sun, Feb 26, 2023 at 11:50:06AM -0800, Andy Tai wrote:
Toggle quote (3 lines)
> There is a comment in the current source requiring the three to be
> updated in lock step

Okay.

Also, the commit message mentions neither the addition of ruby to the
dependencies of opencl-clhpp, nor the BUILD_TESTING flag. Did you mean
to include those changes?

Using diffoscope, I compared the build output with and without ruby, and
they are identical aside from the store paths, so we should leave ruby
out, in any case.
Andy Tai wrote 2 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 61801@debbugs.gnu.org)
CAJsg1E9MGj=Mbbya4ZA3vM=XCHo7GiSk7vBET=vd=edrB_axkg@mail.gmail.com
Are there any guidelines on how the commit messages should be written
in regard to these changes?

I will remove the ruby part from the change.

On Sun, Feb 26, 2023 at 12:40 PM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (17 lines)
>
> On Sun, Feb 26, 2023 at 11:50:06AM -0800, Andy Tai wrote:
> > There is a comment in the current source requiring the three to be
> > updated in lock step
>
> Okay.
>
> Also, the commit message mentions neither the addition of ruby to the
> dependencies of opencl-clhpp, nor the BUILD_TESTING flag. Did you mean
> to include those changes?
>
> Using diffoscope, I compared the build output with and without ruby, and
> they are identical aside from the store paths, so we should leave ruby
> out, in any case.



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2023 民國112年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Andy Tai wrote 2 years ago
[PATCH v2] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.02.06
(name . Andy Tai)(address . atai@atai.org)
20230227063958.17885-1-atai@atai.org
* gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
(opencl-headers): Update to 2023.02.06
(opencl-icd-loader): Update to 2023.02.06
[arguments]: Add configure flag to disable CTest building that
cause errors as tests are meant to be disabled
---
gnu/packages/opencl.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 8cf90698ea..099864dc66 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,7 +55,7 @@ (define-module (gnu packages opencl)
(define-public opencl-headers
(package
(name "opencl-headers")
- (version "2021.06.30")
+ (version "2023.02.06")
(source
(origin
(method git-fetch)
@@ -63,7 +64,7 @@ (define-public opencl-headers
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nrvx0x9r1nz1qpmzbgffnn9h9pn2fwcxsksf101bkpmqziq5lii"))))
+ (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
@@ -95,7 +96,7 @@ (define-public opencl-headers-1.0
(define-public opencl-clhpp
(package
(name "opencl-clhpp")
- (version "2.0.15")
+ (version "2023.02.06")
(source
(origin
(method git-fetch)
@@ -103,14 +104,15 @@ (define-public opencl-clhpp
(url "https://github.com/KhronosGroup/OpenCL-CLHPP")
(commit (string-append "v" version))))
(sha256
- (base32 "1wycdbvwbdn7lqdd3sby8471qg2zdisr70218ava6cfvxdsqcp83"))
+ (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
(file-name (git-file-name name version))))
(native-inputs
`(("python" ,python-wrapper)))
(propagated-inputs
(list opencl-headers))
(arguments
- `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF")
+ `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF"
+ "-DBUILD_TESTING=OFF") ;; CTest needs this to be turned off
;; The regression tests require a lot more dependencies.
#:tests? #f))
(build-system cmake-build-system)
@@ -123,7 +125,7 @@ (define-public opencl-clhpp
(define-public opencl-icd-loader
(package
(name "opencl-icd-loader")
- (version "2021.06.30")
+ (version "2023.02.06")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -132,7 +134,7 @@ (define-public opencl-icd-loader
(file-name (git-file-name name version))
(sha256
(base32
- "007ws357n1ijrxal1bf9lwy68p0dz1sm9cfcfnnz5f88iwc9xd6m"))))
+ "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Tests need stub loader setup.
(native-search-paths

base-commit: cb0d8100b288b5b0d130820207db17764b7d2140
--
2.39.1
Leo Famulari wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 61801-done@debbugs.gnu.org)
Y/0leUJG669LVhcL@jasmine.lan
To answer your question from another message where you asked how to
describe changes to things like package arguments in the commit
message...

On Sun, Feb 26, 2023 at 10:39:58PM -0800, Andy Tai wrote:
Toggle quote (6 lines)
> * gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
> (opencl-headers): Update to 2023.02.06
> (opencl-icd-loader): Update to 2023.02.06
> [arguments]: Add configure flag to disable CTest building that
> cause errors as tests are meant to be disabled

Basically as you've done here, except that the [arguments] portion
should be within the section for the package that it changes.

In this case, you changed the arguments of opencl-clhpp, so you should
list the changes underneath opencl-clhpp's listing in the commit
message.

More generally, our commit messages are in GNU ChangeLog format, which
describes changes at a code level based on variables (i.e. Guix
packages or functions) and the fields within them.


For Guix, if I am unsure, I look for similar commits in our Git log. As
always, feel free to ask for help on IRC or the mailing list.

I tweaked the commit message for you and pushed as
dfcf1d5d6a56d0cabeec4836bab1f1f1f063a0e1
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61801@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61801
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help