[PATCH] gnu: ffmpeg: enable libwebp

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Ryan Sundberg
Owner
unassigned
Submitted by
Ryan Sundberg
Severity
normal

Debbugs page

Ryan Sundberg wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ryan Sundberg)(address . ryan@arctype.co)
20230225195646.16297-1-ryan@arctype.co
* gnu/packages/video.scm (ffmpeg)[configure-flags]: --enable-libwebp

Signed-off-by: Ryan Sundberg <ryan@arctype.co>
---
gnu/packages/video.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f63d5494de..f64608d18a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1634,6 +1634,7 @@ (define-public ffmpeg-5
libvdpau
libvorbis
libvpx
+ libwebp
libx11
libx264
mesa
@@ -1731,6 +1732,7 @@ (define-public ffmpeg-5
"--enable-libvidstab"
"--enable-libvorbis"
"--enable-libvpx"
+ "--enable-libwebp"
"--enable-libxvid"
"--enable-libx264"
"--enable-libx265"
--
2.37.2
Leo Famulari wrote 2 years ago
(name . Ryan Sundberg via Guix-patches via)(address . guix-patches@gnu.org)
Y/rJvZUb9efgeniB@jasmine.lan
On Sat, Feb 25, 2023 at 11:56:46AM -0800, Ryan Sundberg via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/video.scm (ffmpeg)[configure-flags]: --enable-libwebp

Thanks!

Did you test if all the versions of FFmpeg that are packaged in Guix
support libwebp? Or is it only FFmpeg 5.1?

If you look in gnu/packages/video.scm, you'll see several other versions
that inherit from ffmpeg-5.
Leo Famulari wrote 2 years ago
(name . Ryan Sundberg)(address . ryan@arctype.co)(address . 61792-done@debbugs.gnu.org)
ZAAf602t0xq52OJO@jasmine.lan
On Wed, Mar 01, 2023 at 12:13:37AM -0800, Ryan Sundberg wrote:
Toggle quote (4 lines)
> Surprisingly, this flag is supported all the way back to ffmpeg-3. So I
> tested guix shell ffmpeg@5 ffmpeg@4 ffmpeg@3 and ffmpeg@2 (which clears
> all configure flags), all builds passed.

Great! I removed the input from ffmpeg-2.8, since it wouldn't have been
used anyways (although it is supported), and pushed as
03b463b68ba62b0b6f11a585240829fddef37f48
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61792@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61792
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help