[PATCH] gnu: r-dofuture: Fix the check warnings.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20230224064020.5316-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-dofuture): Fix the check warnings.
[propagated-inputs]: Rearrangement of the in inputs in the column way.
[native-inputs]: Add r-markdown for the check phase.
---
gnu/packages/cran.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c7a81b96eb..17301e3469 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12776,9 +12776,13 @@ (define-public r-dofuture
(add-after 'unpack 'set-HOME
(lambda _ (setenv "HOME" "/tmp"))))))
(propagated-inputs
- (list r-foreach r-future r-globals r-iterators))
+ (list r-foreach
+ r-future
+ r-globals
+ r-iterators))
(native-inputs
- (list r-r-rsp)) ; vignette builder
+ (list r-markdown ; check phase requires markdown package
+ r-r-rsp)) ; vignette builder
(home-page "https://github.com/HenrikBengtsson/doFuture")
(synopsis "Foreach parallel adapter using the future API")
(description

base-commit: 31735e0ccfbc61905eb8558c14747bfcaea9b50f
--
2.39.1
Ricardo Wurmus wrote 1 years ago
(address . 61747-done@debbugs.gnu.org)
874jj6raso.fsf@elephly.net
Pushed a variant of this with commit
5f2704517c83e2bd3fbe5d4410531a0ba3ea4461.

I only kept the addition of r-markdown.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61747@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61747
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help