Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
* gnu/packages/cran.scm (r-dofuture): Fix the check warnings.
[propagated-inputs]: Rearrangement of the in inputs in the column way.
[native-inputs]: Add r-markdown for the check phase.
---
gnu/packages/cran.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c7a81b96eb..17301e3469 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12776,9 +12776,13 @@ (define-public r-dofuture
(add-after 'unpack 'set-HOME
(lambda _ (setenv "HOME" "/tmp"))))))
(propagated-inputs
- (list r-foreach r-future r-globals r-iterators))
+ (list r-foreach
+ r-future
+ r-globals
+ r-iterators))
(native-inputs
- (list r-r-rsp)) ; vignette builder
+ (list r-markdown ; check phase requires markdown package
+ r-r-rsp)) ; vignette builder
(home-page "https://github.com/HenrikBengtsson/doFuture")
(synopsis "Foreach parallel adapter using the future API")
(description
base-commit: 31735e0ccfbc61905eb8558c14747bfcaea9b50f
--
2.39.1