[PATCH] gnu: flatbuffers: Update to 23.1.21

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • 宋文武
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230223091505.13292-1-atai@atai.org
* gnu/packages/serialization.scm (flatbuffers): Update to 23.1.21
---
gnu/packages/serialization.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 8ab1efd311..1bf4d357f4 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -670,7 +670,7 @@ (define-public python-cbor
(define-public flatbuffers
(package
(name "flatbuffers")
- (version "2.0.0")
+ (version "23.1.21")
(source
(origin
(method git-fetch)
@@ -680,7 +680,7 @@ (define-public flatbuffers
(file-name (git-file-name name version))
(sha256
(base32
- "1zbf6bdpps8369r1ql00irxrp58jnalycc8jcapb8iqg654vlfz8"))))
+ "1z3a6l8g2y53i5xzraswfs2i0i3kk52zv7nzc2q3fgisbyiri3pz"))))
(build-system cmake-build-system)
(arguments
'(#:build-type "Release"

base-commit: 31735e0ccfbc61905eb8558c14747bfcaea9b50f
prerequisite-patch-id: 5c2c505e1fefe02b0b8fe068d673dcc8fcc8b246
prerequisite-patch-id: b3de9e1babefba1a1903b848f185b9f8bcb224f4
--
2.39.1
宋文武 wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 61728@debbugs.gnu.org)
87o7pbq1ii.fsf@envs.net
Andy Tai <atai@atai.org> writes:

Toggle quote (2 lines)
> * gnu/packages/serialization.scm (flatbuffers): Update to 23.1.21

Hello, this will broke tensorflow-lite@2.5.0, kodi@19.5 not tested.
Andy Tai wrote 2 years ago
(name . 宋文武)(address . iyzsong@envs.net)(address . 61728@debbugs.gnu.org)
CAJsg1E8toqvQca9DesjePVsVg_X2GacuQvpS7-aQwMR7uPQN2A@mail.gmail.com
odd... flatbuffer has incompatibility in later versions? will try to
figure out what happens here.

On Wed, Mar 1, 2023 at 7:23 PM 宋文武 <iyzsong@envs.net> wrote:
Toggle quote (9 lines)
>
> Andy Tai <atai@atai.org> writes:
>
> > * gnu/packages/serialization.scm (flatbuffers): Update to 23.1.21
>
> Hello, this will broke tensorflow-lite@2.5.0, kodi@19.5 not tested.



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2023 民國112年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Andy Tai wrote 2 years ago
[PATCH v2] gnu: Add flatbuffers-next
(name . Andy Tai)(address . atai@atai.org)
20230302080955.17749-1-atai@atai.org
* gnu/packages/serialization.scm (flatbuffers-next): New variable
as flatbuffers@2.0.0 is depended on by tensorflow-lite so we cannot
just upgrade directly, so adding current release flatbuffers@23.1.21
as "next" for flatbuffers
---
gnu/packages/serialization.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 8ab1efd311..5b8f02b184 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -699,6 +699,22 @@ (define-public flatbuffers
game development and other performance-critical applications.")
(license license:asl2.0)))
+(define-public flatbuffers-next
+ (package
+ (inherit flatbuffers)
+ (name "flatbuffers-next")
+ (version "23.1.21")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/flatbuffers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z3a6l8g2y53i5xzraswfs2i0i3kk52zv7nzc2q3fgisbyiri3pz"))))))
+
+
(define-public python-feather-format
(package
(name "python-feather-format")

base-commit: ef7df2ca7bb212455f1d6bbef5bbf7b1ac5a189d
prerequisite-patch-id: 5c2c505e1fefe02b0b8fe068d673dcc8fcc8b246
prerequisite-patch-id: b3de9e1babefba1a1903b848f185b9f8bcb224f4
prerequisite-patch-id: d827e9c76e13bae69214ec1b674b0f6bfc4bfb34
prerequisite-patch-id: f2fc0529e4a54e1947db12df9ee6b2151b64a4b4
prerequisite-patch-id: 3ffc80c780ae73c5dc5574880c13ce173171bf41
--
2.39.1
Ludovic Courtès wrote 2 years ago
Re: bug#61728: [PATCH] gnu: flatbuffers: Update to 23.1.21
(name . Andy Tai)(address . atai@atai.org)
87wn3uoos0.fsf_-_@gnu.org
Hi Andy,

Andy Tai <atai@atai.org> skribis:

Toggle quote (21 lines)
> * gnu/packages/serialization.scm (flatbuffers-next): New variable
> as flatbuffers@2.0.0 is depended on by tensorflow-lite so we cannot
> just upgrade directly, so adding current release flatbuffers@23.1.21
> as "next" for flatbuffers
> ---
> gnu/packages/serialization.scm | 16 ++++++++++++++++
> 1 file changed, 16 insertions(+)
>
> diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
> index 8ab1efd311..5b8f02b184 100644
> --- a/gnu/packages/serialization.scm
> +++ b/gnu/packages/serialization.scm
> @@ -699,6 +699,22 @@ (define-public flatbuffers
> game development and other performance-critical applications.")
> (license license:asl2.0)))
>
> +(define-public flatbuffers-next
> + (package
> + (inherit flatbuffers)
> + (name "flatbuffers-next")

Applied, but I kept the package name “flatbuffers” (the variable name is
fine).

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61728@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61728
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help