Chromium with guix shell container from the manual doesn't work.

  • Open
  • quality assurance status badge
Details
3 participants
  • email@msavoritias.me
  • ??????? ???????
  • Simon Tournier
Owner
unassigned
Submitted by
email@msavoritias.me
Severity
normal
E
E
email@msavoritias.me wrote on 21 Feb 2023 17:50
(address . bug-guix@gnu.org)
c2caae1f-2163-4916-659d-15752c513e24@fannys.me
Followed the manual for guix shell here:

Initially I wanted to setup an icecat container so I just removed
chromium for icecat, I got this error:

```

guix shell --container --network --no-cwd icecat --preserve='^DISPLAY$'
-- icecat
Authorization required, but no authorization protocol specified
Unable to init server: Could not connect: Connection refused
Error: cannot open display: :0.0

```


I tried chromium too. It still errors out but with a different error:

```

guix shell --container --network --no-cwd ungoogled-chromium
--preserve='^DISPLAY$' -- chromium
Authorization required, but no authorization protocol specified
[1:1:0221/164151.354628:ERROR:ozone_platform_x11.cc(238)] Missing X
server or $DISPLAY
[1:1:0221/164151.354678:ERROR:env.cc(255)] The platform failed to
initialize.  Exiting.

```


Chromium starts just fine without the container flag so the problem
seems to be in the container flag specifically.


Msavoritias
E
E
email@msavoritias.me wrote on 6 Mar 2023 14:07
(address . 61697@debbugs.gnu.org)
29b5ebee-32c0-7017-8ce8-6c1a48d86118@fannys.me
The problem was that in xorg you need the specific option:

```

--share=/tmp

```

So the command would look like:

```

guix shell --container --network --share=/tmp --no-cwd icecat
--preserve='^DISPLAY$' -- icecat

```


While in wayland it works as is.

Next step would be documenting this in the manual.
S
S
Simon Tournier wrote on 11 Apr 2023 15:36
(address . email@msavoritias.me)(address . 61697@debbugs.gnu.org)
87bkjuk0c1.fsf@gmail.com
Hi,

On lun., 06 mars 2023 at 15:07, "email@msavoritias.me" <email@msavoritias.me> wrote:

Toggle quote (2 lines)
> Next step would be documenting this in the manual.

Do you want to give a try in fixing the example provided by the manual? WDYT?


Cheers,
simon
?
?
??????? ??????? wrote on 16 Apr 2023 12:37
(address . 61697@debbugs.gnu.org)
CAF2huOj8amoK9P1aE9aQCqDvJut-BOAABainBb8vrV8Dmoj-RA@mail.gmail.com
Still have the same error with specifying --share=/tmp. Maybe I should add
something else?
```
kovalev@mirage ~$ guix shell --container --network --preserve="^DISPLAY$"
--no-cwd --share=/tmp ungoogled-chromium -- chromium
Authorization required, but no authorization protocol specified
[1:1:0416/103619.358790:ERROR:ozone_platform_x11.cc(238)] Missing X server
or $DISPLAY
[1:1:0416/103619.358806:ERROR:env.cc(255)] The platform failed to
initialize. Exiting.
```
```
kovalev@mirage ~$ guix shell --container --network --preserve="^DISPLAY$"
--no-cwd --share=/tmp icecat -- icecat
Authorization required, but no authorization protocol specified
Unable to init server: Could not connect: Connection refused
Error: cannot open display: :1
```
Attachment: file
?