[PATCH] gnu: Add emacs-jsdoc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Demis Balbach
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Demis Balbach
Severity
normal

Debbugs page

Demis Balbach wrote 2 years ago
(address . guix-patches@gnu.org)(name . Demis Balbach)(address . db@minikn.xyz)
20230221150255.9587-1-db@minikn.xyz
---
gnu/packages/emacs-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b12642bc9..68bbc60d08 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -122,6 +122,7 @@
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
+;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -190,6 +191,7 @@ (define-module (gnu packages emacs-xyz)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages tree-sitter)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg)
#:use-module (gnu packages lesstif)
@@ -28685,6 +28687,35 @@ (define-public emacs-js2-refactor-el
JavaScript.")
(license license:gpl3+))))
+(define-public emacs-jsdoc
+ (let ((commit "2f828fe154e0bcb2c22d0a0323dd7f751406f85e")
+ (revision "0")
+ (version "0.2"))
+ (package
+ (name "emacs-jsdoc")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isamert/jsdoc.el")
+ (commit commit)))
+ (sha256
+ (base32 "1iw8x6ff9gjl3zkj48y20f6c68kgnzm682637hzq6n6g4inadkq3"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:emacs ,emacs-next))
+ (propagated-inputs
+ (list emacs-s
+ emacs-dash
+ tree-sitter-javascript))
+ (home-page "https://github.com/isamert/jsdoc.el")
+ (synopsis "Inserts JSDoc function comments/typedefs easily.")
+ (description "This package provides an easy way to insert JSDoc function
+comments and typedefs using Emacs' builtin tree-sitter.")
+ (license license:gpl3+))))
+
(define-public emacs-prettier
(let ((commit "e9b73e81d3e1642aec682195f127a42dfb0b5774")
(version "0.1.0")
--
2.39.1
Nicolas Goaziou wrote 2 years ago
(name . Demis Balbach)(address . db@minikn.xyz)(address . 61683-done@debbugs.gnu.org)
87ilfspi97.fsf@nicolasgoaziou.fr
Hello,

Demis Balbach <db@minikn.xyz> writes:

Toggle quote (5 lines)
> +(define-public emacs-jsdoc
> + (let ((commit "2f828fe154e0bcb2c22d0a0323dd7f751406f85e")
> + (revision "0")
> + (version "0.2"))

I updated it to 0.3, added a proper commit message an applied your
patch. Thank you.


Toggle quote (5 lines)
> + (propagated-inputs
> + (list emacs-s
> + emacs-dash
> + tree-sitter-javascript))

I ordered inputs alphaetically, too.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61683@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61683
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help