(name . bug-guix)(address . bug-guix@gnu.org)
Hi Guix,
I was trying to simplify the Jami packaging tooling using the latest
recursive '--with-source' transformation, like so (in a Makefile):
Toggle snippet (14 lines)
define guix-pack-command
guix pack -C xz -f deb -f extras/packaging/gnu-linux/guix/guix-pack-manifest.scm -v3 \
--with-source=libjami@$(RELEASE_VERSION)=$(RELEASE_TARBALL_FILENAME) \
--with-patch=libjami=extras/packaging/gnu-linux/guix/patches/jami-disable-integration-tests.patch \
--with-source=jami@$(RELEASE_VERSION)=$(RELEASE_TARBALL_FILENAME) \
-S /usr/bin/jami=bin/jami \
-S /usr/share/applications/jami.desktop=share/applications/jami.desktop \
-S /usr/share/icons/hicolor/scalable/apps/jami.svg=share/icons/hicolor/scalable/apps/jami.svg \
-S /usr/share/icons/hicolor/48x48/apps/jami.png=share/icons/hicolor/48x48/apps/jami.png \
-S /usr/share/metainfo/jami.appdata.xml=share/metainfo/jami.appdata.xml \
--postinst-file=extras/packaging/gnu-linux/guix/guix-pack-deb.postinst
endef
But noticed that --with-source and --with-patch were not effective for
the jami-with-certs customized package provided by the
guix-pack-manifest.scm manifest.
It seems to me that the rewriting options should be honored on any
packages being manipulated, whether they come from the Guix collection,
a file, a manifest or another means.
--
Thanks,
Maxim