[PATCH 0/4] gnu: stellarium: Enable ShowMySky.

  • Done
  • quality assurance status badge
Details
5 participants
  • Leo Famulari
  • Ludovic Courtès
  • Maxim Cournoyer
  • Sharlatan Hellseher
  • Simon Tournier
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230221130600.18932-1-sharlatanus@gmail.com
Hi Guix,

This patch series adds support of CalcMyScky/ShowMySky module for
Stellarium that simulates scattering of light by the atmosphere.

It also include both Qt6 and Qt5 - qxlsx and calcmysky to be
compatible with Stellarium build which is packed using Qt5 inputs.

Sharlatan Hellseher (4):
gnu: Add calcmysky.
gnu: qxlsx: Use Qt6.
gnu: Add qxlsx-qt5.
gnu: stellarium: Enable ShowMySky.

gnu/packages/astronomy.scm | 64 +++++++++++++++++++++++++++++++++++---
gnu/packages/qt.scm | 10 +++++-
2 files changed, 69 insertions(+), 5 deletions(-)


base-commit: c81d2d448cbd051800867fe3f4b82ef3f4380ebf
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/4] gnu: Add calcmysky.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230221130723.19077-1-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (calcmysky, calcmysky-qt5): New variables.
---
gnu/packages/astronomy.scm | 57 ++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5cee981671..f13f74a5e8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -26,6 +26,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages astronomy)
+ #:use-module ((guix build utils) #:select (alist-replace))
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -209,6 +210,62 @@ (define-public calceph
@end itemize\n")
(license license:cecill)))
+(define-public calcmysky
+ (package
+ (name "calcmysky")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/10110111/CalcMySky")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bib5shy8wzc7j5ph218dl9hqrqip491mn25gakyghbvaqxgm27d"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=6")))
+ (inputs
+ (list eigen glm qtbase))
+ (home-page "https://10110111.github.io/CalcMySky/")
+ (synopsis "Simulator of light scattering by planetary atmospheres")
+ (description
+ "CalcMySky is a software package that simulates scattering of light by the
+atmosphere to render daytime and twilight skies (without stars). Its primary
+purpose is to enable realistic view of the sky in applications such as
+planetaria. Secondary objective is to make it possible to explore atmospheric
+effects such as glories, fogbows etc., as well as simulate unusual environments
+such as on Mars or an exoplanet orbiting a star with a non-solar spectrum of
+radiation.
+
+This package consists of three parts:
+
+@itemize
+@item @code{calcmysky} utility that does the precomputation of the atmosphere
+model to enable rendering.
+
+@item @code{libShowMySky} library that lets the applications render the
+atmosphere model.
+
+@item @code{ShowMySky} preview GUI that makes it possible to preview the
+rendering of the atmosphere model and examine its properties.
+@end itemize")
+ (license license:gpl3)))
+
+(define-public calcmysky-qt5
+ (package
+ (inherit calcmysky)
+ (name "calcmysky-qt5")
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=5")))
+ (inputs
+ (alist-replace "qtbase" (list qtbase-5)
+ (package-inputs calcmysky)))
+ (synopsis "Qt5 build for the CalcMySky library.")))
+
(define-public aoflagger
(package
(name "aoflagger")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/4] gnu: qxlsx: Use Qt6.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230221130723.19077-2-sharlatanus@gmail.com
* gnu/packages/qt.scm (qxlsx):
[inputs]: Use QTBASE (Qt6) instead QTBASE-5. Add LIBXKBCOMMON,
VULKAN-HEADERS.
---
gnu/packages/qt.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 76e9e519c7..4985a79db4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1148,7 +1148,7 @@ (define-public qxlsx
(invoke "make" "-j" (number->string (parallel-job-count)))
(invoke "./TestExcel"))))))))
(inputs
- (list qtbase-5))
+ (list libxkbcommon qtbase vulkan-headers))
(home-page "https://qtexcel.github.io/QXlsx/")
(synopsis "C++ library to read/write Excel XLSX files using Qt")
(description
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 3/4] gnu: Add qxlsx-qt5.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230221130723.19077-3-sharlatanus@gmail.com
* gnu/packages/qt.scm (qxlsx-qt5): New variable.
---
gnu/packages/qt.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4985a79db4..b2e14e5757 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1156,6 +1156,14 @@ (define-public qxlsx
XLSX document format.")
(license license:expat)))
+(define-public qxlsx-qt5
+ (package
+ (inherit qxlsx)
+ (name "qxlsx-qt5")
+ (inputs
+ (list qtbase-5))
+ (synopsis "Qt5 build for the qxlsx library.")))
+
(define-public qtxmlpatterns
(package (inherit qtsvg-5)
(name "qtxmlpatterns")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 4/4] gnu: stellarium: Enable ShowMySky.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230221130723.19077-4-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (stellarium):
[arguments]<#:configure-flags>: Enable ShowMySky optional dependencies
to simulate scattering of light by the atmosphere.
[inputs]: Replace QXLSX to QXLSX-QT5. Add CALCMYSKY-QT5.
---
gnu/packages/astronomy.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f13f74a5e8..e15df2874a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -917,8 +917,6 @@ (define-public stellarium
#~(list "-DENABLE_GPS=1"
;; TODO: Enable when all of the dependencies are availalbe for Qt6.
"-DENABLE_QT6=0"
- ;; TODO: Pack missing in Guix https://10110111.github.io/CalcMySky/
- "-DENABLE_SHOWMYSKY=0"
"-DENABLE_TESTING=0"
(string-append "-DCMAKE_CXX_FLAGS=-isystem "
#$(this-package-input "qtserialport") "/include/qt5"))
@@ -929,7 +927,8 @@ (define-public stellarium
(setenv "QT_QPA_PLATFORM" "offscreen")
(setenv "HOME" "/tmp"))))))
(inputs
- (list gpsd
+ (list calcmysky-qt5
+ gpsd
indi
libnova
openssl
@@ -942,7 +941,7 @@ (define-public stellarium
qtserialport
qttranslations
qtwebengine-5
- qxlsx
+ qxlsx-qt5
zlib))
(native-inputs
(list doxygen
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
(address . 61674@debbugs.gnu.org)
CAO+9K5pAc3OJNkd_sj9y9h0oddSv7vD=-KsSqCXG=tC2SboZHw@mail.gmail.com
Hi Guix!
I've found the fix for aarch64-linux, thanks to the author's replay -
v2 should pass the QA now :)
Thanks.
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 2 years ago
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230226004406.6215-1-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (calcmysky, calcmysky-qt5): New variables.
---
gnu/packages/astronomy.scm | 59 ++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5cee981671..0f3176bc3e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -26,6 +26,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages astronomy)
+ #:use-module ((guix build utils) #:select (alist-replace))
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -209,6 +210,64 @@ (define-public calceph
@end itemize\n")
(license license:cecill)))
+(define-public calcmysky
+ (package
+ (name "calcmysky")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/10110111/CalcMySky")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bib5shy8wzc7j5ph218dl9hqrqip491mn25gakyghbvaqxgm27d"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=6"
+ "-DCMAKE_CXX_FLAGS=-fPIC")))
+ (inputs
+ (list eigen glm qtbase))
+ (home-page "https://10110111.github.io/CalcMySky/")
+ (synopsis "Simulator of light scattering by planetary atmospheres")
+ (description
+ "CalcMySky is a software package that simulates scattering of light by the
+atmosphere to render daytime and twilight skies (without stars). Its primary
+purpose is to enable realistic view of the sky in applications such as
+planetaria. Secondary objective is to make it possible to explore atmospheric
+effects such as glories, fogbows etc., as well as simulate unusual environments
+such as on Mars or an exoplanet orbiting a star with a non-solar spectrum of
+radiation.
+
+This package consists of three parts:
+
+@itemize
+@item @code{calcmysky} utility that does the precomputation of the atmosphere
+model to enable rendering.
+
+@item @code{libShowMySky} library that lets the applications render the
+atmosphere model.
+
+@item @code{ShowMySky} preview GUI that makes it possible to preview the
+rendering of the atmosphere model and examine its properties.
+@end itemize")
+ (license license:gpl3)))
+
+(define-public calcmysky-qt5
+ (package
+ (inherit calcmysky)
+ (name "calcmysky-qt5")
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=5"
+ "-DCMAKE_CXX_FLAGS=-fPIC")))
+ (inputs
+ (alist-replace "qtbase" (list qtbase-5)
+ (package-inputs calcmysky)))
+ (synopsis "Qt5 build for the CalcMySky library.")))
+
(define-public aoflagger
(package
(name "aoflagger")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 3/4] gnu: Add qxlsx-qt5.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230226004406.6215-3-sharlatanus@gmail.com
* gnu/packages/qt.scm (qxlsx-qt5): New variable.
---
gnu/packages/qt.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4985a79db4..b2e14e5757 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1156,6 +1156,14 @@ (define-public qxlsx
XLSX document format.")
(license license:expat)))
+(define-public qxlsx-qt5
+ (package
+ (inherit qxlsx)
+ (name "qxlsx-qt5")
+ (inputs
+ (list qtbase-5))
+ (synopsis "Qt5 build for the qxlsx library.")))
+
(define-public qtxmlpatterns
(package (inherit qtsvg-5)
(name "qtxmlpatterns")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 4/4] gnu: stellarium: Enable ShowMySky.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230226004406.6215-4-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (stellarium):
[arguments]<#:configure-flags>: Enable ShowMySky optional dependencies
to simulate scattering of light by the atmosphere.
[inputs]: Replace QXLSX to QXLSX-QT5. Add CALCMYSKY-QT5.
---
gnu/packages/astronomy.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0f3176bc3e..ffce19e8fc 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -919,8 +919,6 @@ (define-public stellarium
#~(list "-DENABLE_GPS=1"
;; TODO: Enable when all of the dependencies are availalbe for Qt6.
"-DENABLE_QT6=0"
- ;; TODO: Pack missing in Guix https://10110111.github.io/CalcMySky/
- "-DENABLE_SHOWMYSKY=0"
"-DENABLE_TESTING=0"
(string-append "-DCMAKE_CXX_FLAGS=-isystem "
#$(this-package-input "qtserialport") "/include/qt5"))
@@ -931,7 +929,8 @@ (define-public stellarium
(setenv "QT_QPA_PLATFORM" "offscreen")
(setenv "HOME" "/tmp"))))))
(inputs
- (list gpsd
+ (list calcmysky-qt5
+ gpsd
indi
libnova
openssl
@@ -944,7 +943,7 @@ (define-public stellarium
qtserialport
qttranslations
qtwebengine-5
- qxlsx
+ qxlsx-qt5
zlib))
(native-inputs
(list doxygen
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/4] gnu: qxlsx: Use Qt6.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230226004406.6215-2-sharlatanus@gmail.com
* gnu/packages/qt.scm (qxlsx):
[inputs]: Use QTBASE (Qt6) instead QTBASE-5. Add LIBXKBCOMMON,
VULKAN-HEADERS.
---
gnu/packages/qt.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 76e9e519c7..4985a79db4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1148,7 +1148,7 @@ (define-public qxlsx
(invoke "make" "-j" (number->string (parallel-job-count)))
(invoke "./TestExcel"))))))))
(inputs
- (list qtbase-5))
+ (list libxkbcommon qtbase vulkan-headers))
(home-page "https://qtexcel.github.io/QXlsx/")
(synopsis "C++ library to read/write Excel XLSX files using Qt")
(description
--
2.39.1
Leo Famulari wrote 2 years ago
Re: [bug#61674] [PATCH 1/4] gnu: Add calcmysky.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 61674@debbugs.gnu.org)
Y/rKH/eMUso2oqou@jasmine.lan
On Sun, Feb 26, 2023 at 12:44:03AM +0000, Sharlatan Hellseher wrote:
Toggle quote (2 lines)
> * gnu/packages/astronomy.scm (calcmysky, calcmysky-qt5): New variables.

Thanks for these patches!

Toggle quote (1 lines)
> + #:use-module ((guix build utils) #:select (alist-replace))
[...]
Toggle quote (12 lines)
> +(define-public calcmysky-qt5
> + (package
> + (inherit calcmysky)
> + (name "calcmysky-qt5")
> + (arguments
> + (list #:configure-flags
> + #~(list "-DQT_VERSION=5"
> + "-DCMAKE_CXX_FLAGS=-fPIC")))
> + (inputs
> + (alist-replace "qtbase" (list qtbase-5)
> + (package-inputs calcmysky)))

Can you try rewriting this using modify-inputs, rather than
alist-replace?


Feel free to ask for help if you get stuck.
Ludovic Courtès wrote 2 years ago
Re: bug#61674: [PATCH 0/4] gnu: stellarium: Enable ShowMySky.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 61674@debbugs.gnu.org)
87ilfmhkuh.fsf_-_@gnu.org
Hi!

Thanks for a nice patch series!

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/astronomy.scm (calcmysky, calcmysky-qt5): New variables.

[...]

Toggle quote (2 lines)
> + (license license:gpl3)))

Please double-check whether something explicitly says “version 3 only”;
if not, it’s ‘gpl3+’.

Toggle quote (4 lines)
> +(define-public calcmysky-qt5
> + (package
> + (inherit calcmysky)

Rather:

(package/inherit calcmysky
(name "calcmysky-qt5")
…)

Toggle quote (4 lines)
> + (inputs
> + (alist-replace "qtbase" (list qtbase-5)
> + (package-inputs calcmysky)))

Instead of ‘alist-replace’, write

(modify-inputs (package-inputs calcmysky)
(replace "qtbase" qtbase-5))

You can remove the corresponding #:use-module form at the top.

Ludo’.
Ludovic Courtès wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 61674@debbugs.gnu.org)
87edqahktm.fsf_-_@gnu.org
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (17 lines)
> * gnu/packages/qt.scm (qxlsx-qt5): New variable.
> ---
> gnu/packages/qt.scm | 8 ++++++++
> 1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 4985a79db4..b2e14e5757 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -1156,6 +1156,14 @@ (define-public qxlsx
> XLSX document format.")
> (license license:expat)))
>
> +(define-public qxlsx-qt5
> + (package
> + (inherit qxlsx)

Please use ‘package/inherit’ as well.
Ludovic Courtès wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 61674@debbugs.gnu.org)
87a60yhks4.fsf_-_@gnu.org
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (5 lines)
> * gnu/packages/astronomy.scm (stellarium):
> [arguments]<#:configure-flags>: Enable ShowMySky optional dependencies
> to simulate scattering of light by the atmosphere.
> [inputs]: Replace QXLSX to QXLSX-QT5. Add CALCMYSKY-QT5.

LGTM!

Could you send an updated revision of this patch series taking into
account previous comments? Then we should be all set!

Thanks,
Ludo’.
Sharlatan Hellseher wrote 2 years ago
[PATCH v3 1/4] gnu: Add calcmysky.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230228001230.3573-1-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (calcmysky, calcmysky-qt5): New variables.
---
gnu/packages/astronomy.scm | 57 ++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5cee981671..bf022c1804 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -209,6 +209,63 @@ (define-public calceph
@end itemize\n")
(license license:cecill)))
+(define-public calcmysky
+ (package
+ (name "calcmysky")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/10110111/CalcMySky")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bib5shy8wzc7j5ph218dl9hqrqip491mn25gakyghbvaqxgm27d"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=6"
+ "-DCMAKE_CXX_FLAGS=-fPIC")))
+ (inputs
+ (list eigen glm qtbase))
+ (home-page "https://10110111.github.io/CalcMySky/")
+ (synopsis "Simulator of light scattering by planetary atmospheres")
+ (description
+ "CalcMySky is a software package that simulates scattering of light by the
+atmosphere to render daytime and twilight skies (without stars). Its primary
+purpose is to enable realistic view of the sky in applications such as
+planetaria. Secondary objective is to make it possible to explore atmospheric
+effects such as glories, fogbows etc., as well as simulate unusual environments
+such as on Mars or an exoplanet orbiting a star with a non-solar spectrum of
+radiation.
+
+This package consists of three parts:
+
+@itemize
+@item @code{calcmysky} utility that does the precomputation of the atmosphere
+model to enable rendering.
+
+@item @code{libShowMySky} library that lets the applications render the
+atmosphere model.
+
+@item @code{ShowMySky} preview GUI that makes it possible to preview the
+rendering of the atmosphere model and examine its properties.
+@end itemize")
+ (license license:gpl3+)))
+
+(define-public calcmysky-qt5
+ (package/inherit calcmysky
+ (name "calcmysky-qt5")
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=5"
+ "-DCMAKE_CXX_FLAGS=-fPIC")))
+ (inputs
+ (modify-inputs (package-inputs calcmysky)
+ (replace "qtbase" qtbase-5)))
+ (synopsis "Qt5 build for the CalcMySky library.")))
+
(define-public aoflagger
(package
(name "aoflagger")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH v3 2/4] gnu: qxlsx: Use Qt6.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230228001230.3573-2-sharlatanus@gmail.com
* gnu/packages/qt.scm (qxlsx):
[inputs]: Use QTBASE (Qt6) instead QTBASE-5. Add LIBXKBCOMMON,
VULKAN-HEADERS.
---
gnu/packages/qt.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 76e9e519c7..4985a79db4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1148,7 +1148,7 @@ (define-public qxlsx
(invoke "make" "-j" (number->string (parallel-job-count)))
(invoke "./TestExcel"))))))))
(inputs
- (list qtbase-5))
+ (list libxkbcommon qtbase vulkan-headers))
(home-page "https://qtexcel.github.io/QXlsx/")
(synopsis "C++ library to read/write Excel XLSX files using Qt")
(description
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH v3 3/4] gnu: Add qxlsx-qt5.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230228001230.3573-3-sharlatanus@gmail.com
* gnu/packages/qt.scm (qxlsx-qt5): New variable.
---
gnu/packages/qt.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4985a79db4..643744ee7a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1156,6 +1156,13 @@ (define-public qxlsx
XLSX document format.")
(license license:expat)))
+(define-public qxlsx-qt5
+ (package/inherit qxlsx
+ (name "qxlsx-qt5")
+ (inputs
+ (list qtbase-5))
+ (synopsis "Qt5 build for the qxlsx library.")))
+
(define-public qtxmlpatterns
(package (inherit qtsvg-5)
(name "qtxmlpatterns")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH v3 4/4] gnu: stellarium: Enable ShowMySky.
(address . 61674@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230228001230.3573-4-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (stellarium):
[arguments]<#:configure-flags>: Enable ShowMySky optional dependencies
to simulate scattering of light by the atmosphere.
[inputs]: Replace QXLSX to QXLSX-QT5. Add CALCMYSKY-QT5.
---
gnu/packages/astronomy.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bf022c1804..473e7ce63a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -917,8 +917,6 @@ (define-public stellarium
#~(list "-DENABLE_GPS=1"
;; TODO: Enable when all of the dependencies are availalbe for Qt6.
"-DENABLE_QT6=0"
- ;; TODO: Pack missing in Guix https://10110111.github.io/CalcMySky/
- "-DENABLE_SHOWMYSKY=0"
"-DENABLE_TESTING=0"
(string-append "-DCMAKE_CXX_FLAGS=-isystem "
#$(this-package-input "qtserialport") "/include/qt5"))
@@ -929,7 +927,8 @@ (define-public stellarium
(setenv "QT_QPA_PLATFORM" "offscreen")
(setenv "HOME" "/tmp"))))))
(inputs
- (list gpsd
+ (list calcmysky-qt5
+ gpsd
indi
libnova
openssl
@@ -942,7 +941,7 @@ (define-public stellarium
qtserialport
qttranslations
qtwebengine-5
- qxlsx
+ qxlsx-qt5
zlib))
(native-inputs
(list doxygen
--
2.39.1
Simon Tournier wrote 2 years ago
Re: [bug#61674] [PATCH 0/4] gnu: stellarium: Enable ShowMySky.
(address . 61674@debbugs.gnu.org)
87lekijcwi.fsf@gmail.com
Hi Ludo,

On lun., 27 févr. 2023 at 22:14, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (10 lines)
>> +(define-public calcmysky-qt5
>> + (package
>> + (inherit calcmysky)
>
> Rather:
>
> (package/inherit calcmysky
> (name "calcmysky-qt5")
> …)

Out of curiosity, what is the rationale for this suggestion?

Cheers,
simon
Ludovic Courtès wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
87v8jixg6u.fsf@gnu.org
Hi,

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (14 lines)
> On lun., 27 févr. 2023 at 22:14, Ludovic Courtès <ludo@gnu.org> wrote:
>
>>> +(define-public calcmysky-qt5
>>> + (package
>>> + (inherit calcmysky)
>>
>> Rather:
>>
>> (package/inherit calcmysky
>> (name "calcmysky-qt5")
>> …)
>
> Out of curiosity, what is the rationale for this suggestion?

This is so that the ‘replacement’ field of ‘calcmysky’, when there is
one, inherits the same transformations in ‘calcmysky-qt5’. Quoth the
‘package/inherit’ docstring:

Like (package (inherit P) OVERRIDES ...), except that the same
transformation is done to the package P's replacement, if any. P must
be a bare identifier, and will be bound to either P or its replacement
when evaluating OVERRIDES.

Ludo’.
Simon Tournier wrote 2 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAJ3okZ1oYVdW6R0x3u-zOGnCoSHa+RmB2w7cwsdwnpKzyXYaww@mail.gmail.com
Hi,

On Fri, 3 Mar 2023 at 11:49, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (9 lines)
> This is so that the ‘replacement’ field of ‘calcmysky’, when there is
> one, inherits the same transformations in ‘calcmysky-qt5’. Quoth the
> ‘package/inherit’ docstring:
>
> Like (package (inherit P) OVERRIDES ...), except that the same
> transformation is done to the package P's replacement, if any. P must
> be a bare identifier, and will be bound to either P or its replacement
> when evaluating OVERRIDES.

Thanks for the explanations but it is still unclear. Sorry to be slow.

It is not clear for me why you choose one over the other. From my
current understanding, I would be tempted to always use
'package/inherit' and never plain 'inherit'.

Cheers,
simon
Maxim Cournoyer wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
87o7p94yqk.fsf@gmail.com
Hi Simon,

Simon Tournier <zimon.toutoune@gmail.com> writes:

Toggle quote (19 lines)
> Hi,
>
> On Fri, 3 Mar 2023 at 11:49, Ludovic Courtès <ludo@gnu.org> wrote:
>
>> This is so that the ‘replacement’ field of ‘calcmysky’, when there is
>> one, inherits the same transformations in ‘calcmysky-qt5’. Quoth the
>> ‘package/inherit’ docstring:
>>
>> Like (package (inherit P) OVERRIDES ...), except that the same
>> transformation is done to the package P's replacement, if any. P must
>> be a bare identifier, and will be bound to either P or its replacement
>> when evaluating OVERRIDES.
>
> Thanks for the explanations but it is still unclear. Sorry to be slow.
>
> It is not clear for me why you choose one over the other. From my
> current understanding, I would be tempted to always use
> 'package/inherit' and never plain 'inherit'.

I also got confused by that in the past; The way I process it
internally now is this:

If the inheritance is for *same-source/same-version* variants of a
package, they should use package/inherit, as any security issues found
in the parent package should also be applied to that package (since they
use the same source). Otherwise, plain 'inherit' should be used
(e.g. for newer version variants).

I hope that helps!

Yours in slowness,

--
Maxim
Simon Tournier wrote 2 years ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
CAJ3okZ3x4vV1dnAeQR=Xj8gE_5QYSnOzrEL7v0a+aEkqhMNLLQ@mail.gmail.com
Hi Maxim,

On Fri, 3 Mar 2023 at 16:54, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (6 lines)
> If the inheritance is for *same-source/same-version* variants of a
> package, they should use package/inherit, as any security issues found
> in the parent package should also be applied to that package (since they
> use the same source). Otherwise, plain 'inherit' should be used
> (e.g. for newer version variants).

Aahh, that makes sense. :-) Thank you.

For instance, does it mean that

Toggle snippet (12 lines)
(define-public gst-plugins-good-qt
(package
(inherit gst-plugins-good)
(name "gst-plugins-good-qt")
(inputs
(modify-inputs (package-inputs gst-plugins-good)
(prepend qtbase-5
qtdeclarative-5
qtwayland-5
qtx11extras)))))

would be incorrect? It should be 'package/inherit', right?

Cheers,
simon
Maxim Cournoyer wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
871qm542e7.fsf@gmail.com
Hi Simon,

Simon Tournier <zimon.toutoune@gmail.com> writes:

Toggle quote (27 lines)
> Hi Maxim,
>
> On Fri, 3 Mar 2023 at 16:54, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> If the inheritance is for *same-source/same-version* variants of a
>> package, they should use package/inherit, as any security issues found
>> in the parent package should also be applied to that package (since they
>> use the same source). Otherwise, plain 'inherit' should be used
>> (e.g. for newer version variants).
>
> Aahh, that makes sense. :-) Thank you.
>
> For instance, does it mean that
>
> (define-public gst-plugins-good-qt
> (package
> (inherit gst-plugins-good)
> (name "gst-plugins-good-qt")
> (inputs
> (modify-inputs (package-inputs gst-plugins-good)
> (prepend qtbase-5
> qtdeclarative-5
> qtwayland-5
> qtx11extras)))))
>
> would be incorrect? It should be 'package/inherit', right?

It should be package/inherit yes, since they share the same source, thus
the same defects, thus should receive the same replacements/grafts (if
my preceding reasoning is correct :-)).

--
Thanks,
Maxim
Sharlatan Hellseher wrote 2 years ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
CAO+9K5oH6A-fJkBrT5ZNAOR-x4at0LOv9B-NZsgEFgVRtAOsgA@mail.gmail.com
Hi all,

It was very insightful patch series I ever sent :-)
I hope I covered all recommendations in v3.

Thanks,
Oleg

On Sat, 4 Mar 2023, 03:32 Maxim Cournoyer, <maxim.cournoyer@gmail.com>
wrote:

Toggle quote (40 lines)
> Hi Simon,
>
> Simon Tournier <zimon.toutoune@gmail.com> writes:
>
> > Hi Maxim,
> >
> > On Fri, 3 Mar 2023 at 16:54, Maxim Cournoyer <maxim.cournoyer@gmail.com>
> wrote:
> >
> >> If the inheritance is for *same-source/same-version* variants of a
> >> package, they should use package/inherit, as any security issues found
> >> in the parent package should also be applied to that package (since they
> >> use the same source). Otherwise, plain 'inherit' should be used
> >> (e.g. for newer version variants).
> >
> > Aahh, that makes sense. :-) Thank you.
> >
> > For instance, does it mean that
> >
> > (define-public gst-plugins-good-qt
> > (package
> > (inherit gst-plugins-good)
> > (name "gst-plugins-good-qt")
> > (inputs
> > (modify-inputs (package-inputs gst-plugins-good)
> > (prepend qtbase-5
> > qtdeclarative-5
> > qtwayland-5
> > qtx11extras)))))
> >
> > would be incorrect? It should be 'package/inherit', right?
>
> It should be package/inherit yes, since they share the same source, thus
> the same defects, thus should receive the same replacements/grafts (if
> my preceding reasoning is correct :-)).
>
> --
> Thanks,
> Maxim
>
Attachment: file
Ludovic Courtès wrote 2 years ago
Re: bug#61674: [PATCH 0/4] gnu: stellarium: Enable ShowMySky.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 61674-done@debbugs.gnu.org)
87y1o8dew8.fsf_-_@gnu.org
Hi Oleg,

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61674@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61674
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help