[PATCH 0/1] GNULIB_SRCDIR should not allow multiple entries

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 2 years ago
(address . guix-patches@gnu.org)
cover.1676965886.git.vivien@planete-kraus.eu
Dear guix,

GNULIB_SRCDIR is an environment that should be set when gnulib is in the profile. To do that, I made it a search path specification, but I did not know that I could prevent multiple entries.

I was told in #60358 that I could use (separator #f), so here is the fix. Sorry I’m late!

Vivien

Vivien Kraus (1):
gnu: gnulib: Allow only one directory name in GNULIB_SRCDIR.

gnu/packages/build-tools.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: 73b5c955ae46af2548625fe31afe60193fb83e2a
--
2.39.1
Vivien Kraus wrote 2 years ago
[PATCH 1/1] gnu: gnulib: Allow only one directory name in GNULIB_SRCDIR.
(address . 61673@debbugs.gnu.org)
5eeb169325aec5769cd0d2f78c1e78cdf0759a32.1676965886.git.vivien@planete-kraus.eu
* gnu/packages/build-tools.scm (gnulib-checkout) [search-path-specification
GNULIB_SRCDIR]: Set separator to #f.
---
gnu/packages/build-tools.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 3d03c37a2c..00b8f8caf3 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -997,7 +997,8 @@ (define (find-ucd-files . names)
(native-search-paths
(list (search-path-specification
(variable "GNULIB_SRCDIR")
- (files (list "src/gnulib")))))
+ (files (list "src/gnulib"))
+ (separator #f))))
(license (list license:lgpl2.0+ license:gpl3+))))
(define-public gnulib
--
2.39.1
Ludovic Courtès wrote 2 years ago
Re: bug#61673: [PATCH 0/1] GNULIB_SRCDIR should not allow multiple entries
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 61673-done@debbugs.gnu.org)
87ilfs5rmp.fsf_-_@gnu.org
Vivien Kraus <vivien@planete-kraus.eu> skribis:

Toggle quote (3 lines)
> * gnu/packages/build-tools.scm (gnulib-checkout) [search-path-specification
> GNULIB_SRCDIR]: Set separator to #f.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61673@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61673
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help