[PATCH] gnu: python-clingo: Fix invalid G-expression input.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Christopher Baines
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal

Debbugs page

Simon Tournier wrote 2 years ago
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230221010018.2689405-1-zimon.toutoune@gmail.com
* gnu/packages/maths.scm (python-clingo)[arguments]: Add 'imported-modules'
and 'modules' in order to access to 'python:site-packages'.
[version]: Explicitly reuse from the package 'clingo'.
---

Hi,

This package seems broken:

Toggle snippet (4 lines)
$ guix time-machine --commit=e8fcf1e424 -- build python-clingo
guix build: erreur : #<procedure version ()> : entrée G-expression invalide

The issue seems coming from the field 'version'. Then, commit
8285093cee000d6e28c040f721ddf0be18d32c42 introduces #$version which introduces
the failure.

Well, I have not found the correct G-exp syntax for #:imported-modules.

Cheers,
simon


gnu/packages/maths.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1e40be8722..67634990ae 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2703,12 +2703,20 @@ (define-public python-clingo
(package
(inherit clingo)
(name "python-clingo")
+ (version (package-version clingo)) ;Fix error: invalid G-expression #$version
(arguments
(substitute-keyword-arguments (package-arguments clingo)
((#:configure-flags flags #~'())
#~(cons* "-DCLINGO_BUILD_WITH_PYTHON=pip"
"-DCLINGO_USE_LIB=yes"
#$flags))
+ ((#:imported-modules _ '())
+ `(,@%cmake-build-system-modules
+ (guix build python-build-system)))
+ ((#:modules _ '())
+ '((guix build cmake-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils)))
((#:phases phases #~%standard-phases)
#~(modify-phases #$phases
(add-after 'unpack 'fix-failing-tests

base-commit: e8fcf1e42438113d7e4be82dc5a06de45eaceb76
--
2.38.1
Liliana Marie Prikler wrote 2 years ago
57f926d32bf2aa1208e76207f922b338fb7d7cc3.camel@gmail.com
Am Dienstag, dem 21.02.2023 um 02:00 +0100 schrieb Simon Tournier:
Toggle quote (19 lines)
> * gnu/packages/maths.scm (python-clingo)[arguments]: Add 'imported-
> modules'
> and 'modules' in order to access to 'python:site-packages'.
> [version]: Explicitly reuse from the package 'clingo'.
> ---
>
> Hi,
>
> This package seems broken:
>
> --8<---------------cut here---------------start------------->8---
> $ guix time-machine --commit=e8fcf1e424 -- build python-clingo
> guix build: erreur : #<procedure version ()> : entrée G-expression
> invalide
> --8<---------------cut here---------------end--------------->8---
>
> The issue seems coming from the field 'version'.  Then, commit
> 8285093cee000d6e28c040f721ddf0be18d32c42 introduces #$version which
> introduces the failure.
Thanks.

Toggle quote (2 lines)
> Well, I have not found the correct G-exp syntax for #:imported-
> modules.
Quoting works fine.

Toggle quote (14 lines)
>
>  gnu/packages/maths.scm | 8 ++++++++
>  1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 1e40be8722..67634990ae 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -2703,12 +2703,20 @@ (define-public python-clingo
>    (package
>      (inherit clingo)
>      (name "python-clingo")
> +    (version (package-version clingo)) ;Fix error: invalid G-
> expression #$version
Reworded slightly and pushed (it's a hotfix and CI succeeds).

Cheers
Christopher Baines wrote 2 years ago
87356zfadc.fsf@cbaines.net
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (15 lines)
>>  gnu/packages/maths.scm | 8 ++++++++
>>  1 file changed, 8 insertions(+)
>>
>> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
>> index 1e40be8722..67634990ae 100644
>> --- a/gnu/packages/maths.scm
>> +++ b/gnu/packages/maths.scm
>> @@ -2703,12 +2703,20 @@ (define-public python-clingo
>>    (package
>>      (inherit clingo)
>>      (name "python-clingo")
>> +    (version (package-version clingo)) ;Fix error: invalid G-
>> expression #$version
> Reworded slightly and pushed (it's a hotfix and CI succeeds).

Closing accordingly.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmP0vr9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdzAxAAjwp91512AU6BNErireHGV3XSr0A38vBi
d3KT26KtJArJn29wcbMX4uj3gIwjZOnVaTz3MT8rZG/5oA+2PElLBOG2d35upFW7
A7nyWEpP5sQBSipeejqamZvj7AzYvEukUkKA9N6qwp64uhVgfPKI3IYsVatQI+vH
CU+UwDN/Hur32nWySS8FpIucHVof0RFZEtel+NaR0nxC3QbMBmcfS3bu5pAI9N4I
AqKJt9TQp4cpiSYGlEl+JNlhFlzHj8jtQq4SbnCKD6fSU6BmAFabVGh+HlahoVP+
4lcamTel9rQNRsJFFf/rYcWAVRkFDb7/XX8pGIGjb7F2tVUbcdcZZ2u+a2I+zXSt
j3k1wraNiGPxTNJj54fYYr/RyWq4OswFYzpYIF5TKZ9581nC4nLsF75IkXLokXYF
gPVyHWZgnyVtYBkvCpiaNAyVnVrNuaoDMgro8YWZ9fCSLGtvlK1NvY8S7BGfGkDk
hidxUefMMUwU46bmqY7qx6dvsRFnQUCl4DeUW2yB3lpyTTJtHojDBAp20LxTzGMR
zhvqs3t7LqokY7CFrXVNZhs9ofUMlDdFIC7i9NDpy2pT0yLjRxTHzi7vrOfOvFvP
LDlLadLxaRd/tn4F4SO5gjXpAc60E2ux6o80GBi/xlQ8Qr3xSIuIOEQax1i3h0R8
SV+Z4V8h4VM=
=EFWV
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 61665@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61665
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help