[PATCH 0/6] gnu: Add texlive-minted.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 2 years ago
(address . guix-patches@gnu.org)
DM5PR03MB31631AF924530D504B2C5512C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
[PATCH 1/6] gnu: Add texlive-catchfile.
[PATCH 2/6] gnu: texlive-latex-ifplatform: Add needed propagated-inputs.
[PATCH 3/6] gnu: texlive-mdframed: Add needed propagated-inputs.
[PATCH 4/6] gnu: texlive-latex-fancyvrb: Add needed propagated-inputs.
[PATCH 5/6] gnu: Add texlive-fvextra.
[PATCH 6/6] gnu: Add texlive-minted.
Morgan.J.Smith wrote 2 years ago
[PATCH 1/6] gnu: Add texlive-catchfile.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163D52FEF51BE042E6AC33FC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-catchfile): New variable.
---
gnu/packages/tex.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dafed9d3c3..96c07de51b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5304,6 +5304,23 @@ (define-public texlive-carlisle
in LaTeX documents; a jiffy to create slashed characters for physicists.")
(license license:lppl)))
+(define-public texlive-catchfile
+ (package
+ (inherit (simple-texlive-package
+ "texlive-catchfile"
+ (list "/doc/latex/catchfile/"
+ "/source/latex/catchfile/"
+ "/tex/generic/catchfile/")
+ (base32
+ "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/catchfile")
+ (synopsis "Catch an external file into a macro")
+ (description
+ "Catches the contents of a file and puts it in a macro. It requires
+e-TeX. Both LaTeX and plain TeX are supported.")
+ (license license:lppl1.3+)))
+
(define-public texlive-doi
(package
(inherit (simple-texlive-package
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH 2/6] gnu: texlive-latex-ifplatform: Add needed propagated-inputs.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163810547532B7F338AFFABC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-latex-ifplatform)[propagated-inputs]: Add
texlive-catchfile.
---
gnu/packages/tex.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 96c07de51b..1e6d040106 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4957,6 +4957,7 @@ (define-public texlive-latex-ifplatform
(base32
"157pplavvm2z97b3jl4x41w11k6q9wgy074mfg0dwmsx5lm328jy"))))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-catchfile))
(arguments '(#:tex-directory "latex/ifplatform"))
(home-page "https://www.ctan.org/pkg/ifplatform")
(synopsis "Conditionals to test which platform is being used")
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH 3/6] gnu: texlive-mdframed: Add needed propagated-inputs.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB31633D96E980CF35910E2038C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-mdframed)[propagated-inputs]: Add
texlive-latex-needspace, and texlive-zref.
---
gnu/packages/tex.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1e6d040106..6d961558e9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11515,6 +11515,8 @@ (define-public texlive-mdframed
"tex/latex/mdframed/")
(base32 "1i5rm946wg43rjckxlfhx79zfx5cgd3bxk71206hd1dqkrgpdpa8")
#:trivial? #t))
+ (propagated-inputs (list texlive-latex-needspace
+ texlive-zref))
(home-page "https://ctan.org/pkg/mdframed")
(synopsis "Framed environments that can split at page boundaries")
(description
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH 4/6] gnu: texlive-latex-fancyvrb: Add needed propagated-inputs.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163F418C4CC564A42C10E86C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-latex-fancyvrb)[propagated-inputs]: Add
texlive-latex-upquote.
---
gnu/packages/tex.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d961558e9..3d0d2e5db9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3174,6 +3174,7 @@ (define-public texlive-latex-fancyvrb
(base32
"0pdilgpw4zc0ipp4z9kdi61nymifyjy2mfpk74xk2cw9vhynkk3w")
#:trivial? #t))
+ (propagated-inputs (list texlive-latex-upquote))
(home-page "https://www.ctan.org/pkg/fancyvrb")
(synopsis "Sophisticated verbatim text")
(description
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH 5/6] gnu: Add texlive-fvextra.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163877C9A5DA1B40D5B4A0BC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-fvextra): New variable.
---
gnu/packages/tex.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d0d2e5db9..55f6952cc1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11170,6 +11170,24 @@ (define-public texlive-floatflt
tables and figures to be set left/right or alternating on even/odd pages.")
(license license:lppl1.3+)))
+(define-public texlive-fvextra
+ (package
+ (inherit (simple-texlive-package
+ "texlive-fvextra"
+ (list "/doc/latex/fvextra/"
+ "/source/latex/fvextra/"
+ "/tex/latex/fvextra/")
+ (base32
+ "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/fvextra")
+ (synopsis "Extensions and patches for fancyvrb")
+ (description
+ "Provides several extensions to fancyvrb, including automatic line
+breaking and improved math mode. It also patches some fancyvrb internals.
+Parts of fvextra were originally developed as part of pythontex and minted.")
+ (license license:lppl1.3+)))
+
(define-public bibtool
(package
(name "bibtool")
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH 6/6] gnu: Add texlive-minted.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163EE64DE1B91ED0C74E51BC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-minted): New variable.
---
gnu/packages/tex.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 55f6952cc1..f63c5567fe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10032,6 +10032,33 @@ (define-public texlive-microtype
the bundle.")
(license license:lppl1.3c))))
+(define-public texlive-minted
+ (package
+ (inherit (simple-texlive-package
+ "texlive-minted"
+ (list "/doc/latex/minted/"
+ "/source/latex/minted/"
+ "/tex/latex/minted/")
+ (base32
+ "08pbhp4a9k8v49kji26206zzabp0nn0fz403l4w7gxajw9rj8icr")
+ #:trivial? #t))
+ (propagated-inputs (list python-pygments
+ texlive-etoolbox
+ texlive-fvextra
+ texlive-generic-xstring
+ texlive-latex-fancyvrb
+ texlive-latex-float
+ texlive-latex-framed
+ texlive-latex-ifplatform
+ texlive-latex-newfloat
+ texlive-lineno))
+ (home-page "https://ctan.org/pkg/minted")
+ (synopsis "Highlighted source code for LaTeX")
+ (description "Facilitates expressive syntax highlighting in LaTeX using
+the Pygments library. The package also provides options to customize the
+highlighted source code output using fancyvrb and fvextra.")
+ (license license:lppl1.3+)))
+
(define-public texlive-caption
(let ((template (simple-texlive-package
"texlive-caption"
--
2.39.1
Nicolas Goaziou wrote 2 years ago
Re: [bug#61659] [PATCH 0/6] gnu: Add texlive-minted.
(address . Morgan.J.Smith@outlook.com)(address . 61659@debbugs.gnu.org)
87fsb0qks9.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (7 lines)
> [PATCH 1/6] gnu: Add texlive-catchfile.
> [PATCH 2/6] gnu: texlive-latex-ifplatform: Add needed propagated-inputs.
> [PATCH 3/6] gnu: texlive-mdframed: Add needed propagated-inputs.
> [PATCH 4/6] gnu: texlive-latex-fancyvrb: Add needed propagated-inputs.
> [PATCH 5/6] gnu: Add texlive-fvextra.
> [PATCH 6/6] gnu: Add texlive-minted.

I gave a glance at these patches. Thanks for them.

texlive-catchfile, texlive-fvextra and texlive-minted are not trivial
packages (in the #:trivial? #t) since they contain ".dtx" or ".ins"
files. Could you try generating the run files from those source files
instead?

Also, descriptions need to start with a complete sentence. For example

Catches the contents of a file and puts it in a macro. It requires
e-TeX. Both LaTeX and plain TeX are supported.

could simply become :

Catchfile catches the contents of a file and puts it in a macro.

Regards,
--
Nicolas Goaziou
Morgan.J.Smith wrote 2 years ago
[PATCH v2 1/6] gnu: Add texlive-catchfile.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163122DB221CD130134496FC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-catchfile): New variable.
---
gnu/packages/tex.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dafed9d3c3..efccba17cc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5304,6 +5304,26 @@ (define-public texlive-carlisle
in LaTeX documents; a jiffy to create slashed characters for physicists.")
(license license:lppl)))
+(define-public texlive-catchfile
+ (let ((template (simple-texlive-package
+ "texlive-catchfile"
+ (list "/doc/latex/catchfile/"
+ "/source/latex/catchfile/"
+ "/tex/generic/catchfile/")
+ (base32
+ "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/catchfile")))
+ (home-page "https://ctan.org/macros/latex/contrib/catchfile")
+ (synopsis "Catch an external file into a macro")
+ (description
+ "Catchfile catches the contents of a file and puts it in a macro.")
+ (license license:lppl1.3+))))
+
(define-public texlive-doi
(package
(inherit (simple-texlive-package
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH v2 3/6] gnu: texlive-mdframed: Add needed propagated-inputs.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB31630B3A00720284758304A7C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-mdframed)[propagated-inputs]: Add
texlive-latex-needspace, and texlive-zref.
---
gnu/packages/tex.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2fea0e9697..5d82f98f35 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11518,6 +11518,8 @@ (define-public texlive-mdframed
"tex/latex/mdframed/")
(base32 "1i5rm946wg43rjckxlfhx79zfx5cgd3bxk71206hd1dqkrgpdpa8")
#:trivial? #t))
+ (propagated-inputs (list texlive-latex-needspace
+ texlive-zref))
(home-page "https://ctan.org/pkg/mdframed")
(synopsis "Framed environments that can split at page boundaries")
(description
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH v2 4/6] gnu: texlive-latex-fancyvrb: Add needed propagated-inputs.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB31631C26D1456D77A11B6590C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-latex-fancyvrb)[propagated-inputs]: Add
texlive-latex-upquote.
---
gnu/packages/tex.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5d82f98f35..bf4a50973b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3174,6 +3174,7 @@ (define-public texlive-latex-fancyvrb
(base32
"0pdilgpw4zc0ipp4z9kdi61nymifyjy2mfpk74xk2cw9vhynkk3w")
#:trivial? #t))
+ (propagated-inputs (list texlive-latex-upquote))
(home-page "https://www.ctan.org/pkg/fancyvrb")
(synopsis "Sophisticated verbatim text")
(description
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH v2 5/6] gnu: Add texlive-fvextra.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163AB94C92ADF056FAF70F8C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-fvextra): New variable.
---
gnu/packages/tex.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bf4a50973b..6aef6905a6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11173,6 +11173,28 @@ (define-public texlive-floatflt
tables and figures to be set left/right or alternating on even/odd pages.")
(license license:lppl1.3+)))
+(define-public texlive-fvextra
+ (let ((template (simple-texlive-package
+ "texlive-fvextra"
+ (list "/doc/latex/fvextra/"
+ "/source/latex/fvextra/"
+ "/tex/latex/fvextra/")
+ (base32
+ "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/fvextra")))
+ (home-page "https://ctan.org/macros/latex/contrib/fvextra")
+ (synopsis "Extensions and patches for fancyvrb")
+ (description
+ "This package provides several extensions to fancyvrb, including
+automatic line breaking and improved math mode. It also patches some fancyvrb
+internals.")
+ (license license:lppl1.3+))))
+
(define-public bibtool
(package
(name "bibtool")
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH v2 6/6] gnu: Add texlive-minted.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163226592766A7697AE0F5DC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-minted): New variable.
---
gnu/packages/tex.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6aef6905a6..592ef6943a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10035,6 +10035,37 @@ (define-public texlive-microtype
the bundle.")
(license license:lppl1.3c))))
+(define-public texlive-minted
+ (let ((template (simple-texlive-package
+ "texlive-minted"
+ (list "/doc/latex/minted/"
+ "/source/latex/minted/"
+ "/tex/latex/minted/")
+ (base32
+ "08pbhp4a9k8v49kji26206zzabp0nn0fz403l4w7gxajw9rj8icr"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/minted")))
+ (propagated-inputs (list python-pygments
+ texlive-etoolbox
+ texlive-fvextra
+ texlive-generic-xstring
+ texlive-latex-fancyvrb
+ texlive-latex-float
+ texlive-latex-framed
+ texlive-latex-ifplatform
+ texlive-latex-newfloat
+ texlive-lineno))
+ (home-page "https://ctan.org/pkg/minted")
+ (synopsis "Highlight source code in LaTeX documents")
+ (description "This package facilitates expressive syntax highlighting in
+LaTeX using the Pygments library. This package also provides options to
+customize the highlighted source code output using fancyvrb and fvextra.")
+ (license license:lppl1.3+))))
+
(define-public texlive-caption
(let ((template (simple-texlive-package
"texlive-caption"
--
2.39.1
Morgan.J.Smith wrote 2 years ago
[PATCH v2 2/6] gnu: texlive-latex-ifplatform: Add needed propagated-inputs.
(address . 61659@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163247BF1A1AD4E2E802470C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-latex-ifplatform)[propagated-inputs]: Add
texlive-catchfile.
---
gnu/packages/tex.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index efccba17cc..2fea0e9697 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4957,6 +4957,7 @@ (define-public texlive-latex-ifplatform
(base32
"157pplavvm2z97b3jl4x41w11k6q9wgy074mfg0dwmsx5lm328jy"))))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-catchfile))
(arguments '(#:tex-directory "latex/ifplatform"))
(home-page "https://www.ctan.org/pkg/ifplatform")
(synopsis "Conditionals to test which platform is being used")
--
2.39.1
Morgan Smith wrote 2 years ago
Re: [bug#61659] [PATCH 0/6] gnu: Add texlive-minted.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 61659@debbugs.gnu.org)
DM5PR03MB31633D7EF27C6A76858E3239C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
Hello Nicolas,

I've made the changes you asked for (sent to debbugs as I don't want to
fill up your inbox). I'm able to compile a latex document using minted
so I think everything is in order on the technical side. I do seem to
struggle with the English side a little bit :P

I still have no clue how latex works under the hood or what ".dtx" or
".ins" files are but thankfully Guix seems to be shielding me from such
knowledge with thoughtful abstraction layers! :)

Thanks,

Morgan
Nicolas Goaziou wrote 2 years ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 61659-done@debbugs.gnu.org)
87mt54pib5.fsf@nicolasgoaziou.fr
Hello,
Morgan Smith <Morgan.J.Smith@outlook.com> writes:

Toggle quote (6 lines)
> Hello Nicolas,
>
> I've made the changes you asked for (sent to debbugs as I don't want to
> fill up your inbox). I'm able to compile a latex document using minted
> so I think everything is in order on the technical side.

Applied. Thank you!

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61659@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61659
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help