[PATCH] gnu: gnunet: Update to 0.19.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Adam Faiz
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 20 Feb 2023 14:47
(address . guix-patches@gnu.org)
dd9a732a-296b-2af8-42dc-a1abfdf88ab3@disroot.org
From 7bfd653e503e7e8be16179ed1ba2ac15b303c8b7 Mon Sep 17 00:00:00 2001
Message-Id:
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 20 Feb 2023 19:53:03 +0800
Subject: [PATCH] gnu: gnunet: Update to 0.19.3.

* gnu/packages/gnunet.scm (gnunet): Update to 0.19.3.
---
gnu/packages/gnunet.scm | 17 +++++++++++++----
1 file changed, 13 insertions(+), 4 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index c98ceefad7..58349a798d 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -37,6 +37,7 @@ (define-module (gnu packages gnunet)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -60,6 +61,7 @@ (define-module (gnu packages gnunet)
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages text-editors)
#:use-module (gnu packages tls)
@@ -258,7 +260,7 @@ (define-public gnurl
(define-public gnunet
(package
(name "gnunet")
- (version "0.16.3")
+ (version "0.19.3")
(source
(origin
(method url-fetch)
@@ -266,12 +268,19 @@ (define-public gnunet
".tar.gz"))
(sha256
(base32
- "12n33r9nnkl5xwx8pwf571l2zvnvfllc8vm6mamrlyjk2cphaf9j"))))
+ "09bspbjl6cll8wcrl1vnb56jwp30pcrg1yyj6xy3i0fl2bzdbdw2"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; This is fixed in the upstream repository but the fix
+ ;; has not been released.
+ (substitute* "src/gns/test_proxy.sh"
+ (("test_gnunet_proxy.conf") "test_gns_proxy.conf"))))))
(build-system gnu-build-system)
(inputs
(list bluez
glpk
- gnurl
+ curl
gnutls/dane
gstreamer
jansson
@@ -291,7 +300,7 @@ (define-public gnunet
zbar
zlib))
(native-inputs
- (list curl openssl pkg-config python xxd
+ (list curl openssl pkg-config python xxd python-sphinx
python-sphinx-rtd-theme
(@ (gnu packages base) which)))
(arguments
'(#:parallel-tests? #f ; Parallel tests aren't supported.

base-commit: 08edbd2535ae622d319a51e6f877d23d75dc24f3
--
2.39.1
A
A
Adam Faiz wrote on 20 Feb 2023 14:49
[PATCH] gnu: gnunet-gtk: Update to 0.19.0.
(address . 61651@debbugs.gnu.org)
539e3757-c44f-de0b-2694-d8eb73bd2679@disroot.org
From dce4da889aed8b5102611ee600021dc7e56670a1 Mon Sep 17 00:00:00 2001
Message-Id:
<dce4da889aed8b5102611ee600021dc7e56670a1.1676897203.git.adam.faiz@disroot.org>
In-Reply-To:
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
References:
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 20 Feb 2023 20:08:48 +0800
Subject: [PATCH] gnu: gnunet-gtk: Update to 0.19.0.

* gnu/packages/gnunet.scm (gnunet-gtk): Update to 0.19.0.
---
gnu/packages/gnunet.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 58349a798d..fea6c50947 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -431,14 +431,14 @@ (define-public gnunet-scheme
(define-public gnunet-gtk
(package (inherit gnunet)
(name "gnunet-gtk")
- (version "0.13.1")
+ (version "0.19.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gnunet/gnunet-gtk-"
version ".tar.gz"))
(sha256
(base32
- "1zdzgq16h77w6ybwg3lqjsjr965np6iqvncqvkbj07glqd4wss0j"))))
+ "0z2731l69vnfsa0cdsw8wh8g1d08wz15y5n0a58qjpf7baric01k"))))
(arguments
`(#:configure-flags
(list "--with-libunique"
@@ -452,6 +452,7 @@ (define-public gnunet-gtk
("gtk+" ,gtk+)
("libextractor" ,libextractor)
("libgcrypt" ,libgcrypt)
+ ("libsodium" ,libsodium)
("libunique" ,libunique)
("qrencode" ,qrencode)))
(native-inputs
--
2.39.1
A
A
Adam Faiz wrote on 20 Feb 2023 14:50
[PATCH] gnu: gnunet-gtk: Use new style inputs, gexps.
(address . 61651@debbugs.gnu.org)
77d953d5-d0af-c41e-cffa-bb6acebd243e@disroot.org
From 58f04e934a71781f0232fcd20b4e89df39062db9 Mon Sep 17 00:00:00 2001
Message-Id:
<58f04e934a71781f0232fcd20b4e89df39062db9.1676897203.git.adam.faiz@disroot.org>
In-Reply-To:
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
References:
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 20 Feb 2023 20:18:23 +0800
Subject: [PATCH] gnu: gnunet-gtk: Use new style inputs, gexps.

* gnu/packages/gnunet.scm (gnunet-gtk): Use new style inputs, gexps.
[arguments]: Use new style and gexps.
[inputs]: Use new style.
---
gnu/packages/gnunet.scm | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index fea6c50947..264c876cc4 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -440,21 +440,21 @@ (define-public gnunet-gtk
(base32
"0z2731l69vnfsa0cdsw8wh8g1d08wz15y5n0a58qjpf7baric01k"))))
(arguments
- `(#:configure-flags
- (list "--with-libunique"
- "--with-qrencode"
- (string-append "--with-gnunet="
- (assoc-ref %build-inputs "gnunet")))))
+ (list #:configure-flags
+ #~(list "--with-libunique"
+ "--with-qrencode"
+ (string-append "--with-gnunet="
+ #$(this-package-input "gnunet")))))
(inputs
- `(("glade3" ,glade3)
- ("gnunet" ,gnunet)
- ("gnutls" ,gnutls/dane)
- ("gtk+" ,gtk+)
- ("libextractor" ,libextractor)
- ("libgcrypt" ,libgcrypt)
- ("libsodium" ,libsodium)
- ("libunique" ,libunique)
- ("qrencode" ,qrencode)))
+ (list glade3
+ gnunet
+ gnutls/dane
+ gtk+
+ libextractor
+ libgcrypt
+ libsodium
+ libunique
+ qrencode))
(native-inputs
(list pkg-config libglade))
(synopsis "Graphical front-end tools for GNUnet")
--
2.39.1
G
G
Guillaume Le Vaillant wrote on 22 Feb 2023 17:08
Re: [bug#61651] [PATCH] gnu: gnunet: Update to 0.19.3.
(name . Adam Faiz)(address . adam.faiz@disroot.org)(address . 61651-done@debbugs.gnu.org)
87y1op4qwp.fsf@kitej
Patches pushed as 6d53351a6d13039eb076e584d13225e0158c5a08 and
following.
Thanks.

Note: The patch for updating gnunet was mangled by your email client (it
cut a long line in native-inputs in two). To prevent this from
happening, you can use the "git send-email" command, or send patches as
attachments, or set your email client to no-line-cutting-mode if that's
possible.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY/Y/xg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8wuQEAgZ5ou1SnxpwyEPPVMJs7wIFSjj1gfxoMtsz8
1QG8qoQA/iOg7y9mwMk8QOMrJTtnsS6Uk2ewklTaa3gD/A9sFSpg
=QvoS
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61651@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61651
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch