[PATCH 00/10]: gnu: Add julia-astrotime

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
  • Simon Tournier
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000347.20469-1-sharlatanus@gmail.com
Hi Guix!

Here is a bit longer patch series adding JuliaAstro/AstroTime.jl project with
all it's dependencies which are missed in Guix.

Toggle quote (12 lines)
> ./pre-inst-env guix build --rounds=2 julia-leapseconds julia-optionaldata julia-remotefiles julia-earthorientation julia-inflate julia-arnoldimethod julia-lightgraphs julia-itemgraphs julia-muladdmacro julia-astrotime
> /gnu/store/xz9n4dmdc2cxbbaynqnkqc5scz1f65l1-julia-astrotime-0.7.0
> /gnu/store/a6r9i0y2c328q5w70ai3pyblw162d5sp-julia-muladdmacro-0.2.4
> /gnu/store/hhxk7nawskybgx9srcnja143jgxrm844-julia-itemgraphs-0.4.0
> /gnu/store/4gmvwb02r0z5qn0bv6ishl5jvrz4a2xm-julia-lightgraphs-1.3.5
> /gnu/store/zf6m8p02z9lsclpsyj8xgf4lc71fwvl8-julia-arnoldimethod-0.2.0
> /gnu/store/my607hbls2zv09lwn6k5w67dl2q9cw50-julia-inflate-0.1.2
> /gnu/store/7jf4kkjhhz4v2kl94yr1jclsff68vhm9-julia-earthorientation-0.7.1
> /gnu/store/qshdsa5rb8930lhp4zphs4d7qah6gccy-julia-remotefiles-0.5.0
> /gnu/store/nihf0zkndndym7c66gyrzy7ldqyyqgb7-julia-optionaldata-1.0.0
> /gnu/store/liggpbgi6ff4gyxxlwhbrc0vnknxi3fl-julia-leapseconds-1.1.0

Sharlatan Hellseher (10):
gnu: Add julia-leapseconds.
gnu: Add julia-optionaldata.
gnu: Add julia-remotefiles.
gnu: Add julia-earthorientation.
gnu: Add julia-inflate.
gnu: Add julia-arnoldimethod.
gnu: Add julia-lightgraphs.
gnu: Add julia-itemgraphs.
gnu: Add julia-muladdmacro.
gnu: Add julia-astrotime.

gnu/packages/julia-xyz.scm | 312 +++++++++++++++++++++++++++++++++++++
1 file changed, 312 insertions(+)


base-commit: 037c1b254a84d656b87b6bbb9c339bc04cfdb0a8
prerequisite-patch-id: b3ac2ffdff354e1ba34b14db9680bf5977d568e8
prerequisite-patch-id: 23fc0db8ba47376211c934f68f4ac0032bd49112
prerequisite-patch-id: d339a2d2bfa3c0287d429470bf947a6ede5403cf
prerequisite-patch-id: f1c2ccbbac909e47ae722c93b6c1634219f37ecf
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 01/10] gnu: Add julia-leapseconds.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-1-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-leapseconds): New variable.
---
gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 82429c957d..b391fadd36 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3576,6 +3576,31 @@ (define-public julia-lazyarrays
implementation of matrix-free methods for iterative solvers.")
(license license:expat)))
+(define-public julia-leapseconds
+ (package
+ (name "julia-leapseconds")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaTime/LeapSeconds.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13xa49dx11n7ii77rw6300h1rfl4qlq05ypsprvfmvyww81angkp"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-erfa))
+ (home-page "https://github.com/JuliaTime/LeapSeconds.jl")
+ (synopsis "Leap seconds in Julia")
+ (description
+ "@code{LeapSeconds} provides a functionality to return the difference
+between @acronym{TAI, International Atomic Time} and @acronym{UTC, Coordinated
+Universal Time} or vice versa for a given date. For dates after 1972-01-01, this
+is the number of leap seconds.")
+ (license license:expat)))
+
(define-public julia-linesearches
(package
(name "julia-linesearches")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 02/10] gnu: Add julia-optionaldata.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-2-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-optionaldata): New variable.
---
gnu/packages/julia-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b391fadd36..7eb4cb0dae 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4284,6 +4284,29 @@ (define-public julia-optimtestproblems
JuliaNLSolvers packages.")
(license license:expat)))
+(define-public julia-optionaldata
+ (package
+ (name "julia-optionaldata")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/helgee/OptionalData.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11js258j7cz6362ijsi24nih3lx90aalf8k1n3fv6v7iqas8bz5s"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/helgee/OptionalData.jl")
+ (synopsis "Work with global data that might not be available")
+ (description
+ "This package provides the @code{@@OptionalData} macro and the corresponding
+OptData type which is a thin wrapper around a nullable value (of type @code{Union{T,
+Nothing} where T)}. It allows you to load and access globally available data at
+runtime in a type-stable way.")
+ (license license:expat)))
+
(define-public julia-orderedcollections
(package
(name "julia-orderedcollections")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 03/10] gnu: Add julia-remotefiles.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-3-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-remotefiles): New variable.
---
gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 7eb4cb0dae..bbc1985a4b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5001,6 +5001,31 @@ (define-public julia-reexport
(description "This package provides tools to re-export modules and symbols.")
(license license:expat)))
+(define-public julia-remotefiles
+ (package
+ (name "julia-remotefiles")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/helgee/RemoteFiles.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zpklzpd4ckp7s4wbf93qmq3dyyrx4pzl41x5i9zbiskadhniqnh"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f)) ; Tests try to download from Internet.
+ (propagated-inputs
+ (list julia-fileio julia-http))
+ (home-page "https://github.com/helgee/RemoteFiles.jl")
+ (synopsis "Download files from the Internet and keep them up-to-date")
+ (description
+ "This package provides a functionality of files download with cURL, wget or
+@code{HTTP.jl} backends.")
+ (license license:expat)))
+
(define-public julia-referencetests
(package
(name "julia-referencetests")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 04/10] gnu: Add julia-earthorientation.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-4-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-earthorientation): New variable.
---
gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index bbc1985a4b..a0a24e05a5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1829,6 +1829,31 @@ (define-public julia-dualnumbers
combinations of dual numbers with predefined Julia numeric types.")
(license license:expat)))
+(define-public julia-earthorientation
+ (package
+ (name "julia-earthorientation")
+ (version "0.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/EarthOrientation.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fschx4qmfd83q0ymgbzqi1dl0drbh45cd7hlcbqnm9lfmw2d847"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-leapseconds
+ julia-optionaldata
+ julia-remotefiles))
+ (home-page "https://github.com/JuliaAstro/EarthOrientation.jl")
+ (synopsis "Calculate Earth orientation parameters from IERS tables in Julia")
+ (description
+ "This package provides a functionality to calculate Earth orientation parameters
+with data retrieved from @acronym{IERS, International Earth Rotation Service}.")
+ (license license:expat)))
+
(define-public julia-ellipsisnotation
(package
(name "julia-ellipsisnotation")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 05/10] gnu: Add julia-inflate.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-5-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-inflate): New variable.
---
gnu/packages/julia-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a0a24e05a5..4dbb7e6eea 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3076,6 +3076,33 @@ (define-public julia-indirectarrays
indexed images, sometimes called \"colormap images\" or \"paletted images.\"")
(license license:expat)))
+(define-public julia-inflate
+ (package
+ (name "julia-inflate")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GunnarFarneback/Inflate.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16nbl40b819yzmfqs860xbcbx8nnxm0pkvzj49qmxibv5jnsj47q"))))
+ (build-system julia-build-system)
+ (arguments
+ ;; FIXME: Tests fail hard with a lot of errors.
+ '(#:tests? #f))
+ (propagated-inputs
+ (list julia-codeczlib))
+ (home-page "https://github.com/GunnarFarneback/Inflate.jl")
+ (synopsis "Julia implementation of zlib decompression")
+ (description "Inflate provides a pure Julia implementation of zlib decompression
+functionality, with both in- memory and streaming interfaces. This covers
+decompression of the Deflate algorithm and the Zlib and Gzip wrapper formats, as
+specified in RFC 1950, RFC 1951, and RFC 1952.")
+ (license license:expat)))
+
(define-public julia-infinity
(package
(name "julia-infinity")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 06/10] gnu: Add julia-arnoldimethod.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-6-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-arnoldimethod): New variable.
---
gnu/packages/julia-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4dbb7e6eea..aaaa4afa0e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -147,6 +147,42 @@ (define-public julia-aqua
provides functions to run a few automatable checks for Julia packages.")
(license license:expat)))
+(define-public julia-arnoldimethod
+ (package
+ (name "julia-arnoldimethod")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLinearAlgebra/ArnoldiMethod.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gs7pikgdg436srxxfywpnp12ay1mf45f7z80wym92rfrjzakwh2"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-genericschur julia-staticarrays))
+ (home-page "https://github.com/JuliaLinearAlgebra/ArnoldiMethod.jl")
+ (synopsis "Implicitly Restarted Arnoldi Method, natively in Julia")
+ (description
+ "@code{ArnoldiMethod.jl} provides an iterative method to find a few
+approximate solutions to the eigenvalue problem in standard form with main
+goals:
+
+@itemize
+@item Having a native Julia implementation of the @code{eigs} function that
+performs as well as ARPACK. With native we mean that its implementation should
+be generic and support any number type. Currently the partialschur function
+does not depend on LAPACK, and removing the last remnants of direct calls to
+BLAS is in the pipeline.
+
+@item Removing the dependency of the Julia language on ARPACK. This goal was
+already achieved before the package was stable enough, since ARPACK moved to a
+separate repository @code{Arpack.jl}.
+@end itemize")
+ (license license:expat)))
+
(define-public julia-arrayinterface
(package
(name "julia-arrayinterface")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 07/10] gnu: Add julia-lightgraphs.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-7-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-lightgraphs): New variable.
---
gnu/packages/julia-xyz.scm | 69 ++++++++++++++++++++++++++++++++++++++
1 file changed, 69 insertions(+)

Toggle diff (82 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index aaaa4afa0e..1d88c09647 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3689,6 +3689,75 @@ (define-public julia-leapseconds
is the number of leap seconds.")
(license license:expat)))
+(define-public julia-lightgraphs
+ (package
+ (name "julia-lightgraphs")
+ (version "1.3.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sbromberger/LightGraphs.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ygnbzx32b9ciwgg0rn5i0m33dvrb6dh3an6bnmzac1w67sy2vxq"))))
+ (build-system julia-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; FIXME: 8x tests fails adjusting for now.
+ ;; ERROR: LoadError: Some tests did not pass: 29548 passed, 0 failed,
+ ;; 8 errored, 0 broken.
+ (add-after 'unpack 'adjust-tests
+ (lambda _
+ (substitute* "test/runtests.jl"
+ ;; Got exception outside of a @test BoundsError: attempt to
+ ;; access 1-element Vector{SubString{String}} at index [2]
+ ((".*degeneracy.*") "")
+ ;; Got exception outside of a @test type DataType has no field
+ ;; mutable
+ ((".*shortestpaths.*") ""))
+ (substitute* "test/experimental/experimental.jl"
+ ;; Got exception outside of a @test type DataType has no field mutable
+ (("\"shortestpaths\",") ""))
+ (substitute* "test/linalg/runtests.jl"
+ ;; ArgumentError: Illegal buffers for SparseMatrixCSC
+ ;; construction 5 [1, 3, 5, 7, 9, 10] [1, 2, 1, 3, 2, 4, 3, 5,
+ ;; 4] [1, 1, 1, 1, 1, 1, 1, 1, 1, 1]
+ ;;
+ ;; ArgumentError: Illegal buffers for SparseMatrixCSC
+ ;; construction 5 UInt16[0x0001, 0x0003, 0x0005, 0x0007,
+ ;; 0x0009, 0x000a] UInt16[0x0001, 0x0002, 0x0001, 0x0003,
+ ;; 0x0002, 0x0004, 0x0003, 0x0005, 0x0004] [1, 1, 1, 1, 1, 1,
+ ;; 1, 1, 1, 1]
+ ;;
+ ;; ArgumentError: Illegal buffers for SparseMatrixCSC
+ ;; construction 5 Int32[1, 3, 5, 7, 9, 10] Int32[1, 2, 1, 3,
+ ;; 2, 4, 3, 5, 4] [1, 1, 1, 1, 1, 1, 1, 1, 1, 1]
+ ((".*spectral.*") ""))
+ (substitute* "test/parallel/runtests.jl"
+ ;; Got exception outside of a @test type DataType has no field
+ ;; mutable
+ ((".*shortestpaths/johnson.*") "")
+ ;; Got exception outside of a @test TaskFailedException nested
+ ;; task error: On worker 2: UndefVarError: nv not defined
+ ((".*utils.*") "")))))))
+ (propagated-inputs
+ (list julia-arnoldimethod
+ julia-datastructures
+ julia-inflate
+ julia-simpletraits))
+ (home-page "https://github.com/sbromberger/LightGraphs.jl")
+ (synopsis "Optimized graphs package for Julia")
+ (description
+ "LightGraphs offers both (a) a set of simple, concrete graph implementations --
+Graph (for undirected graphs) and DiGraph (for directed graphs), and (b) an API
+for the development of more sophisticated graph implementations under the
+AbstractGraph type.")
+ (license license:bsd-2)))
+
(define-public julia-linesearches
(package
(name "julia-linesearches")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 08/10] gnu: Add julia-itemgraphs.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-8-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-itemgraphs): New variable.
---
gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 1d88c09647..0a8e1a81cd 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3466,6 +3466,31 @@ (define-public julia-irtools
Cassette.")
(license license:expat)))
+(define-public julia-itemgraphs
+ (package
+ (name "julia-itemgraphs")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/helgee/ItemGraphs.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16w30y7s922dzp7i64wxdrafv4gy13v3rl4k1z5jkvnmnw68kygg"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-lightgraphs))
+ (home-page "https://github.com/helgee/ItemGraphs.jl")
+ (synopsis "Shortest paths between items")
+ (description
+ "ItemGraphs is a simple wrapper around LightGraphs that enables most
+common use case for graph-like data structures: with collection of items that
+are in relations between each other providing the shortest path between two
+items.")
+ (license license:expat)))
+
(define-public julia-iteratorinterfaceextensions
(package
(name "julia-iteratorinterfaceextensions")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 09/10] gnu: Add julia-muladdmacro.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-9-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-muladdmacro): New variable.
---
gnu/packages/julia-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0a8e1a81cd..a07326df6f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4223,6 +4223,33 @@ (define-public julia-msgpack
Julia, with type-driven, overloadable packing/unpacking functionality.")
(license license:expat)))
+(define-public julia-muladdmacro
+ (package
+ (name "julia-muladdmacro")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SciML/MuladdMacro.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pvmfw7f3igpwx0w8c8i40pls0wfm248b1i662wnlrkqiw56j0yq"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/SciML/MuladdMacro.jl")
+ (synopsis "Julia macro to convert expressions to use muladd calls and FMA operations")
+ (description
+ "This package provides the @code{@@muladd} macro. It automatically converts
+expressions with multiplications and additions or subtractions to calls with
+muladd which then fuse via FMA when it would increase the performance of the
+code. The @code{@@muladd} macro can be placed on code blocks and it will automatically
+find the appropriate expressions and nest muladd expressions when necessary. In
+mixed expressions summands without multiplication will be grouped together and
+evaluated first but otherwise the order of evaluation of multiplications and
+additions is not changed.")
+ (license license:expat)))
+
(define-public julia-mutablearithmetics
(package
(name "julia-mutablearithmetics")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 10/10] gnu: Add julia-astrotime.
(address . 61611@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230219000453.20559-10-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-astrotime): New variable.
---
gnu/packages/julia-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a07326df6f..a1561f575e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -262,6 +262,36 @@ (define-public julia-arraylayouts
much wider class of matrix types than Julia's in-built @code{StridedArray}.")
(license license:expat)))
+(define-public julia-astrotime
+ (package
+ (name "julia-astrotime")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/AstroTime.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "032hlanan49ypqh4lwlf91pg7052c8h5sgbxqc1771b8j9srbyd2"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-measurements))
+ (propagated-inputs
+ (list julia-erfa
+ julia-earthorientation
+ julia-itemgraphs
+ julia-macrotools
+ julia-muladdmacro
+ julia-reexport))
+ (home-page "https://github.com/JuliaAstro/AstroTime.jl")
+ (synopsis "Astronomical time keeping in Julia")
+ (description "@code{AstroTime.jl} provides a high-precision, time-scale
+aware, @code{DateTime}-like data type which supports all commonly used
+astronomical time scales.")
+ (license license:expat)))
+
(define-public julia-automa
(package
(name "julia-automa")
--
2.39.1
Ludovic Courtès wrote 2 years ago
Re: bug#61611: [PATCH 00/10]: gnu: Add julia-astrotime
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 61611-done@debbugs.gnu.org)
871qm6x909.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (11 lines)
> gnu: Add julia-leapseconds.
> gnu: Add julia-optionaldata.
> gnu: Add julia-remotefiles.
> gnu: Add julia-earthorientation.
> gnu: Add julia-inflate.
> gnu: Add julia-arnoldimethod.
> gnu: Add julia-lightgraphs.
> gnu: Add julia-itemgraphs.
> gnu: Add julia-muladdmacro.
> gnu: Add julia-astrotime.

Applied, thanks!

Ludo’.
Closed
Simon Tournier wrote 2 years ago
Re: [bug#61611] [PATCH 03/10] gnu: Add julia-remotefiles.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
86h6uvb0vm.fsf@gmail.com
Hi,

Sorry for being late. I have seen that Ludo pushed the series. Cool!


On Sun, 19 Feb 2023 at 00:04, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:

Toggle quote (2 lines)
> + '(#:tests? #f)) ; Tests try to download from Internet.

Question: Is it possible to disallow the tests that require Internet or
is it the whole test suite?

Cheers,
simon
Sharlatan Hellseher wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 61611@debbugs.gnu.org)
CAO+9K5ppZaRO7usP4V+zewnHR-hnWUZwY2KUQPGOeiC9=PvtuQ@mail.gmail.com
Hi Simon,

I'll check it in the next packaging round, but base on the package name and
description it could be the whole test suit is to download remote data :-)

Regards,
Oleg

On Wed, 8 Mar 2023, 17:51 Simon Tournier, <zimon.toutoune@gmail.com> wrote:

Toggle quote (16 lines)
> Hi,
>
> Sorry for being late. I have seen that Ludo pushed the series. Cool!
>
>
> On Sun, 19 Feb 2023 at 00:04, Sharlatan Hellseher <sharlatanus@gmail.com>
> wrote:
>
> > + '(#:tests? #f)) ; Tests try to download from Internet.
>
> Question: Is it possible to disallow the tests that require Internet or
> is it the whole test suite?
>
> Cheers,
> simon
>
Attachment: file
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61611@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61611
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help