[PATCH] platforms: allow cross-target mipsel-linux-gnu

  • Open
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • ??
  • Mathieu Othacehe
Owner
unassigned
Submitted by
??
Severity
normal
?
(name . guix-patches)(address . guix-patches@gnu.org)
CAGNyvehhXd3Qr5iPqyT_bkxpkrAi6HUTJT0Hy_kuwqruNATr+w@mail.gmail.com
From 9a111fd886b89914bd6bafe8202b8a9a1dce7017 Mon Sep 17 00:00:00 2001
From: LuHui <luhux76@gmail.com>
Date: Sat, 18 Feb 2023 20:35:37 +0800
Subject: [PATCH] platforms: allow cross-target mipsel-linux-gnu

* guix/platforms/mips.scm (mips-linux) : new variable.
* guix/utils.scm (target-mipsel?) : new function.
---
guix/platforms/mips.scm | 10 +++++++++-
guix/utils.scm | 5 +++++
2 files changed, 14 insertions(+), 1 deletion(-)

Toggle diff (57 lines)
diff --git a/guix/platforms/mips.scm b/guix/platforms/mips.scm
index e6fa9eb292..c37c8bb292 100644
--- a/guix/platforms/mips.scm
+++ b/guix/platforms/mips.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
+;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,7 +20,7 @@
(define-module (guix platforms mips)
#:use-module (guix platform)
#:use-module (guix records)
- #:export (mips64-linux))
+ #:export (mips64-linux mips-linux))

(define mips64-linux
(platform
@@ -27,3 +28,10 @@ (define mips64-linux
(system "mips64el-linux")
(linux-architecture "mips")
(glibc-dynamic-linker "/lib/ld.so.1")))
+
+(define mips-linux
+ (platform
+ (target "mipsel-linux-gnu")
+ (system "mipsel-linux")
+ (linux-architecture "mips")
+ (glibc-dynamic-linker "/lib/ld.so.1")))
diff --git a/guix/utils.scm b/guix/utils.scm
index 774b80cd25..55af3562eb 100644
--- a/guix/utils.scm
+++ b/guix/utils.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -741,6 +742,10 @@ (define* (target-mips64el? #:optional (target (or
(%current-target-system)
(%current-system))))
(string-prefix? "mips64el-" target))

+(define* (target-mipsel? #:optional (target (or (%current-target-system)
+ (%current-system))))
+ (string-prefix? "mipsel-" target))
+
(define* (target-64bit? #:optional (system (or (%current-target-system)
(%current-system))))
(any (cut string-prefix? <> system) '("x86_64" "aarch64" "mips64"
--
2.39.1
A
A
Andreas Enge wrote on 10 May 2023 15:45
Gnutls
(address . 61604@debbugs.gnu.org)
ZFugFn0wCKR0kwaY@jurong
In the core-updates merge, gnutls-latest has been dropped.
So "guix refresh -l gnutls" works, but it shows an amazing number of
packages:
Building the following 7653 packages would ensure 15845 dependent packages are rebuilt

So this should go to some branch, maybe a "core-team" branch?

Andreas
M
M
Mathieu Othacehe wrote on 26 Oct 2023 14:48
Re: [bug#61604] [PATCH] platforms: allow cross-target mipsel-linux-gnu
(name . ??)(address . luhux76@gmail.com)(address . 61604@debbugs.gnu.org)
87pm11k0rv.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> + (system "mipsel-linux")

That system is unsupported in (gnu packages bootstrap). You can either
set system to #false so that only cross-compilation is supported, or
provided bootstrap packages for that system :).

Thanks,

Mathieu
?