[PATCH] gnu: ableton-link: Update to 3.0.6.

  • Open
  • quality assurance status badge
Details
2 participants
  • Antero Mejr
  • Christopher Baines
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 18 Feb 2023 05:47
(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20230218044700.7559-1-antero@mailbox.org
* gnu/packages/audio.scm (ableton-link): Update to 3.0.6.
* gnu/packages/patches/ableton-link-system-libraries-debian.patch: Update to
match version 3.0.6.
---
Includes the new C bindings that are required for norns, which I am packaging.

gnu/packages/audio.scm | 10 +++++++---
.../patches/ableton-link-system-libraries-debian.patch | 2 +-
2 files changed, 8 insertions(+), 4 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6504ec2345..ba90152981 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5706,7 +5706,7 @@ (define-public mbelib
(define-public ableton-link
(package
(name "ableton-link")
- (version "3.0.3")
+ (version "3.0.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5715,7 +5715,7 @@ (define-public ableton-link
(file-name (git-file-name name version))
(sha256
(base32
- "1wplqj11ww64gmw2kzlxpvfs3v04m2036f7k5ndm34zcv12b91fa"))
+ "140nxqgl50jjwilm9c2r15lyg6k0k38phlcz8kw2i8hpza924wjg"))
(modules '((guix build utils)))
(patches
(search-patches "ableton-link-system-libraries-debian.patch"))
@@ -5786,7 +5786,11 @@ (define-public ableton-link
lib-cmake)
(install-file (string-append source
"/cmake_include/AsioStandaloneConfig.cmake")
- (string-append lib-cmake "/cmake_include"))))))))
+ (string-append lib-cmake "/cmake_include"))
+ (install-file
+ (string-append source "/extensions/abl_link/include/abl_link.h")
+ (string-append out "/include/extensions/abl_link"))
+ (install-file "libabl_link.a" (string-append out "/lib"))))))))
(home-page "https://github.com/Ableton/link")
(synopsis "Synchronize musical beat, tempo, and phase across multiple applications")
(description
diff --git a/gnu/packages/patches/ableton-link-system-libraries-debian.patch b/gnu/packages/patches/ableton-link-system-libraries-debian.patch
index 184896ee61..5717e77f0e 100644
--- a/gnu/packages/patches/ableton-link-system-libraries-debian.patch
+++ b/gnu/packages/patches/ableton-link-system-libraries-debian.patch
@@ -25,5 +25,5 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-set_property(TARGET Catch::Catch APPEND PROPERTY
- INTERFACE_INCLUDE_DIRECTORIES
-- ${CMAKE_SOURCE_DIR}/third_party/catch
+- ${CMAKE_CURRENT_LIST_DIR}/../third_party/catch
-)
--
2.38.1
C
C
Christopher Baines wrote on 2 Mar 2023 10:46
(name . Antero Mejr)(address . antero@mailbox.org)
87jzzzv61v.fsf@cbaines.net
Antero Mejr via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (10 lines)
> * gnu/packages/audio.scm (ableton-link): Update to 3.0.6.
> * gnu/packages/patches/ableton-link-system-libraries-debian.patch: Update to
> match version 3.0.6.
> ---
> Includes the new C bindings that are required for norns, which I am packaging.
>
> gnu/packages/audio.scm | 10 +++++++---
> .../patches/ableton-link-system-libraries-debian.patch | 2 +-
> 2 files changed, 8 insertions(+), 4 deletions(-)

Hi Antero,

This looks to break ableton-link on aarch64-linux:

This is the log:

starting phase `check'
['/tmp/guix-build-ableton-link-3.0.6.drv-0/source/ci/../../build/bin/LinkCoreTest']
Running Tests for LinkCoreTest

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
LinkCoreTest is a Catch v1.3.5 host application.
Run with -? for options

-------------------------------------------------------------------------------
LinearRegression
TwoPoints Float
-------------------------------------------------------------------------------
/tmp/guix-build-ableton-link-3.0.6.drv-0/source/src/ableton/link/tst_LinearRegression.cpp:30
...............................................................................

/tmp/guix-build-ableton-link-3.0.6.drv-0/source/src/ableton/link/tst_LinearRegression.cpp:80: FAILED:
CHECK( 0.f == Approx(result.second) )
with expansion:
0.0f == Approx( -0.0011631348 )

===============================================================================
test cases: 14 | 13 passed | 1 failed
assertions: 524519 | 524518 passed | 1 failed

error: in phase 'check': uncaught exception:
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQAcJxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcSWg/+MbcyYNbrdoyh7tpTSs4T7JQmmw+mbzzy
FR2upbucqy3wIM/klgNNXGuaSdM5FxLyhKaEQKnXDxEHNKlSt4CQVs+zX8v5kJ2O
t0LeVfWWyeYnztwVtCHiaCfht4TAK4u9gUZ5Qtqbj/tPiVmnoghNFXM+9WTj9Dxh
svPMzaUokB1waU0FegGAZ3kFDrwZn4LOvHwm6j9NcI0B59TNVD0lnepzK7vjr/Aa
MLzefxXUyul+7JtgW8s0Iaoy+bb1Vwy+ni59VmbrQnYQTlXB96ozQqnDUGu1B0Ra
GWUHgptBLK1F3855nHhDAsKckoa+9AW5j1fVNm8MsIgOFROG1bhH3/5waiml9bay
nOWb3K37kkbsPowSI8/SYP0IU+d6Zw6mzOFiNZxsF+EnO59ubuMIo8ZnGrdIBmN6
ajIY/nNxw8bWqlv4Kk8bzg3tvHXswNCSCOhmmQ4XCmcQW+GjocSNZ/SFoGjQ/eRV
l0NrNxkn+e4O5hz0hdMR/BsB2f0mjQTn/O0yQUo3YRYmAJ2I6ysQrZ+l0q4zEme8
DLGhprvGEf6cB5lbodqj4nzztfNi09Nwp4rCYarnR/y1tp0q2iPY9rSU19T9odoi
ms+043N6tCRixGIuDP8PxcD0OgNuBiydBe06qptNMI/JnmxWfap01jcqxB07qd2J
18bvTiFeQ9w=
=pBcI
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 61593@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61593
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch