(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
* gnu/packages/audio.scm (ableton-link): Update to 3.0.6.
* gnu/packages/patches/ableton-link-system-libraries-debian.patch: Update to
match version 3.0.6.
---
Includes the new C bindings that are required for norns, which I am packaging.
gnu/packages/audio.scm | 10 +++++++---
.../patches/ableton-link-system-libraries-debian.patch | 2 +-
2 files changed, 8 insertions(+), 4 deletions(-)
Toggle diff (48 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6504ec2345..ba90152981 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5706,7 +5706,7 @@ (define-public mbelib
(define-public ableton-link
(package
(name "ableton-link")
- (version "3.0.3")
+ (version "3.0.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5715,7 +5715,7 @@ (define-public ableton-link
(file-name (git-file-name name version))
(sha256
(base32
- "1wplqj11ww64gmw2kzlxpvfs3v04m2036f7k5ndm34zcv12b91fa"))
+ "140nxqgl50jjwilm9c2r15lyg6k0k38phlcz8kw2i8hpza924wjg"))
(modules '((guix build utils)))
(patches
(search-patches "ableton-link-system-libraries-debian.patch"))
@@ -5786,7 +5786,11 @@ (define-public ableton-link
lib-cmake)
(install-file (string-append source
"/cmake_include/AsioStandaloneConfig.cmake")
- (string-append lib-cmake "/cmake_include"))))))))
+ (string-append lib-cmake "/cmake_include"))
+ (install-file
+ (string-append source "/extensions/abl_link/include/abl_link.h")
+ (string-append out "/include/extensions/abl_link"))
+ (install-file "libabl_link.a" (string-append out "/lib"))))))))
(home-page "https://github.com/Ableton/link")
(synopsis "Synchronize musical beat, tempo, and phase across multiple applications")
(description
diff --git a/gnu/packages/patches/ableton-link-system-libraries-debian.patch b/gnu/packages/patches/ableton-link-system-libraries-debian.patch
index 184896ee61..5717e77f0e 100644
--- a/gnu/packages/patches/ableton-link-system-libraries-debian.patch
+++ b/gnu/packages/patches/ableton-link-system-libraries-debian.patch
@@ -25,5 +25,5 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-set_property(TARGET Catch::Catch APPEND PROPERTY
- INTERFACE_INCLUDE_DIRECTORIES
-- ${CMAKE_SOURCE_DIR}/third_party/catch
+- ${CMAKE_CURRENT_LIST_DIR}/../third_party/catch
-)
--
2.38.1