[PATCH] gnu: meld: Update to 3.22.0

  • Done
  • quality assurance status badge
Details
4 participants
  • Andy Tai
  • Andy Tai
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230218021218.10783-1-atai@atai.org
* gnu/packages/patchutils.scm (meld): Update to 3.22.0
---
gnu/packages/patchutils.scm | 87 +++++++++++++++++--------------------
1 file changed, 39 insertions(+), 48 deletions(-)

Toggle diff (152 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index dd5e6bae9a..b5347d6a22 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,8 @@ (define-module (gnu packages patchutils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages ed)
@@ -37,6 +40,7 @@ (define-module (gnu packages patchutils)
#:use-module (gnu packages check)
#:use-module (gnu packages databases)
#:use-module (gnu packages django)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages file)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -47,8 +51,11 @@ (define-module (gnu packages patchutils)
#:use-module (gnu packages less)
#:use-module (gnu packages mail)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xml))
@@ -214,7 +221,7 @@ (define-public vbindiff
(define-public meld
(package
(name "meld")
- (version "3.20.4")
+ (version "3.22.0")
(source
(origin
(method url-fetch)
@@ -222,66 +229,50 @@ (define-public meld
(version-major+minor version)
"/meld-" version ".tar.xz"))
(sha256
- (base32 "04vx2mdbcdin0g3w8x910czfch5vyrl8drv1f2l8gxh6qvp113pl"))))
- (build-system python-build-system)
+ (base32 "03f4j27amyi28flkks8i9bhqzd6xhm6d3c6jzxc57rzniv4hgh9z"))))
+ (build-system meson-build-system)
(native-inputs
- `(("intltool" ,intltool)
- ("xmllint" ,libxml2)
- ("glib-compile-schemas" ,glib "bin")
- ("python-pytest" ,python-pytest)))
+ (list desktop-file-utils
+ intltool
+ itstool
+ libxml2
+ `(,glib "bin")
+ `(,gtk+ "bin") ; for gtk-update-icon-cache
+ gobject-introspection
+ pkg-config
+ python))
(inputs
- `(("python-cairo" ,python-pycairo)
- ("python-gobject" ,python-pygobject)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtksourceview" ,gtksourceview-3)))
+ (list bash-minimal
+ python
+ python-pycairo
+ python-pygobject
+ gsettings-desktop-schemas
+ gtksourceview-4))
(propagated-inputs
(list dconf))
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
- ,@%python-build-system-modules)
- #:modules ((guix build python-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (list
+ #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
(guix build utils))
#:phases
- (modify-phases %standard-phases
- ;; This setup.py script does not support one of the Python build
- ;; system's default flags, "--single-version-externally-managed".
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "python" "setup.py"
- ;; This setup.py runs gtk-update-icon-cache which we don't want.
- "--no-update-icon-cache"
- ;; "--no-compile-schemas"
- "install"
- (string-append "--prefix=" (assoc-ref outputs "out"))
- "--root=/")))
- ;; The tests need to be run after installation.
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Tests look for installed package
- (add-installed-pythonpath inputs outputs)
- ;; The tests fail when HOME=/homeless-shelter.
- (setenv "HOME" "/tmp")
- (invoke "py.test" "-v" "-k"
- ;; TODO: Those tests fail, why?
- "not test_classify_change_actions")))
+ #~(modify-phases %standard-phases
(add-after 'install 'copy-styles
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((styles "/share/gtksourceview-3.0/styles"))
+ (let ((styles "/share/gtksourceview-4/styles"))
(copy-recursively
(string-append (assoc-ref inputs "gtksourceview") styles)
(string-append (assoc-ref outputs "out") styles))
#t)))
- (add-after 'wrap 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
- (add-after 'wrap 'wrap-typelib
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/meld")
- `("GI_TYPELIB_PATH" prefix
- ,(search-path-as-string->list (getenv "GI_TYPELIB_PATH"))))
- #t))))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/meld")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
(home-page "https://meldmerge.org/")
(synopsis "Compare files, directories and working copies")
(description "Meld is a visual diff and merge tool targeted at

base-commit: c1303a914c172dc80166be22389e7032c5ea5e09
--
2.39.1
Liliana Marie Prikler wrote 2 years ago
392b7a650f6b1730dda4a7b3c7b33558a6189e91.camel@gmail.com
Am Freitag, dem 17.02.2023 um 18:12 -0800 schrieb Andy Tai:
Toggle quote (81 lines)
> * gnu/packages/patchutils.scm (meld): Update to 3.22.0
> ---
>  gnu/packages/patchutils.scm | 87 +++++++++++++++++------------------
> --
>  1 file changed, 39 insertions(+), 48 deletions(-)
>
> diff --git a/gnu/packages/patchutils.scm
> b/gnu/packages/patchutils.scm
> index dd5e6bae9a..b5347d6a22 100644
> --- a/gnu/packages/patchutils.scm
> +++ b/gnu/packages/patchutils.scm
> @@ -5,6 +5,7 @@
>  ;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
>  ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
>  ;;; Copyright © 2022 jgart <jgart@dismail.de>
> +;;; Copyright © 2023 Andy Tai <atai@atai.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -29,6 +30,8 @@ (define-module (gnu packages patchutils)
>    #:use-module (guix download)
>    #:use-module (guix git-download)
>    #:use-module (guix build-system gnu)
> +  #:use-module (guix build-system glib-or-gtk)
> +  #:use-module (guix build-system meson)
>    #:use-module (guix build-system python)
>    #:use-module (gnu packages)
>    #:use-module (gnu packages ed)
> @@ -37,6 +40,7 @@ (define-module (gnu packages patchutils)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages databases)
>    #:use-module (gnu packages django)
> +  #:use-module (gnu packages freedesktop)
>    #:use-module (gnu packages file)
>    #:use-module (gnu packages gawk)
>    #:use-module (gnu packages gettext)
> @@ -47,8 +51,11 @@ (define-module (gnu packages patchutils)
>    #:use-module (gnu packages less)
>    #:use-module (gnu packages mail)
>    #:use-module (gnu packages ncurses)
> +  #:use-module (gnu packages package-management)
>    #:use-module (gnu packages perl)
> +  #:use-module (gnu packages pkg-config)
>    #:use-module (gnu packages python)
> +  #:use-module (gnu packages python-build)
>    #:use-module (gnu packages python-xyz)
>    #:use-module (gnu packages version-control)
>    #:use-module (gnu packages xml))
> @@ -214,7 +221,7 @@ (define-public vbindiff
>  (define-public meld
>    (package
>      (name "meld")
> -    (version "3.20.4")
> +    (version "3.22.0")
>      (source
>       (origin
>         (method url-fetch)
> @@ -222,66 +229,50 @@ (define-public meld
>                             (version-major+minor version)
>                             "/meld-" version ".tar.xz"))
>         (sha256
> -        (base32
> "04vx2mdbcdin0g3w8x910czfch5vyrl8drv1f2l8gxh6qvp113pl"))))
> -    (build-system python-build-system)
> +        (base32
> "03f4j27amyi28flkks8i9bhqzd6xhm6d3c6jzxc57rzniv4hgh9z"))))
> +    (build-system meson-build-system)
>      (native-inputs
> -     `(("intltool" ,intltool)
> -       ("xmllint" ,libxml2)
> -       ("glib-compile-schemas" ,glib "bin")
> -       ("python-pytest" ,python-pytest)))
> +     (list desktop-file-utils
> +       intltool
> +       itstool
> +       libxml2
> +       `(,glib "bin")
> +       `(,gtk+ "bin")                   ; for gtk-update-icon-cache
> +       gobject-introspection
> +       pkg-config
> +       python)
Even if it's a chore, please separate style changes and actual changes
into two commits.

Cheers
Andy Tai wrote 2 years ago
[PATCH v2 1/2] gnu: meld: Update to 3.22.0
(name . Andy Tai)(address . atai@atai.org)
20230223063702.5591-1-atai@atai.org
* gnu/packages/patchutils.scm (meld): Update to 3.22.0
---
gnu/packages/patchutils.scm | 79 ++++++++++++++++---------------------
1 file changed, 35 insertions(+), 44 deletions(-)

Toggle diff (148 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index dd5e6bae9a..d093391ce5 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,8 @@ (define-module (gnu packages patchutils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages ed)
@@ -37,6 +40,7 @@ (define-module (gnu packages patchutils)
#:use-module (gnu packages check)
#:use-module (gnu packages databases)
#:use-module (gnu packages django)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages file)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -47,8 +51,11 @@ (define-module (gnu packages patchutils)
#:use-module (gnu packages less)
#:use-module (gnu packages mail)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xml))
@@ -214,7 +221,7 @@ (define-public vbindiff
(define-public meld
(package
(name "meld")
- (version "3.20.4")
+ (version "3.22.0")
(source
(origin
(method url-fetch)
@@ -222,66 +229,50 @@ (define-public meld
(version-major+minor version)
"/meld-" version ".tar.xz"))
(sha256
- (base32 "04vx2mdbcdin0g3w8x910czfch5vyrl8drv1f2l8gxh6qvp113pl"))))
- (build-system python-build-system)
+ (base32 "03f4j27amyi28flkks8i9bhqzd6xhm6d3c6jzxc57rzniv4hgh9z"))))
+ (build-system meson-build-system)
(native-inputs
- `(("intltool" ,intltool)
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
("xmllint" ,libxml2)
("glib-compile-schemas" ,glib "bin")
- ("python-pytest" ,python-pytest)))
+ ("gtk-update-icon-cache" ,gtk+ "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
(inputs
- `(("python-cairo" ,python-pycairo)
+ `(("bash-minimal" ,bash-minimal)
+ ("python" ,python)
+ ("python-cairo" ,python-pycairo)
("python-gobject" ,python-pygobject)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtksourceview" ,gtksourceview-3)))
+ ("gtksourceview" ,gtksourceview-4)))
(propagated-inputs
(list dconf))
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
- ,@%python-build-system-modules)
- #:modules ((guix build python-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (list
+ #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
(guix build utils))
#:phases
- (modify-phases %standard-phases
- ;; This setup.py script does not support one of the Python build
- ;; system's default flags, "--single-version-externally-managed".
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "python" "setup.py"
- ;; This setup.py runs gtk-update-icon-cache which we don't want.
- "--no-update-icon-cache"
- ;; "--no-compile-schemas"
- "install"
- (string-append "--prefix=" (assoc-ref outputs "out"))
- "--root=/")))
- ;; The tests need to be run after installation.
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Tests look for installed package
- (add-installed-pythonpath inputs outputs)
- ;; The tests fail when HOME=/homeless-shelter.
- (setenv "HOME" "/tmp")
- (invoke "py.test" "-v" "-k"
- ;; TODO: Those tests fail, why?
- "not test_classify_change_actions")))
+ #~(modify-phases %standard-phases
(add-after 'install 'copy-styles
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((styles "/share/gtksourceview-3.0/styles"))
+ (let ((styles "/share/gtksourceview-4/styles"))
(copy-recursively
(string-append (assoc-ref inputs "gtksourceview") styles)
(string-append (assoc-ref outputs "out") styles))
#t)))
- (add-after 'wrap 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
- (add-after 'wrap 'wrap-typelib
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/meld")
- `("GI_TYPELIB_PATH" prefix
- ,(search-path-as-string->list (getenv "GI_TYPELIB_PATH"))))
- #t))))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/meld")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
(home-page "https://meldmerge.org/")
(synopsis "Compare files, directories and working copies")
(description "Meld is a visual diff and merge tool targeted at

base-commit: 31735e0ccfbc61905eb8558c14747bfcaea9b50f
--
2.39.1
Andy Tai wrote 2 years ago
[PATCH v2 2/2] gnu: meld: Use new style inputs and gexps.
(name . Andy Tai)(address . atai@atai.org)
20230223063736.5631-1-atai@atai.org
* gnu/packages/patchutils.scm (meld): Use new style and gexps.
[inputs]: Use new style
[native-inputs]: Use new style
---
gnu/packages/patchutils.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index d093391ce5..04761d5ef7 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -232,22 +232,22 @@ (define-public meld
(base32 "03f4j27amyi28flkks8i9bhqzd6xhm6d3c6jzxc57rzniv4hgh9z"))))
(build-system meson-build-system)
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("xmllint" ,libxml2)
- ("glib-compile-schemas" ,glib "bin")
- ("gtk-update-icon-cache" ,gtk+ "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list desktop-file-utils
+ intltool
+ itstool
+ libxml2
+ `(,glib "bin") ; for glib-compile-schemas
+ `(,gtk+ "bin") ; for gtk-update-icon-cache
+ gobject-introspection
+ pkg-config
+ python))
(inputs
- `(("bash-minimal" ,bash-minimal)
- ("python" ,python)
- ("python-cairo" ,python-pycairo)
- ("python-gobject" ,python-pygobject)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtksourceview" ,gtksourceview-4)))
+ (list bash-minimal
+ python
+ python-pycairo
+ python-pygobject
+ gsettings-desktop-schemas
+ gtksourceview-4))
(propagated-inputs
(list dconf))
(arguments
--
2.39.1
Andy Tai wrote 2 years ago
[PATCH v3 2/2] gnu: meld: Use new package style.
(address . 61592@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
11e9f8f61b36762d05655ea2aafd6542cbb1bdd4.camel@atai.org
* gnu/packages/patchutils.scm (meld)[arguments]: Convert to list of
G-Expressions.
<#:phases>: Drop trailing #t.
[inputs, native-inputs]: Drop labels.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
gnu/packages/patchutils.scm | 74 ++++++++++++++++++-------------------
1 file changed, 37 insertions(+), 37 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index fd1ba83b3c..05a9a62dbf 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -232,50 +232,50 @@ (define-public meld
(base32 "03f4j27amyi28flkks8i9bhqzd6xhm6d3c6jzxc57rzniv4hgh9z"))))
(build-system meson-build-system)
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("xmllint" ,libxml2)
- ("glib-compile-schemas" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list desktop-file-utils
+ intltool
+ itstool
+ libxml2
+ `(,glib "bin") ; for glib-compile-schemas
+ gobject-introspection
+ pkg-config
+ python))
(inputs
- `(("bash-minimal" ,bash-minimal)
- ("python" ,python)
- ("python-cairo" ,python-pycairo)
- ("python-gobject" ,python-pygobject)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtksourceview" ,gtksourceview-4)))
+ (list bash-minimal
+ python
+ python-pycairo
+ python-pygobject
+ gsettings-desktop-schemas
+ gtksourceview-4))
(propagated-inputs
(list dconf))
(arguments
- `(#:glib-or-gtk? #t
- #:imported-modules (,@%meson-build-system-modules
+ (list
+ #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
(guix build python-build-system))
- #:modules ((guix build meson-build-system)
+ #:modules '((guix build meson-build-system)
((guix build python-build-system) #:prefix python:)
(guix build utils))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
- (add-after 'install 'copy-styles
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((styles "/share/gtksourceview-4/styles"))
- (copy-recursively
- (string-append (assoc-ref inputs "gtksourceview") styles)
- (string-append (assoc-ref outputs "out") styles))
- #t)))
- (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (wrap-program (search-input-file outputs "bin/meld")
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
- ,(python:site-packages inputs outputs)))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))))
+ (add-after 'install 'copy-styles
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((styles "/share/gtksourceview-4/styles"))
+ (copy-recursively
+ (string-append (assoc-ref inputs "gtksourceview") styles)
+ (string-append (assoc-ref outputs "out") styles)))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/meld")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
(home-page "https://meldmerge.org/")
(synopsis "Compare files, directories and working copies")
(description "Meld is a visual diff and merge tool targeted at
--
2.39.1
Andy Tai wrote 2 years ago
[PATCH v3 1/2] gnu: meld: Update to 3.22.0
(address . 61592@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
ddc1681ee19786f839af3558f33e239c08d68cd4.camel@atai.org
* gnu/packages/patchutils.scm (meld): Update to 3.22.0
[build-system]: Switch to meson-build-system.
[native-inputs]: Add desktop-file-utils, itstool, gobject-introspection,
pkg-config, and python.
[inputs]: Add bash-minimal, python, and python-pycairo.
Replace gtksourceview-3 with gtksourceview-4.
[arguments]: Add #:glib-or-gtk?, #:imported-modules, and #:modules.
<#:phases>: Remove custom ‘install’ and ‘check’.
Add ‘skip-gtk-update-icon-cache’.
Adjust ‘copy-styles’ to gtksourceview-4.
Replace ‘wrap-typelib’ with ‘python-and-gi-wrap’.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
Hi Andy,

this patch and the following one are the split I intended.
I also fixed up some other issues like the unnecessary gtk+:bin input.
Following standard procedure, I intend to leave this up for a little
over a week to get some proper review by others.

Cheers,
Liliana

gnu/packages/patchutils.scm | 78 +++++++++++++++++--------------------
1 file changed, 36 insertions(+), 42 deletions(-)

Toggle diff (147 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index dd5e6bae9a..fd1ba83b3c 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,8 @@ (define-module (gnu packages patchutils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages ed)
@@ -37,6 +40,7 @@ (define-module (gnu packages patchutils)
#:use-module (gnu packages check)
#:use-module (gnu packages databases)
#:use-module (gnu packages django)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages file)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -47,8 +51,11 @@ (define-module (gnu packages patchutils)
#:use-module (gnu packages less)
#:use-module (gnu packages mail)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xml))
@@ -214,7 +221,7 @@ (define-public vbindiff
(define-public meld
(package
(name "meld")
- (version "3.20.4")
+ (version "3.22.0")
(source
(origin
(method url-fetch)
@@ -222,66 +229,53 @@ (define-public meld
(version-major+minor version)
"/meld-" version ".tar.xz"))
(sha256
- (base32 "04vx2mdbcdin0g3w8x910czfch5vyrl8drv1f2l8gxh6qvp113pl"))))
- (build-system python-build-system)
+ (base32 "03f4j27amyi28flkks8i9bhqzd6xhm6d3c6jzxc57rzniv4hgh9z"))))
+ (build-system meson-build-system)
(native-inputs
- `(("intltool" ,intltool)
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
("xmllint" ,libxml2)
("glib-compile-schemas" ,glib "bin")
- ("python-pytest" ,python-pytest)))
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
(inputs
- `(("python-cairo" ,python-pycairo)
+ `(("bash-minimal" ,bash-minimal)
+ ("python" ,python)
+ ("python-cairo" ,python-pycairo)
("python-gobject" ,python-pygobject)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtksourceview" ,gtksourceview-3)))
+ ("gtksourceview" ,gtksourceview-4)))
(propagated-inputs
(list dconf))
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
- ,@%python-build-system-modules)
- #:modules ((guix build python-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ `(#:glib-or-gtk? #t
+ #:imported-modules (,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules ((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
(guix build utils))
#:phases
(modify-phases %standard-phases
- ;; This setup.py script does not support one of the Python build
- ;; system's default flags, "--single-version-externally-managed".
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "python" "setup.py"
- ;; This setup.py runs gtk-update-icon-cache which we don't want.
- "--no-update-icon-cache"
- ;; "--no-compile-schemas"
- "install"
- (string-append "--prefix=" (assoc-ref outputs "out"))
- "--root=/")))
- ;; The tests need to be run after installation.
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Tests look for installed package
- (add-installed-pythonpath inputs outputs)
- ;; The tests fail when HOME=/homeless-shelter.
- (setenv "HOME" "/tmp")
- (invoke "py.test" "-v" "-k"
- ;; TODO: Those tests fail, why?
- "not test_classify_change_actions")))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))))
(add-after 'install 'copy-styles
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((styles "/share/gtksourceview-3.0/styles"))
+ (let ((styles "/share/gtksourceview-4/styles"))
(copy-recursively
(string-append (assoc-ref inputs "gtksourceview") styles)
(string-append (assoc-ref outputs "out") styles))
#t)))
- (add-after 'wrap 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
- (add-after 'wrap 'wrap-typelib
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/meld")
- `("GI_TYPELIB_PATH" prefix
- ,(search-path-as-string->list (getenv "GI_TYPELIB_PATH"))))
- #t))))))
+ (wrap-program (search-input-file outputs "bin/meld")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
(home-page "https://meldmerge.org/")
(synopsis "Compare files, directories and working copies")
(description "Meld is a visual diff and merge tool targeted at
--
2.39.1
Ludovic Courtès wrote 2 years ago
Re: bug#61592: [PATCH] gnu: meld: Update to 3.22.0
(name . Andy Tai)(address . liliana.prikler@gmail.com)
87356kqux8.fsf_-_@gnu.org
Hi Liliana,

Andy Tai <liliana.prikler@gmail.com> skribis:

Toggle quote (7 lines)
> Hi Andy,
>
> this patch and the following one are the split I intended.
> I also fixed up some other issues like the unnecessary gtk+:bin input.
> Following standard procedure, I intend to leave this up for a little
> over a week to get some proper review by others.

LGTM, please push!

Ludo’.
Andy Tai wrote 2 years ago
(address . control@debbugs.gnu.org)
CAJsg1E_WKTDZZptVqu6xdMhufUHvLHMWe7W+4dVg4ENT0A46+g@mail.gmail.com
close 61592

thanks

Liliana pushed in the changes
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61592@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61592
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help