[PATCH] gnu: Add r-gpg.

  • Open
  • quality assurance status badge
Details
2 participants
  • kyle
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
kyle
Severity
normal
Merged with
K
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
11b240f1df9265e8d63bcccec8daadf0935842fb.1676639326.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6cea202519..5e6f380b6d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -79,6 +79,7 @@ (define-module (gnu packages cran)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages graph)
#:use-module (gnu packages gtk)
#:use-module (gnu packages haskell-xyz)
@@ -668,6 +669,31 @@ (define-public r-googlevis
the output locally.")
(license license:gpl2+)))
+(define-public r-gpg
+ (package
+ (name "r-gpg")
+ (version "1.2.8")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "gpg" version))
+ (sha256
+ (base32
+ "1yysjv335mq6lpdc01yiv56zhs0085bdlanh74k3ahjbszh9cy27"))))
+ (properties `((upstream-name . "gpg")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-askpass r-curl gnupg))
+ (native-inputs (list pkg-config r-knitr gpgme))
+ (home-page "https://github.com/jeroen/gpg")
+ (synopsis "GNU Privacy Guard for R")
+ (description
+ "Bindings to GnuPG for working with OpenGPG (RFC4880) cryptographic methods.
+Includes utilities for public key encryption, creating and verifying digital
+signatures, and managing your local keyring. Some functionality depends on the
+version of GnuPG that is installed on the system. On Windows this package can
+be used together with GPG4Win which provides a GUI for managing keys and
+entering passphrases.")
+ (license license:expat)))
+
(define-public r-gson
(package
(name "r-gson")
--
2.37.2
T
T
Tobias Geerinckx-Rice wrote on 17 Feb 2023 14:34
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
877cwgct4x.fsf@nckx
merge 61572 61571
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 61572@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61572
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch