[PATCH] gnu: Add r-changepoint.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230216154523.20036-1-navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-changepoint): New variable.
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b4dc7822f2..857026a573 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -283,6 +283,27 @@ (define-public r-castor
reading/writing trees in Newick format.")
(license license:gpl2+)))
+(define-public r-changepoint
+ (package
+ (name "r-changepoint")
+ (version "2.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "changepoint" version))
+ (sha256
+ (base32
+ "16v4p2c9zi2w3anwf5y9snl5dy1g5aidiqz1vn2p64qhfvg6yqxc"))))
+ (properties `((upstream-name . "changepoint")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-zoo))
+ (home-page "https://github.com/rkillick/changepoint/")
+ (synopsis "Methods for changepoint detection")
+ (description
+ "Changepoint implements various mainstream and specialised changepoint methods.
+These Methods are suitable for finding single and multiple changepoints within data.
+Many popular non-parametric and frequentist methods are included as well.")
+ (license license:gpl3+)))
+
(define-public r-collections
(package
(name "r-collections")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 61551-done@debbugs.gnu.org)
87ilg1lclg.fsf@elephly.net
Thanks for the patch! Applied with minor changes (line breaks and a
license comment).

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61551@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61551
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help