Erik Giorgis wrote 2 years ago
(address . guix-patches@gnu.org)(name . Erik Giorgis)(address . git@egiorg.is)
---
Waybar built with the experimental flag has support
for additional features, such as displaying the
number of active workspaces in Hyprland.
gnu/packages/wm.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f2149b5be5..07e834df8a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1875,6 +1875,15 @@ (define-public waybar-cpu-histogram
(home-page "https://github.com/plattfot/cpu-histogram/")
(license license:expat)))
+(define-public waybar-experimental
+ (let ((base waybar))
+ (package
+ (inherit base)
+ (name "waybar-experimental")
+ (arguments
+ (list #:configure-flags #~(list "-Dexperimental=true")))
+ (synopsis "Waybar with experimental features"))))
+
(define-public wlr-randr
(package
(name "wlr-randr")
--
2.39.1