[PATCH] gnu: Add waybar-experimental

  • Done
  • quality assurance status badge
Details
2 participants
  • Erik Giorgis
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Erik Giorgis
Severity
normal

Debbugs page

Erik Giorgis wrote 2 years ago
(address . guix-patches@gnu.org)(name . Erik Giorgis)(address . git@egiorg.is)
0a18f0c37e38646cfdc1393a790e1839ccb6591b.1676499728.git.git@egiorg.is
---
Waybar built with the experimental flag has support
for additional features, such as displaying the
number of active workspaces in Hyprland.

gnu/packages/wm.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f2149b5be5..07e834df8a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1875,6 +1875,15 @@ (define-public waybar-cpu-histogram
(home-page "https://github.com/plattfot/cpu-histogram/")
(license license:expat)))
+(define-public waybar-experimental
+ (let ((base waybar))
+ (package
+ (inherit base)
+ (name "waybar-experimental")
+ (arguments
+ (list #:configure-flags #~(list "-Dexperimental=true")))
+ (synopsis "Waybar with experimental features"))))
+
(define-public wlr-randr
(package
(name "wlr-randr")
--
2.39.1
Maxim Cournoyer wrote 2 years ago
(name . Erik Giorgis)(address . git@egiorg.is)(address . 61545-done@debbugs.gnu.org)
87a604hckx.fsf@gmail.com
Hi,

Erik Giorgis <git@egiorg.is> writes:

Toggle quote (21 lines)
> ---
> Waybar built with the experimental flag has support
> for additional features, such as displaying the
> number of active workspaces in Hyprland.
>
> gnu/packages/wm.scm | 9 +++++++++
> 1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index f2149b5be5..07e834df8a 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -1875,6 +1875,15 @@ (define-public waybar-cpu-histogram
> (home-page "https://github.com/plattfot/cpu-histogram/")
> (license license:expat)))
>
> +(define-public waybar-experimental
> + (let ((base waybar))
> + (package
> + (inherit base)

A subtlety of inheritance; this should be package/inherit base, as the
same source code is shared (thus same vulnerabilities may exist and need
the same replacement treatment by grafts).

Toggle quote (9 lines)
> + (name "waybar-experimental")
> + (arguments
> + (list #:configure-flags #~(list "-Dexperimental=true")))
> + (synopsis "Waybar with experimental features"))))
> +
> (define-public wlr-randr
> (package
> (name "wlr-randr")

I've made the above change, along a correct change log message:

Toggle snippet (5 lines)
gnu: Add waybar-experimental.

* gnu/packages/wm.scm (waybar-experimental): New variable.

and installed the change.

Thank you!

--
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61545@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61545
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help