[PATCH 0/2] gnu: leptonica: Update to 1.83.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 2 years ago
(address . guix-patches@gnu.org)
cover.1676478119.git.simon@simonsouth.net
Here's a short patch series that updates Leptonica to 1.83.1, after first
updating its package definition to the modern style.

Tested on x864-64 and AArch64 and all seems well: Of Leptonica's 11 dependent
packages, only "ccextractor" fails to build and this is an existing failure on
both systems.

--
Simon South
simon@simonsouth.net


Simon South (2):
gnu: leptonica: Use new package style.
gnu: leptonica: Update to 1.83.1.

gnu/packages/image.scm | 54 ++++++++++++++++++++----------------------
1 file changed, 26 insertions(+), 28 deletions(-)


base-commit: b4d2670771b8c2b9c4aedbef0371f1d23197d209
--
2.39.1
Simon South wrote 2 years ago
[PATCH 1/2] gnu: leptonica: Use new package style.
(address . 61533@debbugs.gnu.org)
35f498e97ef460ff1da6b06bac2c01e2ba6c5ee9.1676478119.git.simon@simonsouth.net
* gnu/packages/image.scm (leptonica)[inputs]: Remove labels.
[arguments]<#:phases>: Use gexps; use "this-package-input" to locate package
input; do not explicitly return #t from phases.
---
gnu/packages/image.scm | 50 ++++++++++++++++++++----------------------
1 file changed, 24 insertions(+), 26 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 42b7ee055e..af7f2e411b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -619,33 +619,31 @@ (define-public leptonica
libtool
pkg-config))
(inputs
- `(("giflib" ,giflib)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("openjpeg" ,openjpeg)
- ("zlib" ,zlib)))
+ (list giflib
+ libjpeg-turbo
+ libpng
+ libtiff
+ libwebp
+ openjpeg
+ zlib))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-reg-wrapper
- (lambda _
- (substitute* "prog/reg_wrapper.sh"
- ((" /bin/sh ")
- (string-append " " (which "sh") " "))
- (("which gnuplot")
- "true"))
- #t))
- (add-after 'install 'provide-absolute-giflib-reference
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (giflib (assoc-ref inputs "giflib")))
- ;; Add an absolute reference to giflib to avoid propagation.
- (with-directory-excursion (string-append out "/lib")
- (substitute* '("liblept.la" "pkgconfig/lept.pc")
- (("-lgif") (string-append "-L" giflib "/lib -lgif"))))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-reg-wrapper
+ (lambda _
+ (substitute* "prog/reg_wrapper.sh"
+ ((" /bin/sh ")
+ (string-append " " (which "sh") " "))
+ (("which gnuplot")
+ "true"))))
+ (add-after 'install 'provide-absolute-giflib-reference
+ (lambda _
+ (let ((giflib #$(this-package-input "giflib")))
+ ;; Add an absolute reference to giflib to avoid propagation.
+ (with-directory-excursion (string-append #$output "/lib")
+ (substitute* '("liblept.la" "pkgconfig/lept.pc")
+ (("-lgif") (string-append "-L" giflib "/lib -lgif"))))))))))
(home-page "http://www.leptonica.com/")
(synopsis "Library and tools for image processing and analysis")
(description
--
2.39.1
Simon South wrote 2 years ago
[PATCH 2/2] gnu: leptonica: Update to 1.83.1.
(address . 61533@debbugs.gnu.org)
ade81496a8e9718b4fc1e5f4ae2512f3784aa709.1676478119.git.simon@simonsouth.net
* gnu/packages/image.scm (leptonica): Update to 1.83.1.
[arguments]<#:phases>: Update file name in "provide-absolute-giflib-reference"
phase.
---
gnu/packages/image.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index af7f2e411b..d458d8faf2 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -601,7 +601,7 @@ (define-public libtiff
(define-public leptonica
(package
(name "leptonica")
- (version "1.80.0")
+ (version "1.83.1")
(source
(origin
(method git-fetch)
@@ -610,7 +610,7 @@ (define-public leptonica
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "12ddln72z5l3icz0i9rpsfkg5xik8fcwcn8lb0cp3jigjxi8gvkg"))))
+ (base32 "1j7qf9flb48q0aymf0yx9rypy3bs6hfjcln08zmy8qn2qcjzrmvi"))))
(build-system gnu-build-system)
(native-inputs
(list gnuplot ;needed for test suite
@@ -642,7 +642,7 @@ (define-public leptonica
(let ((giflib #$(this-package-input "giflib")))
;; Add an absolute reference to giflib to avoid propagation.
(with-directory-excursion (string-append #$output "/lib")
- (substitute* '("liblept.la" "pkgconfig/lept.pc")
+ (substitute* '("libleptonica.la" "pkgconfig/lept.pc")
(("-lgif") (string-append "-L" giflib "/lib -lgif"))))))))))
(home-page "http://www.leptonica.com/")
(synopsis "Library and tools for image processing and analysis")
--
2.39.1
Ludovic Courtès wrote 2 years ago
Re: bug#61533: [PATCH 0/2] gnu: leptonica: Update to 1.83.1.
(name . Simon South)(address . simon@simonsouth.net)(address . 61533-done@debbugs.gnu.org)
87k002g2hh.fsf@gnu.org
Simon South <simon@simonsouth.net> skribis:

Toggle quote (7 lines)
> Here's a short patch series that updates Leptonica to 1.83.1, after first
> updating its package definition to the modern style.
>
> Tested on x864-64 and AArch64 and all seems well: Of Leptonica's 11 dependent
> packages, only "ccextractor" fails to build and this is an existing failure on
> both systems.

It’s not fully done yet, but qa.guix concurs:

Toggle quote (4 lines)
> Simon South (2):
> gnu: leptonica: Use new package style.
> gnu: leptonica: Update to 1.83.1.

Perfect.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61533@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61533
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help