[PATCH] gnu: distrobox: Skip substitution in man pages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20230215050156.18187-1-mike@rohleder.de
* gnu/packages/containers.scm (distrobox)[arguments]: Change refer-to-inputs
phase to not substitute in man pages.
---
gnu/packages/containers.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 3982f4f059..272b67c38d 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -176,7 +176,7 @@ (define-public distrobox
#~(modify-phases %standard-phases
(add-before 'install 'refer-to-inputs
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "." "^distrobox.*")
+ (substitute* (find-files "." "^distrobox.*[^1]$")
(("podman") (search-input-file inputs "/bin/podman"))
(("wget") (search-input-file inputs "/bin/wget"))
(("command -v") "test -x"))))

base-commit: c0e9ddfa290056f137ee21a53be6be4fbb8586ea
--
2.39.1
Nicolas Goaziou wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 61526-done@debbugs.gnu.org)
87ttzjry4j.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (3 lines)
> * gnu/packages/containers.scm (distrobox)[arguments]: Change refer-to-inputs
> phase to not substitute in man pages.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61526@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61526
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help