[PATCH] settings: Set intl.locale.requested to the empty string.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Mark H Weaver
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 13 Feb 2023 22:52
(address . bug-gnuzilla@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
20230213215232.18524-1-maxim.cournoyer@gmail.com
This causes IceCat to honor the locale used by the system.

* data/settings.js: Replace the obsolete "intl.locale.matchOS"
option with "intl.locale.requested", set to the empty string.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
---

data/settings.js | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/data/settings.js b/data/settings.js
index 0fe5956..0bb2af1 100644
--- a/data/settings.js
+++ b/data/settings.js
@@ -30,8 +30,10 @@ pref("privacy.firstparty.isolate", true);
// Extensions cannot be updated without permission
pref("extensions.update.enabled", false);
-// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
+
+// Set the default locale to that of the operating system.
+pref("intl.locale.requested", "")
+
// Allow unsigned langpacks
pref("extensions.langpacks.signatures.required", false);
// Disable default browser checking.

base-commit: b6260130b9808f550bdb35061af2d7962109a181
--
2.39.1
M
M
Maxim Cournoyer wrote on 14 Feb 2023 02:06
[PATCH v2] settings: Set intl.locale.requested to the empty string.
(address . 61495@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
20230214010646.1857-1-maxim.cournoyer@gmail.com
This causes IceCat to honor the locale used by the system.

* data/settings.js: Replace the obsolete "intl.locale.matchOS"
option with "intl.locale.requested", set to the empty string.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
---

Changes in v2:
- Add a trailing ';'

data/settings.js | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/data/settings.js b/data/settings.js
index 0fe5956..1c13b80 100644
--- a/data/settings.js
+++ b/data/settings.js
@@ -30,8 +30,10 @@ pref("privacy.firstparty.isolate", true);
// Extensions cannot be updated without permission
pref("extensions.update.enabled", false);
-// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
+
+// Set the default locale to that of the operating system.
+pref("intl.locale.requested", "");
+
// Allow unsigned langpacks
pref("extensions.langpacks.signatures.required", false);
// Disable default browser checking.

base-commit: b6260130b9808f550bdb35061af2d7962109a181
--
2.39.1
M
M
Mark H Weaver wrote on 14 Feb 2023 21:40
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 61495-done@debbugs.gnu.org)
87v8k4nfpe.fsf@netris.org
Hi Maxim,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (5 lines)
> This causes IceCat to honor the locale used by the system.
>
> * data/settings.js: Replace the obsolete "intl.locale.matchOS"
> option with "intl.locale.requested", set to the empty string.

Applied to 'master' as commit f9cb9795f7ed0e983166a28a353022a5e3ca88b3.
I'm closing this ticket now.

Thank you!
Mark
Closed
M
M
Maxim Cournoyer wrote on 15 Feb 2023 15:19
Re: bug#61495: closed (Re: bug#61495: [PATCH v2] settings: Set intl.locale.requested to the empty string.)
(address . 61495@debbugs.gnu.org)(name . Mark H Weaver)(address . mhw@netris.org)
87sff7f1u6.fsf@gmail.com
Hi,

Toggle quote (18 lines)
> From: Mark H Weaver <mhw@netris.org>
> Subject: Re: bug#61495: [PATCH v2] settings: Set intl.locale.requested to the empty string.
> To: Maxim Cournoyer <maxim.cournoyer@gmail.com>
> Cc: 61495-done@debbugs.gnu.org
> Date: Tue, 14 Feb 2023 15:40:02 -0500 (17 hours, 38 minutes, 19 seconds ago)
>
> Hi Maxim,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> This causes IceCat to honor the locale used by the system.
>>
>> * data/settings.js: Replace the obsolete "intl.locale.matchOS"
>> option with "intl.locale.requested", set to the empty string.
>
> Applied to 'master' as commit f9cb9795f7ed0e983166a28a353022a5e3ca88b3.
> I'm closing this ticket now.

Thank you!

--
Maxim
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61495@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61495
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch