(address . bug-gnuzilla@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
This causes IceCat to honor the locale used by the system.
* data/settings.js: Replace the obsolete "intl.locale.matchOS"
option with "intl.locale.requested", set to the empty string.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
---
data/settings.js | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
Toggle diff (21 lines)
diff --git a/data/settings.js b/data/settings.js
index 0fe5956..0bb2af1 100644
--- a/data/settings.js
+++ b/data/settings.js
@@ -30,8 +30,10 @@ pref("privacy.firstparty.isolate", true);
// Extensions cannot be updated without permission
pref("extensions.update.enabled", false);
-// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
+
+// Set the default locale to that of the operating system.
+pref("intl.locale.requested", "")
+
// Allow unsigned langpacks
pref("extensions.langpacks.signatures.required", false);
// Disable default browser checking.
base-commit: b6260130b9808f550bdb35061af2d7962109a181
--
2.39.1