[PATCH] In knot-service, shorten SOA refresh to maximum recommended in RFC 1912.

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Lechner
  • ???
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 13 Feb 2023 19:59
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
20230213185943.31648-1-felix.lechner@lease-up.com
The Knot DNS service in Guix uses two days, or 48 hours, for the SOA
refresh interval but that is outside the range of RFC 1912, which is
entitled "Common DNS Operational and Configuration Errors." [1]

Section 2.2 of RFC 1912 recommends a maximum of 12 hours for the SOA
refresh rate: "You can keep it short (20 mins to 2 hours) if you
aren't worried about a small increase in bandwidth used, or longer
(2-12 hours) if your Internet connection is slow or is started on
demand."

This commit sets the default refresh interval at the nearest value
recommended by the standard, which is 12 hours.

Due to the widespread adoption of NOTIFY messages between primary and
secondary DNS servers, the SOA refresh interval has arguably lost some
importance, but the Guix default should still be in line with the
standards.

Values outside the recommended range can provoke warning messages from
services commonly used to find bugs in DNS configurations, such as the
MX Toolbox Super Tool. [2]



---
gnu/services/dns.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/services/dns.scm b/gnu/services/dns.scm
index 50753b7ab6..32fb8c0664 100644
--- a/gnu/services/dns.scm
+++ b/gnu/services/dns.scm
@@ -114,7 +114,7 @@ (define-record-type* <zone-file>
(serial zone-file-serial
(default 1))
(refresh zone-file-refresh
- (default (* 2 24 3600)))
+ (default (* 12 3600)))
(retry zone-file-retry
(default (* 15 60)))
(expiry zone-file-expiry

base-commit: ee69b60426d4f87ea19e32f757f1e7415ae58879
--
2.39.1
?
(name . Felix Lechner)(address . felix.lechner@lease-up.com)(address . 61485-done@debbugs.gnu.org)
87y1oapa6j.fsf@envs.net
Felix Lechner <felix.lechner@lease-up.com> writes:

Toggle quote (5 lines)
> The Knot DNS service in Guix uses two days, or 48 hours, for the SOA
> refresh interval but that is outside the range of RFC 1912, which is
> entitled "Common DNS Operational and Configuration Errors." [1]
> [..]

Pushed, thank you!
Closed
?