[PATCH] gnu: php: Drop the failed test for riscv64.

  • Done
  • quality assurance status badge
Details
2 participants
  • Aleksandr Vityazev
  • Julien Lepiller
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal

Debbugs page

Aleksandr Vityazev wrote 2 years ago
(address . guix-patches@gnu.org)
d131280a272c713b5fe843e8599cb260e69701b9.1676192378.git.avityazev@posteo.org
* gnu/packages/php (php): Drop the failed test for riscv64.
[source, arguments, description]: Fix formatting.
---
gnu/packages/php.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index e0cd47b846..278d7e1760 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -71,7 +71,7 @@ (define-public php
(base32
"0czflx9ikxymjfgnzaifjx9kc30ww2x4063075hcifjjwqwami5x"))
(patches
- (search-patches "php-fix-streams-copy-length.patch"))
+ (search-patches "php-fix-streams-copy-length.patch"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -178,7 +178,7 @@ (define-public php
,@(if (target-arm32?)
;; Drop tests known to fail on armhf.
'((for-each delete-file
- (list
+ (list
"ext/calendar/tests/unixtojd_error1.phpt"
"ext/opcache/tests/preload_006.phpt"
"ext/opcache/tests/preload_011.phpt"
@@ -200,7 +200,7 @@ (define-public php
'())
,@(if (target-x86-32?)
- ;; Drop tests known to fail on i686.
+ ;; Drop tests known to fail on i686.
'((for-each delete-file
(list
"ext/dba/tests/dba_gdbm.phpt")))
@@ -220,6 +220,12 @@ (define-public php
"sapi/phpdbg/tests/watch_006.phpt")))
'())
+ ,@(if (target-riscv64?)
+ ;; Drop tests known to fail on riscv64.
+ '((for-each delete-file
+ (list "sapi/cli/tests/upload_2G.phpt")))
+ '())
+
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.
@@ -419,7 +425,7 @@ (define-public php
("procps" ,procps))) ; for tests
(synopsis "PHP programming language")
(description
- "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
+ "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
language designed primarily for web development but is also used as
a general-purpose programming language. PHP code may be embedded into
HTML code, or it can be used in combination with various web template
--
2.39.1



--
Best regards,
Aleksandr Vityazev
Julien Lepiller wrote 2 years ago
(name . Aleksandr Vityazev)(address . avityazev@posteo.org)(address . 61451-done@debbugs.gnu.org)
20230219101217.08f07435@sybil.lepiller.eu
Thanks for the patch! Pushed to master as
819aaca9d524d2fde3ed82c688d3731ca1797f87.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61451@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61451
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help