[PATCH 0/4] gnu: Add JuliaAstro core packages.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Sharlatan Hellseher
  • zimoun
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230211214830.13428-1-sharlatanus@gmail.com
Hi Guix!

I'm on the track with JuliaAstro mentioned in #60793 :)

This patch series includes 2x JLL and their implementation for Julia - ERFA and
WCS which are core packages to grow the tree on top of them.

x86_64 bulid passed succes:
Toggle quote (6 lines)
> ./pre-inst-env guix build julia-erfa-jll julia-wcs-jll julia-erfa julia-wcs --rounds=2
> /gnu/store/mcdha3hmirsx56y22dq2axvqbfzp4053-julia-wcs-0.6.2
> /gnu/store/2wid9f05sxm619ihykkfalc6nv7ndw5v-julia-erfa-1.1.0
> /gnu/store/q6vvqim7r1fsq0yhbjy6zdzdfkd287sx-julia-wcs-jll-7.7.0+0
> /gnu/store/pnzdlnvvs99pzn8bp9j9k13mxi8ah6qc-julia-erfa-jll-2.0.0+0

aarch64 bulid in Qemue failed:
Toggle quote (24 lines)
> ./pre-inst-env guix build julia-erfa-jll julia-wcs-jll julia-erfa julia-wcs --system=aarch64-linux
> ...
> phase `install' succeeded after 0.0 seconds
> starting phase `check'
> signal (11): Segmentation fault
> in expression starting at none:0
> Timer#663 at ./asyncevent.jl:109
> Timer at ./asyncevent.jl:94 [inlined]
> sleep at ./asyncevent.jl:240
> #44 at ./task.jl:484
> unknown function (ip: 0x555a44469f)
> jl_apply at /tmp/guix-build-julia-1.8.3.drv-0/julia-1.8.3/src/julia.h:1839 [inlined]
> start_task at /tmp/guix-build-julia-1.8.3.drv-0/julia-1.8.3/src/task.c:931
> Allocations: 2560514 (Pool: 2559192; Big: 1322); GC: 3
> qemu: uncaught target signal 11 (Segmentation fault) - core dumped
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "julia" arguments: ("--depwarn=yes" "--procs=15" "/gnu/store/i588g3iyz4h4p6nb0qiy7hks6chl787v-julia-erfa-1.1.0/share/julia/loadpath/ERFA/test/runtests.jl") exit-status: #f term-signal: 11 stop-signal: #f>
> phase `check' failed after 7.0 seconds
> command "julia" "--depwarn=yes" "--procs=15" "/gnu/store/i588g3iyz4h4p6nb0qiy7hks6chl787v-julia-erfa-1.1.0/share/julia/loadpath/ERFA/test/runtests.jl" failed with signal 11
> builder for `/gnu/store/3kg912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv' failed with exit code 1
> build of /gnu/store/3kg912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv failed
> View build log at '/var/log/guix/drvs/3k/g912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv.gz'.
> guix build: error: build of `/gnu/store/3kg912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv' failed

Sharlatan Hellseher (4):
gnu: Add julia-erfa-jll.
gnu: Add julia-wcs-jll.
gnu: Add julia-erfa.
gnu: Add julia-wcs.

gnu/packages/julia-jll.scm | 74 ++++++++++++++++++++++++++++++++++++++
gnu/packages/julia-xyz.scm | 44 +++++++++++++++++++++++
2 files changed, 118 insertions(+)


base-commit: b367f28ed2ac8212d3c8b826b9655a0b2e879f18
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/4] gnu: Add julia-erfa-jll.
(address . 61439@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230211215038.13705-1-sharlatanus@gmail.com
* gnu/packages/julia-jll.scm (julia-erfa-jll): New variable.
---
gnu/packages/julia-jll.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 1aab2f78ce..77bb3ff3d5 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -232,6 +232,42 @@ (define-public julia-compilersupportlibraries-jll
build tree Yggdrasil.")
(license license:expat)))
+(define-public julia-erfa-jll
+ (package
+ (name "julia-erfa-jll")
+ (version "2.0.0+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/ERFA_jll.jl")
+ (commit (string-append "ERFA-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0knlck3vqr19g9z8zgjr7lj0qf1lisji5s2lm00y3ymv9bkj59sl"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ;no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'link-depot 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"ERFA\", \""
+ (assoc-ref inputs "erfa") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs (list erfa))
+ (propagated-inputs (list julia-jllwrappers))
+ (home-page "https://github.com/JuliaBinaryWrappers/ERFA_jll.jl")
+ (synopsis "ERFA library wrappers")
+ (description "This package provides a wrapper for the erfa library.")
+ (license license:expat)))
+
(define-public julia-expat-jll
(package
(name "julia-expat-jll")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 3/4] gnu: Add julia-erfa.
(address . 61439@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230211215038.13705-3-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-erfa): New variable.
---
gnu/packages/julia-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b6da796b59..8f2b29193a 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1852,6 +1852,27 @@ (define-public julia-ellipsisnotation
before (or after)\".")
(license license:expat)))
+(define-public julia-erfa
+ (package
+ (name "julia-erfa")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/ERFA.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1f63kyqpsx9n4dh54hzy1bvm3fpl4vf8wi1279vfiza3vhh2ggx5"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-erfa-jll julia-staticarrays))
+ (home-page "https://github.com/JuliaAstro/ERFA.jl")
+ (synopsis "Julia wrapper for liberfa")
+ (description "This package provides a Julia wrapper for astronomical library ERFA.")
+ (license license:expat)))
+
(define-public julia-example
(let ((commit "f968c69dea24f851d0c7e686db23fa55826b5388"))
(package
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/4] gnu: Add julia-wcs-jll.
(address . 61439@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230211215038.13705-2-sharlatanus@gmail.com
* gnu/packages/julia-jll.scm (julia-wcs-jll): New variable.
---
gnu/packages/julia-jll.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 77bb3ff3d5..2320b03595 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1763,6 +1763,44 @@ (define-public julia-wayland-protocols-jll
(description "This package provides a wrapper for the wayland-protocols library.")
(license license:expat)))
+(define-public julia-wcs-jll
+ (package
+ (name "julia-wcs-jll")
+ (version "7.7.0+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/WCS_jll.jl")
+ (commit (string-append "WCS-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16i9899jwcp5i9mh88rn4b83v3i5v8g1jygixrr0grjnvf5qfvpk"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'link-depot 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"WCS\", \""
+ (assoc-ref inputs "wcslib") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ (list wcslib))
+ (propagated-inputs
+ (list julia-jllwrappers))
+ (home-page "https://github.com/JuliaBinaryWrappers/WCS_jll.jl")
+ (synopsis "WCS library wrappers")
+ (description "This package provides a wrapper for the wcs library.")
+ (license license:expat)))
+
(define-public julia-x264-jll
(package
(name "julia-x264-jll")
--
2.39.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 4/4] gnu: Add julia-wcs.
(address . 61439@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230211215038.13705-4-sharlatanus@gmail.com
* gnu/packages/julia-xyz.scm (julia-wcs): New variable.
---
gnu/packages/julia-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 8f2b29193a..82429c957d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -6141,6 +6141,29 @@ (define-public julia-versionparsing
\"foreign\" version numbers from external packages.")
(license license:expat)))
+(define-public julia-wcs
+ (package
+ (name "julia-wcs")
+ (version "0.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/WCS.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ala8j4mh51gh14k3npcxmnlj2f00l0pij74qz453iqadb2283mi"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-constructionbase julia-wcs-jll))
+ (home-page "https://github.com/JuliaAstro/WCS.jl")
+ (synopsis "Astronomical WCS library for Julia")
+ (description "Astronomical @url{World Coordinate System,
+https://www.atnf.csiro.au/people/mcalabre/WCS/} library for Julia. This package
+wraps the WCSLIB C library.")
+ (license license:expat)))
+
(define-public julia-weakrefstrings
(package
(name "julia-weakrefstrings")
--
2.39.1
zimoun wrote 2 years ago
Re: [bug#61439] [PATCH 0/4] gnu: Add JuliaAstro core packages.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
86k00jdv2x.fsf@gmail.com
Hi,

On Sat, 11 Feb 2023 at 21:48, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:

Toggle quote (10 lines)
> Sharlatan Hellseher (4):
> gnu: Add julia-erfa-jll.
> gnu: Add julia-wcs-jll.
> gnu: Add julia-erfa.
> gnu: Add julia-wcs.
>
> gnu/packages/julia-jll.scm | 74 ++++++++++++++++++++++++++++++++++++++
> gnu/packages/julia-xyz.scm | 44 +++++++++++++++++++++++
> 2 files changed, 118 insertions(+)

This series LGTM.

Cheers,
simon
Efraim Flashner wrote 2 years ago
(name . zimoun)(address . zimon.toutoune@gmail.com)
Y+0XAld+YtwnFRiR@3900XT
On Wed, Feb 15, 2023 at 12:30:46PM +0100, zimoun wrote:
Toggle quote (16 lines)
> Hi,
>
> On Sat, 11 Feb 2023 at 21:48, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:
>
> > Sharlatan Hellseher (4):
> > gnu: Add julia-erfa-jll.
> > gnu: Add julia-wcs-jll.
> > gnu: Add julia-erfa.
> > gnu: Add julia-wcs.
> >
> > gnu/packages/julia-jll.scm | 74 ++++++++++++++++++++++++++++++++++++++
> > gnu/packages/julia-xyz.scm | 44 +++++++++++++++++++++++
> > 2 files changed, 118 insertions(+)
>
> This series LGTM.

Looks good to me too.

Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmPtFwEACgkQQarn3Mo9
g1E8phAArQU2iC30sy6auyyvct+K7RXTjUjgbiWa1Y1048jcs5p7EOBr874KqjtD
ESJwWRXwtCdgYwmI+oHYLu0G+xT5rUm7FHUAzmbOg876dd5ZulWvt2d/MRzEqUxv
pVOk1v+HtoBqjmEuJSCl0CoW0rIPzkHDNL4gyH/XMh5xHTknqPfNMj2mDoLWOuUf
ZBmv9IO8xFaNm070SOX7vwoGcTdbPodBrdOa1cJefFDbIQrLOoSTvdsZaY8Hnhgy
yYhC2cfLMHnYDgWcjy2qcCfdSYYF9MNu0Hj84IFOMiI7Tj1zpvvrqBZtL2fq7sjI
5ai+uuWly3NTUKlnNzilGHB/qBflfggzxkNEKshjxIUIcXg47yLjIMvXI7CZGFDK
ciGzApipVrtsVdu5nSdJxYdKMNWE/K5Q126pcmE2ThVV5UOCJAJDyrDt5ZpWeaba
offHzph2eQvhjuH3tC165rjuKk2vh7gCTpZQAz8GgiX0DUdbAfxRhPAqgPXxxbPa
qWYvOYxLPAwaeW089Fd9527DPDWOYcCGN4zU38MJPQCDbDIkGhoBk4d8g7A370Az
8UhyE9CPUoub6vJhxjM1ihClLJkOM72v1rmCtD8Ez2oXiqMVtdemIF9wiLR/2r6N
jsOYqY8dkFYdjIzuBiU+lflCsEW8uKZ9ZAKWg39gfBHKqvks5g4=
=GJ6P
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61439@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61439
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help