Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
Hi Guix!
I'm on the track with JuliaAstro mentioned in #60793 :)
This patch series includes 2x JLL and their implementation for Julia - ERFA and
WCS which are core packages to grow the tree on top of them.
x86_64 bulid passed succes:
Toggle quote (6 lines)
> ./pre-inst-env guix build julia-erfa-jll julia-wcs-jll julia-erfa julia-wcs --rounds=2
> /gnu/store/mcdha3hmirsx56y22dq2axvqbfzp4053-julia-wcs-0.6.2
> /gnu/store/2wid9f05sxm619ihykkfalc6nv7ndw5v-julia-erfa-1.1.0
> /gnu/store/q6vvqim7r1fsq0yhbjy6zdzdfkd287sx-julia-wcs-jll-7.7.0+0
> /gnu/store/pnzdlnvvs99pzn8bp9j9k13mxi8ah6qc-julia-erfa-jll-2.0.0+0
aarch64 bulid in Qemue failed:
Toggle quote (24 lines)
> ./pre-inst-env guix build julia-erfa-jll julia-wcs-jll julia-erfa julia-wcs --system=aarch64-linux
> ...
> phase `install' succeeded after 0.0 seconds
> starting phase `check'
> signal (11): Segmentation fault
> in expression starting at none:0
> Timer#663 at ./asyncevent.jl:109
> Timer at ./asyncevent.jl:94 [inlined]
> sleep at ./asyncevent.jl:240
> #44 at ./task.jl:484
> unknown function (ip: 0x555a44469f)
> jl_apply at /tmp/guix-build-julia-1.8.3.drv-0/julia-1.8.3/src/julia.h:1839 [inlined]
> start_task at /tmp/guix-build-julia-1.8.3.drv-0/julia-1.8.3/src/task.c:931
> Allocations: 2560514 (Pool: 2559192; Big: 1322); GC: 3
> qemu: uncaught target signal 11 (Segmentation fault) - core dumped
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "julia" arguments: ("--depwarn=yes" "--procs=15" "/gnu/store/i588g3iyz4h4p6nb0qiy7hks6chl787v-julia-erfa-1.1.0/share/julia/loadpath/ERFA/test/runtests.jl") exit-status: #f term-signal: 11 stop-signal: #f>
> phase `check' failed after 7.0 seconds
> command "julia" "--depwarn=yes" "--procs=15" "/gnu/store/i588g3iyz4h4p6nb0qiy7hks6chl787v-julia-erfa-1.1.0/share/julia/loadpath/ERFA/test/runtests.jl" failed with signal 11
> builder for `/gnu/store/3kg912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv' failed with exit code 1
> build of /gnu/store/3kg912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv failed
> View build log at '/var/log/guix/drvs/3k/g912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv.gz'.
> guix build: error: build of `/gnu/store/3kg912881g0anxm3fsvcdvnb3s3arjqs-julia-erfa-1.1.0.drv' failed
Sharlatan Hellseher (4):
gnu: Add julia-erfa-jll.
gnu: Add julia-wcs-jll.
gnu: Add julia-erfa.
gnu: Add julia-wcs.
gnu/packages/julia-jll.scm | 74 ++++++++++++++++++++++++++++++++++++++
gnu/packages/julia-xyz.scm | 44 +++++++++++++++++++++++
2 files changed, 118 insertions(+)
base-commit: b367f28ed2ac8212d3c8b826b9655a0b2e879f18
--
2.39.1