[PATCH 2/6] gnu: Add libpanel.

  • Done
  • quality assurance status badge
Details
One participant
  • Maya Tomasek
Owner
unassigned
Submitted by
Maya Tomasek
Severity
normal

Debbugs page

Maya Tomasek wrote 2 years ago
(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20230211103537.24139-3-maya.tomasek@disroot.org
From: Antero Mejr <antero@mailbox.org>

* gnu/packages/gtk.scm (libpanel): New variable.
---
gnu/packages/gtk.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f575194c73..fa099fe862 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -3039,3 +3039,38 @@ (define-public webp-pixbuf-loader
(synopsis "WebP GdkPixbuf loader library")
(description "Webp-pixbuf-loader is a WebP format loader of GdkPixbuf.")
(license license:lgpl2.0+)))
+
+(define-public libpanel
+ (package
+ (name "libpanel")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libpanel")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10lkysbwg9w0lm1hj7lw4g7y9j8b88kmq07nfgx0r6f319znj12v"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Ddocs=disabled") ;fontconfig issue
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")))))))
+ (native-inputs (list `(,glib-next "bin")
+ gobject-introspection
+ pkg-config
+ vala))
+ (inputs (list glib-next gtk libadwaita))
+ (home-page "https://gitlab.gnome.org/GNOME/libpanel")
+ (synopsis "Dock and panel library for GTK 4")
+ (description "Libpanel provides a library to create IDE-like applications
+using GTK 4 and @code{libadwaita}. It has widgets for panels, docks, columns
+and grids of pages. Primarily, it's design and implementation focus around
+GNOME Builder and Drafting projects.")
+ (license license:lgpl3)))
--
2.39.1
Mája Tomášek wrote 2 years ago
Closing this as this was a mistake
(address . 61427-done@debbugs.gnu.org)
87zg9k4gry.fsf@disroot.org

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61427@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61427
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help