[PATCH 0/6] gnu: zrythm: Update to 1.0.0-beta.4.5.62

  • Done
  • quality assurance status badge
Details
4 participants
  • Alexandros Theodotou
  • kiasoc5
  • Ludovic Courtès
  • Maya Tomasek
Owner
unassigned
Submitted by
Maya Tomasek
Severity
normal
M
M
Maya Tomasek wrote on 11 Feb 2023 11:35
(address . guix-patches@gnu.org)(name . Maya Tomasek)(address . maya.tomasek@disroot.org)
20230211103537.24139-1-maya.tomasek@disroot.org
I have updated 60232 to the latest version of Zrythm. The app launches successfully
and plays audio through JACK (through pw-jack zrythm_launch). I have not managed to
reproduce Sugosha's issues with locale-gen, as I don't have non-english locale. But
I tried to compile Zrythm with -Dalsa=enabled, which didn't make Alsa available as
a backend.

Antero Mejr (5):
gnu: zrythm: Update to 1.0.0-beta.4.5.1.
gnu: Add libpanel.
gnu: Add zix.
gnu: carla: Update to 2.6.0 pre-release.
gnu: libaudec: Update to 0.3.4.

Maya Tomasek (1):
gnu: zrythm: Update to 1.0.0-beta.4.5.62.

gnu/packages/audio.scm | 14 ++--
gnu/packages/datastructures.scm | 40 +++++++++++
gnu/packages/gtk.scm | 35 ++++++++++
gnu/packages/music.scm | 114 +++++++++++++++++++++-----------
4 files changed, 157 insertions(+), 46 deletions(-)

--
2.39.1
M
M
Maya Tomasek wrote on 11 Feb 2023 12:00
[PATCH 1/6] gnu: zrythm: Update to 1.0.0-beta.4.5.1.
(address . 61423@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20230211110039.27645-1-maya.tomasek@disroot.org
From: Antero Mejr <antero@mailbox.org>

* gnu/packages/music.scm (zrythm): Update to 1.0.0-beta.4.5.1.
---
gnu/packages/music.scm | 112 ++++++++++++++++++++++++++---------------
1 file changed, 72 insertions(+), 40 deletions(-)

Toggle diff (149 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e99bee9cc7..0d1386b274 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -112,6 +112,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages datastructures)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages emacs)
@@ -140,6 +141,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libusb)
@@ -6351,7 +6353,7 @@ (define-public zrythm
;; distros to make necessary changes to integrate the software into the
;; distribution.
(name "zrythm")
- (version "1.0.0-alpha.12.0.1")
+ (version "1.0.0-beta.4.5.1")
(source
(origin
(method url-fetch)
@@ -6359,48 +6361,78 @@ (define-public zrythm
version ".tar.xz"))
(sha256
(base32
- "1si4n8rdg0a3frlbj6yqpyzr4f20v3cpl4m6kv0yf7r25psyl5pk"))))
+ "03p958xir2p1pzhiqbqq8sax8zaw4b7ww64ymxcvznjrcj4clrpm"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:configure-flags
- `("-Dtests=true"
- "-Dmanpage=true"
- "-Ddseg_font=false"
- "-Dgraphviz=enabled" ; for exporting routing graphs
- "-Dguile=enabled" ; for Guile scripting
- "-Djack=enabled" ; for JACK audio/MIDI backend
- "-Drtmidi=enabled" ; for RtMidi backend (ALSA sequencer)
- "-Dsdl=enabled"))) ; for SDL audio backend (which uses ALSA)
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("jack" ,jack-1)
- ("font-dseg" ,font-dseg)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("gettext" ,gettext-minimal)
- ("glibc" ,glibc)
- ("graphviz" ,graphviz)
- ("gtk+" ,gtk+)
- ("gtksourceview" ,gtksourceview)
- ("guile" ,guile-2.2)
- ("libaudec" ,libaudec)
- ("libcyaml" ,libcyaml)
- ("libsamplerate" ,libsamplerate)
- ("libsndfile" ,libsndfile)
- ("libyaml" ,libyaml)
- ("lilv" ,lilv)
- ("lv2" ,lv2)
- ("pulseaudio" ,pulseaudio)
- ("reproc" ,reproc)
- ("rubberband" ,rubberband)
- ("rtmidi" ,rtmidi-4.0)
- ("sdl2" ,sdl2)
- ("xdg-utils" ,xdg-utils)
- ("zstd" ,zstd "lib")))
+ (list #:tests? #f ;123 pass, 3 fail. Appears network-related.
+ #:glib-or-gtk? #t
+ #:configure-flags
+ #~(list "-Dtests=true"
+ "-Dmanpage=false" ; fish-completions breaks this
+ "-Ddseg_font=false"
+ "-Dgraphviz=enabled" ; for exporting routing graphs
+ "-Dguile=enabled" ; for Guile scripting
+ "-Djack=enabled" ; for JACK audio/MIDI backend
+ "-Drtmidi=enabled" ; for RtMidi backend (ALSA sequencer)
+ "-Dsdl=enabled") ; for SDL audio backend (which uses ALSA)
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-build
+ (lambda _
+ (setenv "GUILE_AUTO_COMPILE" "0")))
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program (string-append #$output "/bin/zrythm")
+ `("GDK_PIXBUF_MODULE_FILE" =
+ (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))
+ (propagated-inputs (list breeze-icons
+ gdk-pixbuf
+ librsvg)) ;needed for pixbuf SVG loading
+ (inputs (list alsa-lib
+ boost
+ carla
+ curl
+ fftw
+ fftwf
+ flex
+ font-dseg
+ gettext-minimal
+ glib-next
+ glibc
+ graphviz
+ gtk
+ gtksourceview
+ guile-2.2
+ jack-2
+ json-glib
+ libadwaita
+ libaudec
+ (module-ref
+ (resolve-interface '(gnu packages debug)) 'libbacktrace)
+ libcyaml
+ libpanel
+ libsamplerate
+ libsndfile
+ libyaml
+ lilv
+ lv2
+ pango-next
+ pulseaudio
+ reproc
+ rtmidi
+ rubberband
+ sdl2
+ vamp
+ xdg-utils
+ xxhash
+ zix
+ `(,zstd "lib")))
(native-inputs
- (list pkg-config help2man
- `(,glib "bin"))) ; for 'glib-compile-resources'
+ (list help2man
+ `(,glib-next "bin") ; for 'glib-compile-resources'
+ pkg-config
+ python-sphinx
+ python-sphinx-intl
+ sassc))
(synopsis "Digital audio workstation focusing on usability")
(description "Zrythm is a digital audio workstation designed to be
featureful and easy to use. It offers unlimited automation options, LV2
--
2.39.1
M
M
Maya Tomasek wrote on 11 Feb 2023 12:00
[PATCH 2/6] gnu: Add libpanel.
(address . 61423@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20230211110039.27645-2-maya.tomasek@disroot.org
From: Antero Mejr <antero@mailbox.org>

* gnu/packages/gtk.scm (libpanel): New variable.
---
gnu/packages/gtk.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f575194c73..fa099fe862 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -3039,3 +3039,38 @@ (define-public webp-pixbuf-loader
(synopsis "WebP GdkPixbuf loader library")
(description "Webp-pixbuf-loader is a WebP format loader of GdkPixbuf.")
(license license:lgpl2.0+)))
+
+(define-public libpanel
+ (package
+ (name "libpanel")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libpanel")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10lkysbwg9w0lm1hj7lw4g7y9j8b88kmq07nfgx0r6f319znj12v"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Ddocs=disabled") ;fontconfig issue
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")))))))
+ (native-inputs (list `(,glib-next "bin")
+ gobject-introspection
+ pkg-config
+ vala))
+ (inputs (list glib-next gtk libadwaita))
+ (home-page "https://gitlab.gnome.org/GNOME/libpanel")
+ (synopsis "Dock and panel library for GTK 4")
+ (description "Libpanel provides a library to create IDE-like applications
+using GTK 4 and @code{libadwaita}. It has widgets for panels, docks, columns
+and grids of pages. Primarily, it's design and implementation focus around
+GNOME Builder and Drafting projects.")
+ (license license:lgpl3)))
--
2.39.1
M
M
Maya Tomasek wrote on 11 Feb 2023 12:00
[PATCH 3/6] gnu: Add zix.
(address . 61423@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20230211110039.27645-3-maya.tomasek@disroot.org
From: Antero Mejr <antero@mailbox.org>

* gnu/packages/datastructures.scm (zix): New variable.
---
gnu/packages/datastructures.scm | 40 +++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index d40051506f..3d179624b8 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -26,6 +26,7 @@ (define-module (gnu packages datastructures)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix gexp)
@@ -390,3 +391,42 @@ (define-public robin-map
policy, the last two use a prime growth policy instead and are able to cope
better with a poor hash function.")
(license license:expat)))
+
+(define-public zix
+ (let ((commit "56ec14c4369c591f5efbb500b0829b760bee7800")
+ (revision "0"))
+ (package
+ (name "zix")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/drobilla/zix.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "095b2vjmwh9swbwkkkjpcdhsi0c93lxrzd76k7hzdyyf7zb5rgdx"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Ddocs=disabled"))) ;needs "sphinxygen"
+ (native-inputs (list pkg-config))
+ (home-page "https://gitlab.com/drobilla/zix")
+ (synopsis "C library of portability wrappers and data structures")
+ (description
+ "Zix is a C library of portability wrappers and data structures. It
+provides the following components:
+@enumerate
+@item @code{ZixAllocator}: A customizable allocator.
+@item @code{ZixBumpAllocator}: A simple realtime-safe bump-pointer allocator.
+@item @code{ZixBTree}: A page-allocated B-tree.
+@item @code{ZixHash}: An open-addressing hash table.
+@item @code{ZixRing}: A lock-free realtime-safe ring buffer.
+@item @code{ZixSem}: A portable semaphore wrapper.
+@item @code{ZixThread}: A portable thread wrapper.
+@item @code{ZixTree}: A binary search tree.
+@item @code{zix/digest.h}: Digest functions suitable for hashing arbitrary data.
+@item @code{zix/filesystem.h}: Functions for working with filesystems.
+@item @code{zix/path.h}: Functions for working with filesystem paths lexically.
+@end enumerate\n")
+ (license license:isc))))
--
2.39.1
M
M
Maya Tomasek wrote on 11 Feb 2023 12:00
[PATCH 4/6] gnu: carla: Update to 2.6.0 pre-release.
(address . 61423@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20230211110039.27645-4-maya.tomasek@disroot.org
From: Antero Mejr <antero@mailbox.org>

* gnu/packages/audio.scm (carla): Update to 2.6.0 pre-release.
---
gnu/packages/audio.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e443934e51..3ce9c0888d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5335,19 +5335,21 @@ (define-public redkite
(license license:gpl3+)))
(define-public carla
+ (let ((commit "aa400535b31c67f4b6c1b28e6e20e4d4f82111a3")
+ (revision "0"))
(package
(name "carla")
- (version "2.4.1")
+ (version (git-version "2.6.0" revision commit))
(source
(origin
(method git-fetch)
(uri
(git-reference
(url "https://github.com/falkTX/Carla")
- (commit (string-append "v" version))))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "01ngkmfcxyg1bb4qmfvlkkjbx4lx62akxqhizl8zmqnhfcy4p9bx"))))
+ (base32 "0cnj2sgr60f5h6wdfmihc214wf3n74686sipl3iyzmylqrcyhbjn"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f ; no "check" target
@@ -5400,7 +5402,7 @@ (define-public carla
over OSC. Carla currently supports LADSPA (including LRDF), DSSI, LV2, VST2,
and VST3 plugin formats, plus SF2 and SFZ file support. It uses JACK as the
default and preferred audio driver but also supports native drivers like ALSA.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public ecasound
(package
--
2.39.1
M
M
Maya Tomasek wrote on 11 Feb 2023 12:00
[PATCH 5/6] gnu: libaudec: Update to 0.3.4.
(address . 61423@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20230211110039.27645-5-maya.tomasek@disroot.org
From: Antero Mejr <antero@mailbox.org>

* gnu/packages/audio.scm (libaudec): Update to 0.3.4.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3ce9c0888d..75d6cfdb9b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5450,7 +5450,7 @@ (define-public ecasound
(define-public libaudec
(package
(name "libaudec")
- (version "0.2.4")
+ (version "0.3.4")
(source
(origin
(method git-fetch)
@@ -5460,7 +5460,7 @@ (define-public libaudec
(file-name (git-file-name name version))
(sha256
(base32
- "1570m2dfia17dbkhd2qhx8jjihrpm7g8nnyg6n4wif4vv229s7dz"))))
+ "02hhhpcfkycicygh6g9hzps255zkbbi33vks6yv6zk5wp9p2nspj"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
--
2.39.1
M
M
Maya Tomasek wrote on 11 Feb 2023 12:00
[PATCH 6/6] gnu: zrythm: Update to 1.0.0-beta.4.5.62.
(address . 61423@debbugs.gnu.org)(name . Maya Tomasek)(address . maya.tomasek@disroot.org)
20230211110039.27645-6-maya.tomasek@disroot.org
---
gnu/packages/music.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 0d1386b274..c9aaba128d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6353,7 +6353,7 @@ (define-public zrythm
;; distros to make necessary changes to integrate the software into the
;; distribution.
(name "zrythm")
- (version "1.0.0-beta.4.5.1")
+ (version "1.0.0-beta.4.5.62")
(source
(origin
(method url-fetch)
@@ -6361,7 +6361,7 @@ (define-public zrythm
version ".tar.xz"))
(sha256
(base32
- "03p958xir2p1pzhiqbqq8sax8zaw4b7ww64ymxcvznjrcj4clrpm"))))
+ "1nfb3h3aky8f8xslx6qzvcgcfrhlqa1v50kzanmpjxrx9dcllin7"))))
(build-system meson-build-system)
(arguments
(list #:tests? #f ;123 pass, 3 fail. Appears network-related.
@@ -6370,6 +6370,7 @@ (define-public zrythm
#~(list "-Dtests=true"
"-Dmanpage=false" ; fish-completions breaks this
"-Ddseg_font=false"
+ "-Dextra_optimizations=false" ; extra optimizations are machine-specific
"-Dgraphviz=enabled" ; for exporting routing graphs
"-Dguile=enabled" ; for Guile scripting
"-Djack=enabled" ; for JACK audio/MIDI backend
@@ -6417,6 +6418,7 @@ (define-public zrythm
lv2
pango-next
pulseaudio
+ pipewire
reproc
rtmidi
rubberband
--
2.39.1
A
A
Alexandros Theodotou wrote on 25 Feb 2023 00:11
[PATCH 0/6] gnu: zrythm: Update to 1.0.0-beta.4.5.62
(address . 61423@debbugs.gnu.org)
fc8d4047bb454d2b85f6a65a26118e80805fb660.camel@zrythm.org
Hi,

Thanks for working on this. I'm the Zrythm author and was also the
person who first packaged this but I don't use Guix anymore. Feel free
to ask if you need help related to building/running.

From a packager's standpoint I think the unreleased Carla package
should probably be separate from stable Carla.

Toggle quote (3 lines)
> I tried to compile Zrythm with -Dalsa=enabled, which didn't make Alsa
> available as a backend.

The pure Alsa backend is broken so I disabled it. You can enable the
rtaudio dependency for ALSA/pulseaudio support (it acts as a wrapper).

Thanks,
Alex
L
L
Ludovic Courtès wrote on 27 Feb 2023 15:44
(name . Maya Tomasek)(address . maya.tomasek@disroot.org)
87mt4zjhhl.fsf_-_@gnu.org
Hi Maya,

Could you look into the suggestions Alexandros made (I agree regarding
Carla) and send a v2 of the patch series?

It looks almost ready to apply!

Thanks,
Ludo’.

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (17 lines)
> Hi,
>
> Thanks for working on this. I'm the Zrythm author and was also the
> person who first packaged this but I don't use Guix anymore. Feel free
> to ask if you need help related to building/running.
>
>>From a packager's standpoint I think the unreleased Carla package
> should probably be separate from stable Carla.
>
>> I tried to compile Zrythm with -Dalsa=enabled, which didn't make Alsa
>> available as a backend.
>
> The pure Alsa backend is broken so I disabled it. You can enable the
> rtaudio dependency for ALSA/pulseaudio support (it acts as a wrapper).
>
> Thanks,
> Alex
M
M
Mája Tomášek wrote on 28 Feb 2023 19:38
(name . Ludovic Courtès)(address . ludo@gnu.org)
874jr5vdnt.fsf@disroot.org
Ludovic Courtès <ludo@gnu.org> writes:

Hi Ludo',

Toggle quote (5 lines)
> Hi Maya,
>
> Could you look into the suggestions Alexandros made (I agree regarding
> Carla) and send a v2 of the patch series?

Certainly! Should I open it as another patch? I am not certain how these
things work.

From Antero Mejr (the previous person to update the package):
Toggle quote (4 lines)
> (module-ref (resolve-interface ... 'libbacktrace)
> was a quick workaround to avoid an cyclical import. It's not ideal and
> I'm not sure if the maintainers would find it to be acceptable.

Is that line fine? Or should I find some other fix?

Regards
Maya
L
L
Ludovic Courtès wrote on 3 Mar 2023 11:54
(name . Mája Tomášek)(address . maya.tomasek@disroot.org)
87lekexfz8.fsf@gnu.org
Hi Mája,

Mája Tomášek <maya.tomasek@disroot.org> skribis:

Toggle quote (12 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
> Hi Ludo',
>
>> Hi Maya,
>>
>> Could you look into the suggestions Alexandros made (I agree regarding
>> Carla) and send a v2 of the patch series?
>
> Certainly! Should I open it as another patch? I am not certain how these
> things work.

You don’t need to open a new bug.

Instead, create the messages with:

git format-patch --subject-prefix="PATCH v2" …

and send them all to 61423@debbugs.gnu.org.

Toggle quote (7 lines)
> From Antero Mejr (the previous person to update the package):
>> (module-ref (resolve-interface ... 'libbacktrace)
>> was a quick workaround to avoid an cyclical import. It's not ideal and
>> I'm not sure if the maintainers would find it to be acceptable.
>
> Is that line fine? Or should I find some other fix?

No it’s not fine, it should be treated like other packages.

If that causes problem, then we’ll see, but it shouldn’t.

Thanks,
Ludo’.
K
K
kiasoc5 wrote on 19 Aug 2023 03:22
(no subject)
(name . Control)(address . control@debbugs.gnu.org)
3add9fa26aa0a7bd6dfa8a11d48c709d@disroot.org
close 61423
close 54026
thanks

Bugs resolved by upgrading Zrythm to 1.0.0-beta.4.9.1.
?