[PATCH 0/2] Update nvme-cli to 2.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 10 Feb 2023 15:58
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1676041036.git.mirai@makinata.eu
Bruno Victal (2):
gnu: Add libnvme.
gnu: nvme-cli: Update to 2.3.

gnu/packages/linux.scm | 53 ++++++++++++++++++++++++++++++------------
1 file changed, 38 insertions(+), 15 deletions(-)


base-commit: b8f6ead5faac3c1b9a8fa6e060c00cf0917e884e
--
2.38.1
B
B
Bruno Victal wrote on 10 Feb 2023 16:06
[PATCH 1/2] gnu: Add libnvme.
(address . 61402@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
f8affa8d595529fb21c7531fa3ff0e91d27c7743.1676041036.git.mirai@makinata.eu
* gnu/packages/linux.scm (libnvme): New variable.
---
gnu/packages/linux.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 639ae5b558..4faa456333 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5039,6 +5039,35 @@ (define-public hdparm
Translation (@dfn{SAT}) are also supported.")
(license (license:non-copyleft "file://LICENSE.TXT"))))
+(define-public libnvme
+ (package
+ (name "libnvme")
+ (version "1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linux-nvme/libnvme.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1fngj5acp2sl4162xalq5simfasnika6gy0xrbi41x09wikvhn7y"))
+ (file-name (git-file-name name version))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list (format #f "-Dhtmldir=~a/share/doc/~a/html"
+ #$output #$name)
+ "-Ddocs-build=true" "-Ddocs=all")))
+ (native-inputs (list pkg-config perl python python-sphinx))
+ ;; libnvme.pc, libnvme-mi.pc lists these in Requires.private.
+ (propagated-inputs (list dbus json-c openssl))
+ (home-page "https://github.com/linux-nvme/libnvme")
+ (synopsis "C Library for NVM Express on Linux")
+ (description "libnvme provides type definitions for NVMe specification
+structures, enumerations, and bit fields, helper functions to construct,
+dispatch, and decode commands and payloads, and utilities to connect, scan,
+and manage nvme devices on a Linux system.")
+ (license license:lgpl2.1+)))
+
(define-public nvme-cli
(package
(name "nvme-cli")
--
2.38.1
B
B
Bruno Victal wrote on 10 Feb 2023 16:06
[PATCH 2/2] gnu: nvme-cli: Update to 2.3.
(address . 61402@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
9640c9a8c63baa8cdd882c93e3d87bd997f0a20f.1676041036.git.mirai@makinata.eu
* gnu/packages/linux.scm (nvme-cli): Update to 2.3.
[build-system]: Switch to meson-build-system.
[arguments]: Remove stages. Build documentation.
[native-inputs]: Add pkg-config.
[inputs]: Add libnvme, json-c and zlib.
---
gnu/packages/linux.scm | 24 +++++++++---------------
1 file changed, 9 insertions(+), 15 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4faa456333..cc64d5b631 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5071,7 +5071,7 @@ (define-public libnvme
(define-public nvme-cli
(package
(name "nvme-cli")
- (version "1.16")
+ (version "2.3")
(home-page "https://github.com/linux-nvme/nvme-cli")
(source (origin
(method git-fetch)
@@ -5079,22 +5079,16 @@ (define-public nvme-cli
(url home-page)
(commit (string-append "v" version))))
(sha256
- (base32 "130x5cf6kkcnyg5qd35igii249ysfjnbxp1pxfwkickmqg3d007z"))
+ (base32 "1f3bhxh2kr94s6glzibrmgxxgs66qyabn8plnw5y0v9cpi78b3qs"))
(file-name (git-file-name name version))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- (list #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target)))
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure) ; no ./configure script
- (replace 'install
- (lambda _
- (invoke "make" "install-spec" "PREFIX="
- (string-append "DESTDIR=" #$output)))))
- ;; The tests require sysfs, which is not accessible from from the
- ;; build environment.
- #:tests? #f))
+ (list
+ #:configure-flags #~(list (format #f "-Dhtmldir=~a/share/doc/~a/html"
+ #$output #$name)
+ "-Ddocs=all")))
+ (native-inputs (list pkg-config))
+ (inputs (list libnvme json-c zlib))
(synopsis "NVM-Express user space tooling for Linux")
(description "Nvme-cli is a utility to provide standards compliant tooling
for NVM-Express drives. It was made specifically for Linux as it relies on the
--
2.38.1
L
L
Ludovic Courtès wrote on 27 Feb 2023 15:48
Re: bug#61402: [PATCH 0/2] Update nvme-cli to 2.3.
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 61402-done@debbugs.gnu.org)
87edqbjhan.fsf@gnu.org
Hi,

Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (4 lines)
> Bruno Victal (2):
> gnu: Add libnvme.
> gnu: nvme-cli: Update to 2.3.

Applied, thanks!

Ludo’.
Closed
?