[PATCH 00/10] Remove lash, which causes gtk@4 to depend on python2

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal

Debbugs page

Maxim Cournoyer wrote 2 years ago
(address . guix-patches@gnu.org)
20230207041531.5013-1-maxim.cournoyer@gmail.com
Hi Guix,

This removes lash, because it was last released in 2009 and depends on Python
2. This also gets rid of Python2 in the GTK 4 dependency closure:

$ guix graph --path gtk python2
gtk@4.8.1
gst-plugins-bad@1.20.3
fluidsynth@2.2.4
lash@0.6.0-rc2
python2@2.7.18

It seems to cause a rebuild of only 428 packages, so I think it'd be fine on
master.


Maxim Cournoyer (10):
gnu: seq24: Remove lash input.
gnu: muse-sequencer: Remove lash input.
gnu: jack-keyboard: Remove lash input.
gnu: jack-keyboard: Update to 2.7.2.
gnu: hydrogen: Remove lash input.
gnu: fluidsynth: Remove lash input.
gnu: fluidsynth: Update to 2.3.1.
gnu: calf: Remove lash input.
gnu: Remove azr3.
gnu: Remove lash.

gnu/packages/audio.scm | 101 +----------------------------------------
gnu/packages/music.scm | 55 +++++++++++-----------
2 files changed, 31 insertions(+), 125 deletions(-)


base-commit: 1f684d00d25f0f205c4cc4b762d8f56911062581
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 01/10] gnu: seq24: Remove lash input.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-2-maxim.cournoyer@gmail.com
* gnu/packages/music.scm (seq24) [inputs]: Remove lash.
[home-page]: Update URL.
---

gnu/packages/music.scm | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 69e8cbcc79..6c7b3b4533 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4626,11 +4626,9 @@ (define-public seq24
"12dphdhnvfk1k0vmagi1v2lhyxjyj1j3cz6ksjw0ydcvid1x8ap2"))
(patches (search-patches "seq24-rename-mutex.patch"))))
(build-system gnu-build-system)
- (inputs
- (list gtkmm-2 alsa-lib jack-1 lash))
- (native-inputs
- (list pkg-config))
- (home-page "https://edge.launchpad.net/seq24/")
+ (inputs (list gtkmm-2 alsa-lib jack-1))
+ (native-inputs (list pkg-config))
+ (home-page "https://launchpad.net/seq24/")
(synopsis "Real-time MIDI sequencer")
(description "Seq24 is a real-time MIDI sequencer. It was created to
provide a very simple interface for editing and playing MIDI loops.")
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 02/10] gnu: muse-sequencer: Remove lash input.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-3-maxim.cournoyer@gmail.com
* gnu/packages/music.scm (muse-sequencer) [inputs]: Remove lash.
[native-inputs]: Remove labels.
---

gnu/packages/music.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6c7b3b4533..f6aceecac4 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4987,7 +4987,6 @@ (define-public muse-sequencer
glib
jack-1
ladspa
- lash
libinstpatch
liblo
libsamplerate
@@ -5004,10 +5003,10 @@ (define-public muse-sequencer
rubberband
sord))
(native-inputs
- `(("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("qttools-5" ,qttools-5)))
+ (list perl
+ pkg-config
+ python-wrapper
+ qttools-5))
(home-page "https://muse-sequencer.github.io/")
(synopsis "MIDI/Audio sequencer")
(description "MusE is a MIDI/Audio sequencer with recording and editing
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 03/10] gnu: jack-keyboard: Remove lash input.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-4-maxim.cournoyer@gmail.com
* gnu/packages/music.scm (jack-keyboard) [inputs]: Remove lash.
---

gnu/packages/music.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f6aceecac4..9c7bef516f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3218,7 +3218,7 @@ (define-public jack-keyboard
"0mzmg8aavybcfdlq2yd9d0vscqd6is5p6jzrgfpfm5j3xdcvh2s3"))))
(build-system gnu-build-system)
(inputs
- (list jack-1 lash gtk+-2))
+ (list jack-1 gtk+-2))
(native-inputs
(list pkg-config))
(home-page "http://jack-keyboard.sourceforge.net/")
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 04/10] gnu: jack-keyboard: Update to 2.7.2.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-5-maxim.cournoyer@gmail.com
* gnu/packages/music.scm (jack-keyboard): Update to 2.7.2.
[build-system]: Use cmake-build-system.
[arguments]: Set #:tests? to #f. Adjust configure-flags for CMake.
[native-inputs]: Delete field.
[home-page]: Update URL.
---

gnu/packages/music.scm | 26 +++++++++++++++++---------
1 file changed, 17 insertions(+), 9 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9c7bef516f..8c2f74613c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -46,7 +46,7 @@
;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
;;; Copyright © 2022, 2023 Sughosha <sughosha@disroot.org>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
@@ -3207,7 +3207,7 @@ (define-public libgig
(define-public jack-keyboard
(package
(name "jack-keyboard")
- (version "2.5")
+ (version "2.7.2")
(source
(origin
(method url-fetch)
@@ -3215,13 +3215,21 @@ (define-public jack-keyboard
version "/jack-keyboard-" version ".tar.gz"))
(sha256
(base32
- "0mzmg8aavybcfdlq2yd9d0vscqd6is5p6jzrgfpfm5j3xdcvh2s3"))))
- (build-system gnu-build-system)
- (inputs
- (list jack-1 gtk+-2))
- (native-inputs
- (list pkg-config))
- (home-page "http://jack-keyboard.sourceforge.net/")
+ "1z34ga1z6ivgxbp0afsfghz7rn6s8vc9fxnb9ini8mx0dackr5ar"))))
+ (build-system cmake-build-system)
+ ;; Disable Lash support, as it is unmaintained and depends on Python 2.
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:configure-flags
+ #~(list "-DLashEnable=OFF"
+ ;; XXX: FindGTK2.cmake from CMake expects the
+ ;; headers to be in FHS locations; give it some
+ ;; clues.
+ (string-append "-DGTK2_ADDITIONAL_SUFFIXES="
+ "lib/glib-2.0;" ;for glibconfig.h
+ "lib/gtk-2.0")))) ;for gdkconfig.h
+ (inputs (list jack-1 gtk+-2))
+ (home-page "https://jack-keyboard.sourceforge.net/")
(synopsis "Virtual MIDI keyboard")
(description "Jack-keyboard is a virtual MIDI keyboard, a program that
allows you to send JACK MIDI events (i.e. play) using your PC keyboard.")
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 05/10] gnu: hydrogen: Remove lash input.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-6-maxim.cournoyer@gmail.com
* gnu/packages/music.scm (hydrogen) [inputs]: Remove lash.
[phases]: Remove trailing #t.
[native-inputs]: Remove labels.
[home-page]: Update URL.
---

gnu/packages/music.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 8c2f74613c..edb8131d3c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -766,17 +766,15 @@ (define-public hydrogen
(substitute* "CMakeLists.txt"
(("/usr/share/pixmaps")
(string-append (assoc-ref outputs "out")
- "/share/pixmaps")))
- #t)))))
+ "/share/pixmaps"))))))))
(native-inputs
- `(("cppunit" ,cppunit)
- ("pkg-config" ,pkg-config)
- ("qtlinguist" ,qttools-5)))
+ (list cppunit
+ pkg-config
+ qttools-5))
(inputs
(list alsa-lib
jack-1
;; ("ladspa" ,ladspa) ; require LADSPA_PATH to be set
- lash
libarchive
liblo
libsndfile
@@ -785,7 +783,7 @@ (define-public hydrogen
qtbase-5
qtxmlpatterns
zlib))
- (home-page "http://www.hydrogen-music.org")
+ (home-page "http://hydrogen-music.org/")
(synopsis "Drum machine")
(description
"Hydrogen is an advanced drum machine for GNU/Linux. Its main goal is to
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 06/10] gnu: fluidsynth: Remove lash input.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-7-maxim.cournoyer@gmail.com
* gnu/packages/audio.scm (fluidsynth) [inputs]: Remove lash.
---

gnu/packages/audio.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3e46cedd53..589d2cc938 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1970,7 +1970,6 @@ (define-public fluidsynth
(list alsa-lib
glib
jack-1
- lash
libsndfile
readline))
(home-page "https://www.fluidsynth.org/")
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 07/10] gnu: fluidsynth: Update to 2.3.1.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-8-maxim.cournoyer@gmail.com
* gnu/packages/audio.scm (fluidsynth): Update to 2.3.1.
---

gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 589d2cc938..ea8a6e2dfb 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1940,7 +1940,7 @@ (define-public g2reverb
(define-public fluidsynth
(package
(name "fluidsynth")
- (version "2.2.4")
+ (version "2.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1949,7 +1949,7 @@ (define-public fluidsynth
(file-name (git-file-name name version))
(sha256
(base32
- "1061rdj69503spkd8vmfl3fqvyg4l41k5xcc4gw7niy31hnpnjmn"))))
+ "05lr9f0q4x1kvgfa3xrfmagpwvijv9m1s316aa9figqlkcc5vv4k"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no check target
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 08/10] gnu: calf: Remove lash input.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-9-maxim.cournoyer@gmail.com
* gnu/packages/audio.scm (calf) [inputs]: Remove lash.
---

gnu/packages/audio.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ea8a6e2dfb..0a2d87784e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1149,7 +1149,6 @@ (define-public calf
glib
gtk+-2
cairo
- lash
jack-1
lv2
ladspa
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 09/10] gnu: Remove azr3.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-10-maxim.cournoyer@gmail.com
* gnu/packages/audio.scm (azr3): Delete variable.
---

gnu/packages/audio.scm | 41 -----------------------------------------
1 file changed, 41 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0a2d87784e..c600a3f751 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1090,47 +1090,6 @@ (define-public autotalent
;; The FFT routine is under BSD-3.
(license license:gpl2+)))
-(define-public azr3
- (package
- (name "azr3")
- (version "1.2.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://savannah/ll-plugins/azr3-jack-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "18mdw6nc0vgj6k9rsy0x8w64wvzld0frqshrxxbxfj9qi9843vlc"))
- (patches (search-patches "azr3.patch"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:make-flags
- (list "LV2PEG=ttl2c"
- (string-append "prefix=" %output)
- (string-append "pkgdatadir=" %output "/share/azr3-jack"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'fix-timestamp
- (lambda _
- (let ((early-1980 315619200)) ; 1980-01-02 UTC
- (utime "azr3.1" early-1980 early-1980))
- #t)))))
- (inputs
- (list gtkmm-2 lvtk jack-1 lash))
- (native-inputs
- (list pkg-config))
- (home-page "http://ll-plugins.nongnu.org/azr3/")
- (synopsis "Tonewheel organ synthesizer")
- (description
- "AZR-3 is a port of the free VST plugin AZR-3. It is a tonewheel organ
-with drawbars, distortion and rotating speakers. The organ has three
-sections, two polyphonic sections with nine drawbars each and one monophonic
-bass section with five drawbars. A standalone JACK application and LV2
-plugins are provided.")
- (license license:gpl2)))
-
(define-public calf
(package
(name "calf")
--
2.39.1
Maxim Cournoyer wrote 2 years ago
[PATCH 10/10] gnu: Remove lash.
(address . 61336@debbugs.gnu.org)
20230207041925.6292-11-maxim.cournoyer@gmail.com
* gnu/packages/audio.scm (lash): Delete variable.

---

gnu/packages/audio.scm | 54 ------------------------------------------
1 file changed, 54 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index c600a3f751..dbf2727aa0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2583,60 +2583,6 @@ (define-public ladspa
to be plugged into a wide range of audio synthesis and recording packages.")
(license license:lgpl2.1+)))
-(define-public lash
- (package
- (name "lash")
- (version "0.6.0-rc2")
- (source (origin
- (method url-fetch)
- ;; The tilde is not permitted in the builder name, but is used
- ;; in the tarball.
- (uri (string-append
- "mirror://savannah/lash/lash-"
- (string-join (string-split version #\-) "~")
- ".tar.bz2"))
- (file-name (string-append name "-" version ".tar.bz2"))
- (sha256
- (base32
- "12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
- (build-system gnu-build-system)
- (arguments
- '(;; Glibc no longer includes Sun RPC support, so tell the build system
- ;; to use libtirpc instead.
- #:make-flags (list (string-append "CFLAGS=-I"
- (assoc-ref %build-inputs "libtirpc")
- "/include/tirpc -ltirpc"))
- #:phases
- (modify-phases %standard-phases
- ;; lashd embeds an ancient version of sigsegv so we just skip it
- (add-after 'unpack 'skip-lashd
- (lambda _
- (substitute* '("Makefile.am" "Makefile.in")
- (("lashd ") ""))
- #t)))
- #:configure-flags '("--disable-static")))
- (inputs
- `(("bdb" ,bdb)
- ("gtk" ,gtk+-2)
- ("jack" ,jack-1)
- ("libtirpc" ,libtirpc)
- ("readline" ,readline)
- ("python" ,python-2)))
- ;; According to pkg-config, packages depending on lash also need to have
- ;; at least the following packages declared as inputs.
- (propagated-inputs
- (list alsa-lib dbus libxml2))
- (native-inputs
- (list pkg-config))
- (home-page "https://www.nongnu.org/lash/")
- (synopsis "Audio application session manager")
- (description
- "LASH is a session management system for audio applications. It allows
-you to save and restore audio sessions consisting of multiple interconneced
-applications, restoring program state (i.e. loaded patches) and the
-connections between them.")
- (license license:gpl2+)))
-
(define-public libbs2b
(package
(name "libbs2b")
--
2.39.1
Ricardo Wurmus wrote 2 years ago
Re: [PATCH 09/10] gnu: Remove azr3.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 61336@debbugs.gnu.org)
87pmal6cr0.fsf@elephly.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (azr3): Delete variable.

Why delete this?

--
Ricardo
Ricardo Wurmus wrote 2 years ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 61336@debbugs.gnu.org)
87lel96as9.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (6 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> * gnu/packages/audio.scm (azr3): Delete variable.
>
> Why delete this?

I’ve pushed a series of commits to build azr3 without lash. The other
commits look good to me, but I suspect that you can’t do the fluidsynth
change (and the removal of lash) on the master branch.

--
Ricardo
Maxim Cournoyer wrote 2 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 61336-done@debbugs.gnu.org)
87mt5plh6w.fsf@gmail.com
Hi Ricardo,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (12 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>>> * gnu/packages/audio.scm (azr3): Delete variable.
>>
>> Why delete this?
>
> I’ve pushed a series of commits to build azr3 without lash. The other
> commits look good to me, but I suspect that you can’t do the fluidsynth
> change (and the removal of lash) on the master branch.

Thanks for taking a look and preserving azr3. The change to fluidsynth
would require 818 dependent packages to be rebuilt, many of them Python
packages. I've sent it to staging; with the rest merged to master.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61336@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61336
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help