[PATCH core-updates] Update wayland, libdrm, wlroots, wayland-protocols-next, libinput, sway

  • Done
  • quality assurance status badge
Details
3 participants
  • Gabriel Wicki
  • Jonathan Brielmaier
  • Feng Shu
Owner
unassigned
Submitted by
Gabriel Wicki
Severity
normal
G
G
Gabriel Wicki wrote on 7 Feb 2023 00:17
(address . guix-patches@gnu.org)
20230206231710.sh5pmgknkoulasvo@blackbox
Hello!

This is my first patch-set of this size, I hope I'm doing this right.
I wanted to update sway since it's somewhat outdated currently and have
been patching quite a bunch of stuff.

I started building the dependents of package `wayland`, but I'm not sure
whether my machine will finish any time soon. So far 1182 of 1266
packages have successfully built (and I'm not 100% sure whether the
builds fail due to my patches).

The patch-set is based on commit 729eabc6ae8aae32584408f6bbd4526ad21e3476.

TIA for review and merging
gabber
G
G
Gabriel Wicki wrote on 7 Feb 2023 00:21
[PATCH core-updates] Update wayland, ..., sway
(address . 61331@debbugs.gnu.org)
20230206232155.y4g2ptoa3bhe5fyp@blackbox
From 1e06a38d5deca1982d275c00ad61531d67869423 Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 00:22:52 +0100
Subject: [PATCH 1/6] gnu: Update wayland to 1.21.0.

* gnu/packages/freedesktop.scm (wayland): Update to version 1.21.0.
---
gnu/packages/freedesktop.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 130a7adec4..989912f38f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1174,19 +1174,20 @@ (define-public python-pyxdg
(define-public wayland
(package
(name "wayland")
- (version "1.20.0")
+ (version "1.21.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://wayland.freedesktop.org/releases/"
+ (uri (string-append "https://gitlab.freedesktop.org/wayland/"
+ name "/-/releases/" version "/downloads/"
name "-" version ".tar.xz"))
(sha256
(base32
- "09c7rpbwavjg4y16mrfa57gk5ix6rnzpvlnv1wp7fnbh9hak985q"))))
+ "1b0ixya9bfw5c9jx8mzlr7yqnlyvd3jv5z8wln9scdv8q5zlvikd"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
`(#:parallel-tests? #f
- #:phases
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-docbook-xml
(lambda* (#:key native-inputs inputs #:allow-other-keys)
--
2.38.1
G
G
Gabriel Wicki wrote on 7 Feb 2023 00:22
(no subject)
(address . 61331@debbugs.gnu.org)
20230206232256.bssvyzdwvb4sa6xt@blackbox
From 3ce2a3f8fba900294fa186749951d457857db33e Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 00:24:09 +0100
Subject: [PATCH 2/6] gnu: Update libdrm to 2.4.114.

* gnu/packages/xdisorg.scm (libdrm): Update to version 2.4.114.
---
gnu/packages/xdisorg.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index f6f015732d..107ac4c654 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -705,7 +705,7 @@ (define-public pixman
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.107")
+ (version "2.4.114")
(source (origin
(method url-fetch)
(uri (string-append
@@ -713,7 +713,7 @@ (define-public libdrm
version ".tar.xz"))
(sha256
(base32
- "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
+ "09nhk3jx3qzggl5vyii3yh4zm0npjqsbxhzvxrg2xla77a2cyj9h"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
--
2.38.1
G
G
Gabriel Wicki wrote on 7 Feb 2023 00:26
[PATCH 3/6] gnu: Update wlroots to 0.16.1.
(address . 61331@debbugs.gnu.org)
20230206232617.yokszg43hrv2g5iw@blackbox
From 736f047384082f4eaa1ed1414ec3e0595ec19816 Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 00:27:20 +0100
Subject: [PATCH 3/6] gnu: Update wlroots to 0.16.1.

* gnu/packages/wm.scm (wlroots): Update to version 0.16.1.
---
gnu/packages/wm.scm | 21 +++++++++++++++++----
1 file changed, 17 insertions(+), 4 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a860ed1f93..8f812bc14b 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -101,6 +101,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -130,6 +131,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpd)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
@@ -146,6 +148,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
@@ -1538,16 +1541,16 @@ (define-public polybar
(define-public wlroots
(package
(name "wlroots")
- (version "0.14.1")
+ (version "0.16.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/swaywm/wlroots")
+ (url "https://gitlab.freedesktop.org/wlroots/wlroots.git")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1sshp3lvlkl1i670kxhwsb4xzxl8raz6769kqvgmxzcb63ns9ay1"))))
+ (base32 "11kcica9waj1a1xgbi12gif9z5z0b4xzycbcgawbgdmj77pws8sk"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1558,7 +1561,16 @@ (define-public wlroots
(("Xwayland") (string-append (assoc-ref inputs
"xorg-server-xwayland")
"/bin/Xwayland")))
+ #t))
+ (add-before 'configure 'fix-meson-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "backend/drm/meson.build"
+ (("/usr/share/hwdata/pnp.ids")
+ (string-append (assoc-ref inputs "hwdata")
+ "/share/hwdata/pnp.ids")))
#t)))))
+ (inputs (list cmake
+ `(,hwdata "pnp")))
(propagated-inputs
(list ;; As required by wlroots.pc.
eudev
@@ -1567,8 +1579,9 @@ (define-public wlroots
mesa
pixman
libseat
+ vulkan-headers
wayland
- wayland-protocols
+ wayland-protocols-next
xcb-util-errors
xcb-util-wm
xorg-server-xwayland))
--
2.38.1
G
G
Gabriel Wicki wrote on 7 Feb 2023 00:26
[PATCH 4/6] gnu: Update wayland-protocols-next to 1.31.
(address . 61331@debbugs.gnu.org)
20230206232653.oypix7s2hxgfxasw@blackbox
From fdb4d5d1e463da5c26688f448dd3da56090b9593 Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 00:56:38 +0100
Subject: [PATCH 4/6] gnu: Update wayland-protocols-next to 1.31.

* gnu/packages/freedesktop.scm (wayland-protocols-next): Update to version 1.31.
---
gnu/packages/freedesktop.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 989912f38f..5c8f079872 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1272,15 +1272,15 @@ (define-public wayland-protocols-next
(package
(inherit wayland-protocols)
(name "wayland-protocols")
- (version "1.26")
+ (version "1.31")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://wayland.freedesktop.org/releases/"
- "wayland-protocols-" version ".tar.xz"))
+ (uri (string-append "https://gitlab.freedesktop.org/wayland/"
+ name "/-/releases/" version
+ "/downloads/" name "-" version ".tar.xz"))
(sha256
(base32
- "04vgllmpmrv14x3x64ns01vgwx4hriljayjkz9idgbv83i63hly5"))))))
+ "0f72359fzvh6jzri4fd79m34rwm2r55p2ryq4306wrw7xliafzx0"))))))
(define-public wayland-utils
(package
--
2.38.1
G
G
Gabriel Wicki wrote on 7 Feb 2023 00:27
[PATCH 5/6] gnu: Update libinput to 1.22.1.
(address . 61331@debbugs.gnu.org)
20230206232729.g4wfnvwyo4fsdm3s@blackbox
From 4daaffccca2ba1e89592b7302a6e9c9c92428fcc Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 01:06:50 +0100
Subject: [PATCH 5/6] gnu: Update libinput to 1.22.1.

* gnu/packages/freedesktop.scm (libinput): Update to version 1.22.1. [inputs]
Add python.
---
gnu/packages/freedesktop.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 5c8f079872..a718074c19 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -589,14 +589,16 @@ (define-public libinput
;; Updating this will rebuild over 700 packages through libinput-minimal.
(package
(name "libinput")
- (version "1.19.4")
+ (version "1.22.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://freedesktop.org/software/libinput/"
- "libinput-" version ".tar.xz"))
+ (method git-fetch)
+
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libinput/libinput.git")
+ (commit version)))
(sha256
(base32
- "0h5lz54rrl48bhi3vki6s08m6rn2h62rlf08dhgchdm9nmqaaczz"))))
+ "17a5qlym2d6lg2j8fdpxda9k7x5zr35flb4wlj1bz7h0mnkh8326"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Ddocumentation=false")
@@ -613,7 +615,8 @@ (define-public libinput
gtk+
libevdev
libwacom
- mtdev))
+ mtdev
+ python))
(propagated-inputs
`(;; libinput.h requires <libudev.h>, so propagate it.
("udev" ,eudev)))
--
2.38.1
G
G
Gabriel Wicki wrote on 7 Feb 2023 00:29
[PATCH 6/6] gnu: Update sway to 1.8.
(address . 61331@debbugs.gnu.org)
20230206232905.kn6n7qtltviv23ma@blackbox
From 8433a386ff0895c9b43e947fe8d35562b3a65b5f Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 01:40:52 +0100
Subject: [PATCH 6/6] gnu: Update sway to 1.8.

* gnu/packages/wm.scm (sway): Update to version 1.8.
---
gnu/packages/wm.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8f812bc14b..0bc7b2c880 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1597,7 +1597,7 @@ (define-public wlroots
(define-public sway
(package
(name "sway")
- (version "1.6.1")
+ (version "1.8")
(source
(origin
(method git-fetch)
@@ -1606,7 +1606,7 @@ (define-public sway
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j"))))
+ (base32 "17dqr2lkmcv2ssp7vky27zw599i77whpb1aqh1s6kl8a8vkrz6mg"))))
(build-system meson-build-system)
(arguments
`(;; elogind is propagated by wlroots -> libseat
@@ -1629,17 +1629,20 @@ (define-public sway
#t)))))
(inputs (list basu
cairo
+ cmake
gdk-pixbuf
json-c
libevdev
libinput-minimal
libxkbcommon
pango
+ pcre2
+ python-wrapper
swaybg
wayland
wlroots))
(native-inputs
- (list linux-pam mesa pkg-config scdoc wayland-protocols))
+ (list linux-pam mesa pkg-config scdoc wayland-protocols-next))
(home-page "https://github.com/swaywm/sway")
(synopsis "Wayland compositor compatible with i3")
(description "Sway is a i3-compatible Wayland compositor.")
--
2.38.1
F
F
Feng Shu wrote on 7 Feb 2023 06:16
need update cagebreak too.
(address . 61331@debbugs.gnu.org)
87wn4uukbt.fsf@163.com
cagebreak build fail when update wlroot. so it should update too
From 83de1968ee8678c0fc4e15ef77fafffc115b75d9 Mon Sep 17 00:00:00 2001
From: Feng Shu <tumashu@163.com>
Date: Tue, 7 Feb 2023 11:06:06 +0800
Subject: [PATCH 2/3] gnu: cagebreak: Update to 2.0.1.

* gnu/packages/wm.scm (cagebreak): Update to 2.0.1.
---
gnu/packages/wm.scm | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 3cfe7b9707..32aa5f39e5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2680,7 +2680,7 @@ shows a notification for the user on the screen.")
(define-public cagebreak
(package
(name "cagebreak")
- (version "1.8.0")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2689,9 +2689,17 @@ shows a notification for the user on the screen.")
(file-name (git-file-name name version))
(sha256
(base32
- "0296mnzk7qd0zvnhw716jvpp7madjsar373ixx4qcff0m0jwfrxm"))))
+ "0fxfmxl7p63l07lqb83q5lx16hm0rixcidghx00gp08x2yrgr4x9"))))
(build-system meson-build-system)
- (arguments '(#:configure-flags '("-Dxwayland=true")))
+ (arguments
+ (list
+ #:configure-flags #~'("-Dxwayland=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source-paths
+ (lambda _
+ (substitute* '("cagebreak.c" "meson.build")
+ (("/etc/xdg") (string-append #$output "/etc/xdg"))))))))
(native-inputs
(list pandoc pkg-config))
(inputs
@@ -2724,7 +2732,7 @@ for wayland conceptually based on the X11 window manager
`(#:tests? #f)) ;; no tests
(home-page "https://github.com/vstakhov/libucl")
(synopsis "Universal configuration language (UCL) parser")
- (description "libucl implements a configuration language that is easy to
+ (description "libucl implements a configuration language that is easy to
read and write, and compatible with JSON.")
(license license:bsd-2)))
--
2.30.2
--
F
F
Feng Shu wrote on 9 Feb 2023 03:20
Update cagebreak too.
(address . 61331@debbugs.gnu.org)
87a61na8br.fsf@163.com
The below is a update version of cagebreak 2.0.1 patch
From 5bf4be15d210a87270b6750ba840e2bb21bfa378 Mon Sep 17 00:00:00 2001
From: Feng Shu <tumashu@163.com>
Date: Tue, 7 Feb 2023 11:06:06 +0800
Subject: [PATCH 1/3] gnu: cagebreak: Update to 2.0.1.

* gnu/packages/wm.scm (cagebreak): Update to 2.0.1.
---
gnu/packages/wm.scm | 26 +++++++++++++++++++++-----
1 file changed, 21 insertions(+), 5 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 3cfe7b9707..8ed6642498 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -145,6 +145,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages suckless)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages terminals)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages video)
@@ -2680,7 +2681,7 @@ shows a notification for the user on the screen.")
(define-public cagebreak
(package
(name "cagebreak")
- (version "1.8.0")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2689,13 +2690,28 @@ shows a notification for the user on the screen.")
(file-name (git-file-name name version))
(sha256
(base32
- "0296mnzk7qd0zvnhw716jvpp7madjsar373ixx4qcff0m0jwfrxm"))))
+ "0fxfmxl7p63l07lqb83q5lx16hm0rixcidghx00gp08x2yrgr4x9"))))
(build-system meson-build-system)
- (arguments '(#:configure-flags '("-Dxwayland=true")))
+ (arguments
+ (list
+ #:configure-flags #~'("-Dxwayland=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-config-example
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "examples/config"
+ ;; Using a terminal support wayland seem to a good idea.
+ (("xterm") (search-input-file inputs "/bin/foot"))
+ ;; Guix include icecat instead of firefox.
+ (("firefox") "icecat"))))
+ (add-after 'unpack 'patch-source-paths
+ (lambda _
+ (substitute* '("cagebreak.c" "meson.build")
+ (("/etc/xdg") (string-append #$output "/etc/xdg"))))))))
(native-inputs
(list pandoc pkg-config))
(inputs
- (list libevdev pango wlroots))
+ (list foot libevdev pango wlroots))
(home-page "https://github.com/project-repo/cagebreak")
(synopsis "Tiling wayland compositor inspired by ratpoison")
(description
@@ -2724,7 +2740,7 @@ for wayland conceptually based on the X11 window manager
`(#:tests? #f)) ;; no tests
(home-page "https://github.com/vstakhov/libucl")
(synopsis "Universal configuration language (UCL) parser")
- (description "libucl implements a configuration language that is easy to
+ (description "libucl implements a configuration language that is easy to
read and write, and compatible with JSON.")
(license license:bsd-2)))
--
2.30.2
--
J
J
Jonathan Brielmaier wrote on 6 Apr 2023 10:58
[PATCH core-updates] Update wayland, libdrm, wlroots, wayland-protocols-next, libinput, sway
(address . 61331@debbugs.gnu.org)
104ab821-1b7e-3b68-99ca-f343baaae412@web.de
Hello Gabriel & Feng,

thanks for your patches.

[PATCH 1/6] gnu: Update wayland to 1.21.0. -> was already updated on
core-updates
[PATCH 2/6] gnu: Update libdrm to 2.4.114. -> dito
[PATCH 3/6] gnu: Update wlroots to 0.16.1. -> I manually rebased it on
core-updates.
[PATCH 4/6] gnu: Update wayland-protocols-next to 1.31. -> it got remove
in
[PATCH 5/6] gnu: Update libinput to 1.22.1. -> I removed python again, I
think its only necessary for building documentation, which we don't do
in order to keep the closure of this package small.
[PATCH 6/6] gnu: Update sway to 1.8. -> manually rebased to core-updates

[PATCH 1/3] gnu: cagebreak: Update to 2.0.1. -> manually rebased to
core-updates, but left-over this foot thing. That should maybe go later
to master.

I will sent the four remaining patches to this issue.

~Jonathan
J
J
Jonathan Brielmaier wrote on 6 Apr 2023 11:02
[PATCH 4/4] gnu: cagebreak: Update to 2.0.1.
(address . 61331@debbugs.gnu.org)
20230406090225.31969-4-jonathan.brielmaier@web.de
From: Feng Shu <tumashu@163.com>

* gnu/packages/wm.scm (cagebreak): Update to 2.0.1.

Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
---
gnu/packages/wm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d07cb349ff..c480f68aa6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2718,7 +2718,7 @@ (define-public xnotify
(define-public cagebreak
(package
(name "cagebreak")
- (version "1.8.3")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2727,7 +2727,7 @@ (define-public cagebreak
(file-name (git-file-name name version))
(sha256
(base32
- "0vm97ak0589v39m3fljf1qhy92dqgiqcrrfp757gg7q58qwa6dkf"))))
+ "0fxfmxl7p63l07lqb83q5lx16hm0rixcidghx00gp08x2yrgr4x9"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dxwayland=true")
--
2.39.2
J
J
Jonathan Brielmaier wrote on 6 Apr 2023 11:02
[PATCH 3/4] gnu: sway: Update to 1.8.
(address . 61331@debbugs.gnu.org)
20230406090225.31969-3-jonathan.brielmaier@web.de
From: Gabriel Wicki <gabriel@erlikon.ch>

* gnu/packages/wm.scm (sway): Update to 1.8.
[inputs]: Add pcre2.

Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
---
gnu/packages/wm.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2a5459e35a..d07cb349ff 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1596,7 +1596,7 @@ (define-public wlroots
(define-public sway
(package
(name "sway")
- (version "1.7")
+ (version "1.8")
(source
(origin
(method git-fetch)
@@ -1605,7 +1605,7 @@ (define-public sway
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0ss3l258blyf2d0lwd7pi7ga1fxfj8pxhag058k7cmjhs3y30y5l"))))
+ (base32 "17dqr2lkmcv2ssp7vky27zw599i77whpb1aqh1s6kl8a8vkrz6mg"))))
(build-system meson-build-system)
(arguments
`(;; elogind is propagated by wlroots -> libseat
@@ -1634,6 +1634,7 @@ (define-public sway
libinput-minimal
libxkbcommon
pango
+ pcre2
swaybg
wayland
wlroots))
--
2.39.2
J
J
Jonathan Brielmaier wrote on 6 Apr 2023 11:02
[PATCH 1/4] gnu: Update libinput to 1.22.1.
(address . 61331@debbugs.gnu.org)
20230406090225.31969-1-jonathan.brielmaier@web.de
From: Gabriel Wicki <gabriel@erlikon.ch>

* gnu/packages/freedesktop.scm (libinput): Update to version 1.22.1.
[source]: Fetch source via git.

Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
---
gnu/packages/freedesktop.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index fe5e243729..5ef5e9099d 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -592,14 +592,15 @@ (define-public libinput
;; Updating this will rebuild over 700 packages through libinput-minimal.
(package
(name "libinput")
- (version "1.19.4")
+ (version "1.22.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://freedesktop.org/software/libinput/"
- "libinput-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libinput/libinput.git")
+ (commit version)))
(sha256
(base32
- "0h5lz54rrl48bhi3vki6s08m6rn2h62rlf08dhgchdm9nmqaaczz"))))
+ "17a5qlym2d6lg2j8fdpxda9k7x5zr35flb4wlj1bz7h0mnkh8326"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Ddocumentation=false")
--
2.39.2
J
J
Jonathan Brielmaier wrote on 6 Apr 2023 11:02
[PATCH 2/4] gnu: wlroots: Update to 0.16.1.
(address . 61331@debbugs.gnu.org)
20230406090225.31969-2-jonathan.brielmaier@web.de
From: Gabriel Wicki <gabriel@erlikon.ch>

* gnu/packages/wm.scm (wlroots): Update to 0.16.1.
[arguments]: Add 'fix-meson-file phase to fix pnp.ids path.
[native-inputs]: Add hwdata:pnp.

Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
---
gnu/packages/wm.scm | 19 +++++++++++++++----
1 file changed, 15 insertions(+), 4 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 985c1ac56b..2a5459e35a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -60,6 +60,8 @@
;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,6 +133,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpd)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -1539,7 +1542,7 @@ (define-public polybar
(define-public wlroots
(package
(name "wlroots")
- (version "0.15.1")
+ (version "0.16.1")
(source
(origin
(method git-fetch)
@@ -1548,7 +1551,7 @@ (define-public wlroots
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "00s73nhi3sc48l426jdlqwpclg41kx1hv0yk4yxhbzw19gqpfm1h"))))
+ (base32 "11kcica9waj1a1xgbi12gif9z5z0b4xzycbcgawbgdmj77pws8sk"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1559,7 +1562,13 @@ (define-public wlroots
(("Xwayland") (string-append (assoc-ref inputs
"xorg-server-xwayland")
"/bin/Xwayland")))
- #t)))))
+ #t))
+ (add-before 'configure 'fix-meson-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "backend/drm/meson.build"
+ (("/usr/share/hwdata/pnp.ids")
+ (string-append (assoc-ref inputs "hwdata")
+ "/share/hwdata/pnp.ids"))))))))
(propagated-inputs
(list ;; As required by wlroots.pc.
eudev
@@ -1574,7 +1583,9 @@ (define-public wlroots
xcb-util-wm
xorg-server-xwayland))
(native-inputs
- (list pkg-config))
+ (list
+ `(,hwdata "pnp")
+ pkg-config))
(home-page "https://github.com/swaywm/wlroots")
(synopsis "Pluggable, composable, unopinionated modules for building a
Wayland compositor")
--
2.39.2
T
T
tumashu wrote on 6 Apr 2023 13:19
Re:[PATCH 4/4] gnu: cagebreak: Update to 2.0.1.
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 61331@debbugs.gnu.org)
3c728610.45bf.187564b511c.Coremail.tumashu@163.com
I think we should package cagebreak 2.1.0








--
?????????????
<br/><br/><br/>


----- Original Message -----
From: "Jonathan Brielmaier" <jonathan.brielmaier@web.de>
To: 61331@debbugs.gnu.org
Cc: "Feng Shu" <tumashu@163.com>, "Jonathan Brielmaier" <jonathan.brielmaier@web.de>
Sent: Thu, 6 Apr 2023 11:02:25 +0200
Subject: [PATCH 4/4] gnu: cagebreak: Update to 2.0.1.

From: Feng Shu <tumashu@163.com>

* gnu/packages/wm.scm (cagebreak): Update to 2.0.1.

Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
---
gnu/packages/wm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d07cb349ff..c480f68aa6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2718,7 +2718,7 @@ (define-public xnotify
(define-public cagebreak
(package
(name "cagebreak")
- (version "1.8.3")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2727,7 +2727,7 @@ (define-public cagebreak
(file-name (git-file-name name version))
(sha256
(base32
- "0vm97ak0589v39m3fljf1qhy92dqgiqcrrfp757gg7q58qwa6dkf"))))
+ "0fxfmxl7p63l07lqb83q5lx16hm0rixcidghx00gp08x2yrgr4x9"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dxwayland=true")
--
2.39.2
Attachment: file
J
J
Jonathan Brielmaier wrote on 7 Apr 2023 14:25
[PATCH core-updates] Update wayland, libdrm, wlroots, wayland-protocols-next, libinput, sway
(address . 61331-done@debbugs.gnu.org)
03d3b753-3da1-7327-6300-c6a8e1e88407@web.de
I've commited the four commits to core-updates.

@tumashu: cagebreak 2.1.0 fails in the build or check phase. So I left
it out for now...
Closed
?