[PATCH] download: Add bordeaux.guix.gnu.org as a content addressed mirror.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • zimoun
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 6 Feb 2023 16:55
(address . guix-patches@gnu.org)
20230206155505.6397-1-mail@cbaines.net
bordeaux.guix.gnu.org now provides access to some files by hash. This is done
through the nar-herder finding a nar produced by a fixed output derivation for
the requested content, and then providing the content stored inside that nar.

I've put this new entry at the start of the list, as I think it's more likely
to have content than the others. Because bordeaux.guix.gnu.org stores nars
indefinitely, my suspicion is that it's going to be able to fulfil more
requests than ci.guix.gnu.org, which relies on the file requested being in the
store (so the now frequent garbage collection is going to limit the files
available).

* guix/download.scm (%content-addressed-mirrors): Add bordeaux.guix.gnu.org.
---
guix/download.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/guix/download.scm b/guix/download.scm
index fff54d7a17..561a893eee 100644
--- a/guix/download.scm
+++ b/guix/download.scm
@@ -387,7 +387,11 @@ (define (guix-publish host)
file "/" (symbol->string algo) "/"
(bytevector->nix-base32-string hash))))
- (list (guix-publish "ci.guix.gnu.org")
+ (list (guix-publish
+ ;; bordeaux.guix.gnu.org uses the nar-herder rather than guix
+ ;; publish, but it supports the same style of requests
+ "bordeaux.guix.gnu.org")
+ (guix-publish "ci.guix.gnu.org")
(lambda (file algo hash)
;; 'tarballs.nixos.org' supports several algorithms.
(string-append "https://tarballs.nixos.org/"
--
2.38.1
L
L
Ludovic Courtès wrote on 10 Feb 2023 23:41
(name . Christopher Baines)(address . mail@cbaines.net)(address . 61324@debbugs.gnu.org)
877cwpp2ho.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (4 lines)
> bordeaux.guix.gnu.org now provides access to some files by hash. This is done
> through the nar-herder finding a nar produced by a fixed output derivation for
> the requested content, and then providing the content stored inside that nar.

Nice!

Toggle quote (7 lines)
> I've put this new entry at the start of the list, as I think it's more likely
> to have content than the others. Because bordeaux.guix.gnu.org stores nars
> indefinitely, my suspicion is that it's going to be able to fulfil more
> requests than ci.guix.gnu.org, which relies on the file requested being in the
> store (so the now frequent garbage collection is going to limit the files
> available).

Right, could be. (At one point we had nginx caching for /file URLs; not
sure if that’s still the case, and it wouldn’t really solve the
problem.)

Toggle quote (20 lines)
> * guix/download.scm (%content-addressed-mirrors): Add bordeaux.guix.gnu.org.
> ---
> guix/download.scm | 6 +++++-
> 1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/guix/download.scm b/guix/download.scm
> index fff54d7a17..561a893eee 100644
> --- a/guix/download.scm
> +++ b/guix/download.scm
> @@ -387,7 +387,11 @@ (define (guix-publish host)
> file "/" (symbol->string algo) "/"
> (bytevector->nix-base32-string hash))))
>
> - (list (guix-publish "ci.guix.gnu.org")
> + (list (guix-publish
> + ;; bordeaux.guix.gnu.org uses the nar-herder rather than guix
> + ;; publish, but it supports the same style of requests
> + "bordeaux.guix.gnu.org")
> + (guix-publish "ci.guix.gnu.org")

LGTM, thanks!

Ludo’.
C
C
Christopher Baines wrote on 11 Feb 2023 22:04
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 61324-done@debbugs.gnu.org)
87ilg752wh.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (22 lines)
>> * guix/download.scm (%content-addressed-mirrors): Add bordeaux.guix.gnu.org.
>> ---
>> guix/download.scm | 6 +++++-
>> 1 file changed, 5 insertions(+), 1 deletion(-)
>>
>> diff --git a/guix/download.scm b/guix/download.scm
>> index fff54d7a17..561a893eee 100644
>> --- a/guix/download.scm
>> +++ b/guix/download.scm
>> @@ -387,7 +387,11 @@ (define (guix-publish host)
>> file "/" (symbol->string algo) "/"
>> (bytevector->nix-base32-string hash))))
>>
>> - (list (guix-publish "ci.guix.gnu.org")
>> + (list (guix-publish
>> + ;; bordeaux.guix.gnu.org uses the nar-herder rather than guix
>> + ;; publish, but it supports the same style of requests
>> + "bordeaux.guix.gnu.org")
>> + (guix-publish "ci.guix.gnu.org")
>
> LGTM, thanks!

Awesome, I've gone ahead and pushed this as
7d0ebe040d80adcf143656e754a82b569243568c.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmPoAw5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xdecw/9H4WtdqCMQUFhBfpyLX836iADd/DuuvyF
TAo+CcxxksA0eWXY2qRZ/6IqtRuKBM7KpQDoXKegHnY37K3OyOb+k08ptfc5QBJ/
ckGz/xvHmWhm2V5iNCXmfWRzZQBn//ZJOsTvtkbK3qC/2QX1NcrobIinuuj/Nhvm
yr+cSjz8YWOEbCYIISAPuqeWEKkXh9hyOY7h0nTDkJu6J+cXN29drLSbFWyzU3Sx
NSOR9ZwVNpjKnGONXEALJxoSf/Toq8fPKhMBjKUvtG5R57RxeebeIlyB7lZeEgfB
DhvaAvFwvlJ9AMZj2S9yOav/CMVw7dpMyvNiiGrU+sUHhI4J5XkN8DIbtjbDWNve
lOS1P3k4VfrSMDy+Ua6i7of+1GATjLKdOYFRm/sKbgho7dSt8vD0ER7+f6aocjMn
P0TVmMxFGYur9rqAgut3iMcb82bTbP32TurgXqNeYZknefFeS3iltS4UOgbAT1Gy
0nzzD1j/R8AqdOxRwRVZaUsj7owdZkU6y6lkhExDV7EJzi0t2bYuo6tNVuqClP3C
yBMKZ8pgxndQqBhiaOdMEAwD+rKUW4esKcD/SVxsbMJJL/Cw0mpen00vtxmNYYUe
6Kuvyx/8CXU9zeJeq5Oq/NXkFVwjDtoHR7wSVlzpIjMVLUqRyMX1yJAirB0pid5Y
xuNIQr9NcXs=
=Idq0
-----END PGP SIGNATURE-----

Closed
Z
Z
zimoun wrote on 16 Feb 2023 11:13
(address . 61324-done@debbugs.gnu.org)
86sff5c3zv.fsf@gmail.com
Hi,

I am late to the party. :-)

On Sat, 11 Feb 2023 at 21:04, Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (7 lines)
>>> - (list (guix-publish "ci.guix.gnu.org")
>>> + (list (guix-publish
>>> + ;; bordeaux.guix.gnu.org uses the nar-herder rather than guix
>>> + ;; publish, but it supports the same style of requests
>>> + "bordeaux.guix.gnu.org")
>>> + (guix-publish "ci.guix.gnu.org")

The attempts are done in the order of the list, right? First, it tries
bordeaux.guix.gnu.org, then ci.guix.gnu.org, then tarballs.nixos.org.

Somehow it does not really matter, just to be sure the pressure is not
too much for the resources behind Bordeaux. :-)

Cheers,
simon
Closed
?