[PATCH] gnu: lxqt-admin: Fix path for timezone file

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal

Debbugs page

Reza Alizadeh Majd wrote 2 years ago
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20230206065939.16612-1-r.majd@pantherx.org
* gnu/packages/lxqt.scm (lxqt-admin)[arguments]: Update hardcoded path
for zone.tab to point to tzdata reference.
---
gnu/packages/lxqt.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index dde87382e8..b02c624f1c 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -320,7 +320,8 @@ (define-public lxqt-admin
libqtxdg
polkit-qt
qtsvg-5
- qtx11extras))
+ qtx11extras
+ tzdata))
(native-inputs
(list lxqt-build-tools qttools-5))
(arguments
@@ -333,6 +334,10 @@ (define-public lxqt-admin
"lxqt-admin-time/CMakeLists.txt")
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION \"share/polkit-1/actions"))
+ (substitute* '("lxqt-admin-time/timeadmindialog.cpp")
+ (("ZONETAB_PATH \"/usr")
+ (string-append "ZONETAB_PATH \""
+ (assoc-ref %build-inputs "tzdata"))))
#t)))))
(home-page "https://lxqt-project.org")
(synopsis "LXQt system administration tool")

base-commit: 34c7dd7e09fe714229a1ed723994c385d91bd457
--
2.38.1
宋文武 wrote 2 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 61316-done@debbugs.gnu.org)
87lel9exqp.fsf@envs.net
Reza Alizadeh Majd <r.majd@pantherx.org> writes:

Toggle quote (3 lines)
> * gnu/packages/lxqt.scm (lxqt-admin)[arguments]: Update hardcoded path
> for zone.tab to point to tzdata reference.

Hello, while the patch doesn't build, I have fix it and pushed a new one
to master.

Thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61316@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61316
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help